Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tengo problemas con drivers nouveau. (SOLUCIONADO)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
manara39
n00b
n00b


Joined: 21 Dec 2013
Posts: 42

PostPosted: Fri Jan 24, 2014 6:09 pm    Post subject: Tengo problemas con drivers nouveau. (SOLUCIONADO) Reply with quote

Amigos linuxeros:

Hace dos días reinstalé Gentoo en mi máquina:

Se instaló el sistema base con genkernel, todo bien, puse las variables use básicas e instalé xorg-server.

Ahora cuando ejecuto startx sale que no tiene pantalla o no se detecta.

He compilado dos veces el núcleo incorpo.rando las variables de la wiki de Gentoo Xorg y pasa esto.

Les adjunto la salida del archivo log de xorg:

Code:
[   226.580]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[   226.580] X Protocol Version 11, Revision 0
[   226.580] Build Operating System: Linux 3.10.25-gentoo x86_64 Gentoo
[   226.580] Current Operating System: Linux manara 3.10.25-gentoo #1 SMP Thu Jan 23 16:13:53 ART 2014 x86_64
[   226.580] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.10.25-gentoo root=UUID=8114d4fc-5f4c-4000-a79b-78bb2c3c1684 ro
[   226.581] Build Date: 24 January 2014  01:39:07PM
[   226.581] 
[   226.581] Current version of pixman: 0.32.4
[   226.581]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   226.581] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   226.582] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 24 14:18:36 2014
[   226.582] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   226.582] (==) No Layout section.  Using the first Screen section.
[   226.582] (==) No screen section available. Using defaults.
[   226.582] (**) |-->Screen "Default Screen Section" (0)
[   226.582] (**) |   |-->Monitor "<default monitor>"
[   226.582] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   226.582] (==) Automatically adding devices
[   226.582] (==) Automatically enabling devices
[   226.582] (==) Automatically adding GPU devices
[   226.582] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   226.582]    Entry deleted from font path.
[   226.582] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   226.582]    Entry deleted from font path.
[   226.582] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   226.582]    Entry deleted from font path.
[   226.582] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   226.582]    Entry deleted from font path.
[   226.582]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   226.582] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   226.582]    Entry deleted from font path.
[   226.582]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   226.582] (==) FontPath set to:
   /usr/share/fonts/misc/
[   226.582] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   226.582] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   226.582] (II) Loader magic: 0x7fec20
[   226.582] (II) Module ABI versions:
[   226.582]    X.Org ANSI C Emulation: 0.4
[   226.582]    X.Org Video Driver: 14.1
[   226.582]    X.Org XInput driver : 19.1
[   226.582]    X.Org Server Extension : 7.0
[   226.583] (--) PCI:*(0:1:0:0) 10de:0a65:3842:1312 rev 162, Mem @ 0xfa000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[   226.583] Initializing built-in extension Generic Event Extension
[   226.584] Initializing built-in extension SHAPE
[   226.584] Initializing built-in extension MIT-SHM
[   226.584] Initializing built-in extension XInputExtension
[   226.584] Initializing built-in extension XTEST
[   226.584] Initializing built-in extension BIG-REQUESTS
[   226.584] Initializing built-in extension SYNC
[   226.584] Initializing built-in extension XKEYBOARD
[   226.584] Initializing built-in extension XC-MISC
[   226.584] Initializing built-in extension XINERAMA
[   226.584] Initializing built-in extension XFIXES
[   226.585] Initializing built-in extension RENDER
[   226.585] Initializing built-in extension RANDR
[   226.585] Initializing built-in extension COMPOSITE
[   226.585] Initializing built-in extension DAMAGE
[   226.585] Initializing built-in extension MIT-SCREEN-SAVER
[   226.585] Initializing built-in extension DOUBLE-BUFFER
[   226.585] Initializing built-in extension RECORD
[   226.585] Initializing built-in extension DPMS
[   226.585] Initializing built-in extension X-Resource
[   226.585] Initializing built-in extension XVideo
[   226.585] Initializing built-in extension XVideo-MotionCompensation
[   226.586] Initializing built-in extension XFree86-VidModeExtension
[   226.586] Initializing built-in extension XFree86-DGA
[   226.586] Initializing built-in extension XFree86-DRI
[   226.586] Initializing built-in extension DRI2
[   226.586] (II) LoadModule: "glx"
[   226.586] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   226.586] (II) Module glx: vendor="X.Org Foundation"
[   226.586]    compiled for 1.14.3, module version = 1.0.0
[   226.586]    ABI class: X.Org Server Extension, version 7.0
[   226.586] (==) AIGLX enabled
[   226.586] Loading extension GLX
[   226.586] (==) Matched nouveau as autoconfigured driver 0
[   226.586] (==) Matched nv as autoconfigured driver 1
[   226.586] (==) Matched vesa as autoconfigured driver 2
[   226.586] (==) Matched modesetting as autoconfigured driver 3
[   226.586] (==) Matched fbdev as autoconfigured driver 4
[   226.586] (==) Assigned the driver to the xf86ConfigLayout
[   226.586] (II) LoadModule: "nouveau"
[   226.586] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[   226.586] (II) Module nouveau: vendor="X.Org Foundation"
[   226.586]    compiled for 1.14.3, module version = 1.0.9
[   226.586]    Module class: X.Org Video Driver
[   226.586]    ABI class: X.Org Video Driver, version 14.1
[   226.586] (II) LoadModule: "nv"
[   226.587] (WW) Warning, couldn't open module nv
[   226.587] (II) UnloadModule: "nv"
[   226.587] (II) Unloading nv
[   226.587] (EE) Failed to load module "nv" (module does not exist, 0)
[   226.587] (II) LoadModule: "vesa"
[   226.587] (WW) Warning, couldn't open module vesa
[   226.587] (II) UnloadModule: "vesa"
[   226.587] (II) Unloading vesa
[   226.587] (EE) Failed to load module "vesa" (module does not exist, 0)
[   226.587] (II) LoadModule: "modesetting"
[   226.587] (WW) Warning, couldn't open module modesetting
[   226.587] (II) UnloadModule: "modesetting"
[   226.587] (II) Unloading modesetting
[   226.587] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   226.587] (II) LoadModule: "fbdev"
[   226.587] (WW) Warning, couldn't open module fbdev
[   226.587] (II) UnloadModule: "fbdev"
[   226.587] (II) Unloading fbdev
[   226.587] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   226.587] (II) NOUVEAU driver
[   226.587] (II) NOUVEAU driver for NVIDIA chipset families :
[   226.587]    RIVA TNT        (NV04)
[   226.587]    RIVA TNT2       (NV05)
[   226.587]    GeForce 256     (NV10)
[   226.587]    GeForce 2       (NV11, NV15)
[   226.587]    GeForce 4MX     (NV17, NV18)
[   226.587]    GeForce 3       (NV20)
[   226.587]    GeForce 4Ti     (NV25, NV28)
[   226.587]    GeForce FX      (NV3x)
[   226.587]    GeForce 6       (NV4x)
[   226.587]    GeForce 7       (G7x)
[   226.587]    GeForce 8       (G8x)
[   226.587]    GeForce GTX 200 (NVA0)
[   226.587]    GeForce GTX 400 (NVC0)
[   226.587] (--) using VT number 7

[   226.597] (EE) [drm] KMS not enabled
[   226.597] (EE) No devices detected.
[   226.597] (EE)
Fatal server error:
[   226.597] (EE) no screens found(EE)
[   226.597] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   226.597] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   226.597] (EE)


Last edited by manara39 on Sat Jan 25, 2014 2:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 861

PostPosted: Fri Jan 24, 2014 6:47 pm    Post subject: Re: Tengo problemas con drivers nouveau. Reply with quote

manara39 wrote:
...
Code:

[   226.597] (EE) [drm] KMS not enabled
...

Tendrás que configurar el kernel para que tenga esa funcionalidad.

https://wiki.gentoo.org/wiki/Xorg/Configuration/es#Ajuste_del_modo_del_n.C3.BAcleo
Mira la parte que habla de las tarjetas nVidia.
Back to top
View user's profile Send private message
manara39
n00b
n00b


Joined: 21 Dec 2013
Posts: 42

PostPosted: Sat Jan 25, 2014 2:21 pm    Post subject: Instalé el driver nvidia y resolví el problema. Reply with quote

Después de trastear varias veces compilando el nucleo decidí instalar los drivers nvidia.

Seguí las instrucciones al pie de la letra y todo listo.

Ahora tengo KDE 4.11.2 y puedo instalar el software de mi predilección.

Muchas gracias por la ayuda.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum