Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo - Problem z wersją PHP
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
armen10
n00b
n00b


Joined: 24 Jan 2014
Posts: 1

PostPosted: Fri Jan 24, 2014 11:51 am    Post subject: Gentoo - Problem z wersją PHP Reply with quote

Witam
Mam duży problem na swoim serwerze mam zainstalowaną wersje php 5.3.14, a muszę ów wersje zmienić na 5.3.10, czy ma może ktoś jakąś radę ?
Z góry dzięki.
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 491

PostPosted: Thu Jan 30, 2014 11:00 pm    Post subject: Reply with quote

Masz znacznie poważniejszy problem, zarówno 5.3.10 jak i 5.3.14 już wyleciały z portów z powodu dziur bezpieczeństwa, najmłodsza jest teraz 5.3.27.

Dlaczego musisz cofać w obrębie php-5.3, coś nie działa na nowej wersji?

Bo przynajmniej w teorii powinno działać wszystko, co jest zgodne z PHP-5.3.
Może w tej wersji 5.3.14 masz jakiegoś babola, przez którego cośtam nie idzie, jak powinno.
Back to top
View user's profile Send private message
Kubala95
n00b
n00b


Joined: 23 Jul 2012
Posts: 18

PostPosted: Sun Feb 02, 2014 6:34 pm    Post subject: Reply with quote

Właściwie na czym ci zależy ? W obrębie jednej linii nie dokonuje się żadnych znaczących zmian, nie powinno być problemów z interpretacją skryptów.

http://museum.php.net/php5/php-5.3.10.tar.bz2

Możesz skompilować starą wersję ręcznie, ale na własną odpowiedzialność, bo może dojść do konfliktu z Portage'em.
Back to top
View user's profile Send private message
manwe_
Guru
Guru


Joined: 01 Feb 2006
Posts: 560
Location: Kraków/Cracow, Poland

PostPosted: Tue Feb 04, 2014 1:16 pm    Post subject: Reply with quote

Nie musi, wszystkie pliki wciąż są dostępne w repozytorium Portage http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-lang/php/?hideattic=0

Pozostaje zassać ebuild i wciągnąć do jakiegoś własnego PORTDIR_OVERLAY.

Inna sprawa to "wymóg" 5.3.10. Jeżeli jakaś aplikacja działa tylko na tej wersji i nie jest kompatybilna z wyższymi, choćby w ramach 5.3.x (już o 5.4 i 5.5 nie wspominam, chociaż one mają minimalne zmiany) to należy zmienić developera, a potem poprawić aplikację.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum