Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Не запускается X Window Server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Oleg_Ponomaryov
n00b
n00b


Joined: 13 Jan 2014
Posts: 7

PostPosted: Tue Jan 21, 2014 5:29 pm    Post subject: Не запускается X Window Server Reply with quote

После установки Gentoo решил поставить иксы с целью дальнейшей установки KDE. В качестве инструкции использовал эту статью: https://wiki.gentoo.org/wiki/Xorg/Configuration. Однако в результате выполнения команды:
Code:
startx

получаю ошибку:
Code:
(EE) no screens found(EE)

В качестве машины для ОС выступает ноут Dell Inspiron N7110. В нём стоит дискретная видюха NVidia GeForce 525M и встроенная Intel HD Graphics 3000. В идеале их работа совмещается технологией гибридной графики NVidia Optimus.
Получив вышеуказанную ошибку первый раз, я почитал о ней и решил попробовать устранить её установкой драйверов NVidia, делал по этой статье: https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers, однако ошибка никуда не делась, а когда я пытался запустить средства диагностики из пакета mesa-progs, то появлялась ошибка:
Code:
couldn't open display

Помогите, пожалуйста, исправить проблему. Заранее большое спасибо!
Ниже привожу содержание файла Xorg.0.log:
Code:
[  4265.046]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  4265.046] X Protocol Version 11, Revision 0
[  4265.046] Build Operating System: Linux 3.10.25-gentoo x86_64 Gentoo
[  4265.046] Current Operating System: Linux inspiron 3.10.25-gentoo #1 SMP Wed Jan 15 00:57:28 EET 2014 x86_64
[  4265.046] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.10.25-gentoo root=UUID=5fa85daf-3401-4a0a-a26b-ed302cbfc97c ro
[  4265.047] Build Date: 19 January 2014  06:57:28PM
[  4265.047] 
[  4265.047] Current version of pixman: 0.32.4
[  4265.047]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  4265.047] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4265.048] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 21 19:00:51 2014
[  4265.048] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  4265.048] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4265.048] (==) No Layout section.  Using the first Screen section.
[  4265.048] (==) No screen section available. Using defaults.
[  4265.048] (**) |-->Screen "Default Screen Section" (0)
[  4265.048] (**) |   |-->Monitor "<default monitor>"
[  4265.048] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[  4265.048] (**) |   |-->Device "nvidia"
[  4265.048] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  4265.049] (==) Automatically adding devices
[  4265.049] (==) Automatically enabling devices
[  4265.049] (==) Automatically adding GPU devices
[  4265.049] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (==) FontPath set to:
   
[  4265.049] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  4265.049] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4265.049] (II) Loader magic: 0x7fcc00
[  4265.049] (II) Module ABI versions:
[  4265.049]    X.Org ANSI C Emulation: 0.4
[  4265.049]    X.Org Video Driver: 14.1
[  4265.049]    X.Org XInput driver : 19.1
[  4265.049]    X.Org Server Extension : 7.0
[  4265.050] (--) PCI:*(0:0:2:0) 8086:0116:1028:04c4 rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64
[  4265.050] (--) PCI: (0:1:0:0) 10de:0df5:1028:04c4 rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[  4265.050] Initializing built-in extension Generic Event Extension
[  4265.050] Initializing built-in extension SHAPE
[  4265.050] Initializing built-in extension MIT-SHM
[  4265.050] Initializing built-in extension XInputExtension
[  4265.050] Initializing built-in extension XTEST
[  4265.050] Initializing built-in extension BIG-REQUESTS
[  4265.051] Initializing built-in extension SYNC
[  4265.051] Initializing built-in extension XKEYBOARD
[  4265.051] Initializing built-in extension XC-MISC
[  4265.051] Initializing built-in extension XINERAMA
[  4265.051] Initializing built-in extension XFIXES
[  4265.051] Initializing built-in extension RENDER
[  4265.051] Initializing built-in extension RANDR
[  4265.051] Initializing built-in extension COMPOSITE
[  4265.051] Initializing built-in extension DAMAGE
[  4265.051] Initializing built-in extension MIT-SCREEN-SAVER
[  4265.052] Initializing built-in extension DOUBLE-BUFFER
[  4265.052] Initializing built-in extension RECORD
[  4265.052] Initializing built-in extension DPMS
[  4265.052] Initializing built-in extension X-Resource
[  4265.052] Initializing built-in extension XVideo
[  4265.052] Initializing built-in extension XVideo-MotionCompensation
[  4265.052] Initializing built-in extension XFree86-VidModeExtension
[  4265.052] Initializing built-in extension XFree86-DGA
[  4265.052] Initializing built-in extension XFree86-DRI
[  4265.052] Initializing built-in extension DRI2
[  4265.053] (II) LoadModule: "glx"
[  4265.053] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  4265.214] (II) Module glx: vendor="NVIDIA Corporation"
[  4265.214]    compiled for 4.0.2, module version = 1.0.0
[  4265.214]    Module class: X.Org Server Extension
[  4265.214] (II) NVIDIA GLX Module  304.117  Tue Nov 26 21:45:09 PST 2013
[  4265.214] Loading extension GLX
[  4265.214] (II) LoadModule: "nvidia"
[  4265.214] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  4265.215] (II) Module nvidia: vendor="NVIDIA Corporation"
[  4265.215]    compiled for 4.0.2, module version = 1.0.0
[  4265.215]    Module class: X.Org Video Driver
[  4265.215] (II) NVIDIA dlloader X Driver  304.117  Tue Nov 26 21:27:08 PST 2013
[  4265.215] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  4265.216] (--) using VT number 7

[  4265.219] (EE) No devices detected.
[  4265.219] (EE)
Fatal server error:
[  4265.219] (EE) no screens found(EE)
[  4265.219] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  4265.219] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  4265.219] (EE)
[/glsa]

А вот вывод lspci. Обе видеокарты нормально определяются:
Code:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
Back to top
View user's profile Send private message
Etherius
n00b
n00b


Joined: 24 Jan 2014
Posts: 1

PostPosted: Fri Jan 24, 2014 3:07 pm    Post subject: Reply with quote

Установлены xorg-twm xorg-xclock xterm ?Что то похожее без них было вроде.
Back to top
View user's profile Send private message
Oleg_Ponomaryov
n00b
n00b


Joined: 13 Jan 2014
Posts: 7

PostPosted: Fri Jan 24, 2014 4:21 pm    Post subject: Reply with quote

Etherius wrote:
Установлены xorg-twm xorg-xclock xterm ?Что то похожее без них было вроде.

Спасибо за ответ! Установил эти пакеты (до этого не было), но ситуация, к сожалению, не изменилась :roll:
Back to top
View user's profile Send private message
Pinkbyte
Developer
Developer


Joined: 01 Jun 2012
Posts: 93
Location: Rostov-on-Don, Russia

PostPosted: Tue Jan 28, 2014 9:38 am    Post subject: Reply with quote

Данный ноутбук использует технологию Nvidia Optimus для вывода графики. Почитайте как настроить xorg.conf в данном случае. Возможно потребуется установить x11-misc/bumblebee или primus(нет в главном дереве portage). Я говорю возможно, потому что сам подобной настройкой занимался давно и уже не помню что там и как.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum