Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
run-java-tool should only be used via symlinks to it
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Juan Facundo
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2009
Posts: 129

PostPosted: Mon Jan 20, 2014 12:39 pm    Post subject: run-java-tool should only be used via symlinks to it Reply with quote

Hola gente. Estoy intentando correr un programa que está escrito en java, y me está dando el siguiente error. He googleado y no encontré nada. No sé si tal vez no se buscar bien, dado que no tengo experiencia en java. Si alguien me puede dar una mano....

Code:
STATUS | wrapper  | 2014/01/20 09:35:30 | --> Wrapper Started as Daemon
STATUS | wrapper  | 2014/01/20 09:35:30 | Java Service Wrapper Community Edition 32-bit 3.5.22
STATUS | wrapper  | 2014/01/20 09:35:30 |   Copyright (C) 1999-2013 Tanuki Software, Ltd. All Rights Reserved.
STATUS | wrapper  | 2014/01/20 09:35:30 |     http://wrapper.tanukisoftware.com
STATUS | wrapper  | 2014/01/20 09:35:30 |
WARN   | wrapper  | 2014/01/20 09:35:30 | The value of wrapper.java.command does not appear to be a java binary.
WARN   | wrapper  | 2014/01/20 09:35:30 | The use of scripts is not supported. Trying to continue, but some features may not work correctly..
STATUS | wrapper  | 2014/01/20 09:35:30 | Launching a JVM...
ERROR  | wrapper  | 2014/01/20 09:35:31 | JVM exited while loading the application.
INFO   | jvm 1    | 2014/01/20 09:35:31 | * run-java-tool was invoked directly
INFO   | jvm 1    | 2014/01/20 09:35:31 | * run-java-tool should only be used via symlinks to it
WARN   | wrapper  | 2014/01/20 09:35:35 | The value of wrapper.java.command does not appear to be a java binary.
WARN   | wrapper  | 2014/01/20 09:35:35 | The use of scripts is not supported. Trying to continue, but some features may not work correctly..
STATUS | wrapper  | 2014/01/20 09:35:35 | Launching a JVM...
ERROR  | wrapper  | 2014/01/20 09:35:35 | JVM exited while loading the application.
INFO   | jvm 2    | 2014/01/20 09:35:35 | * run-java-tool was invoked directly
INFO   | jvm 2    | 2014/01/20 09:35:35 | * run-java-tool should only be used via symlinks to it
WARN   | wrapper  | 2014/01/20 09:35:39 | The value of wrapper.java.command does not appear to be a java binary.
WARN   | wrapper  | 2014/01/20 09:35:39 | The use of scripts is not supported. Trying to continue, but some features may not work correctly..
STATUS | wrapper  | 2014/01/20 09:35:40 | Launching a JVM...
ERROR  | wrapper  | 2014/01/20 09:35:40 | JVM exited while loading the application.
INFO   | jvm 3    | 2014/01/20 09:35:40 | * run-java-tool was invoked directly
INFO   | jvm 3    | 2014/01/20 09:35:40 | * run-java-tool should only be used via symlinks to it
WARN   | wrapper  | 2014/01/20 09:35:44 | The value of wrapper.java.command does not appear to be a java binary.
WARN   | wrapper  | 2014/01/20 09:35:44 | The use of scripts is not supported. Trying to continue, but some features may not work correctly..
STATUS | wrapper  | 2014/01/20 09:35:44 | Launching a JVM...
ERROR  | wrapper  | 2014/01/20 09:35:44 | JVM exited while loading the application.
INFO   | jvm 4    | 2014/01/20 09:35:44 | * run-java-tool was invoked directly
INFO   | jvm 4    | 2014/01/20 09:35:44 | * run-java-tool should only be used via symlinks to it
WARN   | wrapper  | 2014/01/20 09:35:48 | The value of wrapper.java.command does not appear to be a java binary.
WARN   | wrapper  | 2014/01/20 09:35:48 | The use of scripts is not supported. Trying to continue, but some features may not work correctly..
STATUS | wrapper  | 2014/01/20 09:35:49 | Launching a JVM...
ERROR  | wrapper  | 2014/01/20 09:35:49 | JVM exited while loading the application.
INFO   | jvm 5    | 2014/01/20 09:35:49 | * run-java-tool was invoked directly
INFO   | jvm 5    | 2014/01/20 09:35:49 | * run-java-tool should only be used via symlinks to it
FATAL  | wrapper  | 2014/01/20 09:35:49 | There were 5 failed launches in a row, each lasting less than 300 seconds.  Giving up.
FATAL  | wrapper  | 2014/01/20 09:35:49 |   There may be a configuration problem: please check the logs.
STATUS | wrapper  | 2014/01/20 09:35:49 | <-- Wrapper Stopped
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 840

PostPosted: Mon Jan 20, 2014 4:52 pm    Post subject: Reply with quote

Parece que ese wrapper no puede arrancar la JVM si no le pasas la ruta exacta al ejecutable de la JVM. Tendrás que asignar la variable wrapper.java.command [1] a su valor (quizá /usr/java/bin/javam) en el archivo wrapper.conf [2].

[1] http://wrapper.tanukisoftware.com/doc/spanish/prop-java-command.html#command
[2] http://wrapper.tanukisoftware.com/doc/spanish/props-example-config.html
Back to top
View user's profile Send private message
Juan Facundo
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2009
Posts: 129

PostPosted: Tue Jan 21, 2014 2:29 am    Post subject: Reply with quote

Muchas gracias... Veré que puedo hacer...
Back to top
View user's profile Send private message
Juan Facundo
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2009
Posts: 129

PostPosted: Wed Jan 22, 2014 1:00 pm    Post subject: Reply with quote

Bien, pude hacerlo configurnado el archivo de la aplicacion, llamado wrapper.conf. Muchas gracias.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum