Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge world -- slot conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
idoerg
n00b
n00b


Joined: 22 Jan 2012
Posts: 21

PostPosted: Mon Jan 13, 2014 4:01 pm    Post subject: emerge world -- slot conflicts Reply with quote

Hi,

After sync, I am having quite a few problems with slot conflicts: :(

Code:

# emerge -uDav world


Code:

  (media-libs/libpng-1.5.17-r1::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (dev-qt/qtgui-4.8.5-r1::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (dev-tex/luatex-0.76.0::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/poppler-0.22.5::gentoo, installed)
    (and 3 more with the same problems)

  (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge)
    media-libs/libpng[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/freetype-2.5.0.1::gentoo, ebuild scheduled for merge)
    >=media-libs/libpng-1.4:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/motif-2.3.4-r1::gentoo, installed)
    media-libs/libpng:0/16 required by (app-office/libreoffice-bin-4.1.3.2-r3::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.24.5::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler:0/44 required by (app-office/libreoffice-bin-4.1.3.2-r3::gentoo, ebuild scheduled for merge)

  (app-text/poppler-0.22.5::gentoo, installed) pulled in by
    app-text/poppler:0/37=[xpdf-headers(+)] required by (dev-tex/luatex-0.76.0::gentoo, installed)
    >=app-text/poppler-0.12.3-r3:0/37= required by (app-text/texlive-core-2013-r1::gentoo, installed)

dev-libs/icu:0

  (dev-libs/icu-51.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/51.2 required by (app-office/libreoffice-bin-4.1.3.2-r3::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/icu-51.1::gentoo, installed) pulled in by
    >=dev-libs/icu-4.4:0/51.1= required by (dev-tex/bibtexu-3.71_p20130530::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libcdr-0.0.14::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/raptor-2.0.9::gentoo, installed)
    dev-libs/icu:0/51.1= required by (app-text/libmspub-0.0.6::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libvisio-0.0.30::gentoo, installed)
    (and 5 more with the same problems)

  (dev-libs/icu-52.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-python/pygments:0

  (dev-python/pygments-1.6::gentoo, installed) pulled in by
    dev-python/pygments[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (dev-python/docutils-0.10::gentoo, installed)

  (dev-python/pygments-1.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/pygments[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (dev-python/docutils-0.10::gentoo, ebuild scheduled for merge)
    >=dev-python/pygments-1.2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (dev-python/sphinx-1.2::gentoo, ebuild scheduled for merge)
    dev-python/pygments[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/ipython-1.1.0-r1::gentoo, ebuild scheduled for merge)

dev-python/docutils:0

  (dev-python/docutils-0.10::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/docutils-0.7[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (dev-python/sphinx-1.2::gentoo, ebuild scheduled for merge)

  (dev-python/docutils-0.10::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.15.0::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server[xvfb] required by (dev-python/matplotlib-1.3.1::gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.14.3-r2::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-video-ati-7.2.0::gentoo, installed)

dev-python/dbus-python:0

  (dev-python/dbus-python-1.2.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/dbus-python-1.2.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/dbus-python-0.80[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/PyQt4-4.10.3-r2::gentoo, ebuild scheduled for merge)

dev-python/pycairo:0

  (dev-python/pycairo-1.10.0-r4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pycairo-1.10.0[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/pygobject-3.8.3::gentoo, ebuild scheduled for merge)

  (dev-python/pycairo-1.10.0-r4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/boost:0

  (dev-libs/boost-1.52.0-r6::gentoo, installed) pulled in by
    >=dev-libs/boost-1.51.0:0/1.52= required by (dev-libs/liborcus-0.5.1::gentoo, installed)
    dev-libs/boost:0/1.52= required by (dev-libs/libixion-0.5.0::gentoo, installed)
    dev-libs/boost:0/1.52= required by (dev-cpp/libcmis-0.3.1::gentoo, installed)
    dev-libs/boost:0/1.52 required by (app-office/libreoffice-bin-4.1.3.2-r3::gentoo, ebuild scheduled for merge)

  (dev-libs/boost-1.53.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/python-argparse:0

  (virtual/python-argparse-1::gentoo, installed) pulled in by
    =virtual/python-argparse-1[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (app-portage/gentoolkit-0.3.0.8-r2::gentoo, installed)
    virtual/python-argparse[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (app-portage/gentoolkit-0.3.0.8-r2::gentoo, installed)

  (virtual/python-argparse-1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/python-argparse[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/ipython-1.1.0-r1::gentoo, ebuild scheduled for merge)

virtual/python-imaging:0

  (virtual/python-imaging-2::gentoo, ebuild scheduled for merge) pulled in by
    virtual/python-imaging[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/matplotlib-1.3.1::gentoo, ebuild scheduled for merge)

  (virtual/python-imaging-2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/libjpeg-turbo:0

  (media-libs/libjpeg-turbo-1.3.0-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libjpeg-turbo-1.3.0-r2:0[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (virtual/jpeg-0-r2::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (media-libs/libjpeg-turbo-1.3.0::gentoo, installed) pulled in by
    <media-libs/libjpeg-turbo-1.3.0-r2 required by (app-office/libreoffice-bin-4.1.3.2-r3::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-kernel/module-rebuild-0.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (28 Dec 2013)
# Replaced by 'emerge @module-rebuild' set in Portage itself.
# Removal in 30 days, see http://bugs.gentoo.org/410739

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1158

PostPosted: Mon Jan 13, 2014 5:03 pm    Post subject: Reply with quote

Try without libreoffice-bin
or keep going absolutely stable
_________________
fun2gen2
Back to top
View user's profile Send private message
idoerg
n00b
n00b


Joined: 22 Jan 2012
Posts: 21

PostPosted: Tue Jan 14, 2014 4:03 pm    Post subject: Reply with quote

ulenrich wrote:
Try without libreoffice-bin
or keep going absolutely stable


Unfortunately, emerging without libreoffice-bin did not seem to help. I unmerged libreoffice-bin, and emerged libreoffice. Still being hit by the same conflicts.
Back to top
View user's profile Send private message
slowdive
n00b
n00b


Joined: 01 May 2005
Posts: 34

PostPosted: Tue Jan 14, 2014 5:07 pm    Post subject: Many conflicts for me too Reply with quote

i have many slot conflicts too - perhaps we have the same root cause? has there been some change in how slots work in the last few months?

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (app-emulation/wine-1.7.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.5::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/poppler-0.22.5::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/cinelerra-20120707::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/gthumb-3.0.2::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/dvdauthor-0.7.1::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/mjpegtools-2.0.1_rc1-r1::gentoo, installed)
    (and 1 more with the same problems)

  (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge)
    media-libs/libpng[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]
        required by (media-libs/freetype-2.5.0.1::gentoo, ebuild scheduled for merge)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.9::gentoo, installed)
    >=dev-lang/perl-5.8.2-r1[-build] required by (net-im/pidgin-2.10.7-r2::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.1::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.1::gentoo, installed)

app-text/poppler:0

  (app-text/poppler-0.24.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.22.5::gentoo, installed) pulled in by
    app-text/poppler:0/37=[qt4] required by (app-office/texmaker-4.0.2::gentoo, installed)
    app-text/poppler:0/37=[cairo] required by (mail-client/claws-mail-3.9.2::gentoo, installed)
    app-text/poppler:0/37=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
    >=app-text/poppler-0.20:0/37=[cairo] required by (app-text/evince-3.6.1::gentoo, installed)
    (and 2 more with the same problems)

media-libs/harfbuzz:0

  (media-libs/harfbuzz-0.9.18-r1::gentoo, installed) pulled in by
    >=media-libs/harfbuzz-0.9.10:0/0.9.18=[icu(+)] required by (app-office/libreoffice-4.1.0.2::gentoo, installed)

  (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-editors/vim-core:0

  (app-editors/vim-core-7.4.131::gentoo, ebuild scheduled for merge) pulled in by
    ~app-editors/vim-core-7.4.131 required by (app-editors/vim-7.4.131::gentoo, ebuild scheduled for merge)

  (app-editors/vim-core-7.3.1214::gentoo, installed) pulled in by
    ~app-editors/vim-core-7.3.1214 required by (app-editors/gvim-7.3.1214::gentoo, installed)

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.2-r1::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (app-crypt/gcr-3.6.2::gentoo, installed)
    (and 1 more with the same problem)

  (dev-libs/libgcrypt-1.6.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-db/sqlite:3

  (dev-db/sqlite-3.8.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-db/sqlite-3.7.17::gentoo, installed) pulled in by
    >=dev-db/sqlite-3.3.8:3[extensions] required by (dev-lang/python-3.2.5-r1::gentoo, installed)
    >=dev-db/sqlite-3.3.8:3[extensions] required by (dev-python/pysqlite-2.6.3::gentoo, installed)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, installed)
    (and 11 more with the same problem)

  (dev-qt/qtcore-4.8.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-4.8.5:4[accessibility,dbus(+)] required by (sys-auth/polkit-kde-agent-0.99.0-r1::gentoo, installed)
    ~dev-qt/qtgui-4.8.5[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.5-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problems)

  (dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    (and 6 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 1 more with the same problem)

  (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r1::gentoo, ebuild scheduled for merge)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.4::gentoo, installed)
    (and 1 more with the same problem)

  (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r1::gentoo, ebuild scheduled for merge)

  (dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 1 more with the same problem)

dev-python/setuptools:0

  (dev-python/setuptools-1.1.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,
     python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),
     -python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/numpy-1.8.0::gentoo,
       ebuild scheduled for merge)

  (dev-python/setuptools-0.8::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,
     python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),
     -python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),
     -python_single_target_pypy2_0(-)] required by (dev-python/python-distutils-extra-2.37-r1::gentoo, installed)



I tried the instructions at http://wiki.gentoo.org/wiki/Troubleshooting (search for slot conflict), specifically to manually emerge the highest version, but that doesn't seem to work either:

Code:

# emerge -1avq =app-text/poppler-0.24.5::gentoo
[ebuild     U ] app-text/poppler-0.24.5 [0.22.5] USE="cairo curl cxx introspection jpeg lcms png qt4 tiff utils -cjk -debug -doc -jpeg2k"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.24.5::gentoo, ebuild scheduled for merge) pulled in by
    =app-text/poppler-0.24.5::gentoo

  (app-text/poppler-0.22.5::gentoo, installed) pulled in by
    app-text/poppler:0/37=[qt4] required by (app-office/texmaker-4.0.2::gentoo, installed)
    app-text/poppler:0/37=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.35::gentoo, installed)
    app-text/poppler:0/37=[cairo] required by (mail-client/claws-mail-3.9.2::gentoo, installed)
    app-text/poppler:0/37=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
    >=app-text/poppler-0.20:0/37=[cairo] required by (app-text/evince-3.6.1::gentoo, installed)
    (and 2 more with the same problems)



it doesn't even look like a "slot conflict"; it looks like we just want an update - unless relatively small updates are considered new slots?

next i tried listing the packages depending on 0.22.5, e.g. =app-office/texmaker-4.0.2::gentoo. those packages don't exist anymore, so i had to list them as e.g. app-office/texmaker. so that's annoying, but it seems to get a little farther. now a half dozen dependencies with similar slot issues pop up:

Code:

emerge -1avq =app-text/poppler-0.24.5::gentoo app-office/texmaker net-print/cups-filters mail-client/claws-mail dev-tex/luatex app-text/evince

...

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/atk:0

  (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/atk-2.7.5[introspection?] required by (x11-libs/gtk+-3.8.7::gentoo, ebuild scheduled for merge)

  (dev-libs/atk-2.6.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/glib:2

  (dev-libs/glib-2.34.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.35.3:2 required by (x11-libs/gtk+-3.8.7::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

app-text/ghostscript-gpl:0

  (app-text/ghostscript-gpl-9.07::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge) pulled in by
    >=app-text/ghostscript-gpl-9.09 required by (net-print/cups-filters-1.0.43-r1::gentoo, ebuild scheduled for merge)

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (app-emulation/wine-1.7.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.5::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/ghostscript-gpl-9.07::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/poppler-0.22.5::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/cinelerra-20120707::gentoo, installed)
    media-libs/libpng:0/0= required by (x11-libs/cairo-1.12.14-r2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/gthumb-3.0.2::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/dvdauthor-0.7.1::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/mjpegtools-2.0.1_rc1-r1::gentoo, installed)
    (and 1 more with the same problems)

  (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/zlib-1.2.8-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.24.5::gentoo, ebuild scheduled for merge) pulled in by
    =app-text/poppler-0.24.5::gentoo

  (app-text/poppler-0.22.5::gentoo, installed) pulled in by
    >=app-text/poppler-0.16:0/37=[xpdf-headers(+),cxx] required by (app-office/libreoffice-4.1.0.2::gentoo, installed)
    (and 1 more with the same problem)


note that poppler is no longer complaining about the packages depending on it (at least not the ones i am building with on the command line; now i can see one of the remaining two). but some of these slot dependencies are ridiculous, such as this one:

Code:

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/zlib-1.2.8-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


an -r1 is a new slot?

Code:

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


and this one: it looks like the same package.

anyway, is there some big config change that i missed? or are these really separate slots that need manual attention? i hadn't emerged in a few months. here's my info:

Code:

# emerge --info
Portage 2.1.12.13 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.7.1-gentoo x86_64)
=================================================================
System uname: Linux-3.7.1-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:     4047136 total,   1780376 free
KiB Swap:    4209016 total,   3982404 free
Timestamp of tree: Tue, 07 Jan 2014 00:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x11 multimedia roslin x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/multimedia /var/lib/layman/roslin /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi afs alsa amd64 audiofile bash-completion bcmath berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cscope cups curl cxx dbus dga dri dts dv dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gd gdbm gif glut gmp gnutls gphoto2 gpm gstreamer gtk gtk2 gzip iconv ieee1394 imagemagick imap ipv6 jpeg lame latex lcms ldap lm_sensors mad maildir mbox mime mmap mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz mysql ncurses nls nptl nsplugin ntfs offensive ogg opengl openmp oscar oss pam pango pcre pdf perl png policykit ppds python qt3support qt4 quicktime readline rtmp samba sasl scanner sdl session smp spell sqlite sse sse2 ssl startup-notification svg tcpd theora threads tiff tk truetype udev udisks unicode upower usb vim-syntax vnc vorbis win32codecs wxwidgets wxwindows x264 xcb xcomposite xine xinerama xml xpm xscreensaver xv xvid yahoo zlib" ABI_X86="64" ALSA_CARDS="emu10k1" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template topfield toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



thanks!
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1158

PostPosted: Tue Jan 14, 2014 11:18 pm    Post subject: Reply with quote

idoerg wrote:
ulenrich wrote:
Try without libreoffice-bin
or keep going absolutely stable

Unfortunately, emerging without libreoffice-bin did not seem to help. I unmerged libreoffice-bin, and emerged libreoffice. Still being hit by the same conflicts.

Re-emerging libreoffice again should be your last task!!!

Firstly emerge things which you cannot remove
emerge -c -p SOME

means:
Upgrade ebuilds other packages depend on!
What is dependend on libreoffice? Nothing.


@slowdive
you have a lot of ebuilds active on your system which do not exist in official portage tree any more.
What happens if:
emerge --sync
/usr/sbin/perl-cleaner all
emerge portage
emerge -auvDN @system

Then write down a list of old not existing packages you can safely
emerge -c libreoffice
etc ... then try again .... next cycle .....
And last but not least
emerge -c
emerge -auvDN @world

@slowdive,
alternatively, if you know you don't upgrade very often your system, you should try to change to the stable release of Gentoo.
_________________
fun2gen2
Back to top
View user's profile Send private message
slowdive
n00b
n00b


Joined: 01 May 2005
Posts: 34

PostPosted: Wed Jan 15, 2014 4:28 pm    Post subject: Reply with quote

Thanks for the response.

It's a little unclear to me why certain packages need to be uninstalled. For instance, when trying to update libpng, which is one of the slot offenders:

Code:
# emerge -1qav =media-libs/libpng-1.6.8::gentoo
[ebuild     U ] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] media-libs/libpng-1.6.8 [1.5.15] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (app-emulation/wine-1.7.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.5::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/ghostscript-gpl-9.07::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/cinelerra-20120707::gentoo, installed)
    media-libs/libpng:0/0= required by (net-print/cups-filters-1.0.35::gentoo, installed)
    media-libs/libpng:0/0= required by (x11-libs/cairo-1.12.14-r2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/gthumb-3.0.2::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/poppler-0.22.5::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/dvdauthor-0.7.1::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/mjpegtools-2.0.1_rc1-r1::gentoo, installed)
    (and 1 more with the same problems)

  (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge) pulled in by
    =media-libs/libpng-1.6.8::gentoo


Should I uninstall every one of those packages (wine, kdelibs, etc?). If the new libpng has an API change, wouldn't revdep-rebuild catch them? It just seems odd that 1.6.8 doesn't satisfy the dependency of all those packages, resulting in the slot conflict.

Is there something to the :0/0 vs the ::gentoo that I'm missing?

Here's the full output of @system:
Code:

# emerge -uDavNq @system
[ebuild     U ] sys-devel/gnuconfig-20131128 [20130516]
[ebuild     U ] sys-libs/timezone-data-2013i [2013c] USE="nls"
[ebuild     U ] sys-devel/patch-2.7.1-r3 [2.7.1-r1] USE="-static {-test} -xattr"
[ebuild     U ] app-arch/zip-3.0-r2 [3.0-r1] USE="bzip2 crypt unicode -natspec"
[ebuild     U ] sys-apps/debianutils-4.4 [4.3.4] USE="-static"
[ebuild     U ] sys-apps/sysvinit-2.88-r6 [2.88-r5] USE="(-ibm) (-selinux) -static"
[ebuild     U ] app-misc/ca-certificates-20130906 [20130610]
[ebuild     U ] virtual/man-0-r1 [0]
[ebuild     U ] sys-apps/man-pages-3.56 [3.51] USE="nls" LINGUAS="-da -de -fr -it -ja -nl -pl -ro -ru -zh_CN"
[ebuild     U ] app-admin/eselect-python-20131210 [20111108]
[ebuild     U ] x11-misc/xdg-utils-1.1.0_rc1_p20130921 [1.1.0_rc1_p20120916] USE="perl -doc"
[ebuild     U ] dev-db/mysql-init-scripts-2.0_pre1-r6 [2.0_pre1-r3]
[ebuild     U ] app-editors/vim-core-7.4.131 [7.3.1214] USE="acl nls -minimal% (-livecd%)"
[ebuild     U ] app-text/docbook-xsl-stylesheets-1.78.0-r1 [1.78.0] USE="-ruby"
[ebuild     U ] app-text/build-docbook-catalog-1.20 [1.19.1]
[ebuild     U ] dev-libs/libgcrypt-1.6.0 [1.5.2-r1] USE="static-libs"
[ebuild     U ] virtual/perl-libnet-1.230.0 [1.220.0-r1]
[ebuild     U ] media-fonts/dejavu-2.34 [2.33] USE="X -fontforge"
[ebuild   R   ] dev-lang/perl-5.16.3  USE="berkdb gdbm -debug -doc -ithreads (-build%)"
[ebuild     U ] dev-perl/libintl-perl-1.230.0 [1.210.0]
[ebuild     U ] sys-devel/automake-1.14.1 [1.14]
[ebuild     U ] dev-libs/nspr-4.10.2 [4.10] USE="-debug"
[ebuild     U ] sys-apps/kbd-2.0.1 [1.15.5-r1] USE="nls pam {-test%}"
[ebuild     U ] x11-misc/util-macros-1.18.0 [1.17]
[ebuild     U ] sys-apps/coreutils-8.22 [8.21] USE="acl gmp nls -caps (-selinux) -static -vanilla -xattr"
[ebuild     U ] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-proto/xproto-7.0.25 [7.0.24] USE="-doc" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] app-arch/xz-utils-5.0.5-r1 [5.0.5] USE="nls threads -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-proto/xextproto-7.3.0 [7.2.1-r1] USE="-doc" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] dev-libs/expat-2.1.0-r3 [2.1.0-r2] USE="unicode -examples -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] virtual/libiconv-0-r1 [0] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] virtual/jpeg-0-r2 [0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-libs/gdbm-1.11 [1.10] USE="berkdb nls%* -exporter -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-libs/pixman-0.32.4 [0.30.0] USE="mmxext sse2 (-altivec) (-iwmmxt) (-loongson2f) (-neon) -ssse3% -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-proto/videoproto-2.3.2 [2.3.1-r1] ABI_X86="(64) -32 (-x32)"
[ebuild     U ] app-text/libpaper-1.1.24-r2 [1.1.24-r1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] dev-libs/libffi-3.0.13-r1 [3.0.13] USE="-debug -pax_kernel -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] dev-libs/libusb-1.0.9-r2 [1.0.9] USE="-debug -doc -examples% -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-proto/xf86driproto-2.1.1-r1 [2.1.1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-proto/glproto-1.4.17 [1.4.16] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-proto/dri2proto-2.8-r1 [2.8] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-apps/tcp-wrappers-7.6.22-r1 [7.6.22] USE="ipv6 -netgroups -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] media-libs/libpng-1.6.8 [1.5.15] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] media-libs/tiff-4.0.3-r5 [4.0.3-r2] USE="cxx jpeg zlib -jbig -lzma -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-kernel/linux-headers-3.12 [3.9]
[ebuild     U ] virtual/libusb-1-r1 [1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] net-misc/rsync-3.1.0 [3.0.9-r3] USE="acl iconv ipv6 -static -xattr"
[ebuild     U ] dev-lang/tcl-8.6.1-r1 [8.6.0-r1] USE="threads -debug" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-devel/m4-1.4.17 [1.4.16] USE="-examples"
[ebuild     U ] app-portage/portage-utils-0.41 [0.30] USE="-static"
[ebuild     U ] dev-libs/gmp-5.1.3-r1 [5.1.2] USE="cxx -doc -pgo -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-libs/xtrans-1.3.2 [1.2.7] USE="-doc"
[ebuild     U ] media-libs/lcms-2.5-r1 [2.5] USE="jpeg tiff zlib -doc -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] dev-libs/openssl-1.0.1f [1.0.1e-r1] USE="gmp (sse2) tls-heartbeat%* zlib -bindist -kerberos -rfc3779 -static-libs {-test} -vanilla"
[ebuild     U ] dev-libs/mpfr-3.1.2-r1 [3.1.2] USE="-static-libs"
[ebuild     U ] dev-libs/gobject-introspection-common-1.36.0 [1.34.2]
[ebuild     U ] sys-auth/pambase-20120417-r3 [20120417-r2] USE="consolekit cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd"
[ebuild     U ] dev-libs/glib-2.36.4-r1 [2.34.3] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild     U ] dev-util/desktop-file-utils-0.22 [0.21] USE="-emacs"
[ebuild     U ] dev-qt/qtcore-4.8.5-r1 [4.8.4-r5] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch (-c++0x%)"
[ebuild     U ] dev-qt/qtscript-4.8.5 [4.8.4] USE="exceptions iconv jit (-aqua) -debug -pch (-c++0x%)"
[ebuild     U ] dev-qt/qtgui-4.8.5-r1 [4.8.4-r1] USE="accessibility cups exceptions glib mng qt3support tiff xinerama xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace (-c++0x%) (-dbus%*) (-gif%*)"
[ebuild     U ] dev-qt/qtsql-4.8.5 [4.8.4] USE="exceptions mysql qt3support sqlite (-aqua) -debug -firebird -freetds -oci8 -odbc -pch -postgres (-c++0x%)"
[ebuild     U ] dev-qt/qt3support-4.8.5 [4.8.4] USE="accessibility exceptions (-aqua) -debug -pch (-c++0x%)"
[ebuild     U ] x11-libs/libX11-1.6.2 [1.6.0] USE="ipv6 -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] media-libs/freetype-2.5.0.1 [2.4.12] USE="X adobe-cff* bzip2 png%* -auto-hinter -bindist -debug -doc -fontforge -infinality -static-libs -utils" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] sys-apps/dbus-1.6.18-r1 [1.6.12] USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-libs/libXv-1.0.10 [1.0.9] USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] x11-libs/libXmu-1.1.2 [1.1.1-r1] USE="ipv6 -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] x11-libs/libXrandr-1.4.2 [1.4.1] USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] x11-apps/xprop-1.2.2 [1.2.1]
[ebuild     U ] media-libs/fontconfig-2.11.0 [2.10.2-r1] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] dev-libs/dbus-glib-0.100.2-r1 [0.100.2] USE="-debug -doc -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-apps/xset-1.2.3 [1.2.2]
[ebuild     U ] x11-apps/xauth-1.0.8 [1.0.7] USE="ipv6"
[ebuild     U ] x11-apps/mkfontscale-1.1.1 [1.1.0]
[ebuild     U ] dev-lang/tk-8.6.1 [8.6.0] USE="threads truetype xscreensaver (-aqua) -debug {-test}"
[ebuild     U ] net-misc/openssh-6.4_p1-r1 [6.2_p2] USE="X hpn* pam tcpd -X509 -bindist -kerberos -ldap -ldns -libedit (-selinux) -skey -static"
[ebuild     U ] sys-devel/gettext-0.18.3.1-r1 [0.18.2] USE="acl cxx ncurses%* nls openmp -cvs -doc -emacs -git -java -static-libs"
[ebuild     U ] sys-devel/make-4.0-r1 [3.82-r4] USE="nls -guile% -static"
[ebuild     U ] sys-apps/findutils-4.5.12 [4.5.11] USE="nls (-selinux) -static"
[ebuild     U ] sys-devel/binutils-2.24-r1 [2.23.1] USE="cxx nls zlib -multislot -multitarget -static-libs {-test} -vanilla"
[ebuild     U ] sys-apps/attr-2.4.47-r1 [2.4.47] USE="nls -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-libs/e2fsprogs-libs-1.42.9 [1.42.7] USE="nls -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] x11-libs/libXpm-3.5.11 [3.5.10-r1] USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] dev-libs/elfutils-0.158 [0.155] USE="bzip2 nls static-libs threads utils zlib -lzma {-test}" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] app-arch/tar-1.27.1-r1 [1.26-r1] USE="acl%* nls -minimal (-selinux) -static -xattr"
[ebuild  NS   ] sys-devel/gcc-4.8.2 [4.6.3, 4.7.3] USE="cxx fortran mudflap (multilib) nls nptl openmp (-altivec) -awt -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla"
[ebuild     U ] x11-libs/libXaw-1.0.12 [1.0.11-r2] USE="-deprecated -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] dev-lang/python-2.7.6 [2.7.5-r3] USE="gdbm ipv6 ncurses readline sqlite ssl threads tk (wide-unicode) xml -berkdb -build -doc -examples -hardened -wininst"
[ebuild  NS   ] dev-lang/spidermonkey-17.0.0-r1 [1.8.5-r4] USE="-debug -jit -minimal -static-libs {-test}"
[ebuild     U ] dev-python/pygobject-2.28.6-r55 [2.28.6-r53] USE="-examples -libffi {-test}" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U ] dev-libs/gobject-introspection-1.36.0-r1 [1.34.2-r1] USE="cairo%* -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[blocks b     ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4-r1)
[blocks b     ] <dev-libs/gobject-introspection-1.36.0 ("<dev-libs/gobject-introspection-1.36.0" is blocking dev-libs/gobject-introspection-common-1.36.0)
[uninstall    ] dev-lang/vala-0.14.2-r2  USE="vapigen {-test}"
[blocks b     ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)
[ebuild     U ] dev-libs/atk-2.8.0 [2.6.0] USE="introspection nls {-test%}"
[ebuild     U ] dev-lang/python-3.3.3 [3.3.2-r1] USE="gdbm ipv6 ncurses readline sqlite ssl threads tk xml -build -doc -examples -hardened -wininst"
[ebuild     U ] sys-apps/file-5.16 [5.12-r1] USE="python zlib -static-libs" PYTHON_TARGETS="python2_7%* python3_3%* -pypy2_0% -python2_6% -python3_2%"
[ebuild     U ] dev-python/pyelftools-0.21-r4 [0.21-r2] PYTHON_TARGETS="python2_7%* python3_3%* -python2_6% -python3_2%"
[ebuild     U ] dev-python/setuptools-1.1.6 [0.8] PYTHON_TARGETS="python2_7 python3_3* -pypy2_0 -python2_6 -python3_2* (-pypy1_9%) (-python2_5%) (-python3_1%)"
[ebuild     U ] dev-util/gdbus-codegen-2.36.4-r1 [2.34.3] PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python2_5%) (-python3_1%)"
[ebuild     U ] sys-libs/cracklib-2.9.1 [2.9.0] USE="nls python zlib -static-libs {-test%} (-build%)" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild     U ] dev-python/numpy-1.8.0 [1.7.1] USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python2_5%) (-python3_1%)"
[ebuild     U ] sys-libs/pam-1.1.8 [1.1.6-r4] USE="berkdb cracklib nls vim-syntax -audit -debug -nis (-selinux) {-test}"
[ebuild     U ] sys-apps/busybox-1.22.0 [1.21.0] USE="ipv6 pam static -livecd -make-symlinks -math -mdev -savedconfig (-selinux) -sep-usr -syslog -systemd"
[ebuild     U ] x11-libs/libSM-1.2.2 [1.2.1-r1] USE="ipv6 uuid -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U ] app-accessibility/at-spi2-core-2.8.0 [2.6.3] USE="introspection"
[ebuild     U ] app-accessibility/at-spi2-atk-2.8.1 [2.6.2] USE="{-test}"
[ebuild     U ] dev-db/sqlite-3.8.2 [3.7.17] USE="readline secure-delete -debug -doc -icu -static-libs -tcl {-test} (-extensions%*)"
[ebuild     U ] dev-libs/cyrus-sasl-2.1.26-r3 [2.1.26-r1] USE="berkdb gdbm mysql pam sqlite ssl -authdaemond -java -kerberos -ldapdb -openldap -postgres -sample -srp -static-libs -urandom"
[ebuild     U ] dev-libs/libpcre-8.34 [8.33] USE="bzip2 cxx jit readline recursion-limit (unicode) zlib -libedit -pcre16 -pcre32 -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] app-text/qpdf-5.1.0 [5.0.0] USE="-doc -examples -static-libs {-test}"
[ebuild     U ] sys-apps/grep-2.16 [2.14] USE="nls pcre -static%"
[ebuild     U ] dev-lang/swig-2.0.11 [2.0.9] USE="pcre -ccache -doc"
[ebuild   R   ] media-libs/lcms-1.19-r1  USE="jpeg python tiff zlib -static-libs" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python2_5%)"
[ebuild     U ] x11-libs/cairo-1.12.16 [1.12.14-r2] USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers -openvg (-qt4) -static-libs -valgrind% -xlib-xcb%"
[ebuild     U ] media-libs/harfbuzz-0.9.23 [0.9.18-r1] USE="cairo glib graphite truetype -icu* -introspection% -static-libs"
[ebuild     U ] x11-libs/pango-1.34.1 [1.32.5] USE="X introspection -debug"
[ebuild     U ] net-libs/gnutls-3.2.8 [3.2.1-r1] USE="cxx nls zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN"
[ebuild     U ] net-nds/openldap-2.4.38-r1 [2.4.35] USE="berkdb crypt gnutls ipv6 minimal perl samba sasl ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -kerberos -odbc -overlays (-selinux) -slp -smbkrb5passwd"
[ebuild     U ] media-video/rtmpdump-2.4_p20131018 [2.4] USE="gnutls ssl (-polarssl)"
[ebuild     U ] net-misc/wget-1.14-r1 [1.14] USE="gnutls ipv6 nls pcre ssl zlib -debug -idn -ntlm -static -uuid"
[ebuild     U ] net-misc/curl-7.34.0-r1 [7.31.0] USE="ipv6 ldap rtmp ssl threads -adns -idn -kerberos -metalink -ssh -static-libs {-test}" CURL_SSL="openssl -axtls -cyassl -gnutls -nss -polarssl"
[ebuild     U ] net-print/cups-1.7.1 [1.6.2-r5] USE="X acl dbus gnutls pam python ssl threads usb -debug -java -kerberos -lprng-compat (-selinux) -static-libs -xinetd -zeroconf (-filters%*)" LINGUAS="ca es fr it%* ja ru" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild     U ] dev-vcs/git-1.8.5.3 [1.8.3.2] USE="blksha1 curl gpg gtk iconv nls pcre perl python threads tk webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -mediawiki% (-ppcsha1) -subversion {-test} -xinetd" PYTHON_SINGLE_TARGET="python2_7 -python2_6 (-python2_5%)" PYTHON_TARGETS="python2_7 -python2_6 (-python2_5%)"
[ebuild   R   ] x11-libs/libdrm-9999  USE="libkms -static-libs" ABI_X86="(64%*) -32% (-x32)" VIDEO_CARDS="radeon (-exynos) (-freedreno) -intel -nouveau (-omap) -vmware"
[ebuild     U ] app-text/poppler-0.24.5 [0.22.5] USE="cairo curl cxx introspection jpeg lcms png qt4 tiff utils -cjk -debug -doc -jpeg2k"
[ebuild     U ] x11-libs/gtk+-2.24.22 [2.24.20] USE="cups introspection vim-syntax xinerama (-aqua) -debug -examples {-test}"
[ebuild     U ] app-text/ghostscript-gpl-9.10 [9.07] USE="X cups dbus gtk -bindist -djvu -idn -static-libs (-jpeg2k%)" LINGUAS="-de -ja -ko -zh_CN -zh_TW"
[ebuild     U ] net-print/cups-filters-1.0.43-r1 [1.0.35] USE="dbus%* foomatic%* jpeg perl png tiff -static-libs -zeroconf"
[blocks b     ] <net-print/cups-filters-1.0.36-r2 ("<net-print/cups-filters-1.0.36-r2" is blocking app-text/ghostscript-gpl-9.10)
[uninstall    ] net-print/foomatic-filters-4.0.17  USE="cups dbus"
[blocks b     ] net-print/foomatic-filters ("net-print/foomatic-filters" is blocking net-print/cups-filters-1.0.43-r1)
[ebuild     U ] x11-misc/shared-mime-info-1.2-r1 [1.1] USE="{-test}"
[ebuild     U ] x11-libs/gtk+-3.8.7 [3.6.3-r2] USE="X cups introspection vim-syntax xinerama (-aqua) -colord -debug -examples (-packagekit) {-test} -wayland (-egl%)"
[ebuild     U ] app-shells/bash-4.2_p45-r1 [4.2_p45] USE="afs net nls (readline) -bashlogger -examples -mem-scramble -plugins -vanilla"
[ebuild     U ] sys-auth/polkit-0.112-r1 [0.111] USE="gtk introspection nls pam -examples -kde (-selinux) -systemd"
[ebuild     U ] sys-apps/texinfo-5.2 [5.1] USE="nls -static"
[ebuild     U ] app-editors/vim-7.4.131 [7.3.1214] USE="X acl cscope gpm nls perl python -debug -lua% -luajit% -minimal -racket% -ruby (-selinux) -tcl% -vim-pager" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3 (-python2_5%) (-python3_1%)" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python2_5%) (-python3_1%)"
[ebuild  N    ] app-vim/eselect-syntax-20070506
[ebuild     U ] app-admin/eselect-1.4 [1.3.6] USE="vim-syntax%* -doc -emacs%"
[ebuild     U ] x11-proto/xcb-proto-1.9-r1 [1.8-r3] ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python2_5%) (-python3_1%)"
[ebuild     U ] x11-libs/libxcb-1.9.3-r1 [1.9.1] USE="-doc (-selinux) -static-libs -xkb" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="(-python2_6%) (-python2_7%*) (-python3_1%) (-python3_2%) (-python3_3%)" PYTHON_TARGETS="(-python2_6%) (-python2_7%*) (-python3_1%) (-python3_2%*) (-python3_3%)"
[ebuild     U ] x11-libs/xpyb-1.3.1-r3 [1.3.1-r2] USE="(-selinux) -static-libs" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild   R   ] dev-python/pycairo-1.10.0-r4  USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python3_1%)"
[ebuild     U ] dev-python/pygtk-2.24.0-r4 [2.24.0-r3] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U ] sys-process/psmisc-22.21 [22.20] USE="X ipv6 nls (-selinux)"
[ebuild     U ] sys-process/procps-3.3.9 [3.3.8] USE="ncurses nls unicode -static-libs"
[ebuild   R   ] dev-libs/libxslt-1.1.28-r1  USE="crypt python -debug -static-libs" PYTHON_TARGETS="python2_7 -python2_6 (-python2_5%)"
[ebuild     U ] sys-apps/kmod-16 [14] USE="openrc%* tools zlib -debug -doc -lzma -static-libs"
[ebuild     U ] app-crypt/gnupg-2.0.22 [2.0.20] USE="bzip2 ldap nls readline usb -adns -doc -mta (-selinux) -smartcard -static"
[ebuild     U ] dev-util/cmake-2.8.12.1-r3 [2.8.11.1] USE="ncurses qt4 -emacs (-qt5) {-test} (-vim-syntax%*)"
[ebuild     U ] dev-libs/libxml2-2.9.1-r2 [2.9.1-r1] USE="ipv6 python readline -debug -examples -icu -lzma -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2* (-python2_5%) (-python3_1%)"
[ebuild     U ] sys-devel/autogen-5.18.1 [5.17.4] USE="-libopts -static-libs"
[ebuild     U ] sys-libs/ncurses-5.9-r3 [5.9-r2] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-libs/readline-6.2_p5-r1 [6.2_p4] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="(-selinux) -static-libs" ABI_X86="(64%*) -32% (-x32)"
[ebuild   R   ] sys-apps/gawk-4.1.0  USE="nls readline -mpfr%"
[ebuild     U ] sys-apps/less-462 [460] USE="pcre unicode"
[ebuild     U ] sys-devel/llvm-3.4 [3.2] USE="libffi ncurses%* python%* static-analyzer%* xml%* -clang% -debug -doc -gold -multitarget -ocaml {-test} -udis86 (-vim-syntax%*)" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* -pypy2_0% -python2_6%" VIDEO_CARDS="radeon%*"
[ebuild     U ] app-crypt/pinentry-0.8.3 [0.8.2] USE="gtk ncurses qt4 -caps -static"
[ebuild   R   ] media-libs/mesa-9999  USE="classic egl gallium llvm nptl -bindist -debug -gbm -gles1 -gles2 -opencl% -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xorg -xvmc (-shared-glapi%*)" ABI_X86="(64%*) -32% (-x32)" PYTHON_SINGLE_TARGET="(-python2_6%) (-python2_7%*)" PYTHON_TARGETS="(-python2_6%) (-python2_7%*)" VIDEO_CARDS="radeon (-freedreno) -i915 -i965 -ilo% -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi -vmware"
[ebuild     U ] sys-apps/openrc-0.12.4 [0.11.8] USE="ncurses netifrc%* pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools%"
[blocks b     ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking sys-apps/kmod-16, net-misc/netifrc-0.1)
[blocks b     ] net-misc/netifrc ("net-misc/netifrc" is blocking sys-apps/openrc-0.11.8)
[ebuild  N    ] net-misc/netifrc-0.1
[ebuild  N    ] virtual/service-manager-0  USE="(-prefix)"
[ebuild     U ] sys-fs/udev-208 [205] USE="acl firmware-loader gudev introspection kmod openrc -doc (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] virtual/udev-208 [200] USE="gudev introspection kmod (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ] sys-apps/hwids-20140103 [20130707] USE="udev"
[ebuild     U ] sys-apps/util-linux-2.24 [2.23.1] USE="bash-completion cramfs ncurses nls pam%* python%* suid udev unicode -caps -cytune -fdformat (-selinux) -slang -static-libs {-test} -tty-helpers (-old-linux%)" PYTHON_SINGLE_TARGET="python2_7%* -python3_2% -python3_3%" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2%"
[ebuild     U ] sys-auth/consolekit-0.4.6 [0.4.5_p20120320-r2] USE="acl pam policykit -debug -doc (-selinux) -systemd-units% {-test}"
[ebuild     U ] sys-fs/e2fsprogs-1.42.9 [1.42.7] USE="nls -static-libs"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (app-emulation/wine-1.7.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.5::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/poppler-0.22.5::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/cinelerra-20120707::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/gthumb-3.0.2::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/dvdauthor-0.7.1::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/mjpegtools-2.0.1_rc1-r1::gentoo, installed)
    (and 1 more with the same problems)

  (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge)
    media-libs/libpng[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/freetype-2.5.0.1::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.24.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.22.5::gentoo, installed) pulled in by
    app-text/poppler:0/37=[qt4] required by (app-office/texmaker-4.0.2::gentoo, installed)
    app-text/poppler:0/37=[cairo] required by (mail-client/claws-mail-3.9.2::gentoo, installed)
    app-text/poppler:0/37=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
    >=app-text/poppler-0.20:0/37=[cairo] required by (app-text/evince-3.6.1::gentoo, installed)
    (and 2 more with the same problems)

media-libs/harfbuzz:0

  (media-libs/harfbuzz-0.9.18-r1::gentoo, installed) pulled in by
    >=media-libs/harfbuzz-0.9.10:0/0.9.18=[icu(+)] required by (app-office/libreoffice-4.1.0.2::gentoo, installed)

  (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-editors/vim-core:0

  (app-editors/vim-core-7.4.131::gentoo, ebuild scheduled for merge) pulled in by
    ~app-editors/vim-core-7.4.131 required by (app-editors/vim-7.4.131::gentoo, ebuild scheduled for merge)

  (app-editors/vim-core-7.3.1214::gentoo, installed) pulled in by
    ~app-editors/vim-core-7.3.1214 required by (app-editors/gvim-7.3.1214::gentoo, installed)

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.2-r1::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (app-crypt/gcr-3.6.2::gentoo, installed)
    (and 1 more with the same problem)

  (dev-libs/libgcrypt-1.6.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.9::gentoo, installed)
    >=dev-lang/perl-5.8.2-r1[-build] required by (net-im/pidgin-2.10.7-r2::gentoo, installed)

dev-db/sqlite:3

  (dev-db/sqlite-3.8.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-db/sqlite-3.7.17::gentoo, installed) pulled in by
    >=dev-db/sqlite-3.3.8:3[extensions] required by (dev-python/pysqlite-2.6.3::gentoo, installed)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, installed)
    (and 11 more with the same problem)

  (dev-qt/qtcore-4.8.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-4.8.5:4[accessibility,dbus(+)] required by (sys-auth/polkit-kde-agent-0.99.0-r1::gentoo, installed)
    ~dev-qt/qtgui-4.8.5[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.5-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problems)

  (dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    (and 6 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 1 more with the same problem)

  (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r1::gentoo, ebuild scheduled for merge)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.4::gentoo, installed)
    (and 1 more with the same problem)

  (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r1::gentoo, ebuild scheduled for merge)

  (dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 1 more with the same problem)

dev-python/setuptools:0

  (dev-python/setuptools-1.1.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/numpy-1.8.0::gentoo, ebuild scheduled for merge)

  (dev-python/setuptools-0.8::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (dev-python/python-distutils-extra-2.37-r1::gentoo, installed)



Thanks for the help.
Back to top
View user's profile Send private message
slowdive
n00b
n00b


Joined: 01 May 2005
Posts: 34

PostPosted: Wed Jan 15, 2014 4:57 pm    Post subject: slot conflict: use --ignore-built-slot-operator-deps=y Reply with quote

From scanning the forums for complaints about slots and libpng, it looks like other people have similar problems:

http://forums.gentoo.org/viewtopic-t-981228.html
http://forums.gentoo.org/viewtopic-t-981158.html
http://forums.gentoo.org/viewtopic-t-981120.html

for two of my more offensive slot conflicts (libpng and poppler), i managed to emerge them with the --ignore-built-slot-operator-deps=y flag (which was mentioned in those other posts, and is meant for debugging).

that allowed me to update the package "manually", by ignoring any slot complaints. with those two (and a manual update of sys-apps/sysvinit), i'm able to get a full build plan for @system. Once that's done, i'll try a similar approach with @world: if any package complains about slot conflicts, use the --ignore-built-slot-operator-deps=y flag, and report if it worked out or not.

anyway, based on the recent threads of people with similar problems and the requirement to use debugging flags, maybe this is a more widespread problem? either in portage or in people's understanding of slots (i'm not 100% sure about the notation/lingo/usage of slots).
Back to top
View user's profile Send private message
slowdive
n00b
n00b


Joined: 01 May 2005
Posts: 34

PostPosted: Wed Jan 15, 2014 6:24 pm    Post subject: No luck Reply with quote

After an emerge -u @system, i tried @world. ran into issues with emul-linux packages that are unresolvable even with the magic --ignore flag.

Code:
# emerge -1avq --ignore-built-slot-operator-deps=y =virtual/python-argparse-1::gentoo =app-emulation/emul-linux-x86-baselibs-20131008-r8::gentoo =app-emulation/emul-linux-x86-xlibs-20131008::gentoo =app-emulation/emul-linux-x86-db-20131008::gentoo =app-emulation/emul-linux-x86-soundlibs-20131008-r2::gentoo =app-emulation/emul-linux-x86-medialibs-20131008-r1::gentoo
[ebuild     U ] app-emulation/emul-linux-x86-baselibs-20131008-r8 [20130224] USE="development" ABI_X86="-32%"
[ebuild     U ] app-emulation/emul-linux-x86-db-20131008 [20130224] USE="development"
[ebuild   R   ] virtual/python-argparse-1  PYTHON_TARGETS="python2_7 python3_3* -pypy2_0 -python2_6 -python3_2* (-pypy1_9%) (-python2_5%) (-python3_1%)"
[ebuild     U ] app-emulation/emul-linux-x86-xlibs-20131008 [20130224] USE="(development) opengl" ABI_X86="-32%"
[ebuild     U ] app-emulation/emul-linux-x86-medialibs-20131008-r1 [20130224-r2] USE="development" ABI_X86="-32"
[ebuild     U ] app-emulation/emul-linux-x86-soundlibs-20131008-r2 [20130224-r4] USE="alsa development -pulseaudio%" ABI_X86="-32"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/emul-linux-x86-baselibs:0

  (app-emulation/emul-linux-x86-baselibs-20130224::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20130224 required by (app-emulation/emul-linux-x86-gtklibs-20130224::gentoo, installed)
    (and 5 more with the same problem)

  (app-emulation/emul-linux-x86-baselibs-20131008-r8::gentoo, ebuild scheduled for merge) pulled in by
    =app-emulation/emul-linux-x86-baselibs-20131008-r8::gentoo
    (and 4 more with the same problem)

app-emulation/emul-linux-x86-xlibs:0

  (app-emulation/emul-linux-x86-xlibs-20130224::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224-r2::gentoo, installed)
    (and 1 more with the same problem)

  (app-emulation/emul-linux-x86-xlibs-20131008::gentoo, ebuild scheduled for merge) pulled in by
    =app-emulation/emul-linux-x86-xlibs-20131008::gentoo
    (and 1 more with the same problem)

app-emulation/emul-linux-x86-db:0

  (app-emulation/emul-linux-x86-db-20131008::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-db-20131008 required by (app-emulation/emul-linux-x86-medialibs-20131008-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (app-emulation/emul-linux-x86-db-20130224::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-db-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224-r2::gentoo, installed)
    (and 1 more with the same problem)

app-emulation/emul-linux-x86-soundlibs:0

  (app-emulation/emul-linux-x86-soundlibs-20131008-r2::gentoo, ebuild scheduled for merge) pulled in by
    =app-emulation/emul-linux-x86-soundlibs-20131008-r2::gentoo
    (and 1 more with the same problem)

  (app-emulation/emul-linux-x86-soundlibs-20130224-r4::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-gstplugins-20130224::gentoo, installed)
    (and 1 more with the same problem)

app-emulation/emul-linux-x86-medialibs:0

  (app-emulation/emul-linux-x86-medialibs-20130224-r2::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-medialibs-20130224 required by (app-emulation/emul-linux-x86-gstplugins-20130224::gentoo, installed)
    (and 1 more with the same problem)

  (app-emulation/emul-linux-x86-medialibs-20131008-r1::gentoo, ebuild scheduled for merge) pulled in by
    =app-emulation/emul-linux-x86-medialibs-20131008-r1::gentoo
    (and 1 more with the same problem)


Any ideas?
Back to top
View user's profile Send private message
Meet Joe Black
n00b
n00b


Joined: 19 Mar 2005
Posts: 20

PostPosted: Wed Jan 15, 2014 9:45 pm    Post subject: Reply with quote

Try to emerge -Cp all this app-emulation/emul-linux-x86-* packages. It was the thing that helped me earlier. I have a lot of slot conflicts too while upgrading. And portage became an awful shit with its 2.0 version. It takes several minutes to do "emerge -1uDNp @system" or "emerge -1uDNp @world" and this is completely unbearable. I wanna destroy those who introduced all that crap with 2.0 portage!

That's what "emerge -1uDN @system" gives me:
Code:
Total: 71 packages (52 upgrades, 1 downgrade, 5 new, 1 in new slot, 12 reinstalls, 1 uninstall), Size of downloads: 225,473 kB
Conflict: 4 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.6.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/libpng-1.5.17-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libpng:0/0= required by (media-libs/openjpeg-1.5.1::gentoo, installed)
    media-libs/libpng:0/0= required by (dev-qt/qtgui-4.8.5-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/mjpegtools-2.1.0::gentoo, installed)

sys-apps/dbus:0

  (sys-apps/dbus-1.6.12::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-apps/dbus-1.6.18-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.6.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/dbus-glib-0.100.2-r1::gentoo, ebuild scheduled for merge)

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

dev-python/setuptools:0

  (dev-python/setuptools-0.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/setuptools-0.8-r1::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/numpy-1.7.1::gentoo, installed)
    dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (dev-python/pygments-1.6::gentoo, installed)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-Getopt-Long-2.380.0-r2::gentoo, installed)
    >=dev-lang/perl-5.16 required by (dev-perl/XML-NamespaceSupport-1.110.0::gentoo, installed)
    (and 93 more with the same problems)

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by gnome-base/gconf-2.32.4-r1
# required by media-plugins/gst-plugins-gconf-0.10.31
# required by net-im/pidgin-2.10.7-r4[gstreamer]
# required by @selected
# required by @world (argument)
=sys-apps/dbus-1.6.18-r1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- dev-dotnet/gtk-sharp-2.12.21-r1::dotnet (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (09 Jan 2014)
# Monolithic dev-dotnet/{gnome,gtk}-sharp introduction mask, see bug #382491.

- dev-dotnet/gtk-sharp-2.99.1::dotnet (masked by: package.mask)
- kde-base/solid-4.10.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Johannes Huber <johu@gentoo.org> (14 Dec 2013)
# Masked for removal in 30 days. Not packaged in current
# stable KDE SC 4.11 and later.

- dev-dotnet/gnome-sharp-2.24.2-r1::dotnet (masked by: package.mask)
- sys-kernel/module-rebuild-0.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (28 Dec 2013)
# Replaced by 'emerge @module-rebuild' set in Portage itself.
# Removal in 30 days, see http://bugs.gentoo.org/410739

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

And this is a usual time of emerge -1uDNp @system on modern CPU with 4 cores:
Code:
real    5m11.183s
user    5m4.665s
sys     0m6.294s

I'm trying to update my system second day without success.
_________________
Some strange sentences ? Grammar mistakes ?
I'll be happy if you write a short PM, I always try to improve my English.
Back to top
View user's profile Send private message
slowdive
n00b
n00b


Joined: 01 May 2005
Posts: 34

PostPosted: Thu Jan 16, 2014 7:17 am    Post subject: Reply with quote

Meet Joe Black wrote:
Try to emerge -Cp all this app-emulation/emul-linux-x86-* packages. It was the thing that helped me earlier.


thanks for the advice - i'll try that out when i get to it. i've been plugging along, using the --ignore-built-slot-operator-deps=y flag when things fail to install (anything with a slot conflict). when that fails, i install it with --nodeps. at that point, i (think i) know what i want to install, so i just force it.

with the occasional --nodeps, i got to the point that emerge -uDavq @system gave me a list of things to build without conflict. we'll see how that goes.

Quote:

And this is a usual time of emerge -1uDNp @system on modern CPU with 4 cores:
Code:
real    5m11.183s
user    5m4.665s
sys     0m6.294s

I'm trying to update my system second day without success.


yeah, that's pretty rough. mine is really slow too. i noticed it's single core, so i have a couple tabs that i run different emerges in at the same time to get some parallelism. but still - it is much slower than in the old days (presumably it needs to figure out all these slot conflicts for us to solve!).

i have a couple other gentoo machines that need updating. i think i might just skip updating those - i don't have time to go through and manually install every library, especially on slower hardware. if it's going to be as painful as a reinstall, i don't see it getting any harder.
Back to top
View user's profile Send private message
slowdive
n00b
n00b


Joined: 01 May 2005
Posts: 34

PostPosted: Fri Jan 17, 2014 2:09 am    Post subject: Slot conflicts averted Reply with quote

I ended up not needing to uninstall the emul-* packages. Using --nodeps on specific libraries worked out as a method of last resort.

For libpng, eventually I had packages that insisted on the old 1.5, so I forced the installation of the 1.5 slot:

Code:
emerge -1avq libpng:0 libpng:1.5


I don't know exactly how the separate slots work, but I did notice the ebuild for libpng-1.5.17-r15 has SLOT="1.5", so it looks like this version was kept around to resolve some of these issues.

Other than that, I'm mostly through a -uDavN world with no issues. (And one of my other machines didn't need many --nodeps either).
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1158

PostPosted: Fri Jan 17, 2014 11:18 am    Post subject: Reply with quote

My proposal to forcefully purge ebuilds is meant as a workaround to get a cleaned up and small portage feedback which you can handle :)

If such packages would have to rebuild or upgraded it is just the same compile work when purging at first :)

Most packages are small and do fastly recompile :)

but the big ones (firefox , chromium etc) do need recompilations anyway
when there was upgraded boost, icu, sqlite .... :(
_________________
fun2gen2
Back to top
View user's profile Send private message
thawn
n00b
n00b


Joined: 31 Aug 2004
Posts: 39

PostPosted: Sun Aug 24, 2014 5:39 pm    Post subject: --backtrace=30 solved it for me Reply with quote

For me adding "--backtrack=30" to the emerge command solved the issue:

Code:
emerge -uDNav --backtrack=30 world
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum