Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can not start gnome
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 8:57 am    Post subject: can not start gnome Reply with quote

Hi,

I have just installed gentoo for the first time and now trying install gnome desktop:
I did all instructions according this link: https://wiki.gentoo.org/wiki/GNOME/Configuration with DISPLAYMANAGER="gdm" (not .xinitrc)
and gnome does not start. After writing startx three small GUI screens showing up so i assume it is ok.
what is missing? If there is any needed output or added info please let me know and i will put it here.
Please advise!

Regards
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 9:37 am    Post subject: Reply with quote

Did you also enable the login manager to start up at boot?

Code:
rc-update add xdm default


enables to start up x at boot with the display manager set with the DISPLAYMANGER variable.

You can also manually start it with:

Code:
/etc/init.d/xdm start


If that does not work, what happens if you try to start gdm manually? (just type "gdm" as root in th console)
Back to top
View user's profile Send private message
chi86
n00b
n00b


Joined: 30 Jul 2013
Posts: 39
Location: Austria

PostPosted: Mon Dec 30, 2013 9:51 am    Post subject: Reply with quote

HI,

the 3 small GUI's sound like twm or/and xterm, to get rid of it

Code:
emerge --unmerge twm xterm


If you installed Gnome 3:

http://wiki.gentoo.org/wiki/GNOME/3.8-upgrade-guide

...
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 10:05 am    Post subject: Reply with quote

Kompi wrote:
Did you also enable the login manager to start up at boot?

Code:
rc-update add xdm default


enables to start up x at boot with the display manager set with the DISPLAYMANGER variable.

You can also manually start it with:

Code:
/etc/init.d/xdm start


If that does not work, what happens if you try to start gdm manually? (just type "gdm" as root in th console)


Yes - i have done all the above. when i type gdm i get blank line and nothing happens.
i canceld the three gui screens as you said and now when i type startx i get many lines one of them: xinit: connection to X server lost
I installed standard gnome - not gnome 3.
Please advise!

Thanks


Last edited by pmam on Mon Dec 30, 2013 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 10:10 am    Post subject: Reply with quote

hmm if after you type gdm nothing happens, that suggests that for some reason the X server did not start, even though it seems to work if you do it manually.

Try to have a look at the /var/log/Xorg.0.log file after you typed gdm. This is the log file of the X server. Any line that has a (EE) at the beginning indicates an error that may have prevented the X server from starting up. If there is something, please post thoose lines (or the entire file) here.
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 10:27 am    Post subject: Reply with quote

Kompi wrote:
hmm if after you type gdm nothing happens, that suggests that for some reason the X server did not start, even though it seems to work if you do it manually.

Try to have a look at the /var/log/Xorg.0.log file after you typed gdm. This is the log file of the X server. Any line that has a (EE) at the beginning indicates an error that may have prevented the X server from starting up. If there is something, please post thoose lines (or the entire file) here.


without GUI it is not easy to add outputs but i will try...
in the log file the are some EE lines but it seems to me that it is only in the startup, and afterward it is ok - but there are good chances that i am wrong :) -
EE lines are: failed to load modules: nv, vesa, modesetting, fbdev

Thanks
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 10:37 am    Post subject: Reply with quote

hmm, that could just mean that the X-server is trying to probe your graphics card with different drivers until it find the right one (no problem there) or you do not have the appropriate X driver installed for your graphics card.

If you did not already, try re-merging the xorg-drivers package with the correct VIDEO_CARDS settings in /etc/make.conf, as described in https://wiki.gentoo.org/wiki/Xorg/Configuration#make.conf_configuration

What is your graphics card?
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 10:54 am    Post subject: Reply with quote

my graphics card is nvidia - i compiled the kernel with genkernel --menuconfig all and consequently defined in the menuconfig 'nouveau' driver as a module M -
rather than *.

re-emerge - do you mean to type again: emerge xorg-server?


Last edited by pmam on Mon Dec 30, 2013 11:00 am; edited 1 time in total
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 10:58 am    Post subject: Reply with quote

Ok, that sounds correct for the kernel. You also need the user space drivers for the X server though.

Did you add the line:

Code:
VIDEO_CARDS="nouveau"


to your /etc/portage/make.conf?

This will tell portage to merge the package x11-drivers/xf86-video-nouveau.

If you have not yet, then add the line and re-merge:

emerge -1av x11-base/xorg-drivers

and make sure "nouveau" is in the list.
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 11:12 am    Post subject: Reply with quote

yes - i have the line VIDEO_CARDS="nouveau".
the output of emerge -1av x11-base/xorg-drivers has two RED drivers: "evdev" and "nouveau" and alot of BLUE drivers -
what should i do - to merge or not?
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 11:22 am    Post subject: Reply with quote

hum okay if they are red (without a leading "-") then you already have all you need.

Hmm, hard to say without the Xorg log file, but as your X server did start with startx, I guess then your X server is okay.

I guess then it is really a problem with gdm. Two ideas I have on this:

edit your /etc/gdm/custom.conf file and add the following to the [debug] section:

Code:
[debug]
Enable=true


This should give you more output from gdm about what went wrong. You will probably find some info in /var/log/messages from gdm. Try the following to grep all gdm related messages:

Code:
cat /var/log/messages | grep gdm


Hopefully this will give us a clue what is going on.


Another thing to try is to start gnome manually. Try the following:

Code:
startx


you get your basic x server with the three terminal windows. type "gnome-session" in on of the terminals. This should give a gnome session, so you at least have a GUI to work with for now. (if there are any errors this may be related to gnome not beeing properly started via gdm, you can ignore that).

From here you may have an easier way to start a browser and copy and paste the log files.

Edit: if you cannot start gnome this way and there are any errors that may indicate whats going on, that may be interesting as well of course.
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 11:47 am    Post subject: Reply with quote

just a moment - i want to correct my earlier comment - i assumed that startx is ok due to the three GUI screens that showed up after typing startx -
however, during this discussion i unmerge twm xterm (as suggested to me) and now when i type startx i get blank line - so i do not know if it is ok or not.
in addition: the coomand i typed to install xorg is according to the above link: emerge --ask xorg-server - but not x11-base - if it is important...
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 12:00 pm    Post subject: Reply with quote

after adding enable=true when i type gdm i get: "lost GDM name on bus.
disconnected from D-Bus." we may need to check this issue: D-Bus...
cat /var/log... does not get any output.
i unmerge twm and i do not have the three terminal screens now -
so cannot start gnome-session from there.
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 12:22 pm    Post subject: Reply with quote

hmm, maybe dbus is not running?! It should have been pulled in by the /etc/init.d/xdm, but lets try:

Code:
/etc/init.d/dbus start


before starting gdm. If that helps, enable dbus in boot with:

Code:
rc-update add dbus
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 12:35 pm    Post subject: Reply with quote

pmam wrote:
just a moment - i want to correct my earlier comment - i assumed that startx is ok due to the three GUI screens that showed up after typing startx -
however, during this discussion i unmerge twm xterm (as suggested to me) and now when i type startx i get blank line - so i do not know if it is ok or not.
in addition: the coomand i typed to install xorg is according to the above link: emerge --ask xorg-server - but not x11-base - if it is important...


That should be okay, as twm / xterm is the fallback for the xserver to start anything if nothing else is specified in any xinitrc. As thoose programs aren't there any more I guess the X-server just cannot start anything and exists. You can re-emerge those of course if you still want to try my start gnome manually suggestion from above. Having them is no problem.

the "x11-base" is not important. It is only more specific. The package name is "x11-base/xorg-server", but portage understands "xorg-server" just as well. The subdirectory prefix is only neccessary if there are two packages in different directories with the same name.


If the dbus thing from above does not help, I have yet another idea: You could try starting a different login manager than gdm. If that works, we know for sure that its a problem with gdm. You could use lightdm:

Code:
emerge -a lightdm


and then try start that:

Code:
lightdm


If that works, we know for sure that somethings wrong with gdm.
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 12:39 pm    Post subject: Reply with quote

no - it is written that dbus already running..
should i re-emerge twm and xterm so i will get again the three terminals?
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 12:46 pm    Post subject: Reply with quote

yes, can't hurt, especially if it works you will at least have a way to get GNOME running for now, so you have GUI.

And try it with lightdm (my last post).
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 12:57 pm    Post subject: Reply with quote

i re-emerge twm and xterm but i do not know why not have three terminals now..
lightdm give the same result.
but when i check again the xorg log file i see now something suspicious:
"EE nouveau (0) failed to set drm interface version
error openning the drm
835
screen found but none have usable configuration"

thanks for your clear explanations - at least i understand where am I... :)
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 1:13 pm    Post subject: Reply with quote

ok - now the three terminals return - i type gnome-session and there are a lot of warnings
and afterward there is a big screen with a comment: Oh no! Something has gone wrong... log out
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 1:22 pm    Post subject: Reply with quote

okay, I guess we get closer to the problem. This probably means that the Xorg nouveau driver has some kind of trouble communication with the kernel nouveau driver.

I could think of three reasons for that:

1. the noveau kernel module is not loaded

try
Code:
lsmod | grep nouveau

if there is no output, it isn't loaded. Otherwise it should be something like:
Quote:
nouveau 640633 5

If there is nothing, you need to load the nouveau module:
Code:
modprobe nouveau

To do that at boot time, add a file to /etc/modules.load.d/. Name it for example /etc/modules.load.d/nouveau.conf and put one line in that file:
Code:
nouveau


2. the nouveau kernel moduie is loaded, but another driver is used as frame buffer driver

The text console can have higher resolution if a so called frame buffer driver is used. With an nvidia card the nouveau driver must be used for that in order to be compatible with the Xorg driver.

It may be that either the generic "vesafb" driver is beeing used, or you have compiled in the "nvidiafb" driver in the kernel.

To get all this right, check that you have the following set in the kernel config:

Code:
Device Drivers --> Graphics Support -->
<M> Direct Rendering Manager
<M> Niveau (nvidia) cards


(can also be compiled in with *)

and have NOT set:

Code:
Device Drivers --> Graphics Support --> Support for frame buffer devices -->
< > nvidia Framebuffer Support
< > nvidia Riva support


also, any of the VGA/VESA drivers in that section are not needed, you can uncheck them as well.

If any of that was different, change it and recompile the kernel.

Now, to be sure, boot with the kernel parameter "nouveau.modeset=1" which forces the kernel to use nouveau for the text console. It should happen automatically, but this makes sure this one is used. (you can set kernel parameters in your /boot/grub/grub.conf)


3. version mismatch between kernel driver and xorg driver

If none of the above is the problem, then maybe you have a very recent kernel version but the nouveau driver is too old. I don't think there should be any incompatibility in recent versions. Especially if you are just using the current stable versions in the portage tree, this should not be an issue. But if none of the above helped, have a look which versions are installed:

Code:
emerge -pv xf86-video-nouveau gentoo-sources


should tell you the installed versions.
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 1:25 pm    Post subject: Reply with quote

pmam wrote:
ok - now the three terminals return - i type gnome-session and there are a lot of warnings
and afterward there is a big screen with a comment: Oh no! Something has gone wrong... log out


ok that means xserver is not starting without the nouveau drm error? Well then, maybe it is possible to start lightdm or gdm now?
Back to top
View user's profile Send private message
sling
n00b
n00b


Joined: 28 Nov 2004
Posts: 16
Location: Singapore

PostPosted: Mon Dec 30, 2013 1:28 pm    Post subject: Reply with quote

I am having a similar problem with slim (or kdm) and it has been reported before in http://forums.gentoo.org/viewtopic-t-979602.html. I had a perfectly working system up to the 22nd/23rd December and after a system restart, xdm with slim as windows manager would fail to connect to the xorg-server and the system would stuck on a black screen. Starting X from the console with startx works and I can get into kde or lxde via an appropriate ~/.xinitrc, but no consolekit session would be running. rc-status and ps afx both report Dbus and consolekit processes to be running. As far as I can tell, there are no obvious error messages in the Xorg.0.log and the slim.log reports:

Code:
slim: waiting for X server to begin accepting connections
slim: open_session: Unable to open session: Unable to get information about the calling process


xdm.log reports:
Code:
xdm error (pid .....): fatal IO error 11 (Resource temporarily unavailable)
XIO : Fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
         after 104 requests (73 known processed) with 0 events remaining.
xdm error (pid .....): Server crash frequency too high: stopping display :0


Using xdm with kdm as WDM, I get into the kdm login menue, but upon entering the credential it shows the following warning:
Code:
Cannot open Consolekit Session: Unable to open session: Unable to get information about the calling process

Clicking OK will start kde but without any consolekit session:
Code:
ck-history --log
388395229.597 type=SEAT_ADDED : seat-id='Seat1' seat-kind=0


ck-list-sessions returns an empty string.

For days I try to resolve that but googling for the obvious slim and xdm error messages do unfortunately not yield any clue.
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 1:47 pm    Post subject: Reply with quote

lsmod - it is ok and there is output of some nouveau lines.
i found out only one needed change in menuconfig of the kernel - VESA is checked in frame buffer section -
so i need to change and re-compile the kernel - should i do it like in the handbook instructions with the DOK-liveCD or there is a shorter way?

EDIT: lightdm and gdm not working
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Mon Dec 30, 2013 1:55 pm    Post subject: Reply with quote

after you changed the kernel config, all you would need is:
Code:
make
make modules_install

and copy the arch/x86/boot/bzImage file to /boot, with the correct file name in grub.conf.

The compile should not take as long as the first time, since most of the compiled files should still be there. "make" only recompiles stuff that has changed.

But I guess as the X server started without problems now with the three terminals, the VESA option probably is not a problem. But can't hurt to change it.
Back to top
View user's profile Send private message
pmam
Guru
Guru


Joined: 30 Dec 2013
Posts: 305

PostPosted: Mon Dec 30, 2013 2:17 pm    Post subject: Reply with quote

thanks for the tip regarding the compiling - i am quit new and use to work with SUSE/KDE -
I thought i should mount, chroot ... like in the handbook, every time i need to compile... :)

regarding your advise to add kernel parameter - due to the fact that i am not using gentoo's grub - i installed gentoo in computer that has already two OS -
and with boot menu of SUSE that has grub2 i am loading gentoo - how can i add the kernel parameter? maybe to edit /boot/grub2/grub.cfg of SUSE?

EDIT: i typed this code:
Code:

emerge -pv xf86-video-nouveau gentoo-sources

and got: x11-... nouveau-1.09
sys-kernel/gentoo-sources-3.10.17:3.10.17
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum