Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201312-15 ] Tinyproxy: Denial of Service
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Wed Dec 25, 2013 11:11 am    Post subject: [ GLSA 201312-15 ] Tinyproxy: Denial of Service Reply with quote

Gentoo Linux Security Advisory

Title: Tinyproxy: Denial of Service (GLSA 201312-15)
Severity: normal
Exploitable: remote
Date: December 23, 2013
Bug(s): #432046
ID: 201312-15

Synopsis

A vulnerability has been found in Tinyproxy, allows remote
attackers to cause a Denial of Service condition.


Background

Tinyproxy is a light-weight HTTP/HTTPS proxy daemon for POSIX operating
systems.


Affected Packages

Package: net-proxy/tinyproxy
Vulnerable: < 1.8.3-r3
Unaffected: >= 1.8.3-r3
Architectures: All supported architectures


Description

A vulnerability has been discovered in the way how Tinyproxy works with
headers.


Impact

A remote attacker could send a specially crafted request with too many
headers, possibly resulting in a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Tinyproxy users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-proxy/tinyproxy-1.8.3-r3"
   


References

CVE-2012-3505
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum