Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SciPy ebuild broke for latest MKL?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lednakashim
n00b
n00b


Joined: 09 Jun 2010
Posts: 18

PostPosted: Thu Dec 12, 2013 5:18 am    Post subject: SciPy ebuild broke for latest MKL? Reply with quote

Hi,
I installed a copy of MKL, re-emerged the virtual packages for BLAS and set my eselect to the Intel packages. Now I got this error when trying to rebuild SciPy. Anybody know what to do?

Quote:

 * Package: sci-libs/scipy-0.13.1-r2
 * Repository: gentoo
 * Maintainer: sci@gentoo.org
 * USE: amd64 elibc_glibc kernel_linux python_targets_python2_7 python_targets_python3_3 userland_GNU
 * FEATURES: preserve-libs sandbox userpriv usersandbox
* Using following Fortran compiler:
* F77: x86_64-pc-linux-gnu-gfortran
* FC: x86_64-pc-linux-gnu-gfortran
>>> Unpacking source...
>>> Unpacking scipy-0.13.1.tar.gz to /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work
>>> Source unpacked in /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work
>>> Preparing source in /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1 ...
* Applying scipy-0.12.0-blitz.patch ...
 [ ok ]
* Applying scipy-0.12.0-restore-sys-argv.patch ...
 [ ok ]
* Applying scipy-0.12.0-cephes-missing-include.patch ...
 [ ok ]
* Will copy sources from /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1
* python3_3: copying to /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1-python3_3
* python2_7: copying to /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1-python2_7
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1 ...
* python3_3: running distutils-r1_run_phase python_compile
* python2_7: running distutils-r1_run_phase python_compile
Processing scipy/sparse/csgraph/_traversal.pyx
Processing scipy/sparse/csgraph/_shortest_path.pyx
Processing scipy/sparse/csgraph/_tools.pyx
Processing scipy/sparse/csgraph/_min_spanning_tree.pyx
Processing scipy/interpolate/interpnd.pyx
Processing scipy/signal/_spectral.pyx
Processing scipy/ndimage/src/_ni_label.pyx
Processing scipy/io/matlab/mio5_utils.pyx
Processing scipy/io/matlab/streams.pyx
Processing scipy/io/matlab/mio_utils.pyx
Processing scipy/spatial/ckdtree.pyx
Processing scipy/spatial/qhull.pyx
Processing scipy/special/_ufuncs_cxx.pyx
Processing scipy/special/_ufuncs.pyx
Processing scipy/cluster/_vq_rewrite.pyx
Processing scipy/stats/_rank.pyx
Processing scipy/stats/vonmises_cython.pyx
/usr/bin/python3.3 setup.py build config_fc --noopt --noarch
blas_opt_info:
system_info:
NOT AVAILABLE

blas_info:
libraries mkl_rt,iomp5,mkl_rt,iomp5 not found in ['/opt/intel/composerxe-2013.0.080/mkl/lib/intel64', '/opt/intel/composerxe-2013.0.080/compiler/lib/intel64', '/usr/lib64']
NOT AVAILABLE

blas_src_info:
NOT AVAILABLE

/usr/lib64/python3.3/distutils/dist.py:257: UserWarning: Unknown distribution option: 'test_suite'
warnings.warn(msg)
/usr/lib64/python3.3/site-packages/numpy/distutils/system_info.py:1512: UserWarning:
Atlas (http://math-atlas.sourceforge.net/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [atlas]) or by setting
the ATLAS environment variable.
warnings.warn(AtlasNotFoundError.__doc__)
/usr/lib64/python3.3/site-packages/numpy/distutils/system_info.py:1521: UserWarning:
Blas (http://www.netlib.org/blas/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [blas]) or by setting
the BLAS environment variable.
warnings.warn(BlasNotFoundError.__doc__)
/usr/lib64/python3.3/site-packages/numpy/distutils/system_info.py:1524: UserWarning:
Blas (http://www.netlib.org/blas/) sources not found.
Directories to search for the sources can be specified in the
numpy/distutils/site.cfg file (section [blas_src]) or by setting
the BLAS_SRC environment variable.
warnings.warn(BlasSrcNotFoundError.__doc__)
Traceback (most recent call last):
File "setup.py", line 230, in <module>
setup_package()
File "setup.py", line 227, in setup_package
setup(**metadata)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/core.py", line 135, in setup
config = configuration()
File "setup.py", line 170, in configuration
config.add_subpackage('scipy')
File "/usr/lib64/python3.3/site-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
caller_level = 2)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
caller_level = caller_level + 1)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
config = setup_module.configuration(*args)
File "scipy/setup.py", line 12, in configuration
config.add_subpackage('integrate')
File "/usr/lib64/python3.3/site-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
caller_level = 2)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
caller_level = caller_level + 1)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
config = setup_module.configuration(*args)
File "scipy/integrate/setup.py", line 12, in configuration
blas_opt = get_info('blas_opt',notfound_action=2)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/system_info.py", line 340, in get_info
return cl().get_info(notfound_action)
File "/usr/lib64/python3.3/site-packages/numpy/distutils/system_info.py", line 499, in get_info
raise self.notfounderror(self.notfounderror.__doc__)
numpy.distutils.system_info.BlasNotFoundError:
Blas (http://www.netlib.org/blas/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [blas]) or by setting
the BLAS environment variable.
* ERROR: sci-libs/scipy-0.13.1-r2::gentoo failed (compile phase):
* (no error message)
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 4307: Called distutils-r1_src_compile
* environment, line 1450: Called _distutils-r1_run_foreach_impl 'python_compile'
* environment, line 319: Called python_parallel_foreach_impl 'distutils-r1_run_phase' 'python_compile'
* environment, line 4044: Called multibuild_parallel_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3229: Called multibuild_foreach_variant '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3177: Called _multibuild_run '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3175: Called _multibuild_parallel '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3220: Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_compile'
* environment, line 912: Called distutils-r1_run_phase 'python_compile'
* environment, line 1441: Called python_compile
* environment, line 3633: Called distutils-r1_python_compile 'config_fc' '--noopt' '--noarch'
* environment, line 1325: Called esetup.py 'build' 'config_fc' '--noopt' '--noarch'
* environment, line 2245: Called die
* The specific snippet of code:
* "${@}" || die
*
* If you need support, post the output of `emerge --info '=sci-libs/scipy-0.13.1-r2::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sci-libs/scipy-0.13.1-r2::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/temp/environment'.
* Working directory: '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1-python3_3'
* S: '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1'
Processing scipy/sparse/csgraph/_traversal.pyx
Processing scipy/sparse/csgraph/_shortest_path.pyx
Processing scipy/sparse/csgraph/_tools.pyx
Processing scipy/sparse/csgraph/_min_spanning_tree.pyx
Processing scipy/interpolate/interpnd.pyx
Processing scipy/signal/_spectral.pyx
Processing scipy/ndimage/src/_ni_label.pyx
Processing scipy/io/matlab/mio5_utils.pyx
Processing scipy/io/matlab/streams.pyx
Processing scipy/io/matlab/mio_utils.pyx
Processing scipy/spatial/ckdtree.pyx
Processing scipy/spatial/qhull.pyx
Processing scipy/special/_ufuncs_cxx.pyx
Processing scipy/special/_ufuncs.pyx
Processing scipy/cluster/_vq_rewrite.pyx
Processing scipy/stats/_rank.pyx
Processing scipy/stats/vonmises_cython.pyx
/usr/bin/python2.7 setup.py build config_fc --noopt --noarch
/usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'test_suite'
warnings.warn(msg)
blas_opt_info:
system_info:
NOT AVAILABLE

/usr/lib64/python2.7/site-packages/numpy/distutils/system_info.py:1512: UserWarning:
Atlas (http://math-atlas.sourceforge.net/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [atlas]) or by setting
the ATLAS environment variable.
warnings.warn(AtlasNotFoundError.__doc__)
blas_info:
libraries mkl_rt,iomp5,mkl_rt,iomp5 not found in ['/opt/intel/composerxe-2013.0.080/mkl/lib/intel64', '/opt/intel/composerxe-2013.0.080/compiler/lib/intel64', '/usr/lib64']
NOT AVAILABLE

/usr/lib64/python2.7/site-packages/numpy/distutils/system_info.py:1521: UserWarning:
Blas (http://www.netlib.org/blas/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [blas]) or by setting
the BLAS environment variable.
warnings.warn(BlasNotFoundError.__doc__)
blas_src_info:
NOT AVAILABLE

/usr/lib64/python2.7/site-packages/numpy/distutils/system_info.py:1524: UserWarning:
Blas (http://www.netlib.org/blas/) sources not found.
Directories to search for the sources can be specified in the
numpy/distutils/site.cfg file (section [blas_src]) or by setting
the BLAS_SRC environment variable.
warnings.warn(BlasSrcNotFoundError.__doc__)
Traceback (most recent call last):
File "setup.py", line 230, in <module>
setup_package()
File "setup.py", line 227, in setup_package
setup(**metadata)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/core.py", line 135, in setup
config = configuration()
File "setup.py", line 170, in configuration
config.add_subpackage('scipy')
File "/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
caller_level = 2)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
caller_level = caller_level + 1)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
config = setup_module.configuration(*args)
File "scipy/setup.py", line 12, in configuration
config.add_subpackage('integrate')
File "/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py", line 966, in add_subpackage
caller_level = 2)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py", line 935, in get_subpackage
caller_level = caller_level + 1)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py", line 872, in _get_configuration_from_setup_py
config = setup_module.configuration(*args)
File "scipy/integrate/setup.py", line 12, in configuration
blas_opt = get_info('blas_opt',notfound_action=2)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/system_info.py", line 340, in get_info
return cl().get_info(notfound_action)
File "/usr/lib64/python2.7/site-packages/numpy/distutils/system_info.py", line 499, in get_info
raise self.notfounderror(self.notfounderror.__doc__)
numpy.distutils.system_info.BlasNotFoundError:
Blas (http://www.netlib.org/blas/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [blas]) or by setting
the BLAS environment variable.
* ERROR: sci-libs/scipy-0.13.1-r2::gentoo failed (compile phase):
* (no error message)
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 4307: Called distutils-r1_src_compile
* environment, line 1450: Called _distutils-r1_run_foreach_impl 'python_compile'
* environment, line 319: Called python_parallel_foreach_impl 'distutils-r1_run_phase' 'python_compile'
* environment, line 4044: Called multibuild_parallel_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3229: Called multibuild_foreach_variant '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3177: Called _multibuild_run '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3175: Called _multibuild_parallel '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 3220: Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_compile'
* environment, line 912: Called distutils-r1_run_phase 'python_compile'
* environment, line 1441: Called python_compile
* environment, line 3633: Called distutils-r1_python_compile 'config_fc' '--noopt' '--noarch'
* environment, line 1325: Called esetup.py 'build' 'config_fc' '--noopt' '--noarch'
* environment, line 2245: Called die
* The specific snippet of code:
* "${@}" || die
*
* If you need support, post the output of `emerge --info '=sci-libs/scipy-0.13.1-r2::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sci-libs/scipy-0.13.1-r2::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/temp/environment'.
* Working directory: '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1-python2_7'
* S: '/var/tmp/portage/sci-libs/scipy-0.13.1-r2/work/scipy-0.13.1'
>>> Source compiled.



And

Code:
emerge -pqv =sci-libs/scipy-0.13.1-r2::gentoo
[ebuild   R   ] sci-libs/scipy-0.13.1-r2  USE="-doc -sparse {-test}" PYT


Obvious question is if the libraries are there.
Quote:

libmkl_avx2.so libmkl_intel_lp64.a
libmkl_avx.so libmkl_intel_lp64.so
libmkl_blacs_ilp64.a libmkl_intel_thread.a
libmkl_blacs_intelmpi_ilp64.a libmkl_intel_thread.so
libmkl_blacs_intelmpi_ilp64.so libmkl_lapack95_ilp64.a
libmkl_blacs_intelmpi_lp64.a libmkl_lapack95_lp64.a
libmkl_blacs_intelmpi_lp64.so libmkl_mc3.so
libmkl_blacs_lp64.a libmkl_mc.so
libmkl_blacs_openmpi_ilp64.a libmkl_p4n.so
libmkl_blacs_openmpi_lp64.a libmkl_pgi_thread.a
libmkl_blacs_sgimpt_ilp64.a libmkl_pgi_thread.so
libmkl_blacs_sgimpt_lp64.a libmkl_rt.so
libmkl_blas95_ilp64.a libmkl_scalapack_ilp64.a
libmkl_blas95_lp64.a libmkl_scalapack_ilp64.so
libmkl_cdft_core.a libmkl_scalapack_lp64.a
libmkl_cdft_core.so libmkl_scalapack_lp64.so
libmkl_core.a libmkl_sequential.a
libmkl_core.so libmkl_sequential.so
libmkl_def.so libmkl_vml_avx2.so
libmkl_gf_ilp64.a libmkl_vml_avx.so
libmkl_gf_ilp64.so libmkl_vml_cmpt.so
libmkl_gf_lp64.a libmkl_vml_def.so
libmkl_gf_lp64.so libmkl_vml_mc2.so
libmkl_gnu_thread.a libmkl_vml_mc3.so
libmkl_gnu_thread.so libmkl_vml_mc.so
libmkl_intel_ilp64.a libmkl_vml_p4n.so
libmkl_intel_ilp64.so locale


So, the two libraries it is looking for are in the right directories, I can only assume something is broken with the script that locates them?

Later, following Intel's MKL numpy guide, I set my configuration to
Quote:
[blas]
include_dirs = /opt/intel/composerxe-2013.0.080/mkl/include
library_dirs = /opt/intel/composerxe-2013.0.080/mkl/lib/intel64
blas_libs = mkl_rt,iomp5#,mkl_rt,iomp5
[lapack]
library_dirs = /opt/intel/composerxe-2013.0.080/mkl/lib/intel64
lapack_libs = mkl_rt,iomp5
[mkl]
library_dirs = /opt/intel/composerxe-2013.0.080/mkl/lib/intel64
include_dirs = /opt/intel/composerxe-2013.0.080/mkl/include
mkl_libs = mkl_intel_lp64,mkl_intel_thread,mkl_core
lapack_libs =
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum