Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HowTo Remain at Gnome3 prior to 3.8 (mask gnome-3.8)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2541

PostPosted: Thu Dec 05, 2013 8:35 pm    Post subject: HowTo Remain at Gnome3 prior to 3.8 (mask gnome-3.8) Reply with quote

Quote:
My package.mask isn't for remaining at gome2, it's for remaining at gnome3 prior to gnome-3.8. There are other threads for remaining at gnome2.
To mask Gnome 3 completely: Masking Gnome 3

Altered title and added the above quote from a later post in this thread for clarity. Made sticky. --pjp, 2014.01.08


For the moment, forget meta-discussion, systemd, *kit, etc. I just want to mask gnome-3.8 and systemd, at least for a while. There has been information scattered in various places, and some of it is how to mask gnome-3, which I believe is overkill. I just want to mask gnome-3.8 and later, and I'm not ready to move my system to systemd. My package.mask is below, but it isn't quite right. It's missing some things and over-aggressive in others.

Incidentally, I don't actually run GNOME, I just run some GNOME applications. I run a bare WM. That's part of what makes this whole gnome-3.8 thing so annoying to me - my whole system is getting "transformed" because of a few applications.

I'm asking for working help here, and my results will be kept here for others to use.
Code:
=media-libs/libcanberra-0.28-r4
>=app-accessibility/accerciser-3.2
>=app-accessibility/caribou-0.4
>=app-accessibility/orca-3.0
>=app-arch/file-roller-3.0
>=app-cdr/brasero-3.0
>=app-crypt/gcr-3.8.0
>=app-crypt/seahorse-3.0
>=app-editors/gedit-3.0
>=app-editors/gedit-plugins-3.0
>=app-misc/gnote-3.8.0
>=app-misc/tracker-0.12
>=app-mobilephone/gnome-phone-manager-0.67
>=app-pda/gtkpod-2.1.0
>=app-text/evince-3.0
>=app-text/gtranslator-2.90
>=dev-cpp/gtkmm-3.8.0
>=dev-libs/folks-0.6
>=dev-libs/libgdata-0.9
>=dev-libs/libgweather-3.0
>=dev-python/pyatspi-2.2
>=dev-util/anjuta-3.0
>=dev-util/devhelp-3.0
>=dev-util/gnome-devel-docs-3.0
>=gnome-base/gconf-3.0.0
>=gnome-base/gconf-3.2
>=gnome-base/gdm-3.0
>=gnome-base/gdm-3.8.0
>=gnome-base/gnome-3.0
>=gnome-base/gnome-applets-3.0
>=gnome-base/gnome-common-3.8.0
>=gnome-base/gnome-control-center-3.0
>=gnome-base/gnome-core-apps-3.0
>=gnome-base/gnome-core-libs-3.0
>=gnome-base/gnome-desktop-schemas-3.8.0
>=gnome-base/gnome-extra-apps-3.0
>=gnome-base/gnome-fallback-3.0
>=gnome-base/gnome-keyring-3.0
>=gnome-base/gnome-keyring-3.0.0
>=gnome-base/gnome-keyring-3.8.0
>=gnome-base/gnome-light-3.0
>=gnome-base/gnome-menus-3.0
>=gnome-base/gnome-menus-3.8.0
>=gnome-base/gnome-panel-3.0
>=gnome-base/gnome-session-3.0
>=gnome-base/gnome-settings-daemon-3.0
>=gnome-base/gnome-settings-daemon-3.8.0.0
>=gnome-base/gnome-shell-3.0
>=gnome-base/libgnome-keyring-3.0
>=gnome-base/libgnome-keyring-3.0.0
>=gnome-base/libgnome-keyring-3.8.0
>=gnome-base/libgnomekbd-3.0
>=gnome-base/nautilus-3.0
>=gnome-extra/at-spi-2.2
>=gnome-extra/drwright-3.0
>=gnome-extra/evolution-data-server-3.0
>=gnome-extra/evolution-exchange-3.0
>=gnome-extra/gcalctool-6.0
>=gnome-extra/gconf-editor-3.0
>=gnome-extra/gnome-color-manager-3.0
>=gnome-extra/gnome-games-3.0
>=gnome-extra/gnome-games-extra-data-3.0
>=gnome-extra/gnome-media-2.32.0-r300
>=gnome-extra/gnome-packagekit-3.0
>=gnome-extra/gnome-power-manager-3.0
>=gnome-extra/gnome-screensaver-3.0
>=gnome-extra/gnome-system-monitor-3.0
>=gnome-extra/gnome-tweak-tool-3.0
>=gnome-extra/gnome-user-docs-3.0
>=gnome-extra/gnome-user-share-3.0
>=gnome-extra/gnome-utils-3.0
>=gnome-extra/mousetweaks-3.0
>=gnome-extra/nautilus-open-terminal-0.19
>=gnome-extra/nautilus-sendto-3.0
>=gnome-extra/nautilus-tracker-tags-0.12
>=gnome-extra/nm-applet-0.8.99
>=gnome-extra/yelp-3.0
>=gnome-extra/zenity-3.0
>=mail-client/evolution-3.0
>=media-gfx/eog-3.0
>=media-libs/clutter-1.7
>=media-libs/cogl-1.7
>=media-sound/rhythmbox-2.90
>=media-sound/sound-juicer-2.99
>=media-video/cheese-3.0
>=media-video/totem-3.0
>=net-analyzer/gnome-nettool-3.0
>=net-im/empathy-3.0
>=net-libs/gnome-online-accounts-3
>=net-misc/networkmanager-0.8.99
>=net-misc/networkmanager-openconnect-0.8.99
>=net-misc/networkmanager-openswan-0.8.99
>=net-misc/networkmanager-openvpn-0.8.99
>=net-misc/networkmanager-pptp-0.8.99
>=net-misc/networkmanager-vpnc-0.8.99
>=net-misc/vinagre-3.0
>=net-misc/vino-3.0
>=net-wireless/gnome-bluetooth-3.0
>=sys-apps/gnome-disk-utility-3.0.2-r300
>=www-client/epiphany-3.0
>=www-client/epiphany-extensions-3.0
>=x11-libs/gtk+-3.8.0
>=x11-libs/libcryptui-3
>=x11-misc/alacarte-0.13.2-r50
>=x11-terms/gnome-terminal-3.0
>=x11-themes/gnome-icon-theme-3.8.0
>=x11-themes/gnome-icon-theme-symbolic-3.8.0
>=x11-wm/metacity-2.34
>=x11-wm/mutter-3.0
>gnome-extra/sensors-applet-2.99
app-admin/eselect-gnome-shell-extensions
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-shell-extensions
gnome-extra/office-runner
gnome-extra/sushi

As mentioned, that was a mix of stuff picked up in here in the forums and stuff I'd done Sunday, trying to get my system to update without pulling in all of the stuff. This still doesn't let me update my system cleanly. Note that (at least) one mask is also "=" instead of ">=", which I tend not to trust for very long. If someone has a good reason for that and why later versions might be OK, I'd like to understand, myself.

There are a few other items here where I think I could be less aggressive:
Code:
>=app-crypt/gcr-3.8.0
>=gnome-extra/zenity-3.8.0

Also, one example I picked up in a forum had the gucharmap masking commented out, and I'm not sure why, or if I should choose another level to mask.
Code:
>=gnome-extra/gucharmap-3.0

_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2541

PostPosted: Thu Dec 05, 2013 9:45 pm    Post subject: Reply with quote

Trying to open up more gnome stuff from the 3.0 that I found in the forums to 3.8, and I found this one...
Code:
[nomerge       ] gnome-base/gnome-panel-2.32.1-r3  USE="bonobo introspection -eds -networkmanager"
[nomerge       ]  gnome-base/gnome-menus-3.0.1-r2 [2.30.5-r1] USE="introspection python -debug"
[nomerge       ]   gnome-base/gnome-menus-3.8.1:3 [2.30.5-r1:0] USE="introspection -debug {-test}"
[blocks b      ]    <gnome-base/gnome-menus-3.0.1-r1:0 ("<gnome-base/gnome-menus-3.0.1-r1:0" is blocking gnome-base/gnome-menus-3.8.1)
[ebuild     U  ]     gnome-base/gnome-menus-3.0.1-r2 [2.30.5-r1] USE="introspection python -debug" 464 kB

What the heck is this all about? It looks like an installed gnome-panel-2.32.1 (which I don't even use, it's called in by something else) is calling in gnome-menus-3.0.1, which is in turn calling in gnome-menus-3.8.1, which it then blocks with.

I don't quite understand what portage is doing, here. The gnome-menus-3.0.1 ebuild doesn't hint that it would try to do this. By the way, the emerge is telling me I need to unmask gnome-menus-3.8.1.

Maybe I should give up on whatever is between 3.0<gnome<3.8, but I really like gthumb-3.2,4, which I've had installed for some time now.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2541

PostPosted: Thu Dec 05, 2013 10:24 pm    Post subject: Reply with quote

I've done a bit of tweaking, and here's where I sit at the moment. I'd like to split things apart a bit and put comments back in, at some point - basically reorganize and make clearer.

Code:
>=gnome-base/gdm-3.8.0
>=gnome-base/gnome-settings-daemon-3.8.0.0
>=gnome-base/gsettings-desktop-schemas-3.8.0
>=gnome-extra/zenity-3.8.0
>=gnome-base/libgnome-keyring-3.0.0
>=gnome-base/gnome-keyring-3.0.0
app-crypt/gcr
>=dev-cpp/gtkmm-3.8.0
>=x11-libs/gtk+-3.8.0
>=gnome-base/gnome-common-3.8.0
#>=gnome-base/gnome-menus-3.8.0
>=gnome-base/gnome-menus-3.0
>=gnome-base/gnome-desktop-schemas-3.8.0
>=x11-themes/gnome-icon-theme-symbolic-3.8.0
>=x11-themes/gnome-icon-theme-3.8.0
>=app-misc/gnote-3.8.0
>=gnome-base/gconf-3.8.0
>=gnome-base/libgnomekbd-3.0
=media-libs/libcanberra-0.28-r4
>=app-accessibility/orca-3.8
>=gnome-base/gdm-3.8
>=gnome-base/gnome-applets-3.8
>=gnome-base/gnome-menus-3.8
>=gnome-base/gnome-panel-3.8
>=gnome-base/gnome-session-3.8
>=gnome-base/gnome-settings-daemon-3.8
>=gnome-base/gnome-control-center-3.8
>=gnome-base/gnome-shell-3.8
>=gnome-base/nautilus-3.8
>=x11-wm/metacity-2.34
>=x11-wm/mutter-3.8
>=app-arch/file-roller-3.8
>=app-cdr/brasero-3.8
>=app-crypt/seahorse-3.8
>=app-editors/gedit-3.8
>=app-editors/gedit-plugins-3.8
>=app-text/gtranslator-2.90
>=app-text/evince-3.8
>=dev-util/anjuta-3.8
>=app-pda/gtkpod-2.1.0
>=dev-util/devhelp-3.8
>=gnome-extra/drwright-3.8
>=gnome-extra/evolution-data-server-3.8
>=gnome-extra/evolution-exchange-3.8
>=gnome-extra/gcalctool-6.0
>=gnome-extra/gconf-editor-3.8
>=gnome-extra/gnome-color-manager-3.8
>=gnome-extra/gnome-games-3.8
>=gnome-extra/gnome-games-extra-data-3.8
>=gnome-extra/gnome-media-2.32.0-r300
>=gnome-extra/gnome-packagekit-3.8
>=gnome-extra/gnome-power-manager-3.8
>=gnome-extra/gnome-screensaver-3.8
>=gnome-extra/gnome-system-monitor-3.8
>=gnome-extra/gnome-tweak-tool-3.8
>=gnome-extra/gnome-user-share-3.8
>=gnome-extra/gnome-utils-3.8
>=gnome-extra/mousetweaks-3.8
>=gnome-extra/nautilus-sendto-3.8
gnome-extra/office-runner
>=gnome-extra/zenity-3.8
>=mail-client/evolution-3.8
>=media-gfx/eog-3.8
>=media-sound/rhythmbox-2.90
>=media-sound/sound-juicer-2.99
>=media-video/cheese-3.8
>=media-video/totem-3.8
>=net-analyzer/gnome-nettool-3.8
>=net-im/empathy-3.8
>=net-misc/vinagre-3.8
>=net-misc/vino-3.8
>=net-wireless/gnome-bluetooth-3.8
#>=sys-apps/gnome-disk-utility-3.0.2-r300
>=sys-apps/gnome-disk-utility-3.8.0
>=www-client/epiphany-3.8
>=www-client/epiphany-extensions-3.8
>=x11-terms/gnome-terminal-3.8
>=net-misc/networkmanager-0.8.99
>=net-misc/networkmanager-pptp-0.8.99
>=net-misc/networkmanager-openconnect-0.8.99
>=net-misc/networkmanager-openvpn-0.8.99
>=net-misc/networkmanager-openswan-0.8.99
>=net-misc/networkmanager-vpnc-0.8.99
>=gnome-extra/nm-applet-0.8.99
>=gnome-base/gnome-core-apps-3.8
>=gnome-base/gnome-extra-apps-3.8
>=gnome-base/gnome-core-libs-3.8
>=gnome-base/gnome-fallback-3.8
>=gnome-base/gnome-light-3.8
>=gnome-base/gnome-3.8
>=gnome-extra/nautilus-open-terminal-0.19
>=app-mobilephone/gnome-phone-manager-0.67
>=app-accessibility/caribou-0.4
app-admin/eselect-gnome-shell-extensions
>=app-misc/tracker-0.12
>=dev-libs/folks-0.6
>=dev-libs/libgdata-0.9
>=dev-python/pyatspi-2.2
>=gnome-base/gconf-3.2
>=gnome-extra/at-spi-2.2
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-shell-extensions
>=gnome-extra/nautilus-tracker-tags-0.12
gnome-extra/sushi
>=net-libs/gnome-online-accounts-3
>=x11-libs/libcryptui-3
>=x11-misc/alacarte-0.13.2-r50
>=app-accessibility/accerciser-3.2
>gnome-extra/sensors-applet-2.99
>=dev-python/pygobject-3.8.0
>=gnome-extra/yelp-xsl-3.8.0
>=gnome-base/libgnome-keyring-3.8.0
>=gnome-base/gnome-keyring-3.8.0
>=gnome-extra/yelp-3.8
>=dev-util/gnome-devel-docs-3.8
>=gnome-extra/gnome-user-docs-3.8
>=gnome-base/libgnome-keyring-3.8.0
>=gnome-base/gnome-keyring-3.8.0
#Deletions
#>=gnome-extra/gucharmap-3.0
#>=media-libs/cogl-1.7
#>=media-libs/clutter-1.7


EDIT - I found that gcr won't emerge correctly, and that fact hadn't shown up on 2 of the 3 systems I updated. It turned out that I had to change the masks gnome-keyring-3.0.0, libgnome-keyring-3.0.0, and just plain mask gcr completely. With this I appear to have my 3 "desktop" systems at home updated. (There's still a little work to do on one of them.)
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Princess Nell
Guru
Guru


Joined: 15 Apr 2005
Posts: 530

PostPosted: Sun Dec 08, 2013 8:52 pm    Post subject: Reply with quote

I'm running gnome2 and want to continue to do so for another bit while I'm testing mate on another system. Your package.mask doesn't work for me at all, even after switching to a desktop profile. I'm now trying to manually figure out the packages for the python 3.2 t o3.3 update in order to get a better overview of what else needs to masked.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2541

PostPosted: Sun Dec 08, 2013 9:28 pm    Post subject: Reply with quote

My package.mask isn't for remaining at gome2, it's for remaining at gnome3 prior to gnome-3.8. There are other threads for remaining at gnome2.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
daniel.santos
n00b
n00b


Joined: 05 Jun 2007
Posts: 30

PostPosted: Thu Dec 19, 2013 9:57 pm    Post subject: Reply with quote

depontius wrote:
My package.mask isn't for remaining at gome2, it's for remaining at gnome3 prior to gnome-3.8. There are other threads for remaining at gnome2.

Here ya go: http://forums.gentoo.org/viewtopic-t-978732.html

And thank you for posting your package.mask! I most certainly don't have the time to switch my system to systemd right now, but I want to get updated on everything else, so ...wtf?

Honestly, I'm having trouble taking in that it's so complicated to prevent this change (from 3.6 to 3.8). My upgrade this time has been horrific. To be fair however, my USE flags have gotten out of hand so it's at least prompting me to clean them up. Still, the devs should have added some option to more easily block 3.8. It could be as easy as adding one simple do-nothing package that everything 3.8 depends upon, or some such. I dunno, but I think that when we have so many packages like in a desktop environment like this, there should be some mechanism to control which major/minor version we're on (allow revisions & such). I realize that a desktop environment is very complex, but let's address this complexity at the distro level rather than passing it on to the user.
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Sun Dec 22, 2013 6:20 pm    Post subject: Reply with quote

depontius wrote:
rpil wrote:

NO BLOCKS! :D

TomWij wrote:

`grep -r gtk+ /etc/portage/`

Code:
# grep -r gtk+ /etc/portage/
/etc/portage/package.mask:>=x11-libs/gtk+-3.8.0
/etc/portage/package.mask:#=x11-libs/gtk+-3.8.7
/etc/portage/package.mask:>x11-libs/gtk+-3.4.4


Would you share your /etc/portage/package.mask over in "HowTo mask gnome-3.8"? http://forums.gentoo.org/viewtopic-t-977750-highlight-.html

I've enabled gtk+-3.6.3-r3, and I thought I'd done it so I could pick up gthumb-3.2.4, but now that I look there, I see that >=gtk+-3.4.0 would suffice. So maybe I can revert to the stable <=gtk+-3.8.0 after all.[/quote]

Sure, my friend, if that can help you:
Code:
# cat /etc/portage/package.mask
sys-apps/hal
>www-client/firefox-14.0.1
www-client/chromium
>=x11-base/xorg-server-1.13.0-r1
>=dev-cpp/gtkmm-3.8.0
>=x11-libs/gtk+-3.8.0
>=x11-themes/gnome-icon-theme-symbolic-3.8.0
>=x11-themes/gnome-icon-theme-3.8.0
#=x11-libs/gtk+-3.8.7
>app-cdr/brasero-2.99
>x11-themes/gnome-icon-theme-3.6.3
>app-editors/gedit-2.99
>app-arch/file-roller-2.99
>app-editors/gedit-2.99
>app-text/evince-2.99
>app-editors/ghex-3.6.3
>app-i18n/ibus-1.4.9
sys-apps/systemd
#gnome-base/*
gnome-extra/*
>x11-libs/gtk+-3.4.4
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2338
Location: Dallas area

PostPosted: Sun Dec 22, 2013 6:33 pm    Post subject: Reply with quote

I have gtk+3 masked with

>x11-libs/gtk+-3.4.4

this is the last stable before 3.8*

These are the gnome packages, selected by running a few shell scripts and they may be more than is needed
If one runs emerge and it complains about one of these being blocked then add that pkg to package.mask
Each package has a gnome herd designation in the metadata.xml file.

Code:
>=app-accessibility/accerciser-3.8.0
>=app-accessibility/orca-3.8.0
>=app-admin/gnome-system-log-3.8.0
>=app-arch/file-roller-3.8.0
>=app-cdr/brasero-3.8.0
>=app-crypt/gcr-3.8.0
>=app-crypt/seahorse-3.8.0
>=app-crypt/seahorse-sharing-3.8.0
>=app-dicts/gnome-dictionary-3.8.0
>=app-editors/gedit-3.8.0
>=app-editors/gedit-plugins-3.8.0
>=app-editors/ghex-3.8.0
>=app-misc/bijiben-3.8.0
>=app-misc/gnote-3.8.0
>=app-text/evince-3.8.0
>=dev-cpp/gtkmm-3.8.0
>=dev-libs/gdl-3.8.0
>=dev-libs/libgweather-3.8.0
>=dev-libs/seed-3.8.0
>=dev-python/pygobject-3.8.0
>=dev-util/anjuta-3.8.0
>=dev-util/devhelp-3.8.0
>=dev-util/gnome-devel-docs-3.8.0
>=games-arcade/gnome-nibbles-3.8.0
>=games-arcade/gnome-robots-3.8.0
>=games-board/four-in-a-row-3.8.0
>=games-board/gnome-chess-3.8.0
>=games-board/gnome-mahjongg-3.8.0
>=games-board/gnome-mines-3.8.0
>=games-board/iagno-3.8.0
>=games-board/tali-3.8.0
>=games-puzzle/five-or-more-3.8.0
>=games-puzzle/gnome-klotski-3.8.0
>=games-puzzle/gnome-sudoku-3.8.0
>=games-puzzle/gnome-tetravex-3.8.0
>=games-puzzle/lightsoff-3.8.0
>=games-puzzle/quadrapassel-3.8.0
>=games-puzzle/swell-foop-3.8.0
>=gnome-base/gdm-3.8.0
>=gnome-base/gnome-control-center-3.8.0
>=gnome-base/gnome-core-apps-3.8.0
>=gnome-base/gnome-core-libs-3.8.0
>=gnome-base/gnome-desktop-3.8.0
>=gnome-base/gnome-extra-apps-3.8.0
>=gnome-base/gnome-fallback-3.8.0
>=gnome-base/gnome-keyring-3.8.0
>=gnome-base/gnome-light-3.8.0
>=gnome-base/gnome-menus-3.8.0
>=gnome-base/gnome-3.8.0
>=gnome-base/gnome-panel-3.8.0
>=gnome-base/gnome-session-3.8.0
>=gnome-base/gnome-settings-daemon-3.8.0
>=gnome-base/gnome-shell-3.8.0
>=gnome-base/gsettings-desktop-schemas-3.8.0
>=gnome-base/libgnome-keyring-3.8.0
>=gnome-base/nautilus-3.8.0
>=gnome-extra/evolution-data-server-3.8.0
>=gnome-extra/evolution-ews-3.8.0
>=gnome-extra/evolution-kolab-3.8.0
>=gnome-extra/gnome-calculator-3.8.0
>=gnome-extra/gnome-clocks-3.8.0
>=gnome-extra/gnome-color-manager-3.8.0
>=gnome-extra/gnome-contacts-3.8.0
>=gnome-extra/gnome-documents-3.8.0
>=gnome-extra/gnome-getting-started-docs-3.8.0
>=gnome-extra/gnome-packagekit-3.8.0
>=gnome-extra/gnome-power-manager-3.8.0
>=gnome-extra/gnome-shell-extensions-3.8.0
>=gnome-extra/gnome-system-monitor-3.8.0
>=gnome-extra/gnome-tweak-tool-3.8.0
>=gnome-extra/gnome-user-docs-3.8.0
>=gnome-extra/gnome-user-share-3.8.0
>=gnome-extra/gnome-utils-3.8.0
>=gnome-extra/gnome-weather-3.8.0
>=gnome-extra/gucharmap-3.8.0
>=gnome-extra/mousetweaks-3.8.0
>=gnome-extra/nautilus-sendto-3.8.0
>=gnome-extra/seahorse-nautilus-3.8.0
>=gnome-extra/sushi-3.8.0
>=gnome-extra/yelp-3.8.0
>=gnome-extra/yelp-xsl-3.8.0
>=gnome-extra/zenity-3.8.0
>=mail-client/evolution-3.8.0
>=media-gfx/eog-3.8.0
>=media-gfx/eog-plugins-3.8.0
>=media-gfx/gnome-font-viewer-3.8.0
>=media-gfx/gnome-photos-3.8.0
>=media-gfx/gnome-screenshot-3.8.0
>=media-gfx/simple-scan-3.8.0
>=media-sound/sound-juicer-3.0.0
>=media-video/cheese-3.8.0
>=media-video/totem-3.8.0
>=net-analyzer/gnome-nettool-3.8.0
>=net-im/empathy-3.8.0
>=net-libs/gnome-online-accounts-3.8.0
>=net-misc/vinagre-3.8.0
>=net-misc/vino-3.8.0
>=net-wireless/gnome-bluetooth-3.8.0
>=sys-apps/baobab-3.8.0
>=sys-apps/gnome-disk-utility-3.8.0
>=www-client/epiphany-3.8.0
>=x11-libs/gtk+-3.8.0
>=x11-libs/gtksourceview-3.8.0
>=x11-libs/libcryptui-3.8.0
>=x11-terms/gnome-terminal-3.8.0
>=x11-themes/gnome-backgrounds-3.8.0
>=x11-themes/gnome-icon-theme-3.8.0
>=x11-themes/gnome-icon-theme-symbolic-3.8.0
>=x11-themes/gnome-themes-standard-3.8.0
>=x11-wm/mutter-3.8.0


It should be a start
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4


Last edited by Anon-E-moose on Fri Jan 10, 2014 9:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 913
Location: Denmark

PostPosted: Fri Jan 10, 2014 8:27 pm    Post subject: Reply with quote

I did use the above list. I got this error.

Code:
--- Invalid atom in /etc/portage/package.mask: >=media-sound/sound-juicer-3.5.1_pre2013.8.0
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2338
Location: Dallas area

PostPosted: Fri Jan 10, 2014 9:45 pm    Post subject: Reply with quote

jonfr wrote:
I did use the above list. I got this error.

Code:
--- Invalid atom in /etc/portage/package.mask: >=media-sound/sound-juicer-3.5.1_pre2013.8.0


Weird, it should have read

>=media-sound/sound-juicer-3.0.0

Thanks, I'll change it.
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum