Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wine 1.7.X and zlib abi_x86_32
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
marco.difresco
n00b
n00b


Joined: 29 Jul 2011
Posts: 62

PostPosted: Tue Nov 12, 2013 8:35 am    Post subject: Wine 1.7.X and zlib abi_x86_32 Reply with quote

Hi all,
I usually kept Wine keyworded to have the latest version, but when the version 1.7.3 got released (at least on the portage tree) I had to mask it because at the time it required me to keyword many other packages to get installed (and for maintenance sanity sake I prefer to keep the unstable packages list as short as possible).

Today I tried to unmask it and try again (I have the 1.7.4 as latest version on my local portage tree) and fortunately it required only emul-linux-x86-baselibs-20131008-r4 to be keyworded.

The problem is that when I attempt to update it (using 'emerge --ask --update --deep --newuse world' to be sure to get everything necessary) I get the following:
Code:
emerge: there are no ebuilds to satisfy ">=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]".
(dependency required by "app-emulation/emul-linux-x86-baselibs-20131008-r4[abi_x86_32]" [ebuild])
(dependency required by "sys-boot/grub-0.97-r12[ncurses]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


How can I solve it?

Since I have a 64 bit system, may it be a problem to have zlib with abi_x86_32 (that I admit I don't have a clear idea what does it means beside the name suggesting something about 32 bits)?
_________________
Marco Di Fresco
Silicon Gadget
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Nov 12, 2013 2:45 pm    Post subject: Reply with quote

You may not like the answer I have to provide, but in order to get this to work add:
/etc/portage/package.accept_keywords
Code:
app-emulation/emul-linux-x86-baselibs      ~amd64
app-emulation/emul-linux-x86-soundlibs      ~amd64
app-emulation/emul-linux-x86-xlibs      ~amd64
app-emulation/emul-linux-x86-medialibs      ~amd64
app-emulation/emul-linux-x86-db       ~amd64
app-emulation/emul-linux-x86-sdl      ~amd64
app-emulation/emul-linux-x86-gtklibs      ~amd64
app-emulation/emul-linux-x86-opengl      ~amd64
app-emulation/emul-linux-x86-qtlibs      ~amd64
sys-libs/ncurses            ~amd64
sys-libs/gpm               ~amd64
sys-libs/libraw1394            ~amd64
media-libs/libpng:1.2            ~amd64
sys-libs/zlib               ~amd64
virtual/libffi               ~amd64
dev-libs/libffi               ~amd64
app-arch/xz-utils            ~amd64
media-libs/jbigkit            ~amd64
dev-libs/udis86               ~amd64
virtual/udev               ~amd64
sys-fs/udev               ~amd64
sys-apps/kmod               ~amd64
sys-apps/hwids               ~amd64
dev-libs/glib               ~amd64
virtual/libiconv            ~amd64
sys-apps/attr               ~amd64
virtual/jpeg               ~amd64
media-libs/jpeg               ~amd64
virtual/libusb               ~amd64
dev-libs/libusb-compat            ~amd64
app-arch/bzip2               ~amd64
sys-devel/llvm               ~amd64
app-text/libpaper            ~amd64
dev-libs/libusbx            ~amd64
media-libs/lcms               ~amd64
media-libs/libjpeg-turbo         ~amd64
media-libs/libpng            ~amd64
sys-libs/libavc1394            ~amd64
media-libs/tiff               ~amd64
dev-libs/expat               ~amd64
dev-libs/elfutils            ~amd64
sys-libs/e2fsprogs-libs            ~amd64
dev-libs/gobject-introspection         ~amd64
dev-libs/gobject-introspection-common      ~amd64
sys-fs/e2fsprogs            ~amd64
sys-apps/openrc               ~amd64
net-misc/netifrc            ~amd64
dev-libs/vala-common            ~amd64
x11-libs/libXdamage            ~amd64
x11-libs/libXcomposite            ~amd64
x11-libs/libXft               ~amd64
x11-libs/libvdpau            ~amd64
media-libs/freetype            ~amd64
media-libs/libsamplerate         ~amd64
media-libs/xvid               ~amd64
media-plugins/caps-plugins         ~amd64
media-libs/speex            ~amd64
media-libs/libmad            ~amd64
media-libs/libdvdnav            ~amd64
media-libs/a52dec            ~amd64
media-libs/x264               ~amd64
dev-libs/liboil               ~amd64
media-libs/faad2            ~amd64
media-libs/libmpeg2            ~amd64
media-sound/gsm             ~amd64
media-sound/musepack-tools          ~amd64
sys-libs/libieee1284             ~amd64
media-libs/faac               ~amd64
media-libs/libsidplay             ~amd64
media-libs/libdca             ~amd64
media-libs/libdc1394            ~amd64
media-libs/libtheora             ~amd64
media-libs/webrtc-audio-processing       ~amd64
media-libs/ladspa-sdk             ~amd64
media-libs/libmms             ~amd64
media-libs/libsidplay             ~amd64
media-video/ffmpeg:0.10            ~amd64
media-video/ffmpeg:0            ~amd64
media-sound/lame             ~amd64
dev-libs/libcdio             ~amd64
media-libs/libvorbis             ~amd64
media-plugins/swh-plugins          ~amd64
media-sound/cdparanoia             ~amd64
media-libs/openjpeg             ~amd64
dev-libs/fribidi             ~amd64
media-libs/libv4l             ~amd64
media-libs/libmodplug             ~amd64
media-libs/libvisual             ~amd64
media-libs/vo-aacenc             ~amd64
media-libs/libid3tag             ~amd64
media-libs/audiofile             ~amd64
media-libs/alsa-lib             ~amd64
media-libs/libsndfile             ~amd64
media-libs/libshout             ~amd64
media-libs/libdv             ~amd64
media-libs/libogg             ~amd64
media-plugins/alsaequal          ~amd64
media-libs/libmimic             ~amd64
media-libs/libdvdcss             ~amd64
media-libs/libmikmod             ~amd64
media-libs/libvpx             ~amd64
media-libs/libiec61883             ~amd64
media-sound/jack-audio-connection-kit       ~amd64
media-sound/twolame             ~amd64
media-libs/libdvdread             ~amd64
media-sound/wavpack             ~amd64
media-libs/libreplaygain          ~amd64
media-libs/libcuefile            ~amd64
app-admin/eselect-cdparanoia          ~amd64
dev-libs/libcdio-paranoia          ~amd64
media-libs/flac               ~amd64
media-sound/mpg123             ~amd64
media-libs/portaudio             ~amd64
x11-proto/dri2proto             ~amd64
virtual/glu                ~amd64
media-libs/mesa             ~amd64
x11-proto/glproto             ~amd64
virtual/opengl                ~amd64
x11-proto/xf86driproto             ~amd64
media-libs/glew             ~amd64
x11-libs/libdrm             ~amd64
media-libs/freeglut             ~amd64
media-libs/glu               ~amd64


/etc/portage/profile/use.mask
-abi_x86_32
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
marco.difresco
n00b
n00b


Joined: 29 Jul 2011
Posts: 62

PostPosted: Tue Nov 12, 2013 4:15 pm    Post subject: Reply with quote

eyoung100 wrote:
/etc/portage/package.accept_keywords
Code:
app-emulation/emul-linux-x86-baselibs      ~amd64
[CUT]...[CUT]
media-libs/glu               ~amd64


/etc/portage/profile/use.mask
-abi_x86_32

I don't know how to embed an image to a post in this forum so let's link it: http://cdn.alltheragefaces.com/img/faces/jpg/surprised-long-neck-surprise.jpg

eyoung100 wrote:
You may not like the answer I have to provide

You are right, but I give you credit for indeed giving me a possible solution. :D

Just to be sure: if I put the following line to /etc/portage/package.keywords:
=app-emulation/wine-1.7.0 ~amd64
does emerge sticks with it as unstable until the stable version get an equal or higher version number and then automatically switch to 'stable' or does it keep me stuck with such version even if the stable version get an higer number?

Thank you very much for your help
_________________
Marco Di Fresco
Silicon Gadget
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Nov 12, 2013 4:31 pm    Post subject: Reply with quote

marco.difresco wrote:

I don't know how to embed an image to a post in this forum so let's link it: http://cdn.alltheragefaces.com/img/faces/jpg/surprised-long-neck-surprise.jpg

eyoung100 wrote:
You may not like the answer I have to provide

You are right, but I give you credit for indeed giving me a possible solution. :D

Just to be sure: if I put the following line to /etc/portage/package.keywords:
=app-emulation/wine-1.7.0 ~amd64
does emerge sticks with it as unstable until the stable version get an equal or higher version number and then automatically switch to 'stable' or does it keep me stuck with such version even if the stable version get an higer number?

Thank you very much for your help


Hilarious Image :lol: :lol: Please(This assumes you have no package.accept_keywords). This is the new file portage uses, dunno how long backwards compatibility will last:
Code:
mv -v /etc/portage/package.keywords /etc/portage/package.accept_keywords


Re: Wine. I believe you will be stuck, as you are using the equals sign. Even if a higher version gets marked stable the equals has "masked" the newer version, and even though you stuck your neck out, the solution I gave you is the only solution as all the emul-libs in that set are marked testing, and they all require packages marked testing in order to compile. That was as of the last weekend in October.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
marco.difresco
n00b
n00b


Joined: 29 Jul 2011
Posts: 62

PostPosted: Tue Nov 12, 2013 6:41 pm    Post subject: Reply with quote

eyoung100 wrote:
Please(This assumes you have no package.accept_keywords). This is the new file portage uses, dunno how long backwards compatibility will last:
Code:
mv -v /etc/portage/package.keywords /etc/portage/package.accept_keywords



Thanks for the tip. File moved.

eyoung100 wrote:

Re: Wine. I believe you will be stuck, as you are using the equals sign. Even if a higher version gets marked stable the equals has "masked" the newer version, and even though you stuck your neck out, the solution I gave you is the only solution as all the emul-libs in that set are marked testing, and they all require packages marked testing in order to compile. That was as of the last weekend in October.


Thanks for the info.

I have to admit that for the moment I am playing only Lotro as major Windows program and it runs very well with Wine 1.7.0, therefore I may stick with it for some time without immediate urgency to upgrade. Still, I have bookmarked this thread, I have put a generic 'app-emulation/wine ~amd64' in package.accept_keywords and '>=app-emulation/wine-1.7.3' in package.mask; if any upgrade to Lotro (it is going to have an expansion in about two weeks), or any other Windows program I may use, starts to have problems with Wine 1.7.0, I will first try to just remove the line in package.mask to see if those packages you have indicated have become stable in the meantime and if not I'll put the package list you provided on package.accept_keywords.

Thank you very much for your help. :D
_________________
Marco Di Fresco
Silicon Gadget
Back to top
View user's profile Send private message
Letharion
Veteran
Veteran


Joined: 13 Jun 2005
Posts: 1259
Location: Sweden

PostPosted: Sun Dec 08, 2013 11:38 am    Post subject: Reply with quote

I had two conflicts with wine's 32bit dependencies, but instead of keywording a lot of packages, I just removed 32bit support for those packages.

Code:
dev-libs/expat -abi_x86_32
dev-libs/libffi -abi_x86_32


I didn't need to do so for zlib, not sure why our experience differs there, but this requires less re-emerging. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum