Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
make menuconfig (lxdialog) and UTF-8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
xabi
n00b
n00b


Joined: 17 Feb 2004
Posts: 7
Location: Donostia

PostPosted: Tue Jan 02, 2007 3:53 pm    Post subject: make menuconfig (lxdialog) and UTF-8 Reply with quote

I have recently moved my Gentoo from ISO-8859-1 to UTF-8 and the Using UTF-8 with Gentoo guide provides good help to accomplish the change. My system now uses UTF-8, but there's a program that didn't like the change: ncurses-based make menuconfig dialog (lxdialog), the one used to configure the kernel. The special characters for drawing the borders (such as '|') show messed up, they only show correctly if i change PuTTY's configuration back to ISO-8859-1.

Has anybody experienced similar problems? Did you find a solution for this?
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Wed Jan 03, 2007 1:29 am    Post subject: Reply with quote

Have you tried rebuilding ncurses since the switch? Also, there's a setting in /etc/conf.d/consolefont which might be influencing things:
Code:

CONSOLETRANSLATION="8859-1_to_uni"


I haven't looked too closely, so I don't know if this gets applied only to the chosen console font, or if the setting is used for terminal/console sessions in general.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 432
Location: New Mexico

PostPosted: Wed Jan 03, 2007 1:42 am    Post subject: Reply with quote

While trying to figure out the console font you could:
Code:
# reset

This works for me. I also have this problem with mc.
Back to top
View user's profile Send private message
nikaya
Veteran
Veteran


Joined: 13 May 2006
Posts: 1471
Location: Germany

PostPosted: Wed Jan 03, 2007 2:04 am    Post subject: Reply with quote

http://www.gentoo.org/doc/en/utf-8.xml#doc_chap3 wrote:

Ncurses and Slang
Note: Ignore any mention of Slang in this section if you do not have it installed or do not use it.

It is wise to add unicode to your global USE flags in /etc/make.conf, and then to remerge sys-libs/ncurses and sys-libs/slang if appropriate. Portage will do this automatically when you update your system

Source:
http://www.gentoo.org/doc/en/utf-8.xml#doc_chap3
_________________
Notes on Dhamma
How to waste your time: look for an explanation of consciousness, ask to know what feeling is. (Nanavira Thera)
Back to top
View user's profile Send private message
Black Imp
Apprentice
Apprentice


Joined: 09 Oct 2004
Posts: 168

PostPosted: Fri Jan 12, 2007 3:48 am    Post subject: Reply with quote

why do I have the same problem without changing to unicode?
Back to top
View user's profile Send private message
erik258
Advocate
Advocate


Joined: 12 Apr 2005
Posts: 2650
Location: Twin Cities, Minnesota, USA

PostPosted: Fri Jan 12, 2007 10:52 pm    Post subject: Reply with quote

I have this problem too; it's apparent in such ncurses output as menuconfig and alsamixer.

I would really like to know how to make it go away... as I clearly don't have enough changes to propogate to my dozen gentoo boxes ; ) Seriously, any fixes guys?
_________________
Configuring a Firewall? Try my iptables configuration
LinuxCommando.com is my blog for linux-related scraps and tidbits. Stop by for a visit!
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Jan 12, 2007 11:03 pm    Post subject: Reply with quote

This is starting to look more and more like a bug somewhere in gentoo's handling of unicode and/or ncurses. Check out this topic:

GenKernel display is garbled
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Jan 12, 2007 11:09 pm    Post subject: Reply with quote

Oh yeah, I completely forgot about this other thread I posted on:

weird menuconfig screen
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Jan 12, 2007 11:37 pm    Post subject: Reply with quote

And some more:

mc distorted graphics in console mode
Weird curses problem
Ncurses apps not working properly
Unicode and Midnight Commander
displaying problems with midnight comander
terminal display weirdness: alsamixer, mp3blaster look odd
utf8 not working always?
mc doesnt shows lines
Midnight Commander "Console" trouble....
framebuffer console curses corruption
make menuconfig and fonts issue
ncurses messed up
ncurses apps are messed up

I suppose all of these various issues could be down to "user error", i.e. misconfiguration; but then, given how often it happens, I'd say the documentation has a bug.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
Mandr4ke
Apprentice
Apprentice


Joined: 25 Jul 2002
Posts: 214
Location: Chicago, IL

PostPosted: Sat Jan 13, 2007 2:39 am    Post subject: Reply with quote

I just did a fresh install and by default it's all messed up weather you use "unicode" or not in your use flags.

This never would occur provious as untill the latest major system update ncurses always displayed perfectly by default!
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7301
Location: Groton, Massachusetts USA

PostPosted: Sat Jan 13, 2007 2:46 am    Post subject: Reply with quote

Black Imp wrote:
why do I have the same problem without changing to unicode?

Have you changed profiles recently ?

Older profiles didn't have USE="unicode" in make.defaults , but the newer profiles do.

Take a look at the USE= line when you do "emerge --info".
Back to top
View user's profile Send private message
Black Imp
Apprentice
Apprentice


Joined: 09 Oct 2004
Posts: 168

PostPosted: Sun Jan 14, 2007 4:10 am    Post subject: Reply with quote

thank you: no i have not changed anything. I've just installed the snapshots ready 2 or 3 weeks ago on a bios raid 0 system . Processor amd xp barton 2600+, abit nf7s v2. I have not installed unicod nor chaged profile thou ppl are telling me to do it for solving the problem. i've tried installing unicode but it gave my some error in setting variables and beside nothing chianged in displaying characters.
As i said in another topic entering "reset" the problem disappears but only for that console and not permanently
this could be a [edit]HINT.

I 've also tried to re-emerge ncurses and after glibc... nothin.

USE variable doesn't include 'unicode' flag

something set in kernel config file?


Last edited by Black Imp on Thu Jan 25, 2007 7:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Sun Jan 14, 2007 5:12 am    Post subject: Reply with quote

Well, the profile may still have unicode set, so you'd have to have -unicode in make.conf to get rid of it. As far as the kernel, there in fact is an option under "File Systems", "Native Language Support", where you can define the default codepage and choose whether the unicode codepage is built in.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
Black Imp
Apprentice
Apprentice


Joined: 09 Oct 2004
Posts: 168

PostPosted: Wed Feb 14, 2007 4:50 pm    Post subject: Reply with quote

sorry I couldn't read here for a while. So you suggest to add -unicode to the USE list? have I to recompile the kernel then?
Back to top
View user's profile Send private message
Black Imp
Apprentice
Apprentice


Joined: 09 Oct 2004
Posts: 168

PostPosted: Fri Feb 16, 2007 12:03 am    Post subject: Reply with quote

up
Back to top
View user's profile Send private message
solamour
Guru
Guru


Joined: 21 Dec 2004
Posts: 493
Location: San Diego, CA

PostPosted: Thu Oct 17, 2013 6:30 am    Post subject: Reply with quote

When I login to my machine from Windows using PuTTY, I get the following.
Code:
 .config - Linux/x86 3.10.7-gentoo-r1 Kernel Configuration
 qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq
  lqqqqqqqqqqqq Linux/x86 3.10.7-gentoo-r1 Kernel Configuration qqqqqqqqqqqqk
  x  Arrow keys navigate the menu.  <Enter> selects submenus --->.          x
  x  Highlighted letters are hotkeys.  Pressing <Y> includes, <N> excludes, x
  x  <M> modularizes features.  Press <Esc><Esc> to exit, <?> for Help, </> x
  x  for Search.  Legend: [*] built-in  [ ] excluded  <M> module  < >       x
  x lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk x
  x x        Gentoo Linux  --->                                           x x
  x x    [*] 64-bit kernel                                                x x
  x x        General setup  --->                                          x x
  x x    [*] Enable loadable module support  --->                         x x
  x x    -*- Enable the block layer  --->                                 x x
  x x        Processor type and features  --->                            x x
  x x        Power management and ACPI options  --->                      x x
  x x        Bus options (PCI etc.)  --->                                 x x
  x x        Executable file formats / Emulations  --->                   x x
  x x    [*] Networking support  --->                                     x x
  x mqqqqv(+)qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj x
  tqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqu
  x        <Select>    < Exit >    < Help >    < Save >    < Load >         x
  mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj


But when I login directly from console (i.e. no remote login) or remotely from Ubuntu, all the lines show up correctly. Also, if I use the same problematic Windows/PuTTY to login to a different Gentoo box, the lines look fine.

Changing PuTTY's setting to "ISO-8859-1" does solve the problem, but then I'm not able to see any of the Unicode characters. If you already figured out, please share how you did. Thanks.
__
sol
Back to top
View user's profile Send private message
badm4n
n00b
n00b


Joined: 12 Oct 2012
Posts: 2
Location: Pennsylvania

PostPosted: Sat Nov 09, 2013 9:12 pm    Post subject: Reply with quote

I used the instructions from the following page to correct this issue for my Gentoo setups at home.

http://www.koerner.in/2011/08/ugly-borders-and-lines-in-curses-based-programs-using-putty/

To summarize the steps from that page...
  1. From the main PuTTY window, navigate to Window > Translation category
  2. Ensure Remote character set is set to UTF-8
  3. Under Adjust how PuTTY handles line drawing characters select Use Unicode line drawing code points
  4. Navigate to Connection > Data
  5. Under Terminal details, enter putty for Terminal-type string
  6. Navigate to Session
  7. Highlight Default Settings and then click Save

The above steps will make the appropriate changes for any new or one-off sessions. If you have saved sessions (like I do) unfortunately, you will need to load each session and repeat the above steps, overwriting the original saved session.
_________________
[ badm4n ]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum