Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers-13.1_pre897 fgl_glxgears build failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1393

PostPosted: Sat Nov 09, 2013 8:08 pm    Post subject: ati-drivers-13.1_pre897 fgl_glxgears build failed Reply with quote

The subject about sums it up. Here is my complete build log, emerge --info, and kernel config

The error itself seems to be
Code:
In file included from fgl_glxgears.c:81:0:
/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/usr/include/GL/glATI.h:5370:0: warning: "GL_PROXY_TEXTURE_2D_MULTISAMPLE" redefined [enabled by default]
 #define GL_PROXY_TEXTURE_2D_MULTISAMPLE                    0X9101
 ^
In file included from /usr/include/GL/gl.h:2085:0,
                 from /usr/include/GL/glu.h:38,
                 from fgl_glxgears.c:64:
/usr/include/GL/glext.h:1445:0: note: this is the location of the previous definition
 #define GL_PROXY_TEXTURE_2D_MULTISAMPLE   0x9101
I have already rebuilt mesa with -radon, but this problem persists. Any help would be appreciated.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
tw04l124
Veteran
Veteran


Joined: 03 Oct 2006
Posts: 1310
Location: A t z e l, lower austria

PostPosted: Mon Nov 11, 2013 9:53 am    Post subject: Reply with quote

Just a guess but judging on the output you give, they changed something in the kernel you are using or in the drivers. So in short you need to patch something to get it running.

I use NVidia myself and when I get such things I know i need to find a patch, because of that missing define I read in your output.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1393

PostPosted: Mon Nov 11, 2013 9:32 pm    Post subject: Reply with quote

Yes, it seems to be the kernel. After a few more hours of trying different things (including looking at similar problems on google), it appears that the newer kernels broke all of the ati packages, but new ones where released for the newer cards. Unfortunately, my computer doesn't have one of these cards so it seems that all non-masked kernels are broken and AMD isn't going to fix it since this is for the older cards.

I'm leaving this open just in case I am wrong and there actually is a way to get it working.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
kumarnikhil
n00b
n00b


Joined: 03 Mar 2014
Posts: 1

PostPosted: Mon Mar 03, 2014 4:42 pm    Post subject: Reply with quote

The Doctor wrote:
Yes, it seems to be the kernel. After a few more hours of trying different things (including looking at similar problems on google), it appears that the newer kernels broke all of the ati packages, but new ones where released for the newer cards. Unfortunately, my computer doesn't have one of these cards so it seems that all non-masked kernels are broken and AMD isn't going to fix it since this is for the older cards.

I'm leaving this open just in case I am wrong and there actually is a way to get it working.



Catalyst legacy version doesn't compile with the newer version of Mesa(i.e. Mesa9 onwards). To build catalyst legacy, you should consider the below setup:
Supported Kernel version for catalyst legacy 3.10
Mesa version 8.x
Xorg version 1.12

With Gentoo you can install both open source version of radeon & keep your system up to date while also enjoy catalyst legacy version without messing up your current setup.
For a detailed how-to, on setting up both the driver, check out my post :
http://mytech-zone.blogspot.com/2013/12/amd-catalyst-binary-driver-and-open.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum