Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[pulse] deinstallation complete (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ayame99
n00b
n00b


Joined: 07 Oct 2013
Posts: 20

PostPosted: Sun Nov 17, 2013 7:51 pm    Post subject: [pulse] deinstallation complete (résolu) Reply with quote

Bonjour,

Je souhaite enlever complètement pulse de mon système mais je me heurte à un drôle de problème.J ai essaye de suivre ce post http://forums.gentoo.org/viewtopic-t-876357-start-0.html
mais quand je fais

Code:
emerge -uDNavt world


j obtient

Code:
shibusen ayame # emerge -uDNavt world

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; quitting.


pourtant j ai bien -pulseaudio dans mon make.conf
J ai essayé
Code:


shibusen ayame # emerge --depclean pulseaudio

Calculating dependencies... done!
  media-sound/pulseaudio-2.1-r1 pulled in by:
    media-libs/libsdl-2.0.0_pre7046 requires >=media-sound/pulseaudio-0.9
    media-plugins/alsa-plugins-1.0.27 requires media-sound/pulseaudio


Donc je vois bien que media-libs/libsdl a besoin de pulse et quand je verifie je vois bien que media-libs/libsdl est compile sans pulseaudio

Code:

shibusen ayame # emerge media-libs/libsdl

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/libsdl-1.2.15-r4  USE="X alsa audio joystick opengl video xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -pulseaudio -static-libs (-svga) -tslib -xinerama" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

pour information j utilise xfce4 comme bureau
alsa-mixer utilise bien pulse:

Code:
Carte: PulseAudio 
Puce: PulseAudio


du coup je suis bloqué
_________________
"Parfois je me demande si la meilleure preuve qu'il existe des espèces intelligentes quelque part dans l'Univers c'est qu'aucune d'entre elles n'a encore essayé de nous contacter."
(extrait de Calvin et Hobbes)


Last edited by ayame99 on Wed Nov 20, 2013 12:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5474
Location: ~Brussels - Belgique

PostPosted: Sun Nov 17, 2013 7:57 pm    Post subject: Reply with quote

as-tu aussi nettoyé les packages :
Code:
emerge --deep --ask --depclean
?

EDIT: as-tu vraiment besoin de alsa-plugins ? C'est un ebuild assez modulaire, regarde ce qui a été installé :
Code:
emerge -pv alsa-plugins

Idem pour SDL.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ayame99
n00b
n00b


Joined: 07 Oct 2013
Posts: 20

PostPosted: Tue Nov 19, 2013 4:12 pm    Post subject: Reply with quote

Quote:
as-tu aussi nettoyé les packages :


oui j avais essayé

Code:
>>> No packages selected for removal by depclean
Packages installed:   872
Packages in world:    118
Packages in system:   44
Required packages:    872
Number removed:       0


Quote:
EDIT: as-tu vraiment besoin de alsa-plugins ? C'est un ebuild assez modulaire, regarde ce qui a été installé :


il me semble que alsa-plugins est une dépendance de pulseaudio (je dit peut être une connerie )

par contre c est bizarre hier j ai fini la mise a jour complète via

Code:
 emerge --update --newuse --deep --with-bdeps=y world


(bien sur avec le reste des commandes --depclean et revdep-rebuid)

Ce que j ai du mal à comprendre c'est qu en principe il aurait du voir la variable -pulseaudio dans le make.conf
je viens de relancer la commande sans avoir mis jour la liste des ebuilds

Code:

shibusen ayame # emerge --update --newuse --deep --with-bdeps=y world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; quitting.


jusque là rien de bizarre mais je viens d essayer

Code:
emerge alsa-plugins


(pas besoin de rajouter -pv dans mon cas EMERGE_DEFAULT_OPTS="--ask --verbose")

et la
Code:

shibusen ayame # emerge alsa-plugins

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-plugins/alsa-plugins-1.0.27  USE="-debug -ffmpeg -jack -libsamplerate -pulseaudio* -speex" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-plugins/alsa-plugins:0

  (media-plugins/alsa-plugins-1.0.27::gentoo, installed) pulled in by
    media-plugins/alsa-plugins[pulseaudio] required by (media-sound/pulseaudio-2.1-r1::gentoo, installed)

  (media-plugins/alsa-plugins-1.0.27::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.



je vois qu il remarque bien le fait que je ne veus pas pulse (-pulseaudio*)
mais y a un problème visiblement (ebuild scheduled for merge) visiblement portage a pas tous "emergé"
Code:

shibusen ayame # emerge alsa-plugins --newuse --update

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB


 * media-plugins/alsa-plugins

Would you like to add these packages to your world favorites? [Yes/No] n


Quote:
Idem pour SDL.


sdl oui j en ai besoin c est une dépendance de plusieurs paquets que j utilise (ames-emulation/dosbox-0.74 requires media-libs/libsdl ; games-strategy/wesnoth-1.10. requires >=media-libs/libsdl-1.2.7:07 ; media-video/vlc-2.0.7 requires >=media-libs/libsdl-1.2.8 et bien d autre)
_________________
"Parfois je me demande si la meilleure preuve qu'il existe des espèces intelligentes quelque part dans l'Univers c'est qu'aucune d'entre elles n'a encore essayé de nous contacter."
(extrait de Calvin et Hobbes)
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5474
Location: ~Brussels - Belgique

PostPosted: Tue Nov 19, 2013 6:13 pm    Post subject: Reply with quote

essaie de désinstaller explicitement pulseaudio, au cas où il serait dans ton fichier world:
Code:
emerge -C pulseaudio

puis
Code:
emerge -av @preserved-rebuild

_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ayame99
n00b
n00b


Joined: 07 Oct 2013
Posts: 20

PostPosted: Wed Nov 20, 2013 12:56 pm    Post subject: Reply with quote

Quote:
essaie de désinstaller explicitement pulseaudio, au cas où il serait dans ton fichier world:


J y avais pensé il n y était pas dans le fichier world mais en utilisant

Code:
emerge -C pulseaudio


et

Code:
emerge -av @preserved-rebuild


c est résolu , merci pour le coup de main
_________________
"Parfois je me demande si la meilleure preuve qu'il existe des espèces intelligentes quelque part dans l'Univers c'est qu'aucune d'entre elles n'a encore essayé de nous contacter."
(extrait de Calvin et Hobbes)
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5474
Location: ~Brussels - Belgique

PostPosted: Wed Nov 20, 2013 12:59 pm    Post subject: Reply with quote

De rien ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum