Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] ld: cannot find -lhcrypto
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1036
Location: Schweiz

PostPosted: Sun Nov 10, 2013 8:39 pm    Post subject: [solved] ld: cannot find -lhcrypto Reply with quote

Ich bin gerade dabei ein neues Gentoo aufzusetzen und bleibe nun zum dritten mal ein der gleichen Fehlermeldung stelle hängen und kann dafür keine Lösung finden.
Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lhcrypto

Zuerst kam der Fehler bei ghostscript-gpl sowohl stable als auch eine Version höher und tiefer, dann passierte es bei cups-filters und nun bei gtk+3.
Eine Google suche hat leider nicht viel gebracht nur das bei exim mal das selbe passiert ist und es etwas mit sasl zu tun hatte aber leider spielt es keine rolle ob sasl nun drauf ist oder nicht der Fehler kommt immer.

Weiß einer von euch woher (aus welchem Paket) dieses lhcrypto kommt damit ich es von Hand nachinstallieren kann?
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Mon Nov 11, 2013 2:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
bug_report
n00b
n00b


Joined: 17 Sep 2010
Posts: 69
Location: Frankfurt, Germany

PostPosted: Sun Nov 10, 2013 9:27 pm    Post subject: Reply with quote

libhcrypto könnte von heimdal kommen. Ist das kerberos USE-Flag gesetzt?
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1036
Location: Schweiz

PostPosted: Mon Nov 11, 2013 5:29 am    Post subject: Reply with quote

Ja das kerberos Flag ist Global gesetzt, ausser bei openssl und virtuoso-server (weil sie heimdal nicht akzeptieren), und ich verwende auch schon länger problemlos auf all meinen Installationen heimdal anstelle von mit-krb.

EDIT1:
Aber du hast recht, auf meinen anderen Kisten wurde über das Paket "app-crypt/heimdal" die Datei "/usr/lib64/libhcrypto.so" installiert und vermutlich ist das genau die welche von ld vermisst wird. Ich werde das noch etwas untersuchen vielleicht finde ich ja noch den Grund für diesen Unterschied.

EDIT2:
Problem gelöst.
Scheinbar wird die library nicht mehr installiert wenn das USE-Flag "ssl" auf "app-crypt/heimdal" aktiv ist, ob das nun ein Bug im ebuild oder in heimdal selbst ist weis ich nicht.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum