Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Google Earth on Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 643

PostPosted: Mon Mar 31, 2014 1:51 am    Post subject: Google Earth on Gentoo Reply with quote

Hello:

I've had an old ebuild of gentoo on my system for some time, googleearth-7.1.2.2041 which was a bit unstable to start. I'd have to try 5-6 times to get it up and running just to run.

So O emerge -C googleearth yesterday and decided to try and use the RPMs offered by google instead.

First tried the 64 bit one:

rpm -ev google-earth-stable_current_x86_64.rpm

But ran into trouble withe the lib-lsb issue. I could not get this to work. The ebuild had an interesting line in it:

patchelf --set-interpreter /lib/ld-linux$(usex amd64 "-x86-64" "").so.2 ${PN}-bin || die "patchelf failed"

Which is used to generate the lib file but could not get it to work for the 64 bit. I really don't understand what I was looking at.

So:
rpm -ev google-earth-stable-7.1.2.2041-0.x86_64

Got rid of the 64 bit version, and installed the 32bit version:
rpm -ivh --nodeps google-earth-stable_current_i386.rpm

This ran perfectly fine. No crashing, no stability issues and I guess the left over /lib/ld-lsb.so.3 from the ebuild was still there so it ran.

I'm pretty happy with things as need google earth for work and running it inside a qemu windows VM with no 3D acceleration was not something I wanted to try.

Oh yah, I did try to installed the windows version under wine but the install routine would crash. so gave that up.

In short, am happy with the current 32bit p[erformance and will stay with that.

My current rpm holdings:
jserinki7 jserink # rpm -qa
draftsight-2014.1.55-2.i386
aaronia-mcs-1.9.0-1.x86_64
rpm-4.11.0.1-1.noarch
google-earth-stable-7.1.2.2041-0.i386
lib64apt-pkg0-0.5.15cnc6-15mdv2007.0.x86_64
libapt-pkg0-0.5.15cnc6-15mdv2007.0.i586
apt-0.5.15cnc6-15mdv2007.0.x86_64
libaudio2-1.8-5.i386
jserinki7 jserink #

Most of the stuff you see was required to get draftsight to work.

Hope this information will be of some help to people.

Cheers,
John
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 462
Location: United Kingdom

PostPosted: Fri Apr 04, 2014 8:53 am    Post subject: Reply with quote

Another approach.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum