Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] emerge libreoffice bricht ab
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 868
Location: Eppingen, Germany

PostPosted: Thu Nov 07, 2013 9:54 pm    Post subject: [gelöst] emerge libreoffice bricht ab Reply with quote

Code:
rm -f /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/sdk/classes/win/unowinreg.dll && ln /var/tmp/portage/app-office/libreoffice-4.1.3.2/distdir/185d60944ea767075d27247c3162b3bc-unowinreg.dll /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/sdk/classes/win/unowinreg.dll && touch -hr /var/tmp/portage/app-office/libreoffice-4.1.3.2/distdir/185d60944ea767075d27247c3162b3bc-unowinreg.dll /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/sdk/classes/win/unowinreg.dll
rm -f /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/share/registry/oo-ldap.xcd.sample && ln /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/officecfg/registry/schema/oo-ldap.xcd.sample /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/share/registry/oo-ldap.xcd.sample && touch -hr /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/officecfg/registry/schema/oo-ldap.xcd.sample /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/share/registry/oo-ldap.xcd.sample
rm -f /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/share/registry/oo-ad-ldap.xcd.sample && ln /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/officecfg/registry/schema/oo-ad-ldap.xcd.sample /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/share/registry/oo-ad-ldap.xcd.sample && touch -hr /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/officecfg/registry/schema/oo-ad-ldap.xcd.sample /var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/share/registry/oo-ad-ldap.xcd.sample
[build PKG] officecfg_tools
ln: failed to create hard link ‘/var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/sdk/classes/win/unowinreg.dll’ => ‘/var/tmp/portage/app-office/libreoffice-4.1.3.2/distdir/185d60944ea767075d27247c3162b3bc-unowinreg.dll’: Operation not permitted
make[1]: *** [/var/tmp/portage/app-office/libreoffice-4.1.3.2/work/libreoffice-4.1.3.2/instdir/unxlngx6.pro/sdk/classes/win/unowinreg.dll] Error 1


Anscheinend kann emerge den hard link nicht erstellen - was kann ich da tun?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Fri Nov 08, 2013 2:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 174
Location: Essen

PostPosted: Fri Nov 08, 2013 6:02 am    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-t-973908.html

Bitte vorher im Forum genau hinschauen. Das Thema wurde bereits mehrmals behandelt!
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 868
Location: Eppingen, Germany

PostPosted: Fri Nov 08, 2013 6:16 am    Post subject: Reply with quote

@arfe: Da bricht libreoffice beim touch-Befehl ab (Error 1) - jetzt könnte ich sagen "lies mal genau, was in den posts steht bevor Du antwortest...."
Selbstverständlich habe ich die Forensuche bemüht... ich denke aber, dass dieser post einen anderen Fehler beschreibt.

Bei mir ist das ein Hard Link... Wieso kann emerge als root keine hard Link erstellen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4113

PostPosted: Fri Nov 08, 2013 7:06 am    Post subject: Reply with quote

uhai wrote:

Bei mir ist das ein Hard Link... Wieso kann emerge als root keine hard Link erstellen?

vielleicht weil der emerge process beim kompilieren nicht als root läuft?
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 868
Location: Eppingen, Germany

PostPosted: Fri Nov 08, 2013 2:26 pm    Post subject: Reply with quote

@firefly: Ich starte emerge immer als root in der Konsole.

@arfe: Hat trotzdem mit FEATURES="-userpriv" emerge -v app-office/libreoffice geklappt...?! Verstehe ich zwar immer noch nicht, aber danke für den Tip und nimm mir die Bemerkung bitte nicht übel....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4009

PostPosted: Fri Nov 08, 2013 4:22 pm    Post subject: Reply with quote

Bei mir bricht libreoffice fast jedesmal mit irgendeinem anderen Fehler ab - beim nächsten Mal geht es dann. Ich vermute, in deren Makefile herrscht fürchterliches Chaos. Wenn man neu emerget, geht es meistens, und wenn man ccache benutzt - was man sowieso immer tun sollte - verliert man dabei auch kaum Zeit.
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 174
Location: Essen

PostPosted: Fri Nov 08, 2013 5:33 pm    Post subject: Reply with quote

mv wrote:
Bei mir bricht libreoffice fast jedesmal mit irgendeinem anderen Fehler ab - beim nächsten Mal geht es dann. Ich vermute, in deren Makefile herrscht fürchterliches Chaos. Wenn man neu emerget, geht es meistens, und wenn man ccache benutzt - was man sowieso immer tun sollte - verliert man dabei auch kaum Zeit.


In der neuen libreoffice Version als stable geht es nur mit FEATURES="-userpriv" emerge -v app-office/libreoffice. Ein wiederholtes emerge bringt rein gar nichts.
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 174
Location: Essen

PostPosted: Fri Nov 08, 2013 5:33 pm    Post subject: Reply with quote

uhai wrote:

@arfe: Hat trotzdem mit FEATURES="-userpriv" emerge -v app-office/libreoffice geklappt...?! Verstehe ich zwar immer noch nicht, aber danke für den Tip und nimm mir die Bemerkung bitte nicht übel....


Kein Problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum