Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] sshd with only wifi?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
PatEr
n00b
n00b


Joined: 07 Nov 2013
Posts: 3

PostPosted: Thu Nov 07, 2013 8:57 pm    Post subject: [SOLVED] sshd with only wifi? Reply with quote

How can I start sshd without eth0? I only use wifi and wlan0 with a 192.168.0.x address from dhcp. When I try to start sshd I get an error "sshd is scheduled to start When net.eth0 has started"

Is there a way to get around this problem?

/
PatEr


Last edited by PatEr on Sat Nov 09, 2013 10:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Thu Nov 07, 2013 10:44 pm    Post subject: Reply with quote

PatEr,

Welcome to Gentoo.

By default, the net service is only considered up when all network interfaces are up.
You can change this to when any interface is up.

Read the comments in /etc/rc.conf

You can also tell sshd to need a particular interface.
Code:
# /etc/conf.d/sshd: config file for /etc/init.d/sshd
rc_need="net.br1"

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
PatEr
n00b
n00b


Joined: 07 Nov 2013
Posts: 3

PostPosted: Sat Nov 09, 2013 10:42 pm    Post subject: Reply with quote

Thanks, It's working now!
Back to top
View user's profile Send private message
dataking
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 104

PostPosted: Sat Dec 21, 2013 1:40 am    Post subject: Reply with quote

I'm having a similar issue.

I changed /etc/conf.d/sshd to need wlan0. And when I try to start sshd, it says:
Code:
* WARNING: sshd is scheduled to start when net.wlan0 has started


So when I try to start wlan0, it complains that wlan0 is already up.

I'm using wicd (and the KDE widget) for wireless connectivity.

What else do I need to tweak to get sshd up on wlan0?

(I even tried changing the listening address in sshd_conf to the IP address of wkan0, but suspect that the solution will be lower level, and I should be able to change it back to 0.0.0.0.)
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
dataking
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 104

PostPosted: Sat Dec 21, 2013 2:55 am    Post subject: Reply with quote

A quick reboot seems to have gotten things working. *shrug*
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum