Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HDMI audio choppy/distorted with ALSA
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
bhokaal
n00b
n00b


Joined: 16 Feb 2014
Posts: 1

PostPosted: Sun Feb 16, 2014 12:29 am    Post subject: HDMI audio choppy/distorted with ALSA Reply with quote

Hi,
I have ATI AMD video card HD7770 with HDMI o/p i use. I am able to get sound but its very very choppy/distorted. The strange fact is output works perfectly with default Pulse audio settings (no distortion/choppiness) . Since ALSA sounds better has better support for bit streaming i am very interested to get native ALSA running. Things i have already tried

1. Completely removing/stopping pulse audio the alsa choppiness/distortion still remains
2. I have tried both fglrx & opensource radeon driver with same result
3. So basically when a stream plays through default pulse audio its perfect but when directly through ALSA its distorted. to see the difference i recorded the info in cat /proc/asound/card1/pcm3p/sub0/* in both the cases the major difference in o/p was

access: MMAP_INTERLEAVED >>>pluse audio
access: RW_INTERLEAVED >>> native alsa

Is there a way to force mmap mode in native alsa or any other idea ??
If you can suggest a better place to pose this query please ??
_________________
--
Enjoy
Bhokaal
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum