Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg config Lenvo T430s
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jonas_H
n00b
n00b


Joined: 06 Nov 2013
Posts: 5

PostPosted: Wed Nov 06, 2013 11:01 pm    Post subject: [SOLVED] xorg config Lenvo T430s Reply with quote

Hi,

Been trying for some time to get xorg running on my lenovo laptop... anyway ran nvidia-settings today and still no luck.. attaching xorg.conf and xorg.log.0 maybe someone can help me...

xorg.conf http://pastebin.com/m7KqTueK
xorg.log.0 http://pastebin.com/pVu7Had3

Basicly it ends with

Code:
[   234.890] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   234.890] (--) using VT number 7
 
[   234.893] (EE) No devices detected.
[   234.893]
Fatal server error:
[   234.893] no screens found
[   234.893] (EE)


Even tho they exist in the configuration....

Hope someone can shed some light on this for me... Thanks

BR


Last edited by Jonas_H on Sun Nov 10, 2013 5:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Wed Nov 06, 2013 11:12 pm    Post subject: Reply with quote

Is this laptop Optimus based :?:
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31884
Location: 56N 3W

PostPosted: Wed Nov 06, 2013 11:22 pm    Post subject: Reply with quote

Jonas_H,

Welcome to Gentoo.

From your log
Code:
[   234.887] (--) PCI:*(0:0:2:0) 8086:0166:17aa:2200 rev 9, Mem @ 0xf1000000/4194304, 0xe0000000/268435456, I/O @ 0x00006000/64
[   234.887] (--) PCI: (0:1:0:0) 10de:1140:17aa:2200 rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00005000/128

it looks like you have an Optimus graphics system as eyoung100 suggests.

If so, make the Intel graphics work first. The nVidia graphics isn't all there.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jonas_H
n00b
n00b


Joined: 06 Nov 2013
Posts: 5

PostPosted: Thu Nov 07, 2013 9:00 pm    Post subject: Reply with quote

Thank you all for your replies.. =)

I have looked over the other threads regarding this and now i have the same issue as some other people... segfaulting xorg...

Xorg.log.0 : http://pastebin.com/fxbPTcyK
xorg.conf : http://pastebin.com/zBV9Xg1W

Conclusion...

Code:

[    26.500] adjust shatters 0 1600
[    26.501] need to create shared pixmap 1(EE)
[    27.791] (EE) Backtrace:
[    27.801] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x81f53a9]
[    27.801] (EE) 1: /usr/bin/X (0x8048000+0x1b12ba) [0x81f92ba]
[    27.801] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xffffe40c]
[    27.801] (EE) 3: /usr/bin/X (RRCrtcDetachScanoutPixmap+0x52) [0x814bb92]
[    27.801] (EE) 4: /usr/bin/X (0x8048000+0x103d13) [0x814bd13]
[    27.801] (EE) 5: /usr/bin/X (0x8048000+0x5a7ce) [0x80a27ce]
[    27.801] (EE) 6: /usr/bin/X (FreeClientResources+0x75) [0x80a39c5]
[    27.801] (EE) 7: /usr/bin/X (FreeAllResources+0x4c) [0x80a3a6c]
[    27.801] (EE) 8: /usr/bin/X (0x8048000+0x225b5) [0x806a5b5]
[    27.801] (EE) 9: /lib/libc.so.6 (__libc_start_main+0xf3) [0xb748e943]
[    27.801] (EE) 10: /usr/bin/X (0x8048000+0x22929) [0x806a929]
[    27.801] (EE)
[    27.801] (EE) Segmentation fault at address 0x26c
[    27.801] (EE)
Fatal server error:
[    27.801] (EE) Caught signal 11 (Segmentation fault). Server aborting


Code:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M] (rev a1)


re-emerged everything... again and again.. cant solve it :(
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Nov 07, 2013 9:44 pm    Post subject: Reply with quote

How Gentoo Savvy are you :?: We have plenty of users here with your setup. As such, I'm going to present you with two methods. I want you to try each one and report back with the one you got working best.

Method 1: Use the New Kernel Option - VGA Switcharoo
Method 2: Install Bumblebee

Please let me know which method you choose. Neddy and I are going to try and sticky something soon.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Jonas_H
n00b
n00b


Joined: 06 Nov 2013
Posts: 5

PostPosted: Thu Nov 07, 2013 10:12 pm    Post subject: Reply with quote

eyoung100 wrote:
How Gentoo Savvy are you :?: We have plenty of users here with your setup. As such, I'm going to present you with two methods. I want you to try each one and report back with the one you got working best.

Method 1: Use the New Kernel Option - VGA Switcharoo
Method 2: Install Bumblebee

Please let me know which method you choose. Neddy and I are going to try and sticky something soon.


Oh im savvy alright......

Method #1: noted in topic that vga_swicharoo didnt matter, i have it compiled in to the kernel but was the same without.. tried everything from this thread, no luck.
Method #2: Gives a really crappy result according to Method #1.. Why would it be interesting.... :(
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Nov 07, 2013 10:22 pm    Post subject: Reply with quote

Jonas_H wrote:

Oh im savvy alright......

Method #1: noted in topic that vga_swicharoo didnt matter, i have it compiled in to the kernel but was the same without.. tried everything from this thread, no luck.
Method #2: Gives a really crappy result according to Method #1.. Why would it be interesting.... :(


Re: Crappy Result
The Crappy Result may be the only result...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31884
Location: 56N 3W

PostPosted: Thu Nov 07, 2013 10:34 pm    Post subject: Reply with quote

Jonas_H,

Make the Intel graphics work unaided first. You will always use the Intel Graphics for the screen refresh, so it has to work.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jonas_H
n00b
n00b


Joined: 06 Nov 2013
Posts: 5

PostPosted: Sat Nov 09, 2013 9:35 am    Post subject: Reply with quote

NeddySeagoon wrote:
Jonas_H,

Make the Intel graphics work unaided first. You will always use the Intel Graphics for the screen refresh, so it has to work.


Alright... tried to only make it with the INTEL card now and basicly reinstalled the whole system.. Now xorg still does not work and i don't get any clear error messages in the log...

xorg.log: http://pastebin.com/hR9iK2TC
xorg.conf http://pastebin.com/P4NYVamv

Card0 or Card2 doest matter.. same end result....
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31884
Location: 56N 3W

PostPosted: Sat Nov 09, 2013 6:18 pm    Post subject: Reply with quote

Jonas_H,

It looks like Xorg started properly, so the problem is probably elsewhere.

You do not need an xorg.conf file for xorg to work. Rename xorg.conf to xorg.conf_NOT_Needed so its not found.
If you have xdm in the default runlevel, remove it. This will stop a broken login manager from being ru.
If you have a ~/.xinitrc file, rename it too.

Now, when you startx, you just get the defaults with a USA keymap. The defaults don't give Xorg anything to do, so for our test, thats not useful either.
Code:
emerge -1 twm xterm xclock
will provide some applications for Xorg to start.

Reboot.

At the login prompt log in as your normal user. Give the startx command and report back.
You should get three xterms and am analogue clock.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jonas_H
n00b
n00b


Joined: 06 Nov 2013
Posts: 5

PostPosted: Sun Nov 10, 2013 5:22 pm    Post subject: Reply with quote

Oh man this feels good :)

Code:
Theodore jonas # glxgears
32691 frames in 5.0 seconds = 6538.094 FPS
44113 frames in 5.0 seconds = 8822.556 FPS
46431 frames in 5.0 seconds = 9286.046 FPS
45914 frames in 5.0 seconds = 9182.779 FPS
46333 frames in 5.0 seconds = 9266.448 FPS
46158 frames in 5.0 seconds = 9231.587 FPS



Savvy.. as someone posted up...

Took a complete rebuild of the system, with the correct make.conf changes

VIDEO_CARDS="nvidia intel modesetting" .. atleast thats what did it for me :)

Thanks All.. now just gotta find out how to enable the trackpad and not only the track ball on the synaptics driver!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum