Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.10
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Mon Nov 04, 2013 3:46 pm    Post subject: Gnome 3.10 Reply with quote

The irc user lxnay from #gentoo-desktop on freenode mentioned this overlay
https://github.com/Heather/gentoo-gnome
It provides gnome 3.10 as an overlay for gentoo. I tried it and it works as before so far :)

What are your experiences with gnome 3.10 so far? Since I do not use all components of gnome (e.g. evolution) yet, I do not know what might not work.

Here is my current setup (starting from a working gnome 3.8 setup):


    1. Add the gnome-next overlay via layman:

    Code:
    layman -fa gnome-next


    2. Package unmasks and use changes:

      /etc/portage/package.use/gnome-3.10

    Code:
    =app-cdr/brasero-3.8.0 tracker
    =gnome-base/nautilus-3.10.0 tracker


      /etc/portage/package.unmask/gnome-3.10

    Code:
    =media-libs/libquvi-scripts-0.9.20130903
    =sci-geosciences/geocode-glib-3.10.0
    =media-libs/libquvi-0.9.2-r1
    =app-crypt/libsecret-0.16


    3. Update @world set:
    Code:
    emerge -auvDN world


    4. Most likely rebuild broken packages:
    Code:
    emerge -v @preserved-rebuild



Failed packages:

    media-video/cheese-3.10.1: http://bpaste.net/show/146657/
    dropped: gnome-base/gnome-extra-apps-3.10.1 depends on >=media-video/cheese-3.10.1
    dropped: gnome-base/gnome-3.10.1 depends on >=gnome-base/gnome-extra-apps-3.10.1[tracker]


Quick fix for building cheese:
Code:
FEATURES="-sandbox" emerge -1uv cheese
Back to top
View user's profile Send private message
dambacher
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 285
Location: Germany

PostPosted: Tue Nov 05, 2013 5:35 pm    Post subject: Reply with quote

Hi
I installed gnome 3.10 from heaters repository the last 3 days.
This was mostly because I had to
1) switch to systemd before (I will not bash it, for me it works as fine as openrc and I get to like the concept) and It took time to figure out how to break out of the blocking of systemd, udev and kmod.
The gentoo systemd install howto is gerat for this: http://wiki.gentoo.org/wiki/Systemd

2) Install the ultra-latest packets for mesa and xorg to get egl/opengl with gallium support on my nvidia NVC3 chipset without glitches. I used the overlay X11.

3) Find out where to get the 3.10 ebuild. I fetched heathers git repository manually,
Edit 20131226: gnome3.10 is in portage and in gnome overlay, no need to use gnome-next or the git repository any more
I inserted the package.mask and package.use out of the status/portag-configs directory and emerged with use=-extras.
There were some minor glitches but everything went fine.
And --autounmask-write is your friend...

Now I work on my production system with gnome 3.10.
Nvidia egl has some glitches with the shell background. And I installed the application menu plugin.
And for those who get a shiver when reading "production system". my emergency exit is to roll back to the old xfce setup just by switching to my btrfs root snspashot i made before start .-)

Next on my list is experimenting with wayland.
1.12 starts and gives a shell, but xwayland does not start my firefox and my gnome-session aborts with error.
Has someone seen 1.13 ebuilds?

For the curious - These are my running versions:
sys-kernel/vanilla-sources-3.10.17
virtual/udev-206-r3
sys-apps/systemd-208-r2
sys-apps/kmod-15
sys-apps/hwids-20130915.1

x11-base/nouveau-drm-99999999
media-libs/mesa-9.2.2
x11-libs/libdrm-2.4.47

gnome-shell-3.10.1
x11-wm/mutter-3.10.1.1
gnome-base/gnome-shell-3.10.1
gnome-base/gnome-3.10.1

And some special uses:
USE: gallium wayland egl gles2 systemd -consolekit -extras -acl
# for mesa with nouveau
media-libs/mesa xorg gbm
x11-libs/libdrm libkms
# dependencys force udev in
sys-apps/kmod -openrc


bye
dambacher


Last edited by dambacher on Thu Dec 26, 2013 7:20 am; edited 1 time in total
Back to top
View user's profile Send private message
Cynede
Developer
Developer


Joined: 30 Nov 2012
Posts: 36

PostPosted: Wed Nov 06, 2013 4:07 am    Post subject: Reply with quote

maintain this overlay since Gnome 3.9.90 ... But I suggest to post all the issues to github.
_________________
GitHub
Twitter
Last.fm

“Pain is inevitable Suffering is optional” Haruki Murakami, What I Talk About When I Talk About Running
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Wed Nov 06, 2013 3:24 pm    Post subject: Reply with quote

no known issues so far for me ;) thanks for sharing your work :)
Back to top
View user's profile Send private message
Cynede
Developer
Developer


Joined: 30 Nov 2012
Posts: 36

PostPosted: Thu Nov 07, 2013 11:18 am    Post subject: Reply with quote

Note that there needs some work on quality. Like some dependencies versions etc... could be not very correct.
_________________
GitHub
Twitter
Last.fm

“Pain is inevitable Suffering is optional” Haruki Murakami, What I Talk About When I Talk About Running


Last edited by Cynede on Fri Nov 08, 2013 5:15 am; edited 1 time in total
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Thu Nov 07, 2013 10:25 pm    Post subject: Reply with quote

Issues trying to update another pc to gnome 3.10:
I had to build app-misc/tracker with USE="-rss" because otherwise it pulls in net-libs/libgrss as a dependency, which failed to build. As a consequence of that, portage could not continue updating gnome.
net-libs/libgrss-0.5.0 build.log: http://bpaste.net/show/147721/

I attached a small patch fixing the build to this bug https://bugs.gentoo.org/show_bug.cgi?id=490722

How to use the patch:

1. Save it as e.g. /etc/portage/patches/net-libs/libgrss-0.5.0/missing-includes.patch
2. Create /etc/portage/bashrc with this content:

Code:
post_src_prepare() {
    if type epatch_user &> /dev/null ; then
        epatch_user
    fi
}


3. optional: verify that the patch is applied and the build succeeds: emerge -1v --jobs=1 =net-libs/libgrss-0.5.0
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3748

PostPosted: Wed Dec 25, 2013 9:01 am    Post subject: Reply with quote

umm, i see 3.11 stuff now being pulled in and that it is suggested now to switch to gnome overlay in case you want to stick with 3.10.
which i did but there you get 3.8 by default and i dont see any mask files, do we have to do them on our own ?

just wondering what is the "official" or better supported way to have 3.10 now.

thanks !
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Wed Dec 25, 2013 1:32 pm    Post subject: Reply with quote

Code:
[  601.808247] empathy[6116]: segfault at 8 ip 00007f730c77c868 sp 00007fff2e627030 error 4 in libglib-2.0.so.0.3902.0[7f730c6df000+142000]
[  620.810386] empathy[6214]: segfault at 7fff99ec0ff8 ip 00007f859b812a2b sp 00007fff99ec1000 error 6 in libglib-2.0.so.0.3902.0[7f859b77c000+142000]


I don't know why, but since a few days empathy crashes most of the time. Firefox and Skype also tend to crash quite often lately. All these programs seem to have problems with libglib?
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 180

PostPosted: Wed Dec 25, 2013 4:19 pm    Post subject: Reply with quote

3.10 is in portage (~amd64) now, but masked.

Unmasking leads to a whopping amount of slot conflicts, I'm not sure if that is only true for my box.

Rüdiger
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Wed Dec 25, 2013 6:27 pm    Post subject: Reply with quote

elxa wrote:
Code:
[  601.808247] empathy[6116]: segfault at 8 ip 00007f730c77c868 sp 00007fff2e627030 error 4 in libglib-2.0.so.0.3902.0[7f730c6df000+142000]
[  620.810386] empathy[6214]: segfault at 7fff99ec0ff8 ip 00007f859b812a2b sp 00007fff99ec1000 error 6 in libglib-2.0.so.0.3902.0[7f859b77c000+142000]


I don't know why, but since a few days empathy crashes most of the time. Firefox and Skype also tend to crash quite often lately. All these programs seem to have problems with libglib?


See https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces on how to get more information about that.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Wed Dec 25, 2013 6:27 pm    Post subject: Reply with quote

Wallsandfences wrote:
Unmasking leads to a whopping amount of slot conflicts, I'm not sure if that is only true for my box.


Can we see the complete emerge output?
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 180

PostPosted: Thu Dec 26, 2013 12:07 am    Post subject: Reply with quote

Sure, here it is:

http://pastebin.com/9nx0rn4V

Im running 3.8 at the moment.

Rüdiger
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Thu Dec 26, 2013 2:18 am    Post subject: Reply with quote

Quote:
[blocks B ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)


Upgrade to a newer version of dev-libs/gobject-introspection (might need to accept keywords on it) or find a version of dev-libs/glib that doesn't have this restriction (likely older versions); I think it is more favorable to upgrade the former library than to downgrade the latter. So, putting dev-libs/gobject-introspection in /etc/portage/package.accept_keywords is the way to go.
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Thu Dec 26, 2013 6:56 am    Post subject: Reply with quote

I have compiled glib and empathy with debug symbols and got this in gdb. As you can see empathy crashes immediately :D Btw I use the overlays gnome and gnome-next.

dev-libs/glib: 2.39.2
net-im/empathy: 3.10.2

Code:
$ gdb empathy -ex r
GNU gdb (Gentoo 7.6.2 p1) 7.6.2
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/empathy...Reading symbols from /usr/lib64/debug/usr/bin/empathy.debug...done.
done.
Starting program: /usr/bin/empathy
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe9213700 (LWP 25542)]
[New Thread 0x7fffe37ff700 (LWP 25543)]
[New Thread 0x7fffd68df700 (LWP 25544)]
[New Thread 0x7fffcea0f700 (LWP 25545)]
[New Thread 0x7fffce20e700 (LWP 25546)]
[New Thread 0x7fffcda0d700 (LWP 25547)]

(empathy:25538): folks-WARNING **: backend-store.vala:409: Error preparing Backend 'bluez': No BlueZ 5 object manager running, so the BlueZ backend will be inactive. Either your BlueZ installation is too old (only version 5 is supported) or the service can’t be started.

(empathy:25538): folks-WARNING **: backend-store.vala:409: Error preparing Backend 'ofono': No oFono object manager running, so the oFono backend will be inactive. Either oFono isn’t installed or the service can’t be started.
[New Thread 0x7fffbfdf2700 (LWP 25548)]
[New Thread 0x7fffbf5f1700 (LWP 25558)]
[New Thread 0x7fffbe9e2700 (LWP 25562)]
[New Thread 0x7fffbe1e1700 (LWP 25563)]
[New Thread 0x7fffbd9e0700 (LWP 25564)]
[New Thread 0x7fffbd1df700 (LWP 25565)]
[New Thread 0x7fffbc9de700 (LWP 25566)]
[New Thread 0x7fffb7fff700 (LWP 25567)]
[New Thread 0x7fffb77fe700 (LWP 25568)]
[New Thread 0x7fffb6ffd700 (LWP 25569)]
[New Thread 0x7fffb67fc700 (LWP 25570)]
[New Thread 0x7fffb5ffb700 (LWP 25571)]
[New Thread 0x7fffb57fa700 (LWP 25572)]
[New Thread 0x7fffb4ff9700 (LWP 25573)]
[New Thread 0x7fffaffff700 (LWP 25574)]
[New Thread 0x7fffaf7fe700 (LWP 25575)]
[New Thread 0x7fffaeffd700 (LWP 25576)]
[New Thread 0x7fffae7fc700 (LWP 25577)]
[New Thread 0x7fffadffb700 (LWP 25578)]
[New Thread 0x7fffad7fa700 (LWP 25579)]
[New Thread 0x7fffacff9700 (LWP 25580)]
[New Thread 0x7fffac7f8700 (LWP 25581)]
[New Thread 0x7fffabff7700 (LWP 25582)]
[New Thread 0x7fffab7f6700 (LWP 25583)]
[New Thread 0x7fffaaff5700 (LWP 25584)]
[New Thread 0x7fffaa7f4700 (LWP 25585)]
[New Thread 0x7fffa9ff3700 (LWP 25586)]
[New Thread 0x7fffa97f2700 (LWP 25587)]
[New Thread 0x7fffa8ff1700 (LWP 25588)]
[New Thread 0x7fffa87f0700 (LWP 25589)]
[New Thread 0x7fffa7fef700 (LWP 25590)]
[New Thread 0x7fffa77ee700 (LWP 25591)]
[New Thread 0x7fffa6fed700 (LWP 25592)]
[New Thread 0x7fffa67ec700 (LWP 25593)]

(empathy:25538): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed

(empathy:25538): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed

(empathy:25538): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed

(empathy:25538): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed

(empathy:25538): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed

(empathy:25538): folks-WARNING **: Error preparing persona store 'eds:1387660905.4052.5@thinkgentoo': Couldn't open address book ‘1387660905.4052.5@thinkgentoo’: Unable to connect to 'Contacts': The connection is closed

(empathy:25538): folks-WARNING **: Error preparing persona store 'eds:1362963665.2805.5@thinkgentoo': Couldn't open address book ‘1362963665.2805.5@thinkgentoo’: Unable to connect to 'Contacts': The connection is closed

(empathy:25538): telepathy-CRITICAL **: _logger_logger_vanished: assertion 'conn != NULL' failed

(empathy:25538): telepathy-CRITICAL **: _logger_logger_vanished: assertion 'conn != NULL' failed

(empathy:25538): telepathy-CRITICAL **: _logger_logger_vanished: assertion 'conn != NULL' failed

(empathy:25538): telepathy-CRITICAL **: _logger_logger_vanished: assertion 'conn != NULL' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Error sending message: Broken pipe (g-io-error-quark, 44). Exiting.

Program received signal SIGTERM, Terminated.
0x000000342960f5fb in raise (sig=15) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:37
37   ../nptl/sysdeps/unix/sysv/linux/pt-raise.c: No such file or directory.
(gdb) bt
#0  0x000000342960f5fb in raise (sig=15) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:37
#1  0x00007ffff6c3dbb9 in g_dbus_connection_real_closed (connection=0x70b0a0, remote_peer_vanished=1, error=0x149bc70) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gio/gdbusconnection.c:811
#2  0x0000003c7de05b98 in ffi_call_unix64 () at /var/tmp/portage/dev-libs/libffi-3.0.13-r1/work/libffi-3.0.13/src/x86/unix64.S:76
#3  0x0000003c7de05549 in ffi_call (cif=0x7fffffffcf10, fn=0x7ffff6c3daf5 <g_dbus_connection_real_closed>, rvalue=0x7fffffffce80, avalue=0x7fffffffce00) at /var/tmp/portage/dev-libs/libffi-3.0.13-r1/work/libffi-3.0.13/src/x86/ffi64.c:522
#4  0x00007ffff63fe3d5 in g_cclosure_marshal_generic (closure=0x71a390, return_gvalue=0x0, n_param_values=3, param_values=0x7fffffffd1c0, invocation_hint=0x7fffffffd100, marshal_data=0x7ffff6c3daf5 <g_dbus_connection_real_closed>)
    at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gobject/gclosure.c:1454
#5  0x00007ffff63fd1de in g_type_class_meta_marshal (closure=0x71a390, return_value=0x0, n_param_values=3, param_values=0x7fffffffd1c0, invocation_hint=0x7fffffffd100, marshal_data=0x88) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gobject/gclosure.c:970
#6  0x00007ffff63fcaaa in g_closure_invoke (closure=0x71a390, return_value=0x0, n_param_values=3, param_values=0x7fffffffd1c0, invocation_hint=0x7fffffffd100) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gobject/gclosure.c:777
#7  0x00007ffff641cb50 in signal_emit_unlocked_R (node=0x71a420, detail=0, instance=0x70b0a0, emission_return=0x0, instance_and_params=0x7fffffffd1c0) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gobject/gsignal.c:3594
#8  0x00007ffff641bc46 in g_signal_emit_valist (instance=0x70b0a0, signal_id=145, detail=0, var_args=0x7fffffffd4c8) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gobject/gsignal.c:3312
#9  0x00007ffff641c19b in g_signal_emit (instance=0x70b0a0, signal_id=145, detail=0) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gobject/gsignal.c:3368
#10 0x00007ffff6c3ea13 in emit_closed_in_idle (user_data=0x7fffe40243c0) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gio/gdbusconnection.c:1385
#11 0x00007ffff60e8380 in g_idle_dispatch (source=0x7fffe4030110, callback=0x7ffff6c3e99e <emit_closed_in_idle>, user_data=0x7fffe40243c0) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/glib/gmain.c:5257
#12 0x00007ffff60e58b0 in g_main_dispatch (context=0x6d1530) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/glib/gmain.c:3068
#13 0x00007ffff60e6712 in g_main_context_dispatch (context=0x6d1530) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/glib/gmain.c:3643
#14 0x00007ffff60e6940 in g_main_context_iterate (context=0x6d1530, block=1, dispatch=1, self=0x713960) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/glib/gmain.c:3714
#15 0x00007ffff60e6a14 in g_main_context_iteration (context=0x6d1530, may_block=1) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/glib/gmain.c:3775
#16 0x00007ffff6c0ad3f in g_application_run (application=0xbef200, argc=1, argv=0x7fffffffd8c8) at /var/tmp/portage/dev-libs/glib-2.39.2/work/glib-2.39.2/gio/gapplication.c:1643
#17 0x0000000000433f74 in main (argc=1, argv=0x7fffffffd8c8) at empathy.c:843
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3748

PostPosted: Thu Dec 26, 2013 8:30 am    Post subject: Reply with quote

Quote:
3.10 is in portage (~amd64) now, but masked.


oops, hadnt seen that. thanks !

Quote:
dev-libs/glib: 2.39.2


any reason for using that version of glib ? they are moving lots of development packages into gnome-next overlay already.
try with 2.38.2.

cheers
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 180

PostPosted: Thu Dec 26, 2013 7:00 pm    Post subject: Reply with quote

I Follewed the advice and unmasked gobject-introspection, and the blocks are gone. However, the slot conflicts are not.

http://pastebin.com/PikgvgK2

Rüdiger
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Fri Dec 27, 2013 11:29 am    Post subject: Reply with quote

Increase the --backtrack option to a higher value as it suggests.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 180

PostPosted: Sun Dec 29, 2013 9:30 am    Post subject: Reply with quote

it compiled!
it boots as well. but, my mousepointer is invisible! Kind of funny, but....

This is both in gdm and in gnome. The mouse works as expected in LXDE

Rüdiger
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 180

PostPosted: Mon Dec 30, 2013 10:01 am    Post subject: Reply with quote

Mouse works now, some more packages needed unmasking.
Online accounts crashes when I try do add a new account.

Rüdiger
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum