Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UPDATE] FYI: python-exec2 and java problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
spork
n00b
n00b


Joined: 26 Nov 2012
Posts: 4

PostPosted: Sat Nov 02, 2013 1:25 pm    Post subject: [UPDATE] FYI: python-exec2 and java problems Reply with quote

Hi,

after a world update yesterday evening (which pulled dev-python/python-exec-1000.2 in my case) I had problems to launch java programs. Getting it to work again was a lot of pain, since i was not able to find useful information how to fix this issue. Therefore I decided to share my solution to help those who ran into the same pitfall. I hope it is helpful.

I realized the problem when I tried to execute eclipse, which resulted in the following error message:

Code:

JVM terminated. Exit code=127
/usr/bin/java
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/spork/eclipses/eclipse-jee//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
...


Manually executing a jar (java -jar ... ) resulted in this message:
"/usr/bin/java: no supported Python implementation variant found!"

Then I figured out that /usr/bin/java was a link which pointed to python-exec2.

java-config -J told me that the java executable is located in '/opt/oracle-jre-bin-1.7.0.45/bin/java'. In order to verify it was no java problem I ran:
Code:

/opt/oracle-jre-bin-1.7.0.45/bin/java
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/spork/eclipses/eclipse-jee//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
...


and everything worked fine. Therefore I guessed it must be a python-exec2 problem.

First, I have reemerged dev-python/python-exec-1000.2, but it did not help. Then I cleaned my package.keywords and fell back to dev-python/python-exec-1000.1 but the problem remained. I ran emerge -avuDN world, emerge --depclean and revdep-rebuild, even emerge -a @world but no improvements.

After a while I realized that dev-lang/python-exec-2.0 was still installed. Thus, I had to unmerge it manually (so only dev-lang/python-exec-0.3.1 is installed). Then it took me some time to figure out I had to reemerge dev-java/java-config. Now calling /usr/bin/java works again.

UPDATE:

This minute i saw that app-portage/layman-2.0.0 pulls dev-lang/python-exec-2.

Code:

spork:~ % sudo emerge -av layman                                                                                                                          [14:57:20]
Password:

 * IMPORTANT: 1 news items need reading for repository 'gentoo-zh'.
 * IMPORTANT: 1 news items need reading for repository 'mva'.
 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-lang/python-exec-0.3.1  PYTHON_TARGETS="(jython2_5) (jython2_7) (python2_6) (python2_7) (python3_2) (-pypy2_0) (-python3_3)" 0 kB
[ebuild  N    ~] dev-lang/python-exec-2.0:2  PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3)" 0 kB
[ebuild   R    ] app-portage/layman-2.0.0  USE="cvs git mercurial subversion -bazaar -darcs {-test}" PYTHON_TARGETS="python2_7 (-pypy2_0) -python2_6" 0 kB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 0 kB

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/python-argparse-1
# required by app-portage/layman-2.0.0
# required by layman (argument)
=dev-lang/python-exec-2.0 ~amd64


Therefore i masked version 2.0.0 and fell back to layman-1.4.2-r3.

Kind regards, Spork
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2541
Location: Richmond, BC, Canada

PostPosted: Sat Nov 02, 2013 3:47 pm    Post subject: Reply with quote

The last problem is not restricted layman-2.0.0. It is any ebuild that relies on the newer python-r1 eclasses.
The problem stems from the recent python-exec versions out there.

Hopefully it will be fixed properly soon!

It is screwing with peoples systems in all kinds of different ways.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
vlynd
n00b
n00b


Joined: 23 Jan 2012
Posts: 42

PostPosted: Tue Nov 26, 2013 3:02 pm    Post subject: Reply with quote

I can confirm this is working. Thank you so much for saving me endless hours!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum