Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dont understand how to install ati-drivers?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 29

PostPosted: Tue Oct 29, 2013 6:12 am    Post subject: Dont understand how to install ati-drivers? Reply with quote

I have an ati radeon 8200m g in my laptop. Ive read a lot of guides about installing the drivers but i domt understand exactly what to do. Can someone just kind off give me a guide to what i need to do?
Back to top
View user's profile Send private message
grey_dot
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2012
Posts: 142

PostPosted: Tue Oct 29, 2013 6:18 am    Post subject: Re: Dont understand how to install ati-drivers? Reply with quote

austinramsay wrote:
I have an ati radeon 8200m g in my laptop. Ive read a lot of guides about installing the drivers but i domt understand exactly what to do. Can someone just kind off give me a guide to what i need to do?


1. Ensure that you have CONFIG_DRM=m in your kernel config.
2. run "emerge ati-drivers"
3. ???
4. PROFIT
Back to top
View user's profile Send private message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 29

PostPosted: Tue Oct 29, 2013 6:21 am    Post subject: Reply with quote

Wow really thats it? Ha! Alright then! And one more question its saying it will download gentoo-sources-3.10.7 and i dont want it to download any kernel. Im running 3.11.6 right now. How do i get it to skip that?
Back to top
View user's profile Send private message
grey_dot
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2012
Posts: 142

PostPosted: Tue Oct 29, 2013 6:39 am    Post subject: Reply with quote

austinramsay wrote:
Wow really thats it? Ha! Alright then! And one more question its saying it will download gentoo-sources-3.10.7 and i dont want it to download any kernel. Im running 3.11.6 right now. How do i get it to skip that?


Dunno. Ati-drivers ebuild doesnt seem to have any references to a kernel version. Its probably a requirement from some other package or something. Recent versions of portage have a bit weird dependency resolution.
Back to top
View user's profile Send private message
austinramsay
n00b
n00b


Joined: 25 Oct 2010
Posts: 29

PostPosted: Tue Oct 29, 2013 1:10 pm    Post subject: Reply with quote

grey_dot wrote:
Dunno. Ati-drivers ebuild doesnt seem to have any references to a kernel version. Its probably a requirement from some other package or something. Recent versions of portage have a bit weird dependency resolution.


Hmm alright. Do you think there will be any problems with kernels if i emerge it then?
Back to top
View user's profile Send private message
mrbassie
Apprentice
Apprentice


Joined: 31 May 2013
Posts: 219

PostPosted: Tue Oct 29, 2013 1:55 pm    Post subject: Reply with quote

austinramsay wrote:


Hmm alright. Do you think there will be any problems with kernels if i emerge it then?


It won't do anything other than download the source code and unpack it in /usr/src. That's only a problem if you're concerned about your disk space.

if you put =sys-kernel/gentoo-sources-3.11.6 ~{your architecture} in /etc/portage/package.accept_keywords I believe it will stop portage trying to pull in 3.10.7. I may be wrong, it should be there already anyway.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4656
Location: Saint Amant, Acadiana

PostPosted: Tue Oct 29, 2013 11:37 pm    Post subject: Reply with quote

You do not need to install ATI drivers by hand.
You set VIDEO_CARDS="fglrx" in your make.conf and the driver will be pulled in.
However, to load it you probably need to create a four-line xorg.conf with Device section.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum