Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201310-21 ] MediaWiki: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Mon Oct 28, 2013 6:26 pm    Post subject: [ GLSA 201310-21 ] MediaWiki: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: MediaWiki: Multiple vulnerabilities (GLSA 201310-21)
Severity: normal
Exploitable: remote
Date: October 28, 2013
Bug(s): #460352, #466124, #468110, #471140, #483594
ID: 201310-21

Synopsis

Multiple vulnerabilities have been found in MediaWiki, the worst of
which could lead to Denial of Service.


Background

The MediaWiki wiki web application as used on wikipedia.org.

Affected Packages

Package: www-apps/mediawiki
Vulnerable: < 1.21.2
Unaffected: >= 1.21.2
Unaffected: >= 1.20.7 < 1.20.8
Unaffected: >= 1.19.8 < 1.19.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in MediaWiki. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker may be able to execute arbitrary code, perform
man-in-the-middle attacks, obtain sensitive information or perform
cross-site scripting attacks.


Workaround

There is no known workaround at this time.

Resolution

All MediaWiki 1.21.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.21.2"
   
All MediaWiki 1.20.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.20.7"
   
All MediaWiki 1.19.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.19.8"
   


References

CVE-2013-1816
CVE-2013-1817
CVE-2013-1818
CVE-2013-1951
CVE-2013-2031
CVE-2013-2032
CVE-2013-2114
CVE-2013-4301
CVE-2013-4302
CVE-2013-4303
CVE-2013-4304
CVE-2013-4305
CVE-2013-4306
CVE-2013-4307
CVE-2013-4308
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum