Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alsaplayer makes sound as root only
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
grj
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2002
Posts: 96

PostPosted: Fri Jul 26, 2002 3:08 pm    Post subject: Alsaplayer makes sound as root only Reply with quote

I installed alsaplayer and it only makes music as root. When logged in as regular user no sound. It is playing the cd, but not making sound. I also installed aumix and set the cd and volume to 100%. Is there a permission thing that needs to be set. Another post I read made mention of an audio group which I do not have.

Thanks,
_________________
Hope this helps!

GRJ
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Fri Jul 26, 2002 5:09 pm    Post subject: Re: Alsaplayer makes sound as root only Reply with quote

grj wrote:
Another post I read made mention of an audio group which I do not have.
That'd be the problem. Do you mean the user doesn't belong to the group, or the group doesn't exist (grep audio /etc/group)?

EDIT: Also covered in the Gentoo Linux Desktop Configuration Guide (See the note under code listing 19)
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
grj
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2002
Posts: 96

PostPosted: Sat Jul 27, 2002 8:36 pm    Post subject: How to add user to audio group Reply with quote

The grep command above revealed that i do have an audio group. But when I run groups I am not a member of audio, only wheel. How do I make myself a member of audio. The other settings(from previous post) are as they should be.


Thanks,
_________________
Hope this helps!

GRJ
Back to top
View user's profile Send private message
tomas
n00b
n00b


Joined: 05 Jul 2002
Posts: 62
Location: Sweden

PostPosted: Sat Jul 27, 2002 10:22 pm    Post subject: Reply with quote

You can use usermod, vigr or just edit /etc/group with your editor of choice. usermod is probably the safest way to do it. All of these, of course, have to be done as root.
Back to top
View user's profile Send private message
grj
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2002
Posts: 96

PostPosted: Sun Jul 28, 2002 3:21 pm    Post subject: Fixed Reply with quote

Thanks for the help. usermod did the trick.


Thanks,
_________________
Hope this helps!

GRJ
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum