Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3 vs Systemd
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 412
Location: münchen.de

PostPosted: Sat Oct 19, 2013 10:01 pm    Post subject: Gnome 3 vs Systemd Reply with quote

Hallo zusammen,

ich habe seit Anfang August Gnome 3 und Systemd auf zwei Rechnern am Laufen. Seit einem Update vor ca einer Woche funktioniert Gnome 3 auf meinem Laptop nicht mehr. Nachdem Login via GDM dauerts 5 Sekunden, dann bleibt der Bildschirm leer mit GDM Hintergrundbild. Starten via startx klappt auch nicht. Egal ob mit GDM oder startx, die Ausgabe in /var/log/messages sieht folgendermaßen aus:
Code:

Oct 19 21:34:50 i5 logger: Switching to default runlevel
Oct 19 21:34:50 i5 /etc/init.d/iptables[1669]: ERROR: iptables failed to start
Oct 19 21:34:50 i5 /etc/init.d/distccd[1670]: WARNING: distccd is scheduled to start when NetworkManager has started
Oct 19 21:34:50 i5 /etc/init.d/sysfs[1671]: ERROR: sysfs failed to start
Oct 19 21:34:54 i5 accounts-daemon[1741]: started daemon version 0.6.34
Oct 19 21:34:58 i5 gdm-password]: pam_unix(gdm-password:session): session opened for user peet by (uid=0)
Oct 19 21:34:58 i5 gdm-password]: pam_systemd(gdm-password:session): Failed to create session: Launch helper exited with unknown return code 1
Oct 19 21:34:58 i5 gdm-password]: pam_systemd(gdm-password:session): Failed to create session: Launch helper exited with unknown return code 1
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: Gck: gck_module_new: assertion `funcs != NULL' failed
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: module_instances: assertion `module' failed
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: egg_error_message: assertion `error' failed
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: couldn't find secret store module: (unknown)
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: lookup_login_keyring: assertion `GCK_IS_SESSION (session)' failed
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: create_credential: assertion `GCK_IS_SESSION (session)' failed
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: egg_error_message: assertion `error' failed
Oct 19 21:34:58 i5 gnome-keyring-daemon[1752]: couldn't create login credential: (unknown)
Oct 19 21:34:58 i5 gdm-password]: gkr-pam: the password for the login keyring was invalid.
Oct 19 21:35:01 i5 logger: ACPI event unhandled: battery PNP0C0A:00 00000080 00000001
Oct 19 21:35:01 i5 logger: Switching to default runlevel
Oct 19 21:35:01 i5 /etc/init.d/iptables[1763]: ERROR: iptables failed to start
Oct 19 21:35:01 i5 /etc/init.d/distccd[1764]: WARNING: distccd is scheduled to start when NetworkManager has started
Oct 19 21:35:01 i5 /etc/init.d/sysfs[1765]: ERROR: sysfs failed to start
Oct 19 21:35:09 i5 gnome-session[1825]: WARNING: Failed to connect to systemd: Error calling StartServiceByName for org.freedesktop.login1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Oct 19 21:35:09 i5 gnome-session[1825]: GLib-GObject-WARNING: invalid (NULL) pointer instance
Oct 19 21:35:09 i5 gnome-session[1825]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Oct 19 21:35:09 i5 gnome-session[1825]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.


Die Meldung von pam_systemd gefällt mir gar nicht. Ich hab das aber konfiguriert wie im Gentoo Wiki beschrieben:
Code:
session     optional     pam_systemd.so


Ich finde keine .xsession-errors (das schreiben neue Gnome Versionen wohl nicht) und ich finde auch nichts in dem neuen Gnome Log unter ~/.cache/gdm/... In der Xorg.log findet sich kein Fehler.

Übrigens funktioniert hostnamectl oder timedatectl auch nicht. Beides ergibt folgende Meldung:
Code:
Failed to issue method call: Launch helper exited with unknown return code 1


Ich nutze ein selbsterstelltes initramfs, welches mit "exec switch_root /mnt/root /usr/lib/systemd/systemd" ins richtige Root wechselt. Networkmanager funktioniert auf der Kiste momentan auch nicht, deshalb ist der sync Stand von der ersten Oktoberwoche.

Ich hab mittlerweile diverse Versionen der vom Update letzte Woche betroffenen Pakete ausprobiert, hunderte Systemd Threads gelesen, aber ich komme nicht weiter. Weiß einer von euch Rat?


[Edit]
Mit Live CD und chroot hab ich jetzt Netz, Portage synchronisiert und Updates installiert. Das Problem tritt aber immer noch auf. Außerdem habe ich Journald auf Debug Logging gestellt und folgende Fehlermeldung gefunden:
Code:
Okt 20 12:34:56 i5 env[370]: * Starting local
Okt 20 12:34:56 i5 env[370]: /etc/acpi/actions/pmg_switch_runlevel.sh: line 23: /var/lib/init.d/softlevel: No such file or directory
Okt 20 12:34:56 i5 env[370]: distccd          | * WARNING: distccd is scheduled to start when NetworkManager has started
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/openrc’: File exists
Okt 20 12:34:56 i5 env[370]: mount: openrc is already mounted or /sys/fs/cgroup/openrc busy
Okt 20 12:34:56 i5 env[370]: openrc is already mounted on /sys/fs/cgroup/openrc
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/cpuset’: File exists
Okt 20 12:34:56 i5 env[370]: mount: cpuset is already mounted or /sys/fs/cgroup/cpuset busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/cpu’: File exists
Okt 20 12:34:56 i5 env[370]: mount: cpu is already mounted or /sys/fs/cgroup/cpu,cpuacct busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/cpuacct’: File exists
Okt 20 12:34:56 i5 env[370]: mount: cpuacct is already mounted or /sys/fs/cgroup/cpu,cpuacct busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/memory’: File exists
Okt 20 12:34:56 i5 env[370]: mount: memory is already mounted or /sys/fs/cgroup/memory busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/devices’: File exists
Okt 20 12:34:56 i5 env[370]: mount: devices is already mounted or /sys/fs/cgroup/devices busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/freezer’: File exists
Okt 20 12:34:56 i5 env[370]: mount: freezer is already mounted or /sys/fs/cgroup/freezer busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/blkio’: File exists
Okt 20 12:34:56 i5 env[370]: mount: blkio is already mounted or /sys/fs/cgroup/blkio busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/perf_event’: File exists
Okt 20 12:34:56 i5 env[370]: mount: perf_event is already mounted or /sys/fs/cgroup/perf_event busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/hugetlb’: File exists
Okt 20 12:34:56 i5 env[370]: mount: hugetlb is already mounted or /sys/fs/cgroup/hugetlb busy
Okt 20 12:34:56 i5 env[370]: sysfs            | * ERROR: sysfs failed to start
Okt 20 12:34:56 i5 env[370]: udev             | * ERROR: cannot start udev as sysfs would not start
Okt 20 12:34:56 i5 env[370]: [ ok ]
Okt 20 12:34:56 i5 env[370]: * Caching service dependencies ... [ ok ]
Okt 20 12:34:56 i5 systemd[1]: Received SIGCHLD from PID 370 (sh).
Okt 20 12:34:56 i5 systemd[1]: Got SIGCHLD for process 370 (sh)
Okt 20 12:34:56 i5 systemd[1]: Child 370 died (code=exited, status=0/SUCCESS)
Okt 20 12:34:56 i5 systemd[1]: Child 370 belongs to gentoo-local-baselayout1.service

Kann das vielleicht an meinem selbsterstellten initramfs liegen?

Gnome Session spuckt auch eine Menge Fehlermeldungen aus:
Code:
Okt 20 12:34:56 i5 systemd[1]: Got D-Bus request: org.freedesktop.DBus.Local.Disconnected() on /org/freedesktop/DBus/Local
Okt 20 12:34:56 i5 polkitd[340]: Registered Authentication Agent for unix-session:c1 (system bus name :1.21 [gnome-shell --mode=gdm], object path /org
Okt 20 12:34:56 i5 gnome-session[462]: JS LOG: GNOME Shell started at Sun Oct 20 2013 12:34:56 GMT+0200 (CEST)
Okt 20 12:34:57 i5 gnome-session[462]: Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Okt 20 12:34:57 i5 gnome-session[462]: Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happe
Okt 20 12:34:59 i5 dbus[1230]: [system] Activating service name='org.freedesktop.Accounts' (using servicehelper)
Okt 20 12:34:59 i5 dbus[1230]: [system] Successfully activated service 'org.freedesktop.Accounts'
Okt 20 12:35:07 i5 gdm[357]: GLib-GIO: g_dbus_method_invocation_return_value_internal: assertion `G_IS_DBUS_METHOD_INVOCATION (invocation)' failed
Okt 20 12:35:08 i5 dbus[1230]: [system] Activating service name='org.freedesktop.login1' (using servicehelper)
Okt 20 12:35:08 i5 dbus[1230]: [system] Activated service 'org.freedesktop.login1' failed: Launch helper exited with unknown return code 1
Okt 20 12:35:08 i5 dbus[1230]: [system] Activating service name='org.freedesktop.login1' (using servicehelper)
Okt 20 12:35:08 i5 dbus[1230]: [system] Activated service 'org.freedesktop.login1' failed: Launch helper exited with unknown return code 1
Okt 20 12:35:20 i5 dbus-daemon[296]: dbus[296]: [system] Failed to activate service 'org.freedesktop.locale1': timed out
Okt 20 12:35:20 i5 dbus[296]: [system] Failed to activate service 'org.freedesktop.locale1': timed out
Okt 20 12:35:20 i5 gnome-session[462]: (gnome-settings-daemon:565): keyboard-plugin-WARNING **: Failed to contact localed: Error calling StartServiceB
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 529 (at-spi2-registr).
Okt 20 12:35:29 i5 systemd[1]: Got SIGCHLD for process 529 (at-spi2-registr)
Okt 20 12:35:29 i5 systemd[1]: Child 529 died (code=killed, status=15/TERM)
Okt 20 12:35:29 i5 gnome-session[462]: (gnome-settings-daemon:565): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon: The connection
Okt 20 12:35:29 i5 gnome-session[462]: (gnome-settings-daemon:565): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon.Power: The conn
Okt 20 12:35:29 i5 gnome-session[462]: (gnome-settings-daemon:565): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon.XRANDR: The con
Okt 20 12:35:29 i5 gnome-session[462]: (gnome-settings-daemon:565): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon.Keyboard: The c
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 1513 (gconfd-2).
Okt 20 12:35:29 i5 systemd[1]: Got SIGCHLD for process 1513 (gconfd-2)
Okt 20 12:35:29 i5 systemd[1]: Child 1513 died (code=exited, status=0/SUCCESS)
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 475 (dbus-daemon).
Okt 20 12:35:29 i5 systemd[1]: Got SIGCHLD for process 475 (dbus-daemon)
Okt 20 12:35:29 i5 systemd[1]: Child 475 died (code=exited, status=0/SUCCESS)
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 1782 (ibus-daemon).
Okt 20 12:35:29 i5 systemd[1]: Got SIGCHLD for process 1782 (ibus-daemon)
Okt 20 12:35:29 i5 systemd[1]: Child 1782 died (code=killed, status=15/TERM)
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 1785 (ibus-dconf).
Okt 20 12:35:29 i5 systemd[1]: Got SIGCHLD for process 1785 (ibus-dconf)
Okt 20 12:35:29 i5 systemd[1]: Child 1785 died (code=killed, status=15/TERM)
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 1795 (ibus-engine-sim).
Okt 20 12:35:29 i5 systemd[1]: Got SIGCHLD for process 1795 (ibus-engine-sim)
Okt 20 12:35:29 i5 systemd[1]: Child 1795 died (code=exited, status=0/SUCCESS)
Okt 20 12:35:29 i5 systemd[1]: Received SIGCHLD from PID 1789 (ibus-x11).
Okt 20 12:35:30 i5 /etc/gdm/Xsession[1850]: /etc/gdm/Xsession: Beginning session setup...
Okt 20 12:35:30 i5 /etc/gdm/Xsession[1850]: xrdb:  "URxvt*font" on line 36 overrides entry on line 32
Okt 20 12:35:30 i5 /etc/gdm/Xsession[1850]: localuser:peet being added to access control list
Okt 20 12:35:30 i5 polkitd[340]: Unregistered Authentication Agent for unix-session:c1 (system bus name :1.21, object path /org/freedesktop/PolicyKit1
Okt 20 12:35:30 i5 systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
Okt 20 12:35:30 i5 systemd[1]: Received SIGCHLD from PID 679 (gnome-shell).
Okt 20 12:35:30 i5 systemd[1]: Got SIGCHLD for process 679 (gnome-shell)
Okt 20 12:35:30 i5 systemd[1]: Child 679 died (code=exited, status=0/SUCCESS)
....
Okt 20 12:35:30 i5 /etc/gdm/Xsession[1850]: /etc/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session gnome-session
Okt 20 12:35:30 i5 dbus[1230]: [system] Activating service name='org.freedesktop.login1' (using servicehelper)
Okt 20 12:35:30 i5 dbus[1230]: [system] Activated service 'org.freedesktop.login1' failed: Launch helper exited with unknown return code 1
Okt 20 12:35:30 i5 gnome-session[1850]: gnome-session[1850]: WARNING: Failed to connect to systemd: Error calling StartServiceByName for org.freedeskt
Okt 20 12:35:30 i5 gnome-session[1850]: gnome-session[1850]: GLib-GObject-WARNING: invalid (NULL) pointer instance
Okt 20 12:35:30 i5 gnome-session[1850]: gnome-session[1850]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)
Okt 20 12:35:30 i5 gnome-session[1850]: gnome-session[1850]: WARNING: Could not get session id for session. Check that logind is properly installed an
Okt 20 12:35:30 i5 gnome-session[1850]: GNOME_KEYRING_CONTROL=/home/peet/.cache/keyring-m5uPkj
Okt 20 12:35:30 i5 gnome-session[1850]: SSH_AUTH_SOCK=/home/peet/.cache/keyring-m5uPkj/ssh
Okt 20 12:35:30 i5 gnome-session[1850]: GNOME_KEYRING_CONTROL=/home/peet/.cache/keyring-m5uPkj
Okt 20 12:35:30 i5 gnome-session[1850]: SSH_AUTH_SOCK=/home/peet/.cache/keyring-m5uPkj/ssh
Okt 20 12:35:30 i5 gnome-session[1850]: GPG_AGENT_INFO=/home/peet/.cache/keyring-m5uPkj/gpg:0:1
Okt 20 12:35:30 i5 gnome-session[1850]: GNOME_KEYRING_CONTROL=/home/peet/.cache/keyring-m5uPkj
Okt 20 12:35:30 i5 gnome-session[1850]: SSH_AUTH_SOCK=/home/peet/.cache/keyring-m5uPkj/ssh
Okt 20 12:35:30 i5 gnome-session[1850]: GPG_AGENT_INFO=/home/peet/.cache/keyring-m5uPkj/gpg:0:1
Okt 20 12:35:30 i5 gnome-session[1850]: GNOME_KEYRING_CONTROL=/home/peet/.cache/keyring-m5uPkj
Okt 20 12:35:30 i5 gnome-session[1850]: SSH_AUTH_SOCK=/home/peet/.cache/keyring-m5uPkj/ssh
Okt 20 12:35:30 i5 gnome-session[1850]: GPG_AGENT_INFO=/home/peet/.cache/keyring-m5uPkj/gpg:0:1
Okt 20 12:35:30 i5 dbus[1230]: [system] Activating service name='org.freedesktop.login1' (using servicehelper)
Okt 20 12:35:30 i5 dbus[1230]: [system] Activated service 'org.freedesktop.login1' failed: Launch helper exited with unknown return code 1
Okt 20 12:35:30 i5 gnome-session[1850]: (gnome-settings-daemon:1889): power-plugin-WARNING **: Unable to start gsd_power manager: Error calling StartS
Okt 20 12:35:30 i5 dbus[1230]: [system] Activating service name='org.freedesktop.UPower' (using servicehelper)
Okt 20 12:35:30 i5 dbus[1230]: [system] Successfully activated service 'org.freedesktop.UPower'
Okt 20 12:35:30 i5 dbus[1230]: [system] Activating service name='org.freedesktop.login1' (using servicehelper)
Okt 20 12:35:30 i5 dbus[1230]: [system] Activated service 'org.freedesktop.login1' failed: Launch helper exited with unknown return code 1
Okt 20 12:35:30 i5 gnome-session[1850]: (gnome-settings-daemon:1889): media-keys-plugin-WARNING **: Failed to connect to systemd: Error calling StartS
Okt 20 12:35:30 i5 gnome-session[1850]: (gnome-settings-daemon:1889): GLib-GIO-CRITICAL **: g_dbus_proxy_call_internal: assertion `G_IS_DBUS_PROXY (pr
Okt 20 12:35:30 i5 dbus[1230]: [system] Activating service name='org.freedesktop.ColorManager' (using servicehelper)
Okt 20 12:35:30 i5 dbus[1230]: [system] Successfully activated service 'org.freedesktop.ColorManager'

Kann damit jemand was anfangen?
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1053
Location: /dev/koelsch

PostPosted: Sun Oct 20, 2013 2:32 pm    Post subject: Reply with quote

Hi forrestfunk81.

Ich hab da eine Vermutung, jedenfalls für den Fall dass Du den nvidia-drivers-331.13 verwenden solltest.
n diesem Fall empfehle ich ein Downgrade auf Version-325.15 mit anschließendem reload bzw. reboot.

Wie ich darauf komme, und das obwohl ich KDE-User mit Openrc bin?

Ich hatte vergleichbare dbus Logmeldungen wie Du, die bei mir den Start des Akonadi-Servers verhinderten.
Wurde mir zwar bisher nicht von anderen bestätigt, dafür aber diverse andere Probleme deren Ursache nvidia-drivers-331.13 ist.

Hier ein paar Referenzen:
https://bugs.gentoo.org/show_bug.cgi?id=487700
https://bugs.gentoo.org/show_bug.cgi?id=487590
https://bugs.gentoo.org/show_bug.cgi?id=487782
https://bugs.gentoo.org/show_bug.cgi?id=488136

Viel Erfolg, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4218

PostPosted: Sun Oct 20, 2013 5:06 pm    Post subject: Reply with quote

Ich würde auf dbus tippen. Vielleicht hilft re-emerge von dbus. Achte darauf, dass dabei USE=systemd gesetzt ist!

Edit: Die Fehlermeldung bzgl. Launch helper kommt von dbus, wenn sich der gestartete Daemon mit einem Exit-Code beendet, der nicht auf dbus zugeschneidert ist.
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 412
Location: münchen.de

PostPosted: Sun Oct 20, 2013 9:27 pm    Post subject: Reply with quote

Auf dem betroffenen Laptop läuft eine Intel Grafikkarte. Im Arch Forum wurde zu einem Problem mit gleichen Symptomen schon Intel mit SNA vorgeschlagen. Das hab ich hier aber schon lange am Laufen. Mein Nvidia Desktop ist nicht betroffen (fast gleiche Software Auswahl).

Code:
 # genlop -t dbus
...
     Sun Sep  8 22:54:30 2013 >>> sys-apps/dbus-1.6.12
       merge time: 1 minute and 58 seconds.

     Tue Oct  8 21:07:24 2013 >>> sys-apps/dbus-1.6.14
       merge time: 2 minutes.

     Sat Oct 19 13:18:55 2013 >>> sys-apps/dbus-1.6.12
       merge time: 1 minute and 52 seconds.

     Sat Oct 19 21:18:30 2013 >>> sys-apps/dbus-1.6.14
       merge time: 1 minute and 50 seconds.

     Sun Oct 20 07:29:06 2013 >>> sys-apps/dbus-1.6.16
       merge time: 1 minute and 53 seconds.


[I] sys-apps/dbus
     Available versions:  1.6.12 (~)1.6.14 (~)1.6.16 {X debug doc selinux static-libs systemd test}
     Installed versions:  1.6.16(07:28:49 20.10.2013)(X systemd -debug -doc -selinux -static-libs -test)


DBus hab ich alle aktuellen Versionen durch, überall das gleiche Problem. Seit dem ersten Update auf 1.6.14 tritt das Problem auf. Bei diesem Update waren aber auch über 100 andere Pakete dabei (u.a. einige Gnome und X Komponenten). Viele der möglichen Schuldigen hab ich davon schon neugebaut und in der alten Version nochmal getestet. Bei der Migration auf Systemd bin ich nach Gentoo Wiki vorgegangen was auch zwei Monate lang funktionierte. Systemd USE Flag ist seither systemweit gesetzt.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Tue Oct 29, 2013 9:42 am    Post subject: Reply with quote

forrestfunk81

wie ist denn dein aktueller Status? Dein System bootet doch durch oder? Läuft systemd normal? Startet dbus ohne Fehlermeldung?

Stürzt GDM schon ab, oder erst der Benutzer nach dem einloggen?
Du vermutest jetzt das dein Grafiktreiber Probleme macht und deswegen GDM nicht startet?
Hast du diesen Laptop schon mal fehlerfrei mit Gnome3 nutzen können und das Problem startet erst NACH dem Start mit Systemd?

Was passiert wenn du GDM via systemd neu startest?

Code:
systemctl restart graphical.target


Installiere und nutze Fluxbox doch erstmals als bequemen Arbeitsbereich für diesen Fall.
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 412
Location: münchen.de

PostPosted: Mon Nov 04, 2013 8:13 pm    Post subject: Reply with quote

Sorry für die späte Antwort. Ich hab in den letzten zwei Wochen nichts am Laptop gemacht, daher immer noch der gleiche Status.

System bootet, DBus startet fehlerfrei, sysfs und udev starten nicht:
Code:
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/blkio’: File exists
Okt 20 12:34:56 i5 env[370]: mount: blkio is already mounted or /sys/fs/cgroup/blkio busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/perf_event’: File exists
Okt 20 12:34:56 i5 env[370]: mount: perf_event is already mounted or /sys/fs/cgroup/perf_event busy
Okt 20 12:34:56 i5 env[370]: mkdir: cannot create directory ‘/sys/fs/cgroup/hugetlb’: File exists
Okt 20 12:34:56 i5 env[370]: mount: hugetlb is already mounted or /sys/fs/cgroup/hugetlb busy
Okt 20 12:34:56 i5 env[370]: sysfs            | * ERROR: sysfs failed to start
Okt 20 12:34:56 i5 env[370]: udev             | * ERROR: cannot start udev as sysfs would not start


Die ersten DBus Fehler kommen beim Login:
Code:
Okt 20 12:35:08 i5 dbus[1230]: [system] Activated service 'org.freedesktop.login1' failed: Launch helper exited with unknown return code 1
Okt 20 12:35:20 i5 dbus-daemon[296]: dbus[296]: [system] Failed to activate service 'org.freedesktop.locale1': timed out
Okt 20 12:35:20 i5 dbus[296]: [system] Failed to activate service 'org.freedesktop.locale1': timed out


GDM stürtzt erst beim Login ab. Bei einem systemctl restart graphical.target passiert gar nichts. Aber:
Code:
# systemctl restart gdm.service
Job for gdm.service failed.
# systemctl status gdm.service
...
GdmLocalDisplayFactory: Failed to issue method call: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper ... return code 1

_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
boospy
Apprentice
Apprentice


Joined: 07 Feb 2010
Posts: 257
Location: Austria

PostPosted: Mon Nov 25, 2013 11:01 pm    Post subject: Reply with quote

Maskiere PAM:

=sys-auth/pambase-20120417-r3

Das Teil ist böse und tut mit Gnome3 nicht ganz. Aber auch nur unter bestimmten Voraussetzungen. Ich dachte mir das ist die LDAP Anbindung. Liegt wohl auch noch an was anderen. Nach dem Downgrade gings bei mir.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum