Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chromium Locks Up System with Binary Nvidia Driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
AustinMatherne
n00b
n00b


Joined: 25 Jul 2012
Posts: 32
Location: Minneapolis, Minnesota, USA

PostPosted: Thu Oct 17, 2013 4:54 am    Post subject: Chromium Locks Up System with Binary Nvidia Driver Reply with quote

With the binary Nvidia drivers installed, both Chrome and Chromium (but not Firefox) are acting very strange. To be clear, I don't have any issues if I use the nouveau drivers; however, they don't provide OpenCL support, which I need for another application.

Without flash disabled, Chromium will often hang if I go to a page that runs flash (and it will even lock up my entire system forcing a hard reboot on occasion). While Chrome hasn't locked up my entire PC while running flash, it has prevented some tabs from rendering, but that isn't nearly as bad because I can close the tab and reopen the URL and most of the time it just works on the second attempt. The other issue which happens equally in both Chrome and Chromium (with or without flash disabled) is black boxes showing up on my screens (see the images below). The black boxes have shown up on both the window the browser is running in, and on a secondary screen. I can git rid of the black boxes by moving an application window over the area of the screen where they were rendering.

I'd say to hell with it and use Firefox, but I'm a web developer and I need the Chrome DevTools for my job.

I'm guessing this has something to do with GPU hardware acceleration, but neither a Google nor a forum search turned up much of any help. Any ideas on how I should go about debugging this?
Image of black bar on empty secondary screen
Back to top
View user's profile Send private message
zeronullity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2010
Posts: 94

PostPosted: Fri Oct 18, 2013 1:37 am    Post subject: Reply with quote

If it only hangs with Flash enabled I would start with that..
What version of Flash are you using PepperFlash v. xxx?
Also what does your compile/use flags look like for chromium?
Using pre-compiled Chrome binaries?
And NVidia driver version? GPU model?
Double check make sure your video driver is correctly loaded.. using glxinfo command.
Back to top
View user's profile Send private message
AustinMatherne
n00b
n00b


Joined: 25 Jul 2012
Posts: 32
Location: Minneapolis, Minnesota, USA

PostPosted: Fri Oct 18, 2013 4:35 am    Post subject: Reply with quote

Chromium Flash version: 11.2 r202
Chrome Flash version: 11.9.900.117
Chromium use flags: cups -bindist -custom-cflags -gnome -gnome-keyring -gps -kerberos (-neon) -pulseaudio (-selinux) (-system-sqlite) (-tcmalloc) -test
Chrome use flags: (multilib) plugins
I'm using the pre-compiled Chrome binaries, but as far as I'm aware, that's the only option for Chrome.
Nvidia drivers version: 331.13. Two GTX 670s which are connected to three displays.
glxinfo output: https://gist.github.com/AustinMatherne/7036263
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 225
Location: England, UK

PostPosted: Fri Oct 18, 2013 9:19 am    Post subject: Reply with quote

Maybe it could be in some related or similar to this: Chromium 28 slow on certain pages?
Do you get any errors shown if you start in the terminal? Are all the GPU settings enabled and working correctly?
Back to top
View user's profile Send private message
zeronullity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2010
Posts: 94

PostPosted: Fri Oct 18, 2013 1:06 pm    Post subject: Reply with quote

Have you already tried driver 319.60?
What does your compile flags look like in make.conf? Post the whole file if you can.
Also post your /etc/X11/xorg.conf
And last but not least have you tried it from a NEW user account under the same system.. are the results the same?
Back to top
View user's profile Send private message
zeronullity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2010
Posts: 94

PostPosted: Sat Oct 19, 2013 3:22 am    Post subject: Reply with quote

Also make sure.. your not running the graphics card in 30-bit color mode no greater then 24-bit should be used, and if your using any custom settings in
xorg.conf / .nvidia-settings-rc you might try clearing those out as well.
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 788
Location: Montréal

PostPosted: Sat Oct 19, 2013 5:50 am    Post subject: Reply with quote

I suggest to activate the pulseaudio USE flag globally. Flash was freezing the whole Gentoo system before, but since Pulseaudio no.
_________________
Paul
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Sat Oct 19, 2013 5:57 am    Post subject: Reply with quote

In Flash, you can try to enable / disable hardware acceleration; you can also try to switch between the Flash implementations (adobe-flash <--> pepper).

Not all of this combinations work for me; I have something that works now, but I've found myself to sometimes (rarely) needing to switch to another implementation / acceleration.

It does seem to be a bit more stable lately; but well, time will tell...
Back to top
View user's profile Send private message
AustinMatherne
n00b
n00b


Joined: 25 Jul 2012
Posts: 32
Location: Minneapolis, Minnesota, USA

PostPosted: Sun Oct 20, 2013 1:23 am    Post subject: Reply with quote

There are quite a few recommendations to try, but first I figured I should roll back Chromium (30.0.1599.101), the nvidia drivers (319.49), and my kernel (gentoo-sources-3.10.17) to their latest stable versions with the pulseaudio use flag enabled globally. So far this has vastly increased stability. I still have a lot of issues, but I've only had one lockup that forced me to perform a hard reboot and I've only experienced black bars on sites that use a lot of flash, such as youtube. Now when not running flash Chromium is slow at times, but mostly usable, once flash starts running, however, everything goes to hell.

My observations so far from launching Chromium from the terminal have been that while visiting a relatively intensive application such as evernote (with flash disabled or when visiting youtube with it enabled) I'll sometimes, but not always, get lockups for about five seconds while switching between notes. I get a handful of the following messages in the terminal output right after a lockup ends:
[30023:30023:1020/045733:ERROR:gles2_cmd_decoder.cc(2819)] GLES2DecoderImpl: Context lost during MakeCurrent.
[30023:30023:1020/045733:ERROR:gles2_cmd_decoder.cc(2819)] GLES2DecoderImpl: Context lost during MakeCurrent.
[30023:30023:1020/045733:ERROR:gles2_cmd_decoder.cc(2819)] GLES2DecoderImpl: Context lost during MakeCurrent.
[30023:30023:1020/045733:ERROR:gles2_cmd_decoder.cc(2819)] GLES2DecoderImpl: Context lost during MakeCurrent.
NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).
NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).
NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).
NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).
NVIDIA: could not open the device file /dev/nvidia1 (Operation not permitted).
NVIDIA: could not open the device file /dev/nvidia1 (Operation not permitted).

I am a member of the video group, so I'm not sure why I'm getting the device opening failures.

My next test will be under a new user account. I'll post the results once I'm done.

make.conf
xorg.conf

I appreciate the help.


Last edited by AustinMatherne on Sun Oct 20, 2013 3:35 am; edited 1 time in total
Back to top
View user's profile Send private message
AustinMatherne
n00b
n00b


Joined: 25 Jul 2012
Posts: 32
Location: Minneapolis, Minnesota, USA

PostPosted: Sun Oct 20, 2013 3:24 am    Post subject: Reply with quote

From a small testing sample size it appears that unchecking "Use hardware acceleration when available" in Chromium's settings fixes everything... Not really a solution, but it's a start.
Back to top
View user's profile Send private message
zeronullity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2010
Posts: 94

PostPosted: Sun Oct 20, 2013 9:39 am    Post subject: Reply with quote

Using ACCEPT_KEYWORDS="~amd64" in make.conf is a bad idea globally and could be contributing to your
problem. If you absolutely need to install a unstable/untested package use /etc/portage/package.accept_keywords
on a per package basis instead. If you use unstable branches plan on picking up the pieces yourself..
as your almost guaranteed to run into a problem more often.

If you've already tried a new user account, new drivers, etc.

*I would disable sand-boxing in the kernel for testing,
Disable PID namespaces
Disable Network namespaces
If I recall correctly
CONFIG_PID_NS=n
CONFIG_NET_NS=n
then recompile/reinstall/reboot kernel

*Remove all your use flag cpu extensions that you have in your /etc/make.conf mmx,sse3,sse4 etc.. Your compiler will use all it needs to
with the march=native that you already have listed in make.conf

*I would disable the ~amd64 along with ACCEPT_LICENSE="*" in make.conf and then "emerge -e world", being very selective on which packages you install with ~amd64 flag. And only adding them to /etc/portage/package.accept_keywords if really needed.

Packages can be added to package.accept_keywords in this format..
net-firewall/fwbuilder
sys-apps/frandom
app-arch/rarcrack
sys-boot/grub:2
media-sound/puddletag

.. or even version specific if needed.


And of course you'll need to re-install your NVidia binary driver after all this.

ALL in one shot & in that specific order. (edit kernel .config & recompile/reinstall,reboot, edit /etc/make.conf,"emerge -e world","emerge --depclean", "revdep-rebuild")
Then retest chromium/flash with acceleration enabled.
Back to top
View user's profile Send private message
phajdan.jr
Developer
Developer


Joined: 23 Mar 2006
Posts: 1766
Location: Poland

PostPosted: Sat Nov 02, 2013 10:38 pm    Post subject: Reply with quote

AustinMatherne wrote:
From a small testing sample size it appears that unchecking "Use hardware acceleration when available" in Chromium's settings fixes everything... Not really a solution, but it's a start.


Please file bugs for issues you see with that option. It's a workaround, but upstream works a lot on the acceleration, and I'm afraid the non-accelerated codepaths might rot over time. Please make sure I can see the bugs and try to bring more attention to them (e.g. post links here or to Gentoo Bugzilla).
_________________
http://phajdan-jr.blogspot.com/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum