Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme de rsync sur portage.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
destroyedlolo
Guru
Guru


Joined: 17 Jun 2011
Posts: 406
Location: Close to Annecy

PostPosted: Tue Oct 08, 2013 7:40 pm    Post subject: Probleme de rsync sur portage. Reply with quote

Bonjour,

Depuis quelques temps, j'ai du mal a synchronisé mon dépot portage :

Code:
>>> Starting retry 3 of 3 with rsync://91.121.125.139/gentoo-portage
>>> Checking server timestamp ...
receiving file list ... done
timestamp.chk

Number of files: 1
Number of files transferred: 1
Total file size: 32 bytes
Total transferred file size: 32 bytes
Literal data: 32 bytes
Matched data: 0 bytes
File list size: 32
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 205
Total bytes received: 146

sent 205 bytes  received 146 bytes  140.40 bytes/sec
total size is 32  speedup is 0.09
receiving file list ... [Receiver] io timeout after 181 seconds -- exiting
rsync error: timeout in data send/receive (code 30) at io.c(140) [Receiver=3.0.9]
>>> Retrying...
!!! Exhausted addresses for rsync.fr.gentoo.org


et mon make.conf contient :
Code:
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"


Est-ce que vous avez noter ce genre de pb, ou est-ce encore un bridage de Free :?:
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5450
Location: ~Brussels - Belgique

PostPosted: Tue Oct 08, 2013 8:25 pm    Post subject: Reply with quote

Hello,

As-tu essayé un autre miroir ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
mcsky2
Apprentice
Apprentice


Joined: 25 Aug 2005
Posts: 268

PostPosted: Wed Oct 09, 2013 8:37 am    Post subject: Reply with quote

J'ai aussi le même problème.
J'ai changé de miroir sans amélioration.

emerge --sync me donne :

>>> Synchronization of repository 'gentoo' located in '/usr/portage'...
>>> Starting rsync with rsync://88.190.216.145/gentoo-portage...
>>> Checking server timestamp ...
_ _
http://modulix.org \_\__ _\_\
http://modulix.net \_\_\_\
http://modulix.com _\_\__
33000 Bordeaux _\_\ \_\__
webmaster@modulix.net \_\ \_\

rsync4.fr.gentoo.org - gentoo.modulix.net (88.190.216.145)
GNU/Linux-Gentoo 3.8.13-gentoo - x86_64 QEMU Virtual CPU version 1.4.2
2 processors activated (12371.88 BogoMIPS)
RAM : 2Go
HD : 500 Go (RAID 5)
Internet : 100 Mbits/sec

Portage faisait 803 Mo le 08/10/2013 à 22:00 :
- Distfiles/ebuilds : 62518/36597
- Catégories/Packages : 158/17076

receiving incremental file list
rsync: mkstemp "/data/.tmph716Pj.a1xa80" failed: Permission denied (13)

Number of files: 1
Number of files transferred: 1
Total file size: 32 bytes
Total transferred file size: 32 bytes
Literal data: 32 bytes
Matched data: 0 bytes
File list size: 27
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 98
Total bytes received: 793

sent 98 bytes received 793 bytes 1.78K bytes/sec
total size is 32 speedup is 0.04
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1518) [generator=3.0.9]
>>> Retrying...
!!! Exhausted addresses for gentoo.modulix.net
Back to top
View user's profile Send private message
ayame99
n00b
n00b


Joined: 07 Oct 2013
Posts: 20

PostPosted: Wed Oct 09, 2013 5:52 pm    Post subject: Reply with quote

Bonjour,

Pour information j ai lancé la commande hier

Code:
emerge --sync


aucun problème MAIS dans mon make .conf je ne specifie pas un serveur rsync seul le serveur GENTOO_MIRRORS= est spécifié
_________________
"Parfois je me demande si la meilleure preuve qu'il existe des espèces intelligentes quelque part dans l'Univers c'est qu'aucune d'entre elles n'a encore essayé de nous contacter."
(extrait de Calvin et Hobbes)
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5450
Location: ~Brussels - Belgique

PostPosted: Wed Oct 09, 2013 6:11 pm    Post subject: Reply with quote

N'ayant pas Free, je ne puis vous aider.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ayame99
n00b
n00b


Joined: 07 Oct 2013
Posts: 20

PostPosted: Wed Oct 09, 2013 6:39 pm    Post subject: Reply with quote

Ayant aussi ce FAI je viens de tester en mettant dans mon make.conf le meme reglage que destroyedlolo a savoir

Code:
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"


aucun problème

Code:
umber of files: 174780
Number of files transferred: 3470
Total file size: 307.48M bytes
Total transferred file size: 10.90M bytes
Literal data: 10.90M bytes
Matched data: 0 bytes
File list size: 4.32M
File list generation time: 3.859 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 110.88K
Total bytes received: 8.36M

sent 110.88K bytes  received 8.36M bytes  245.56K bytes/sec
total size is 307.48M  speedup is 36.29
q: Updating ebuild cache ...
q: Finished 36614 entries in 0.187654 seconds

_________________
"Parfois je me demande si la meilleure preuve qu'il existe des espèces intelligentes quelque part dans l'Univers c'est qu'aucune d'entre elles n'a encore essayé de nous contacter."
(extrait de Calvin et Hobbes)
Back to top
View user's profile Send private message
destroyedlolo
Guru
Guru


Joined: 17 Jun 2011
Posts: 406
Location: Close to Annecy

PostPosted: Thu Oct 10, 2013 9:27 pm    Post subject: Reply with quote

Non, je n'ai pas essayé avec un autre mirroir ... quand je vois que ça passe pas, je fais un wget sur le dernier latest qui va à vitesse maxi (il sature ma ligne).

@ayame99 : t'es dégroupé ou non dégroupé ?
Ce FAI fait du bridage ... pardon, de la qualité de service, différente en fonction de la situation ...
Back to top
View user's profile Send private message
ayame99
n00b
n00b


Joined: 07 Oct 2013
Posts: 20

PostPosted: Tue Oct 15, 2013 8:13 am    Post subject: Reply with quote

En zone degroupé

Quote:
Ce FAI fait du bridage ... pardon, de la qualité de service


J'ai connu ca, si tu as un serveur distant utilise un vpn (aucun bridage)
_________________
"Parfois je me demande si la meilleure preuve qu'il existe des espèces intelligentes quelque part dans l'Univers c'est qu'aucune d'entre elles n'a encore essayé de nous contacter."
(extrait de Calvin et Hobbes)
Back to top
View user's profile Send private message
castor_fou
Apprentice
Apprentice


Joined: 23 May 2002
Posts: 249
Location: Clermont-Ferrand, France

PostPosted: Wed Jan 01, 2014 7:07 pm    Post subject: Reply with quote

J'ai le même problème depuis 2 mois.
Je suis sous Free et non dégroupé.

Pfff
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5450
Location: ~Brussels - Belgique

PostPosted: Wed Jan 01, 2014 9:17 pm    Post subject: Reply with quote

Avez-vous essayé d'autres serveurs ?
et via un webrsync ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
castor_fou
Apprentice
Apprentice


Joined: 23 May 2002
Posts: 249
Location: Clermont-Ferrand, France

PostPosted: Wed Jan 01, 2014 9:20 pm    Post subject: Reply with quote

Oui pas mal de serveur sans succès.
Aucun pb avec webrsync, c'est comme ça que je me mets à jour désormais...
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5450
Location: ~Brussels - Belgique

PostPosted: Thu Jan 02, 2014 9:36 am    Post subject: Reply with quote

Vu les antécédents que vous avez déjà en France (Youtube flitré "au ralenti"), je soupçonnerais votre fournisseur de filtrer les ports RSYNC...
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
castor_fou
Apprentice
Apprentice


Joined: 23 May 2002
Posts: 249
Location: Clermont-Ferrand, France

PostPosted: Sat Feb 01, 2014 10:27 am    Post subject: Reply with quote

C'est résolu pour moi.
J'ai ajouté un noload=ipv6 au boot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum