Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] fotowall-0.9 - & libpng-1.5
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Oct 08, 2013 7:28 pm    Post subject: [gelöst] fotowall-0.9 - & libpng-1.5 Reply with quote

Die beiden scheinen sich nicht zu vertragen:

Code:
In file included from Shared/VideoProvider.cpp:20:0:
./3rdparty/videocapture/VideoDevice.h:44:32: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make: *** [.build/VideoProvider.o] Error 1
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: media-gfx/fotowall-0.9-r1::gentoo failed (compile phase):
 *   died running emake, base_src_make
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 2420:  Called qt4-r2_src_compile
 *   environment, line 2385:  Called base_src_compile
 *   environment, line  358:  Called base_src_make
 *   environment, line  396:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "died running emake, $FUNCNAME";
 *
 * If you need support, post the output of `emerge --info '=media-gfx/fotowall-0.9-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/fotowall-0.9-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/fotowall-0.9-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/fotowall-0.9-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/fotowall-0.9-r1/work/Fotowall-0.9'
 * S: '/var/tmp/portage/media-gfx/fotowall-0.9-r1/work/Fotowall-0.9'

>>> Failed to emerge media-gfx/fotowall-0.9-r1, Log file:

>>>  '/var/tmp/portage/media-gfx/fotowall-0.9-r1/temp/build.log'


Gibt es dafür einen workaround?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Thu Oct 10, 2013 9:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Tue Oct 08, 2013 7:57 pm    Post subject: Reply with quote

Wie kommst du auf libpng?
eine include datei im linux unterverzeichnis gehört eher zu den linux-headers, und vermutlich musst du einfach warten, bis fotowall geupdatet wird, weil vermutlich was im kernel geändert hat, wodurch die datei fehlt.
provisorisch könntest du deine jetzige linux-headers masken und mal ältere ausprobieren.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Oct 08, 2013 8:09 pm    Post subject: Reply with quote

Hatte ich gegoogelt, finde es aber nicht mehr...
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 174
Location: Essen

PostPosted: Tue Oct 08, 2013 8:26 pm    Post subject: Reply with quote

fotowall lässt sich mit dem vanilla-kernel 3.11.4 problemlos kompilieren:

Code:
>>> Installing (1 of 1) media-gfx/fotowall-0.9-r1
 * checking 5 files for package collisions
>>> Merging media-gfx/fotowall-0.9-r1 to /
--- /usr/
--- /usr/share/
--- /usr/share/doc/
>>> /usr/share/doc/fotowall-0.9-r1/
>>> /usr/share/doc/fotowall-0.9-r1/README.markdown.bz2
--- /usr/share/pixmaps/
>>> /usr/share/pixmaps/fotowall.png
--- /usr/share/man/
--- /usr/share/man/man1/
>>> /usr/share/man/man1/fotowall.1.bz2
--- /usr/share/applications/
>>> /usr/share/applications/fotowall.desktop
--- /usr/bin/
>>> /usr/bin/fotowall
>>> media-gfx/fotowall-0.9-r1 merged.
>>> Regenerating /etc/ld.so.cache...

>>> Recording media-gfx/fotowall in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.


Vermutlich fehlt der Softlink zu den Kernel-Sourcen (/usr/src/linux..)


Mach doch bitte mal folgendes, dann sollte das hier stehen und "*" markiert den aktuellen Kernel-Source bei Dir, wenn er richtig gesetzt wurde:

Code:
eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.5.7
  [2]   linux-3.6.11
  [3]   linux-3.7.10
  [4]   linux-3.8.10
  [5]   linux-3.9.8
  [6]   linux-3.10.7-gentoo-r1
  [7]   linux-3.10.10
  [8]   linux-3.11.4 *


Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Oct 08, 2013 8:29 pm    Post subject: Reply with quote

Code:
(chroot) livecd / # eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.9.11-gentoo-r1
  [2]   linux-3.10.7-gentoo-r1 *


Das stimmt. Kann es sein, dass das im chroot ein Problem ist? Direkt von /dev/sda3 läuft meine Kiste noch nicht wieder richtig...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Tue Oct 08, 2013 8:50 pm    Post subject: Reply with quote

also linux-sources ist eigentlich ein eigenes paket, welches die header des kernel nach /usr/include/linux installiert. dort werden sie von auto-config u.ä. gefunden. wenn fotowall nicht was spezielles macht hat der /usr/src/linux symlink keinen einfluss.
PS: ohne gewähr...
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Oct 09, 2013 4:52 am    Post subject: Reply with quote

Code:
eix linux-sources
[I] virtual/linux-sources
     Available versions:  0 ~1 {firmware}
     Installed versions:  0(05:04:28 09/30/13)
     Description:         Virtual for Linux kernel sources


Warum sehe ich da die Versionsnummer "0" und nicht 3.10.7 wie mein Kernel?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Wed Oct 09, 2013 10:42 am    Post subject: Reply with quote

weil das paket linux-headers heißt und ich mich vertan hab...
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Oct 09, 2013 4:13 pm    Post subject: Reply with quote

Siehste mal christian99, dir glaub ich halt alles :-)

Code:
eix linux-headers
[I] sys-kernel/linux-headers
     Available versions:  *2.4.33.3^bs ~*2.4.36^bs 3.1^bs (~)3.2-r1^bs (~)3.3^bs 3.4^bs 3.4-r1^bs 3.4-r2^bs (~)3.5^bs 3.6^bs 3.7^bs (~)3.8^bs 3.9^bs (~)3.10^bs (~)3.11^bs
     Installed versions:  3.11^bs(14:30:22 10/06/13)
     Homepage:            http://www.kernel.org/ http://www.gentoo.org/
     Description:         Linux system headers


Da stimmt die Version aber auch nicht mit meinem Kernel überein....

Ich installiere mal die linux-headers-3.10 dazu und probiere es nochmal... -> klappt auch nicht:

Code:
In file included from 3rdparty/videocapture/VideoDevice.cpp:16:0:               
3rdparty/videocapture/VideoDevice.h:44:32: fatal error: linux/videodev.h: No such file or directory                                                             
compilation terminated.                                                         
make: *** [.build/VideoDevice.o] Error 1                                       
make: *** Waiting for unfinished jobs....                                       
In file included from Shared/VideoProvider.cpp:20:0:                           
./3rdparty/videocapture/VideoDevice.h:44:32: fatal error: linux/videodev.h: No such file or directory                                                           
compilation terminated.                                                         
make: *** [.build/VideoProvider.o] Error 1                                     
emake failed                                                                   
 * ERROR: media-gfx/fotowall-0.9-r1::gentoo failed (compile phase):             
 *   died running emake, base_src_make                                         
 *                                                                             
 * Call stack:                                                                 
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 2421:  Called qt4-r2_src_compile
 *   environment, line 2386:  Called base_src_compile
 *   environment, line  359:  Called base_src_make
 *   environment, line  397:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "died running emake, $FUNCNAME";
 *
 * If you need support, post the output of `emerge --info '=media-gfx/fotowall-0.9-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/fotowall-0.9-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/fotowall-0.9-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/fotowall-0.9-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/fotowall-0.9-r1/work/Fotowall-0.9'
 * S: '/var/tmp/portage/media-gfx/fotowall-0.9-r1/work/Fotowall-0.9'

>>> Failed to emerge media-gfx/fotowall-0.9-r1


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Wed Oct 09, 2013 7:33 pm    Post subject: Reply with quote

naja, wie schon im ersten post von mir gemeint: warten, bis das von fotowall seite behoben wird, oder mal ältere linux-headers probieren. die müssen nicht unbedingt mit den aktuellen kernel übereinstimmen. stable sind linux-headers-3.9, oder arfe, welche hast du denn installiert? bei dir läufts ja.
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 426

PostPosted: Wed Oct 09, 2013 7:56 pm    Post subject: Reply with quote

Wozu braucht ein "Qt4 tool for creating wallpapers" einen direkten Zugriff auf die Kernel Funktionen? Solche Software würde ich meiden.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Wed Oct 09, 2013 8:01 pm    Post subject: Reply with quote

@Christian99
Vermutlich liegt es nicht an media-gfx/fotowall-0.9-r1 Es gibt keine bekannten Bugs, und bei anderen Leuten baut es doch auch einwandfrei.

@uhai
Gibt es eventuell noch Altlasten unter /usr/local/ die genutzt werden?
Schau doch auch mal weiter oben im build.log wo das Zeugs überhaupt herkommt.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Wed Oct 09, 2013 8:25 pm    Post subject: Reply with quote

habs mal selber ausprobiert:
mit USE=webcam gehts nicht, ohne webcam baut er. linux-headers-3.11
@bell, dafür braucht er auchzugriff auf den kernel.

die besagte linux/videodev.h ist in den linux-headers-3.11 nicht enthalten, da gibts nur eine videodev2.h.
da muss fotowall für die verwendung an diese kernel versionen angepasst werden, sonst wird das wohl nix. wie gesagt, wenn du webcam brauchst, muss du dir einen kernel suchen, mit dem fotowall baut, oder bau einfach ohne webcam support.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Thu Oct 10, 2013 9:36 pm    Post subject: Reply with quote

Klasse Christian, die USE=webcam waren es. Jetzt hat's hier auch funktioniert. Meine Webcam ist eh hops, also eigentlich ok ohne.... :wink:

Vielen Dank an alle für's helfen

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum