Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel i7 3930-K Speed issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Mon Sep 30, 2013 3:17 am    Post subject: Intel i7 3930-K Speed issues Reply with quote

Hi, I installed Gentoo via SystemRescueCD USB key, and everything went pretty smooth. Now when I recompile the kernel to install the propietary NVIDIA graphics driver, the kernel compiling time is really SLOW compared to when I compile the kernel on the SystemRescueCD instance. I am pretty sure something is wrong with my kernel configuration but I don't know what exactly could be, I have checked the kernel config many times already. Compile time in the SRCD instance goes to 7 minutes, on my own running kernel goes up to more than one hour and a half. I monitorized with TOP on both while compiling , and while in the SRCD the core number 0 is being pushed to the max, about 87% constantly and the rest of the cores take 1 or 2% randomly, on my kernel it takes just like 2% of each core randomly.

my MAKEOPTS are -j14

Any hints on this ? Thank you.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2087
Location: Near Toronto

PostPosted: Mon Sep 30, 2013 12:38 pm    Post subject: Reply with quote

that's really bad

what cpu governor are you using

(
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
)
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Mon Sep 30, 2013 2:19 pm    Post subject: Reply with quote

The output is really bad too I guess :

Code:
 cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
powersave
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2087
Location: Near Toronto

PostPosted: Mon Sep 30, 2013 5:45 pm    Post subject: Reply with quote

make sure the kernel is set to use ondemand governor
as default in the power management and acpi options
/ cpu frequency scaling section

IMO, the "help" advice is too conservative (where it says:
"in in doubt, say N" for ondemand ...
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Mon Sep 30, 2013 6:32 pm    Post subject: Reply with quote

Made the changes you suggested ... compiling now, will let you know.

Now that makes sense, thank you !
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 7:41 am    Post subject: Reply with quote

Recompiled kernel disabling powersave and set all options ondemand when I do

Code:
cat /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
powersave


All CPU still appear on powersave. What Im doing wrong ?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2087
Location: Near Toronto

PostPosted: Tue Oct 01, 2013 11:50 am    Post subject: Reply with quote

Quote:

All CPU still appear on powersave. What Im doing wrong ?


as root, try

Code:
echo "ondemand" > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor


I guess you should do that for all cpus (cpu0 thru, in you lucky case, cpu11) ...

if that works we can figure out why it's not automatically setting the right
governor ...
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 2:54 pm    Post subject: Reply with quote

Code:

echo "ondemand" >> /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
bash: echo: write error: Invalid argument


can't write it ... same happens when I open the file with nano. I guess it looks like it is not supported on the kernel ?
I compiled twice, made Bzimage and rebooted ...

Thanks
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 230
Location: S.O. France

PostPosted: Tue Oct 01, 2013 3:21 pm    Post subject: Reply with quote

Please post

Code:
cat /usr/src/linux/.config | grep CONFIG_CPU_FREQ
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 3:57 pm    Post subject: Reply with quote

Code:

speed cf # cat /usr/src/linux/.config | grep CONFIG_CPU_FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_GOV_COMMON=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_GOV_CONSERVATIVE is not set


As you can see everything looks like its on demand ...

Thanks !
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 230
Location: S.O. France

PostPosted: Tue Oct 01, 2013 4:26 pm    Post subject: Reply with quote

And
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

Have you rebooted?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2087
Location: Near Toronto

PostPosted: Tue Oct 01, 2013 4:28 pm    Post subject: Reply with quote

also post

Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors


just to be sure ondemand is there
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 4:40 pm    Post subject: Reply with quote

Code:

speed cf # cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
performance powersave


Thanks.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 230
Location: S.O. France

PostPosted: Tue Oct 01, 2013 5:11 pm    Post subject: Reply with quote

Quote:
I compiled twice, made Bzimage and rebooted

Have you installed the new Bzimage?
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 5:17 pm    Post subject: Reply with quote

I do this after compiling :

Code:

speed boot # ls
bzImage
speed boot # cp bzImage /boot/kernel-3.10.7-gentoo
speed boot #


Thanks
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 230
Location: S.O. France

PostPosted: Tue Oct 01, 2013 5:24 pm    Post subject: Reply with quote

I think you forgot to mount your /boot partition.

Try this if you use grub1
Code:
mount /boot
cp /urc/src/linux/arch/x.../bzimage /boot/kernel-3.10.7-gentoo
umount /boot
reboot
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 5:35 pm    Post subject: Reply with quote

Hi, mounted, copied and rebooted, all the output still the same .... :?:
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 230
Location: S.O. France

PostPosted: Tue Oct 01, 2013 6:13 pm    Post subject: Reply with quote

Are you using grub1 or grub2?
I'm confused with your other post
http://forums.gentoo.org/viewtopic-t-971264-start-0-postdays-0-postorder-asc-highlight-.html
See the wiki and the handbook for installing a new kernel
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 6:16 pm    Post subject: Reply with quote

I solved that problem already ... I was using a wrong arch stage. Now I am on a working install of amd64. I am using grub 2, not legacy.

Thanks
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 230
Location: S.O. France

PostPosted: Tue Oct 01, 2013 7:37 pm    Post subject: Reply with quote

We can not help you if you're not more explicit.
You know you are using grub2 but you try to install bzimage like if you have grub1.
Looking at your other posts, I see that you do not read the messages of emerge and the logs.

See the handbook and the wiki. Everything is explained about how compiling and installing a kernel with grub2
http://wiki.gentoo.org/wiki/GRUB2
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Tue Oct 01, 2013 7:45 pm    Post subject: Reply with quote

I will ! Thank you
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Tue Oct 29, 2013 9:50 pm    Post subject: Reply with quote

Just in case someone with a similar problem finds this thread (like I did).

My problem was that although all governors were compiled into the kernel, only "performance" and "powersave" were available.

In my case it is because CONFIG_X86_INTEL_PSTATE is set:

Code:
grep CONFIG_X86_INTEL_PSTATE /usr/src/linux/.config
CONFIG_X86_INTEL_PSTATE=y


Quote:
This driver provides a P state for Intel core processors.
The driver implements an internal governor and will become
the scaling driver and governor for Sandy bridge processors.

When this driver is enabled it will become the perferred
scaling driver for Sandy bridge processors.

If in doubt, say N.


This also seems to apply to my Ivy bridge CPU, so I guess that's why the other governors are not showing up.

Btw, the P state governor works well and I will stick to it. I only came across this "issue" because an error showed up when I restarted laptop_mode:
Code:
sudo /etc/init.d/laptop_mode restart
 * WARNING: you are stopping a boot service
 * Stopping laptop_mode ...
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument                      [ ok ]
 * Starting laptop_mode ...
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument                      [ ok ]


I resolved this by disabling frequency scaling in /etc/laptop-mode/conf.d/cpufreq.conf. I learned that my kernel already does frequency scaling.
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum