Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unresolved Conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
eleanor
l33t
l33t


Joined: 01 Nov 2004
Posts: 661

PostPosted: Sun Sep 29, 2013 8:50 pm    Post subject: Unresolved Conflicts Reply with quote

Hi,

Recently I've done emerge --sync and then tried to update my system with "emerge -DuvaN" world, but I've come across some strange conflicts. Does anybody know how to solve them:

Quote:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

(app-text/poppler-0.22.2-r2::gentoo, ebuild scheduled for merge) pulled in by
<app-text/poppler-0.24:0/35=[cxx,lcms,xpdf-headers(+)] required by (net-print/cups-filters-1.0.34-r1::gentoo, installed)
>=app-text/poppler-0.12.3-r3:0/35=[qt4,xpdf-headers(+)] required by (app-text/calibre-1.2::gentoo, installed)
app-text/poppler:0/35=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
(and 2 more with the same problems)

(app-text/poppler-0.22.5::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

dev-python/PyQt4:0

(dev-python/PyQt4-4.10.2::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-python/PyQt4-4.10.2::gentoo, installed) pulled in by
>=dev-python/PyQt4-4.9.1[X,svg,webkit] required by (app-text/calibre-1.2::gentoo, installed)

dev-lang/python:2.7

(dev-lang/python-2.7.5-r2::gentoo, installed) pulled in by
=dev-lang/python-2.7*[sqlite] required by (media-sound/exaile-0.3.2.0::gentoo, installed)
=dev-lang/python-2*[sqlite] required by (gnome-extra/zeitgeist-extensions-0.0.13-r1::gentoo, installed)
>=dev-lang/python-2.7.1:2.7[sqlite,ssl] required by (app-text/calibre-1.2::gentoo, installed)
dev-lang/python:2.7[sqlite(+)] required by (dev-python/scrapy-0.17.0::gentoo, installed)
dev-lang/python:2.7[sqlite,xml] required by (app-text/keepnote-0.7.8-r1::gentoo, installed)

(dev-lang/python-2.7.5-r2::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-gfx/imagemagick:0

(media-gfx/imagemagick-6.8.6.8::gentoo, installed) pulled in by
>=media-gfx/imagemagick-6.5.9[jpeg,png] required by (app-text/calibre-1.2::gentoo, installed)

(media-gfx/imagemagick-6.8.6.8::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

sys-libs/zlib:0

(sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
>=sys-libs/zlib-1.2.5.1-r2[minizip] required by (media-video/vlc-2.0.7::gentoo, ebuild scheduled for merge)
sys-libs/zlib[minizip] required by (dev-libs/quazip-0.5.1-r1::gentoo, installed)
sys-libs/zlib:=[minizip] required by (www-client/chromium-29.0.1547.57::gentoo, ebuild scheduled for merge)
sys-libs/zlib[minizip] required by (app-office/scribus-1.4.1-r1::gentoo, installed)

(sys-libs/zlib-1.2.7::gentoo, ebuild scheduled for merge) pulled in by
sys-libs/zlib[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libpciaccess-0.13.2::gentoo, ebuild scheduled for merge)

x11-libs/cairo:0

(x11-libs/cairo-1.12.14-r4::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-libs/cairo-1.12.14-r4::gentoo, installed) pulled in by
x11-libs/cairo[xcb] required by (x11-misc/i3lock-2.5::gentoo, installed)
x11-libs/cairo[xcb] required by (x11-wm/awesome-3.4.15::gentoo, installed)

app-text/texlive-core:0

(app-text/texlive-core-2012-r1::gentoo, installed) pulled in by
>=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-xetex-2012::gentoo, installed)

(app-text/texlive-core-2012-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

x11-libs/qscintilla:0

(x11-libs/qscintilla-2.7.2::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qscintilla-2.7.2:= required by (dev-python/qscintilla-python-2.7.2::gentoo, ebuild scheduled for merge)

(x11-libs/qscintilla-2.6.2::gentoo, installed) pulled in by
~x11-libs/qscintilla-2.6.2 required by (dev-python/qscintilla-python-2.6.2::gentoo, installed)
x11-libs/qscintilla:0/0= required by (dev-util/monkeystudio-1.9.0.4::gentoo, installed)

dev-python/qscintilla-python:0

(dev-python/qscintilla-python-2.6.2::gentoo, installed) pulled in by
~dev-python/qscintilla-python-2.6.2 required by (x11-libs/qscintilla-2.6.2::gentoo, installed)

(dev-python/qscintilla-python-2.7.2::gentoo, ebuild scheduled for merge) pulled in by
~dev-python/qscintilla-python-2.7.2 required by (x11-libs/qscintilla-2.7.2::gentoo, ebuild scheduled for merge)

dev-dotnet/libgdiplus:0

(dev-dotnet/libgdiplus-2.10.9::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-dotnet/libgdiplus-2.10.9::gentoo, installed) pulled in by
dev-dotnet/libgdiplus[cairo] required by (app-admin/keepass-2.22::gentoo, installed)

net-misc/freerdp:0

(net-misc/freerdp-1.1.0_beta1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(net-misc/freerdp-1.1.0_beta1_p20130710::gentoo, installed) pulled in by
>=net-misc/freerdp-1.1.0_beta1_p20130710 required by (net-misc/remmina-1.0.0_p20130723::gentoo, installed)

x11-base/xorg-server:0

(x11-base/xorg-server-1.14.3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-base/xorg-server-1.13.4::gentoo, installed) pulled in by
<x11-base/xorg-server-1.13.99[-minimal] required by (x11-drivers/xf86-video-virtualbox-4.1.26::gentoo, installed)

x11-libs/wxGTK:2.8

(x11-libs/wxGTK-2.8.12.1::gentoo, installed) pulled in by
>=x11-libs/wxGTK-2.8.12.1:2.8[opengl?,tiff,X] required by (dev-python/wxpython-2.8.12.1-r1::gentoo, installed)

(x11-libs/wxGTK-2.8.12.1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

net-misc/rsync:0

(net-misc/rsync-3.0.9-r3::gentoo, installed) pulled in by
net-misc/rsync[xattr,acl] required by (app-backup/backintime-1.0.8-r1::gentoo, installed)

(net-misc/rsync-3.0.9-r3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/gconf:2

(gnome-base/gconf-2.32.4-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(gnome-base/gconf-2.32.4-r1::gentoo, installed) pulled in by
>=gnome-base/gconf-2:2[gtk(+)] required by (gnome-base/gnome-session-2.32.1-r3::gentoo, installed)

virtual/udev:0

(virtual/udev-200::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(virtual/udev-200::gentoo, installed) pulled in by
virtual/udev:0/0=[gudev] required by (gnome-base/gvfs-1.12.3-r1::gentoo, installed)
>=virtual/udev-197[gudev,hwdb(+)] required by (sys-fs/udisks-2.1.0::gentoo, installed)
>=virtual/udev-143[hwdb(+)] required by (media-sound/pulseaudio-2.1-r1::gentoo, installed)
virtual/udev:=[gudev] required by (gnome-base/gvfs-1.12.3-r1::gentoo, installed)
>=virtual/udev-200[gudev] required by (sys-power/upower-0.9.21::gentoo, installed)
virtual/udev[gudev] required by (media-gfx/shotwell-0.14.1::gentoo, installed)
virtual/udev[gudev] required by (net-misc/networkmanager-0.9.6.4::gentoo, installed)
>=virtual/udev-197[gudev,hwdb(+)] required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)

sys-fs/udev:0

(sys-fs/udev-204::gentoo, installed) pulled in by
>=sys-fs/udev-200[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?] required by (virtual/udev-200::gentoo, installed)

(sys-fs/udev-204::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



Thank you
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 749
Location: Germany

PostPosted: Mon Sep 30, 2013 5:47 am    Post subject: Reply with quote

I usually solve these issues manually, by getting a list of what will be upgraded (emerge --update --deep -pv world) and then merging individual packages (if it is a dependency additionally using -1 so it won't be recorded in the world file.
It can be quite a hassle and sometimes you have to --depclean some packages or even --unmerge them for it to work.

Wouldn't this thread better fit into portage and programming?
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Mon Sep 30, 2013 8:11 pm    Post subject: Reply with quote

suggest start with:
Code:
emerge --sync
emerge portage
emerge --unmerge poppler
emerge -1av =app-text/poppler-0.22.5
results??
_________________
Defund the FCC.
Back to top
View user's profile Send private message
eleanor
l33t
l33t


Joined: 01 Nov 2004
Posts: 661

PostPosted: Wed Oct 02, 2013 8:56 pm    Post subject: Reply with quote

Hi,

I unmerged the conflicting packages, masked some, rebuild, unmasked the masked packaged, rebuilt some more and now the problem is solved.

Thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum