Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub2 UEFI error ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Sun Sep 29, 2013 1:12 pm    Post subject: Grub2 UEFI error ? Reply with quote

Hi, trying to install GRUB2 :


sysresccd linux # grub2-install /dev/sda
/usr/lib/grub/x86_64-efi doesn't exist. Please specify --target or --directory



Any help appreciated, thanks !
Back to top
View user's profile Send private message
croutch
n00b
n00b


Joined: 04 Aug 2012
Posts: 31
Location: göteborg

PostPosted: Sun Sep 29, 2013 2:02 pm    Post subject: Reply with quote

Hello.

I think this page can help you
http://wiki.gentoo.org/wiki/GRUB2#UEFI.2FGPT

and this one
http://wiki.gentoo.org/wiki/GRUB2_Quick_Start

croutch
Back to top
View user's profile Send private message
chromaf
Tux's lil' helper
Tux's lil' helper


Joined: 29 Sep 2013
Posts: 79

PostPosted: Sun Sep 29, 2013 3:47 pm    Post subject: Reply with quote

Thanks, I tried that but my system is not EFI, its a boot partition inside a a root partition, a regular install. Looks like GRUB2 is guessing my boot partition is an EFI one ...
Back to top
View user's profile Send private message
amair
n00b
n00b


Joined: 12 Aug 2003
Posts: 36

PostPosted: Mon Sep 30, 2013 10:16 am    Post subject: Reply with quote

Hi,

try adding "--target=pc" to your grub2-install call. That helped in my case.

Best regards,
Andreas
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum