Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OVH] Comment recompiler ffmpeg et h264 ? help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
cedrus83
n00b
n00b


Joined: 28 Sep 2013
Posts: 4

PostPosted: Sat Sep 28, 2013 3:20 pm    Post subject: [OVH] Comment recompiler ffmpeg et h264 ? help Reply with quote

Bonjour,
J'ai besoin de votre aide. Je ne sais pas comment corriger le problème étant débutant. J'ai un serveur dédié OVH avec Gentoo. Mon site permet d'uploader des vidéos et le .MP4 est converti en .flv avant la mise en ligne de la vidéo. ffmpeg fonctionnait très bien mais là il ne fait plus de conversion et le error_log affiche cela:

Code:
[Fri Sep 27 15:32:01 2013] [error] [client ] Compiler did not align stack variables. Libavcodec has been miscompiled, referer: http://www.monsite.com/mon_compte/envoi_cours_step3.php
[Fri Sep 27 15:32:01 2013] [error] [client ] and may be very slow or crash. This is not a bug in libavcodec,, referer: http://www.monsite.com/mon_compte/envoi_cours_step3.php
[Fri Sep 27 15:32:01 2013] [error] [client ] but in the compiler. Do not report crashes to FFmpeg developers., referer: http://www.monsite.com/mon_compte/envoi_cours_step3.php
[Fri Sep 27 15:32:01 2013] [error] [client ] [h264 @ 0x7ffc53008bc0]no frame!, referer: http://www.monsite.com/mon_compte/envoi_cours_step3.php


Je ne sais pas comment interpréter le message d'erreur et comment le corriger. Je n'ai fait aucune mise à jour du serveur depuis la création du site, je sais même pas comment on met tous ces programmes à jour d'ailleurs.

On m'a dit qu'il faut recompiler ffmpeg ou h264 mais je ne sais pas du tout comment faire. Quelqu'un peut il me dire la procédure étape par étape pour recompiler tout ça ?

Merci d'avance pour votre aide, c'est la grosse galère là.
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Sun Sep 29, 2013 1:05 pm    Post subject: Reply with quote

C'est du basique là quand même...

Code:
# emerge -a1v media-video/ffmpeg


Du coup je suppose que ton dédié n'est jamais mis à jour ?
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5584
Location: ~Brussels - Belgique

PostPosted: Sun Sep 29, 2013 6:05 pm    Post subject: Reply with quote

CryoGen wrote:
C'est du basique là quand même...

Code:
# emerge -a1v media-video/ffmpeg


Du coup je suppose que ton dédié n'est jamais mis à jour ?


OVH à jour ? Mwahahahaha !!!
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
cedrus83
n00b
n00b


Joined: 28 Sep 2013
Posts: 4

PostPosted: Sun Sep 29, 2013 6:45 pm    Post subject: Reply with quote

Merci pour la réponse, je suis débutant. C 'est tout nouveau pour moi la gestion du serveur. Je suis allé dans webmin puis dans Commande Shell puis j'ai entré ton code dans le champs et cliqué sur le bouton "Exécuter la commande".

Et là gros bug si j'upload une vidéo qui doit être converti, ça mouline dans le vide et plante et errorlog indique:
Quote:
FFmpeg version 0.6, Copyright (c) 2000-2010 the FFmpeg developers
built on Oct 11 2010 16:01:16 with gcc 3.4.5 (Gentoo 3.4.5, ssp-3.4.5-1.0, pie-8.7.9)
configuration:
libavutil 50.15. 1 / 50.15. 1
libavcodec 52.72. 2 / 52.72. 2
libavformat 52.64. 2 / 52.64. 2
libavdevice 52. 2. 0 / 52. 2. 0
libswscale 0.11. 0 / 0.11. 0
Compiler did not align stack variables. Libavcodec has been miscompiled
and may be very slow or crash. This is not a bug in libavcodec,
but in the compiler. You may try recompiling using gcc >= 4.2.
Do not report crashes to FFmpeg developers.
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/monsite/www/cours/upload_videos/226.mp4':
Metadata:
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
Duration: 00:00:50.68, start: 0.000000, bitrate: 715 kb/s
Stream #0.0(und): Video: h264, yuv420p, 640x360 [PAR 1:1 DAR 16:9], 601 kb/s, 25 fps, 25 tbr, 25k tbn, 50 tbc
Stream #0.1(und): Audio: aac, 44100 Hz, stereo, s16, 111 kb/s
Output #0, flv, to '/home/monsite/www/cours/peda_videos/120-test2.flv':
Metadata:
encoder : Lavf52.64.2
Stream #0.0(und): Video: flv, yuv420p, 640x480 [PAR 4:3 DAR 16:9], q=2-3, 200 kb/s, 1k tbn, 25 tbc
Stream #0.1(und): Audio: adpcm_swf, 44100 Hz, stereo, s16, 64 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Press [q] to stop encoding
frame= 55 fps= 0 q=24.8 size= 409kB time=2.28 bitrate=1470.4kbits/s \rframe= 124 fps=123 q=31.0 size= 821kB time=5.02 bitrate=1341.5kbits/s \rframe= 182 fps=119 q=31.0 size= 1396kB time=7.36 bitrate=1554.0kbits/s \rframe= 239 fps=118 q=31.0 size= 2023kB time=9.64 bitrate=1719.0kbits/s \rframe= 294 fps=116 q=31.0 size= 2586kB time=11.84 bitrate=1789.5kbits/s \rframe= 350 fps=115 q=31.0 size= 3200kB time=14.08 bitrate=1861.6kbits/s \rframe= 404 fps=114 q=31.0 size= 3759kB time=16.24 bitrate=1896.2kbits/s \rframe= 457 fps=113 q=31.0 size= 4376kB time=18.36 bitrate=1952.7kbits/s \rframe= 504 fps=111 q=31.0 size= 5174kB time=20.24 bitrate=2094.1kbits/s \rframe= 555 fps=109 q=31.0 size= 5898kB time=22.28 bitrate=2168.6kbits/s \rframe= 590 fps=106 q=31.0 size= 6631kB time=23.68 bitrate=2294.0kbits/s \rframe= 644 fps=106 q=31.0 size= 7230kB time=25.84 bitrate=2292.0kbits/s \rframe= 699 fps=106 q=31.0 size= 7840kB time=28.04 bitrate=2290.3kbits/s \rframe= 753 fps=106 q=31.0 size= 8456kB time=30.20 bitrate=2293.8kbits/s \rframe= 807 fps=106 q=31.0 size= 8995kB time=32.36 bitrate=2277.2kbits/s \rframe= 861 fps=106 q=31.0 size= 9592kB time=34.52 bitrate=2276.4kbits/s \rframe= 912 fps=106 q=31.0 size= 10224kB time=36.56 bitrate=2290.8kbits/s \rframe= 942 fps=103 q=31.0 size= 10618kB time=37.76 bitrate=2303.6kbits/s \rframe= 980 fps=102 q=31.0 size= 11202kB time=39.28 bitrate=2336.3kbits/s \rframe= 1038 fps=102 q=31.0 size= 11862kB time=41.60 bitrate=2335.9kbits/s \rframe= 1083 fps=102 q=31.0 size= 12408kB time=43.40 bitrate=2342.2kbits/s \rframe= 1117 fps=100 q=31.0 size= 12886kB time=44.76 bitrate=2358.5kbits/s \rframe= 1170 fps=100 q=31.0 size= 13502kB time=46.88 bitrate=2359.4kbits/s \rframe= 1221 fps=100 q=31.0 size= 14225kB time=48.92 bitrate=2382.1kbits/s \rframe= 1264 fps=101 q=31.0 Lsize= 14644kB time=50.64 bitrate=2368.9kbits/s dup=0 drop=1 \r
video:12418kB audio:2189kB global headers:0kB muxing overhead 0.254001%


HELP.....
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Sun Sep 29, 2013 10:53 pm    Post subject: Reply with quote

cedrus83 wrote:
Merci pour la réponse, je suis débutant. C 'est tout nouveau pour moi la gestion du serveur. Je suis allé dans webmin puis dans Commande Shell puis j'ai entré ton code dans le champs et cliqué sur le bouton "Exécuter la commande".



ssh pour la gestion...

un petit # gcc --version

Et si la version de GCC est bien supérieure ou égale à 4.2, refait le emerge -a1v media-video/ffmpeg
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
cedrus83
n00b
n00b


Joined: 28 Sep 2013
Posts: 4

PostPosted: Sun Sep 29, 2013 11:39 pm    Post subject: Reply with quote

version gcc 3.4.5 (Gentoo 3.4.5)

Du coup je fais quoi ?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5584
Location: ~Brussels - Belgique

PostPosted: Mon Sep 30, 2013 6:26 am    Post subject: Reply with quote

Hello,

Si tu veux des versions à jour, évite la "Gentoo Release OVH 2" qui est très très très obsolète.
Ou prends contact avec le support OVH.

Ici, nous te conseillons fortement de passer à une vraie Gentoo "vanilla", installée via notre manuel.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3138

PostPosted: Mon Sep 30, 2013 9:50 am    Post subject: Reply with quote

'alute

j'ai lu ton threads et tes suppliques sur les forums ovh (dédiés, mutualisés, ...) et très très sincèrement vu ce qu'on y voit en plus d'ici je ne peux que te conseiller à l'instar de XavierMiller, de contacter rapidement soit le support ovh pour voir s'ils peuvent te proposer une solution pour revenir dans la R2 ou t'aider a passer sur d'autres outils ; soit celui qui a géré ton site avant cela (voire de prendre une presta pour solutionner çà si c'est vital).

On ne va pas rentrer ici dans les détails du pourquoi du comment car tu es débutant et que ce ne doit pas être en plus ton usage premier donc pour être le plus efficace et si tu en es capable :arrow: backup et migration de ton site web et de ses données sur une distribution que tu maîtrises réellement si tu dois l'administrer - ou paye une structure compétente pour le faire et gérer cela pour toi -.
Ne fait pas cette économie de temps ou d'argent si ton usage est autre que le loisir.

Ensuite seulement, si Gentoo te tient vraiment à coeur, apprends ses bases tranquillement au calme dans un coin et repart ensuite sur une Gentoo native puis remigre ton site dessus.

Ce n'est je me doute pas les réponses que tu espérais mais ce que tu prends pour un simple "bug" n'en est pas un... les causes et les solutions sont plus complexes.

Donc c'est réellement la meilleure aide que l'ont puisse te faire... à vouloir essayer de corriger ces problèmes, tu irais au-devant de pas mal de déconvenues voire pire.

Après, libre à toi de décider (et donc d'assumer) :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
cedrus83
n00b
n00b


Joined: 28 Sep 2013
Posts: 4

PostPosted: Tue Oct 01, 2013 1:07 pm    Post subject: Reply with quote

Merci d'avoir pris le temps de répondre. Je vais suivre vos conseils, ne rien toucher en attendant de trouver des personnes compétentes pour le faire.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum