Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] GRUB2 install reports no errors, boots into shell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1336
Location: /uk/sheffield

PostPosted: Mon Sep 23, 2013 2:46 pm    Post subject: [SOLVED] GRUB2 install reports no errors, boots into shell Reply with quote

Hi,

I've recently encountered some problems with GRUB2, not too sure when they arose, but the installs/updates for GRUB itself are shown below along with the date I installed more recent kernels...

Code:

# genlop -s grub
 * matches found:

     Wed Nov 14 09:27:21 2012 >>> sys-boot/grub-2.00-r1
     Wed Nov 14 16:48:08 2012 >>> sys-boot/grub-2.00-r1
     Wed Feb  6 08:41:55 2013 >>> sys-boot/grub-2.00-r2
     Sun Apr 28 07:33:47 2013 >>> sys-boot/grub-2.00-r3
     Mon Jul 22 09:42:10 2013 >>> sys-boot/grub-2.00-r4
     Tue Aug 13 18:20:06 2013 >>> sys-boot/grub-2.00_p5086
     Sat Aug 17 10:45:44 2013 >>> sys-boot/grub-2.00_p5107
     Wed Sep 11 10:56:03 2013 >>> sys-boot/grub-2.00_p5107-r1
 # ls -l /boot/
total 12604
drwxr-xr-x 6 root root    4096 Sep 16 10:57 grub
drwxr-xr-x 6 root root    4096 Sep 23 15:34 grub2
-rw-r--r-- 1 root root 1294688 Sep 23 14:01 initramfs-genkernel-3.11.1
-rw-r--r-- 1 root root 5799088 Sep  4 14:17 vmlinuz-3.11.0
-rw-r--r-- 1 root root 5799136 Sep 16 10:15 vmlinuz-3.11.1


My /etc/grub.d/40_custom looks like this and it appears to install fine, with no errors reported....

Code:

# cat /etc/grub.d/40_custom
#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
timeout=5
set root=(hd0,1)
menuentry "Gentoo 3.11.0" {
    insmod ext2
    search --no-floppy
    linux /boot/vmlinuz-3.11.0 root=/dev/sda1 rootfstype=ext4 libahci.ignore_sss=1 i915.i915_enable_rc6=1 resume=swap:/dev/sda3
}
menuentry "Gentoo 3.11.1" {
    insmod ext2
    search --no-floppy
    linux /boot/vmlinuz-3.10.10 root=/dev/sda1 rootfstype=ext4 libahci.ignore_sss=1 i915.i915_enable_rc6=1 resume=swap:/dev/sda3
}
# grub2-mkconfig -o /boot/grub2/grub.cfg && grub2-install --boot-directory=/boot /dev/sda
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.11.1
Found initrd image: /boot/initramfs-genkernel-3.11.1
Found linux image: /boot/vmlinuz-3.11.0
done
Installation finished. No error reported.


Upon rebooting though I get dropped into a GRUB shell and have followed the following steps (from here).....

Code:

grub> set root=(hd0,1)
grub> linux (hd0,1)/boot/vmlinuz-3.11.1 root=/dev/sda1 rhgb quiet selinux=0
grub> initrd (hd0,1)/boot/initramfs-genkernel-3.11.1
grub> boot


Obviously after booting back into my system I've repeated trying to install grub and it still doesn't report any problems/errors, yet when I reboot I'm thrown back into the GRUB shell and have to manually boot rather than being presented with a menu from which to choose.

Any pointers as to what I might be doing wrong would be very much appreciated as I'm stumped, I seem to be doing all steps as per instructions and they've worked fine for the last year or so.

Thanks in advance,

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth


Last edited by slackline on Mon Sep 23, 2013 3:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 258
Location: S.O. France

PostPosted: Mon Sep 23, 2013 3:01 pm    Post subject: Reply with quote

Hello
Quote:
WARN: postinst
│The grub directory has changed from /boot/grub2 to /boot/grub.
│Please run grub2-install and grub2-mkconfig -o /boot/grub/grub.cfg.
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1336
Location: /uk/sheffield

PostPosted: Mon Sep 23, 2013 3:06 pm    Post subject: Reply with quote

sebB wrote:
Hello
Quote:
WARN: postinst
│The grub directory has changed from /boot/grub2 to /boot/grub.
│Please run grub2-install and grub2-mkconfig -o /boot/grub/grub.cfg.


Hi sedB,

EDIT : That was almost what I had done, multiple times, from the above post...

slackline wrote:


....it appears to install fine, with no errors reported....

Code:

# grub2-mkconfig -o /boot/grub2/grub.cfg && grub2-install --boot-directory=/boot /dev/sda
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.11.1
Found initrd image: /boot/initramfs-genkernel-3.11.1
Found linux image: /boot/vmlinuz-3.11.0
done
Installation finished. No error reported.



I needed to not put the output file in /boot/grub2/grub2.conf but instead put it into /boot/grub/grub/conf Thanks for highlighting my error. Have to read post install messages more carefully in the future.

Cheers,

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum