Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conflitto di dipendenze (PORTAGE)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 61

PostPosted: Wed Sep 18, 2013 11:04 am    Post subject: Conflitto di dipendenze (PORTAGE) Reply with quote

Sono alle prime armi con Gentoo. Per aggiornare il sistema ho provato a dare (da root) questo comando:
Code:
emerge --update --deep --newuse world

l'output è il seguente:
Code:
 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild   R    ] x11-libs/libdrm-2.4.45  USE="-libkms*"
[ebuild   R    ] media-libs/mesa-9.1.2-r1  USE="-xa*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/mesa:0

  (media-libs/mesa-9.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/mesa-9.1.2-r1::gentoo, installed) pulled in by
    media-libs/mesa[xa] required by (x11-drivers/xf86-video-vmware-12.0.2-r1::gentoo, installed)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.45::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libdrm-2.4.45::gentoo, installed) pulled in by
    x11-libs/libdrm[libkms,video_cards_vmware] required by (x11-drivers/xf86-video-vmware-12.0.2-r1::gentoo, installed)


It might be possible to solve these slot collisions
by applying all of the following changes:
   - media-libs/mesa-9.1.2-r1 (Change USE: +xa)
   - x11-libs/libdrm-2.4.45 (Change USE: +libkms)


quel conflitto che dice, come faccio a risolverlo?
Ho provato a mettere in package.use
Code:
media-libs/mesa-9.1.2-r1 xa
x11-libs/libdrm-2.4.45 libkms

e dopo aver ridato il comando mi fa uguale.

Ho anche provato ad installarli tutti e due con i comandi:
Code:
USE="xa" emerge mesa

Code:
USE="libkms" emerge libdrm

E li ho ridati anche dopo aver rimosso ciò che avevo messo dentro package.use

Forse non c'entra niente quello che ho provato a fare. Ma come faccio a risolvere questa cosa? (cmq finora non riscontro nessun problema ad usare gentoo, questo conflitto non mi dà problemi)
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10118
Location: Córdoba (Spain)

PostPosted: Wed Sep 18, 2013 11:14 am    Post subject: Reply with quote

Moved from Portage & Programming to Forum di discussione italiano.

Only English allowed on the main forum.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 290
Location: Italy

PostPosted: Thu Sep 19, 2013 7:29 am    Post subject: Re: Conflitto di dipendenze (PORTAGE) Reply with quote

mrfabiolo wrote:
Ho provato a mettere in package.use
Code:
media-libs/mesa-9.1.2-r1 xa
x11-libs/libdrm-2.4.45 libkms

e dopo aver ridato il comando mi fa uguale.

Probabilmente hai dimenticato di mettere il segno uguale davanti ai pacchetti (necessario quando vuoi indicare una particolare versione):
Code:
=media-libs/mesa-9.1.2-r1 xa
=x11-libs/libdrm-2.4.45 libkms
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum