Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage und webapps
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1000

PostPosted: Sat Sep 14, 2013 12:50 pm    Post subject: portage und webapps Reply with quote

Hi, ich hab beim heutigen update ein problem festgestellt: webapps (in meinem Fall phpmyadmin, owncloud und tt-rss) bleiben hängen.
ich hab mal ebuild mit der debugoption aufgerufen und festgestellt das alle drei bei "doins" hängen bleiben. Z.B. phpmyadmin (nur das ende):
Code:
+ messagetype=LOG
+ shift
+ echo -e 'The phpMyAdmin setup utility has been removed.'
+ read -r
+ echo 'LOG The phpMyAdmin setup utility has been removed.'
+ read -r
+ return 0
+ [[ yes != \y\e\s ]]
+ echo -e 'The phpMyAdmin setup utility has been removed.'
+ read -r
+ echo ' * The phpMyAdmin setup utility has been removed.'
 * The phpMyAdmin setup utility has been removed.
+ read -r
+ LAST_E_CMD=elog
+ return 0
+ elog 'It is a regular target of various exploits. If you need it, set USE=setup.'
+ __elog_base LOG 'It is a regular target of various exploits. If you need it, set USE=setup.'
+ local messagetype
+ '[' -z LOG -o -z /var/tmp/portage/dev-db/phpmyadmin-4.0.6/temp -o '!' -d /var/tmp/portage/dev-db/phpmyadmin-4.0.6/temp/logging ']'
+ case "${1}" in
+ messagetype=LOG
+ shift
+ echo -e 'It is a regular target of various exploits. If you need it, set USE=setup.'
+ read -r
+ echo 'LOG It is a regular target of various exploits. If you need it, set USE=setup.'
+ read -r
+ return 0
+ [[ yes != \y\e\s ]]
+ echo -e 'It is a regular target of various exploits. If you need it, set USE=setup.'
+ read -r
+ echo ' * It is a regular target of various exploits. If you need it, set USE=setup.'
 * It is a regular target of various exploits. If you need it, set USE=setup.
+ read -r
+ LAST_E_CMD=elog
+ return 0
+ insinto /usr/share/webapps//phpmyadmin/4.0.6/htdocs
+ '[' /usr/share/webapps//phpmyadmin/4.0.6/htdocs == / ']'
+ export INSDESTTREE=/usr/share/webapps//phpmyadmin/4.0.6/htdocs
+ INSDESTTREE=/usr/share/webapps//phpmyadmin/4.0.6/htdocs
+ ___eapi_has_prefix_variables
+ [[ ! 4 =~ ^(0|1|2)$ ]]
+ '[' '!' -d /var/tmp/portage/dev-db/phpmyadmin-4.0.6/image//usr/share/webapps//phpmyadmin/4.0.6/htdocs ']'
+ doins -r .


die doins aufrufe sehen bei jedem paket anders aus, aber bleiben halt hängen...
Ich hab auch schon portage von 2.2.4 auf 2.2.1 downgegraded (mit der hat es letzte woche noch funktioniert) aber das selbe.
Ich kenne mich jetzt mit portage nicht so gut aus, aber ich vermute mal das die meisten/alle ebuild irgendwo mal doins aufrufen, aber bis auf die drei der category www-apps funktioniert alles. das ist schon ein bisschen seltsam, vor allem weil es mit der alten version genau das gleiche ist. hat da jemand eine idee was da schief geht?


EDIT: nach der Rückkehr zu portage-2.2.4 scheint es jetzt auf einmal zu funktionieren.... :?:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum