Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blocks, slots & lvm + Systemd...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Fri Sep 13, 2013 5:18 am    Post subject: blocks, slots & lvm + Systemd... Reply with quote

Hallo zusammen,

kämpfe immer noch mit lvm2 und updates....

Anscheinend gibt es ein overlay mit gepatchtem lvm2 - siehe diesen thread. Damit sollten die Partitionen beim Boot-Vorgang wieder automatisch eingebunden werden...

Allerdings kann ich das nicht finden... Weiß da jemand mehr?

Außerdem habe ich einen Block, den ich nicht beseitigen kann:

Code:
[blocks B      ] <kde-base/kbreakout-4.10.50:4 ("<kde-base/kbreakout-4.10.50:4" is blocking kde-base/libkdegames-4.11.1)                 
* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  (kde-base/kbreakout-4.10.5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kbreakout-4.10.5:4[aqua=] (>=kde-base/kbreakout-4.10.5:4[-aqua]) required by (kde-base/kdegames-meta-4.10.5::gentoo, ebuild scheduled for merge)                                                       

  (kde-base/libkdegames-4.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kspaceduel-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/klines-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kolf-4.10.5::gentoo, installed)                                                                             
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/klickety-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.11.1:4[aqua=] (>=kde-base/libkdegames-4.11.1:4[-aqua]) required by (kde-base/ksnakeduel-4.11.1::gentoo, ebuild scheduled for merge)                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kdegames-meta-4.10.5::gentoo, ebuild scheduled for merge)                                                   
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kmahjongg-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/palapeli-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kubrick-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/killbots-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kgoldrunner-4.10.5::gentoo, installed)                                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kfourinline-4.10.5::gentoo, installed)                                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/lskat-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kapman-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kreversi-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kjumpingcube-4.10.5::gentoo, installed)                                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/katomic-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/bovo-4.10.5::gentoo, installed)                                                                             
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kblackbox-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kmines-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kpat-4.10.5::gentoo, installed)                                                                             
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kiriki-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ksudoku-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/granatier-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/konquest-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/knetwalk-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ktuberling-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kollision-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kbounce-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kajongg-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ksirk-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/bomber-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kblocks-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kdiamond-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kigo-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ksquares-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kshisen-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.11.1:4[aqua=] (>=kde-base/libkdegames-4.11.1:4[-aqua]) required by (kde-base/knavalbattle-4.11.1::gentoo, ebuild scheduled for merge)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kbreakout-4.10.5::gentoo, ebuild scheduled for merge)


Die beteiligten Pakete (kbreakout, libkdegames, kdegames-meta) habe ich einzeln entfernt und upgedatet. Das hat funktioniert. Aber das world-Update (emerge --update --newuse --deep --with-bdeps=y @world) hat den Block wieder gebracht. Woher das kommt ist mir nicht klar...

Der letzte Punkt sind die vielen Slot-Installationen, die meiner Ansicht nach unnötig sind. Die würde ich gerne beseitigen (oder wenigstens reduzieren). auch damit war ich bisher erfolglos...
Code:
0.5:4[-aqua]) required by (kde-base/kdegames-meta-4.10.5::gentoo, ebuild scheduled for merge)                                                       

  (kde-base/libkdegames-4.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kspaceduel-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/klines-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kolf-4.10.5::gentoo, installed)                                                                             
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/klickety-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.11.1:4[aqua=] (>=kde-base/libkdegames-4.11.1:4[-aqua]) required by (kde-base/ksnakeduel-4.11.1::gentoo, ebuild scheduled for merge)                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kdegames-meta-4.10.5::gentoo, ebuild scheduled for merge)                                                   
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kmahjongg-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/palapeli-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kubrick-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/killbots-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kgoldrunner-4.10.5::gentoo, installed)                                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kfourinline-4.10.5::gentoo, installed)                                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/lskat-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kapman-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kreversi-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kjumpingcube-4.10.5::gentoo, installed)                                                                     
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/katomic-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/bovo-4.10.5::gentoo, installed)                                                                             
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kblackbox-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kmines-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kpat-4.10.5::gentoo, installed)                                                                             
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kiriki-4.10.5::gentoo, installed)                                                                           
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ksudoku-4.10.5::gentoo, installed)                                                                         
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/granatier-4.10.5::gentoo, installed)                                                                       
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/konquest-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/knetwalk-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ktuberling-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kollision-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kbounce-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kajongg-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ksirk-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/bomber-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kblocks-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kdiamond-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kigo-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/ksquares-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kshisen-4.10.5::gentoo, installed)
    >=kde-base/libkdegames-4.11.1:4[aqua=] (>=kde-base/libkdegames-4.11.1:4[-aqua]) required by (kde-base/knavalbattle-4.11.1::gentoo, ebuild scheduled for merge)
    >=kde-base/libkdegames-4.10.5:4[aqua=] (>=kde-base/libkdegames-4.10.5:4[-aqua]) required by (kde-base/kbreakout-4.10.5::gentoo, ebuild scheduled for merge)


Die beteiligten Pakete (kbreakout, libkdegames, kdegames-meta) habe ich einzeln entfernt und upgedatet. Das hat funktioniert. Aber das world-Update (emerge --update --newuse --deep --with-bdeps=y @world) hat den Block wieder gebracht. Woher das kommt ist mir nicht klar...

Der letzte Punkt sind die vielen Slot-Installationen, die meiner Ansicht nach unnötig sind. Die würde ich gerne beseitigen (oder wenigstens reduzieren). auch damit war ich bisher erfolglos...[/code]

Jede Hilfe ist herzlich willkommen...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Fri Sep 13, 2013 2:16 pm    Post subject: Reply with quote

uhai wrote:
Code:
[blocks B      ] <kde-base/kbreakout-4.10.50:4 ("<kde-base/kbreakout-4.10.50:4" is blocking kde-base/libkdegames-4.11.1)                 
* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  (kde-base/kbreakout-4.10.5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kbreakout-4.10.5:4[aqua=] (>=kde-base/kbreakout-4.10.5:4[-aqua]) required by (kde-base/kdegames-meta-4.10.5::gentoo, ebuild scheduled for merge)

Wahrscheinlich hast du nicht alle für kde-4.11 erforderlichen Pakete in den keywords freigeschaltet. (4.10 und 4.11 kannst du nicht mischen)
Nutze am besten (wie schon mal empfohlen) das im http://wiki.gentoo.org/wiki/KDE verlinkte keywords fille

/edit
Achso, da kommt auch noch die Frage auf welche KDE Version du eigentlich letztendlich installieren möchtest - die stabile 4.10.5 oder die experimentelle 4.11.1 aus dem testing-zweig?
............................................................................................................
Eine mit systemd kompatible lvm2 Version sollte inzwischen im portage Tree verfügbar sein (ungetestet)

uhai, ich denke es ist besser und übersichtlicher zwei solche Themen nicht in einem Thread zu mischen - mache dafür in Zukunft doch besser zwei Threads auf, sprich ein Thema pro Thread :)
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Fri Sep 13, 2013 9:37 pm    Post subject: Reply with quote

ok, das keywordfile hat den Block beseitigt. daran habe ich gar nicht mehr gedacht...

Was bleibt sind die Slots:

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

kde-base/kdelibs:4

  (kde-base/kdelibs-4.10.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    <kde-base/kdelibs-4.11.0 required by (media-sound/amarok-2.7.1-r1::gentoo, ebuild scheduled for merge)

  (kde-base/kdelibs-4.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdelibs-4.11.1:4[aqua=,handbook] required by (kde-base/kabcclient-4.11.1::gentoo, ebuild scheduled for merge)                                                                                         
    (and 359 more with the same problem)                                                                   

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, ebuild scheduled for merge)                                                                                                     

  (dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, ebuild scheduled for merge)

dev-libs/soprano:0

  (dev-libs/soprano-2.9.3::gentoo, installed) pulled in by
    >=dev-libs/soprano-2.9.3[dbus,raptor,redland,virtuoso] required by (kde-base/nepomuk-core-4.11.1::gentoo, ebuild scheduled for merge)                                                                             

  (dev-libs/soprano-2.9.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)     

app-text/texlive-core:0

  (app-text/texlive-core-2012-r1::gentoo, installed) pulled in by
    >=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-context-2012-r1::gentoo, ebuild scheduled for merge)                                                                                         

  (app-text/texlive-core-2012-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)             

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libpng:0/0= required by (media-plugins/kipi-plugins-3.2.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/openjpeg-1.5.1::gentoo, installed)       
    >=media-libs/libpng-1.5:0/0= required by (dev-java/icedtea-bin-6.1.12.6::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/rawstudio-2.0-r1::gentoo, installed)         
    media-libs/libpng:0/0= required by (media-libs/vigra-1.8.0::gentoo, installed)             
    (and 1 more with the same problems)                                                       

  (media-libs/libpng-1.6.3-r1::gentoo, installed) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge)

dev-util/mdds:0

  (dev-util/mdds-0.7.1::gentoo, installed) pulled in by
    <dev-util/mdds-0.8.0 required by (app-office/libreoffice-4.0.4.2::gentoo, installed)

  (dev-util/mdds-0.8.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/jpeg:0

  (virtual/jpeg-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/jpeg:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/tiff-4.0.3-r5::gentoo, ebuild scheduled for merge)
    virtual/jpeg:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/lcms-2.5-r1::gentoo, ebuild scheduled for merge)

  (virtual/jpeg-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Fri Sep 13, 2013 11:57 pm    Post subject: Reply with quote

uhai wrote:
Code:
kde-base/kdelibs:4

  (kde-base/kdelibs-4.10.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    <kde-base/kdelibs-4.11.0 required by (media-sound/amarok-2.7.1-r1::gentoo, ebuild scheduled for merge)

  (kde-base/kdelibs-4.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdelibs-4.11.1:4[aqua=,handbook] required by (kde-base/kabcclient-4.11.1::gentoo, ebuild scheduled for merge)                                                                                         
    (and 359 more with the same problem)
amarok-2.7 ist mit kde-4.11 nicht mehr kompatibel
Für kde-4.11 wird >=amarok-2.8 benötigt.
Schalte den mal frei, damit sollten sich dann wahrscheinlich schon ne menge Abhängigkeitskonflikte lösen.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sun Sep 15, 2013 1:53 pm    Post subject: Reply with quote

amarok-2.8 habe ich freigeschaltet, das sind die Konflikte, die bleiben:

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, ebuild scheduled for merge)                                                                                                     

  (dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, ebuild scheduled for merge)

dev-libs/soprano:0

  (dev-libs/soprano-2.9.3::gentoo, installed) pulled in by
    >=dev-libs/soprano-2.9.3[dbus,raptor,redland,virtuoso] required by (kde-base/nepomuk-core-4.11.1::gentoo, ebuild scheduled for merge)                                                                             

  (dev-libs/soprano-2.9.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)     

app-text/texlive-core:0

  (app-text/texlive-core-2012-r1::gentoo, installed) pulled in by
    >=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-context-2012-r1::gentoo, ebuild scheduled for merge)                                                                                         

  (app-text/texlive-core-2012-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)             

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libpng:0/0= required by (media-plugins/kipi-plugins-3.2.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/openjpeg-1.5.1::gentoo, installed)       
    >=media-libs/libpng-1.5:0/0= required by (dev-java/icedtea-bin-6.1.12.6::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/rawstudio-2.0-r1::gentoo, installed)         
    media-libs/libpng:0/0= required by (media-libs/vigra-1.8.0::gentoo, installed)             
    (and 1 more with the same problems)                                                       

  (media-libs/libpng-1.6.3-r1::gentoo, installed) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.10::gentoo, ebuild scheduled for merge)

dev-util/mdds:0

  (dev-util/mdds-0.7.1::gentoo, installed) pulled in by
    <dev-util/mdds-0.8.0 required by (app-office/libreoffice-4.0.4.2::gentoo, installed)

  (dev-util/mdds-0.8.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/jpeg:0

  (virtual/jpeg-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/jpeg:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/tiff-4.0.3-r5::gentoo, ebuild scheduled for merge)
    virtual/jpeg:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/lcms-2.5-r1::gentoo, ebuild scheduled for merge)

  (virtual/jpeg-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3919
Location: Irgendwo im Nirgendwo

PostPosted: Sun Sep 15, 2013 3:18 pm    Post subject: Reply with quote

Setz noch dev-libs/gobject-introspection auf deine Liste und schau weiter.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sun Sep 15, 2013 3:32 pm    Post subject: Reply with quote

bei den keywords habe ich das schon drin. Das sche4int nichts zu bringen... Sollte ich die kleinere Version noch maskieren?

uhai

Das ist mir gar nicht verständlich:

Code:
  (app-text/texlive-core-2012-r1::gentoo, installed) pulled in by
    >=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-context-2012-r1::gentoo, ebuild scheduled for merge)                                                                                         

  (app-text/texlive-core-2012-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)             


Was will mir portage damit sagen? Das ist doch installiert... und da wird doch nur eine Version texlive-core erwähnt: 2012-r1?
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Sun Sep 15, 2013 9:43 pm    Post subject: Reply with quote

uhai wrote:
bei den keywords habe ich das schon drin. Das sche4int nichts zu bringen... Sollte ich die kleinere Version noch maskieren?

uhai
Hm, magst du dazu bitte mal die Ausgabe von
Code:
emerge -pv dev-libs/glib gobject-introspection gdk-pixbuf
posten?

Quote:
Das ist mir gar nicht verständlich:

Code:
  (app-text/texlive-core-2012-r1::gentoo, installed) pulled in by
    >=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-context-2012-r1::gentoo, ebuild scheduled for merge)                                                                                         

  (app-text/texlive-core-2012-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)             


Was will mir portage damit sagen? Das ist doch installiert... und da wird doch nur eine Version texlive-core erwähnt: 2012-r1?
Beachte beim
>=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-context-2012-r1
das geforderte "xetex" Use-Flag. Ist dein schon installiertes =app-text/texlive-core-2012-r1 mit "xetex" Use-Flag gebaut, bzw würde es damit gebaut werden?
Schau dazu zb in der Ausgabe von "emerge -pv app-text/texlive-core"
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Sep 16, 2013 5:28 am    Post subject: Reply with quote

Danke für deine Hilfe, Josef.95

Das gobject-introspection-Problem habe ich inzwischen gelöst bekommen. Momentan sehen die Slot-Geschichten hier so aus:

Code:
# required by sys-fs/lvm2-2.02.100-r2[thin]
# required by @selected
# required by @world (argument)
=sys-block/thin-provisioning-tools-0.2.1 ~amd64


Bei libpng scheitere ich beim emerge @preserved-rebuild an kdelibs-4.11....

Die keyword changes habe ich ergänzt, ebenso wie das USE=xetex.

So sieht es jetzt aus:

Code:
>>> Verifying ebuild manifests
>>> Running pre-merge checks for media-libs/libraw-0.15.4                               
>>> Running pre-merge checks for media-video/mjpegtools-2.0.0-r3                                           
 * Current versions of mjpegtools only support V4L1 which is not available                                 
 * for kernel versions 2.6.38 and above. V4L1 will be disabled.                                           
>>> Running pre-merge checks for net-fs/samba-3.6.16                                                       
>>> Running pre-merge checks for sys-apps/systemd-204
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.9.11-gentoo-r1y
 * Checking for suitable kernel configuration options...                                            [ ok ]
>>> Running pre-merge checks for net-libs/webkit-gtk-1.8.3-r201
 * Checking for sufficient disk space to build webkit-gtk with debugging CFLAGS
 * Checking for at least 18 gigabytes disk space at "/media/Backup/portage/net-libs/webkit-gtk-1.8.3-r201/temp" ...                                                                                            [ ok ]
>>> Running pre-merge checks for kde-base/kdelibs-4.11.1
>>> Running pre-merge checks for sys-block/thin-provisioning-tools-0.2.1
 * ERROR: sys-block/thin-provisioning-tools-0.2.1::gentoo failed (pretend phase):
 *   Need gcc 4.7 or later to build, current version is 4.6.3
 *
 * Call stack:
 *                              ebuild.sh, line  93:  Called pkg_pretend
 *   thin-provisioning-tools-0.2.1.ebuild, line  26:  Called die
 * The specific snippet of code:
 *      die "Need gcc 4.7 or later to build, current version is `gcc-fullversion`"
 *
 * If you need support, post the output of `emerge --info '=sys-block/thin-provisioning-tools-0.2.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-block/thin-provisioning-tools-0.2.1::gentoo'`.
 * The complete build log is located at '/media/Backup/portage/sys-block/thin-provisioning-tools-0.2.1/temp/build.log'.
 * The ebuild environment file is located at '/media/Backup/portage/sys-block/thin-provisioning-tools-0.2.1/temp/die.env'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/media/Backup/portage/sys-block/thin-provisioning-tools-0.2.1/work/thin-provisioning-tools-0.2.1'
>>> Running pre-merge checks for net-libs/webkit-gtk-1.8.3-r300
 * Checking for sufficient disk space to build webkit-gtk with debugging CFLAGS
 * Checking for at least 18 gigabytes disk space at "/media/Backup/portage/net-libs/webkit-gtk-1.8.3-r300/temp" ...             


Das sagt eix gcc:

Code:
[I] sys-devel/gcc
     Available versions:                   
      (2.95)    ~*2.95.3-r10^s                                 
      (3.1)     *3.1.1-r2                                                     
      (3.2)     **3.2.2^s *3.2.3-r4                                                                   
      (3.3)     ~3.3.6-r1^s                                                                               
      (3.4)     3.4.6-r2^s                                                                                 
      (4.0)     ~*4.0.4^s                                                                                 
      (4.1)     4.1.2^s                                                                                   
      (4.2)     ~4.2.4-r1^s                                                                               
      (4.3)     ~4.3.3-r2^s 4.3.4^s ~4.3.5^s 4.3.6-r1^s                                                   
      (4.4)     ~4.4.2^s ~4.4.3-r3^s 4.4.4-r2^s 4.4.5^s 4.4.6-r1^s 4.4.7^s                                 
      (4.5)     ~4.5.1-r1^s ~4.5.2^s 4.5.3-r2^s 4.5.4^s                                                   
      (4.6)     ~4.6.0^s ~4.6.1-r1^s ~4.6.2^s 4.6.3^s ~4.6.4^s                                             
      (4.7)     ~4.7.0^s ~4.7.1^s ~4.7.2-r1^s ~4.7.3^s                                                     
      (4.8)     [M]**4.8.0^s [M]**4.8.1^s                                                                 
      {{altivec bootstrap boundschecking build cxx d doc fixed-point fortran gcj go graphite gtk hardened ip28 ip32r10k java libssp lto mudflap multilib multislot n32 n64 nls nopie nossp nptl objc objc++ objc-gc openmp regression-test static vanilla}}                                                                     
     Installed versions:  4.6.3(4.6)^s(05:51:44 01.08.2013)(cxx fortran mudflap multilib nls nptl openmp -altivec -doc -fixed-point -gcj -graphite -gtk -hardened -libssp -lto -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla)                                                                       
     Homepage:            http://gcc.gnu.org/                                                             
     Description:         The GNU Compiler Collection


Ist es ratsam, gcc-4.7 freizuschalten?

Ich habe Probleme, ,die Infos in der portage-Ausgabe alle richtig zu deuten. Gibt es da (außer der man-page) eine Hilfe? Am liebsten mit Screenshots, so dass ich auch die Farben richtig deuten lerne...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Mon Sep 16, 2013 5:54 pm    Post subject: Reply with quote

Hehe, prima :)

Ja, =sys-devel/gcc-4.7.3 kann man normal schon durchweg gut nutzen, es gibt zZt nur noch sehr wenige offene Bugs
Ein Vorschlag:
Nimm die zZt stabile gcc:4.6 Version mit in world auf, somit wird verhindert das sie beim --depclean mit entfernt wird:
Code:
emerge -av --noreplace gcc:4.6

Und schalte dir dann zusätzlich ~sys-devel/gcc-4.7.3 mit frei, merge ihn, stell mit gcc-config auf den neuen um, und merge thin-provisioning-tools

Sorry, eine Dokumentation zu den Farben der emerge Ausgabe ist mir zZt nicht bekannt.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Sep 16, 2013 7:39 pm    Post subject: Reply with quote

ok, emerge läuft jetzt (407 Pakete)...

Melde mich morgen wieder :D Herzlichen Dank Josef.95

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Sep 17, 2013 3:37 am    Post subject: Reply with quote

Abbruch bei kdelibs-4.11.1:

Code:
cd /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kdecore && /usr/bin/cmake -E cmake_symlink_library ../lib/libkdecore.so.5.11.1 ../lib/libkdecore.so.5 ../lib/libkdecore.so
make[2]: Leaving directory `/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build'
/usr/bin/cmake -E cmake_progress_report /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/CMakeFiles  11 12 13 14 15 16 17
[ 28%] Built target kdecore
make[1]: Leaving directory `/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build'
make: *** [all] Error 2
 * ERROR: kde-base/kdelibs-4.11.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=kde-base/kdelibs-4.11.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-base/kdelibs-4.11.1::gentoo'`.
 * The complete build log is located at '/media/Backup/portage/kde-base/kdelibs-4.11.1/temp/build.log'.
 * The ebuild environment file is located at '/media/Backup/portage/kde-base/kdelibs-4.11.1/temp/environment'.
 * Working directory: '/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build'
 * S: '/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1'

>>> Failed to emerge kde-base/kdelibs-4.11.1, Log file:

>>>  '/media/Backup/portage/kde-base/kdelibs-4.11.1/temp/build.log'

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4114

PostPosted: Tue Sep 17, 2013 5:54 am    Post subject: Reply with quote

wo ist die fehlermeldung?
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Sep 17, 2013 7:42 pm    Post subject: Reply with quote

Error2 ist dürftig...

Mit grep finde ich noch das:

Code:
grep E rror /media/Backup/portage/kde-base/kdelibs-4.11.1/temp/build.log
automoc4: empty source file: /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/khtml/JSMediaError.cpp
make[2]: *** [lib/libsolid.so.4.11.1] Error 1
make[1]: *** [solid/solid/CMakeFiles/solid.dir/all] Error 2
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/network/k3resolverstandardworkers.cpp: In member function âKNetwork::KResolver::ErrorCodes KNetwork::Internal::KStandardWorker::addUnix()â:
make: *** [all] Error 2


Das komplette build.log würde ich ja gerne hochladen, aber mein pastebin verweigert die Arbeit (Bad API request, invalid api-option).

uhai

Code:
[D] kde-base/solid
     Available versions:  (4) 4.10.4 ~4.10.5
       {aqua bluetooth debug networkmanager wicd}
     Installed versions:  4.10.5(4)(16:36:10 10.08.2013)(-aqua -bluetooth -debug -networkmanager -wicd)
     Homepage:            http://www.kde.org/
     Description:         Solid: the KDE hardware library

[I] kde-base/solid-runtime
     Available versions:  (4) 4.10.4 (~)4.10.5
       {aqua debug}
     Installed versions:  4.10.5(4)(23:22:28 02.07.2013)(-aqua -debug)
     Homepage:            http://www.kde.org/
     Description:         KDE SC solid runtime modules (autoeject, automounter and others)


Keine 4.11????
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Wed Sep 18, 2013 7:03 am    Post subject: Reply with quote

Hm, an solid wird es vermutlich eher nicht liegen. Poste doch mal die letzten ~100 Zeilen von vorm "Error 1" Interessant ist wie es zum "Error 1" kommt, sprich warum, und wie er überhaupt entsteht.

kde-base/solid gibt es in 4.11 so nicht mehr, stattdessen kommt kde-base/solid-actions-kcm
Aber kde-base/solid-runtime-4.11.1 sollte es geben. Wurde nach dem letzten --sync eventuelle ein eix-update vergessen? Was sagt "ls -l /usr/portage/kde-base/solid-runtime/" dazu?
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Sep 18, 2013 6:06 pm    Post subject: Reply with quote

Code:
s -l /usr/portage/kde-base/solid-runtime/
insgesamt 36
-rw-r--r-- 1 root root 17212 15. Sep 16:31 ChangeLog
-rw-r--r-- 1 root root  2820 15. Sep 16:31 Manifest
-rw-r--r-- 1 root root   156  9. Feb 2010  metadata.xml
-rw-r--r-- 1 root root   656  2. Aug 16:31 solid-runtime-4.10.5.ebuild
-rw-r--r-- 1 root root   750 15. Sep 16:31 solid-runtime-4.11.1.ebuild


Richtig, eix -update hat auch ein Problem:

Code:
Datenbankfile '/var/cache/eix/portage.eix' nicht beschreibbar (mode = 'wb')

ls -ali /var/cache/eix/portage.eix
2121 -rw-r--r-- 1 root root 6523363  4. Aug 09:54 /var/cache/eix/portage.eix


So ein Live-chroot-System hat seine Tücken.... wie sollten die Rechte denn da aussehen? Nach dem Chroot bin ich ja als root unterwegs, eventuell mit einer anderen id?

Die bestellten 100 Zeilen:

Code:
(chroot) livecd / # grep -B 100 "Error 1" /media/Backup/portage/kde-base/kdelibs-4.11.1/temp/build.log                                             
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/FastMalloc.h:56:1: warning: "WTF_USE_MULTIPLE_THREADS" is not defined [-Wundef]                                                               
cd /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/solid/solid && /usr/bin/x86_64-pc-linux-gnu-g++  -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=50 -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -DWITH_SOLID_UDISKS2  -DQT_NO_DEBUG -DNDEBUG -march=native -O2 -pipe -ggdb  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/solid/solid -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1 -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/interfaces -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/solid -I/usr/include/qca2/QtCrypto -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtDBus    -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o CMakeFiles/solid_static.dir/backends/fstab/fstabstorageaccess.o -c /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/fstab/fstabstorageaccess.cpp                                                                                                                                                                                           
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/ustring.h:33:0,                                                                                                             
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/value.h:28,                                                                                                                 
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:29:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/Vector.h:723:1: warning: "WTF_COMPILER_MSVC7" is not defined [-Wundef]                                                                         
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTraits.h:26:0,                                                                                                       
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTable.h:26,                                                                                                         
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashMap.h:25,                                                                                                           
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashCountedSet.h:27,                                                                                                     
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/collector.h:28,                                                                                                             
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/ustring.h:36,                                                                                                               
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/value.h:28,                                                                                                                 
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:29:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashFunctions.h:110:1: warning: "WTF_COMPILER_MSVC" is not defined [-Wundef]                                                                   
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashFunctions.h:115:1: warning: "WTF_COMPILER_MSVC" is not defined [-Wundef]                                                                   
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTraits.h:26:0,                                                                                                       
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTable.h:26,                                                                                                         
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashMap.h:25,                                                                                                           
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashCountedSet.h:27,                                                                                                     
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/collector.h:28,                                                                                                             
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/ustring.h:36,                                                                                                               
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/value.h:28,                                                                                                                 
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:29:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashFunctions.h:159:1: warning: "WTF_COMPILER_MSVC" is not defined [-Wundef]                                                                   
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTable.h:26:0,                                                                                                       
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashMap.h:25,                                                                                                           
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashCountedSet.h:27,                                                                                                     
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/collector.h:28,                                                                                                             
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/ustring.h:36,                                                                                                               
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/value.h:28,                                                                                                                 
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:29:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTraits.h:49:1: warning: "WTF_COMPILER_MSVC" is not defined [-Wundef]                                                                       
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/wtf/HashTraits.h:66:1: warning: "WTF_COMPILER_MSVC" is not defined [-Wundef]                                                                       
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/value.h:28:0,                                                                                                               
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:29:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/ustring.h:43:1: warning: "WTF_PLATFORM_FORCE_PACK" is not defined [-Wundef]                                                                       
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/protect.h:29:0,                                                                                                             
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/interpreter.h:28,                                                                                                           
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/object.h:30,                                                                                                                 
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:30:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/JSLock.h:76:1: warning: "WTF_USE_MULTIPLE_THREADS" is not defined [-Wundef]                                                                       
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/object.h:30:0,                                                                                                               
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:30:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/interpreter.h:42:1: warning: "WTF_USE_BINDINGS" is not defined [-Wundef]                                                                           
In file included from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/object.h:30:0,                                                                                                               
                 from /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization/ktranscript.cpp:30:                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs/interpreter.h:332:1: warning: "WTF_USE_BINDINGS" is not defined [-Wundef]                                                                         
Linking CXX executable ../bin/kjs                                                                                                                                                                                       
cd /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kjs && /usr/bin/cmake -E cmake_link_script CMakeFiles/kjs_bin.dir/link.txt --verbose=1                                                       
/usr/bin/x86_64-pc-linux-gnu-g++   -march=native -O2 -pipe -ggdb  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden  -Wl,--enable-new-dtags  -Wl,-O1 -Wl,--as-needed CMakeFiles/kjs_bin.dir/kjs_bin_automoc.o CMakeFiles/kjs_bin.dir/kjs.o  -o ../bin/kjs -rdynamic ../lib/libkjs.so.4.11.1 -Wl,-rpath,/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/lib:                                                           
/usr/bin/cmake -E cmake_progress_report /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/CMakeFiles                                                                                               
[ 21%] Building CXX object kdecore/CMakeFiles/kdecore.dir/services/kservicegroup.o                                                                                                                                       
cd /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kdecore && /usr/bin/x86_64-pc-linux-gnu-g++  -DMAKE_KDECORE_LIB -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=50 -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -DQT_NO_CAST_FROM_ASCII  -DQT_NO_DEBUG -DNDEBUG -march=native -O2 -pipe -ggdb  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kdecore -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1 -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/interfaces -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kdecore/network -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kdecore/date -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kdecore/compression -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/auth -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kjs -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1_build/kjs -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/compression -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/config -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/date -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/io -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/jobs -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/kernel -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/network -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/services -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/localization -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/sycoca -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/text -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/util -I/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/sonnet -I/usr/include/qca2/QtCrypto -I/usr/include/polkit-qt-1 -I/usr/include/qt4/QtXmlPatterns -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtWebKit -I/usr/include/qt4/QtUiTools -I/usr/include/qt4/QtTest -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtScriptTools -I/usr/include/qt4/QtScript -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtMultimedia -I/usr/include/qt4/QtHelp -I/usr/include/qt4/QtDesigner -I/usr/include/qt4/QtDeclarative -I/usr/include/qt4/QtDBus -I/usr/include/qt4/Qt3Support -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtCore -I/usr/include/qt4/Qt -I/usr/share/qt4/mkspecs/default -I/usr/include/qt4    -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o CMakeFiles/kdecore.dir/services/kservicegroup.o -c /media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/kdecore/services/kservicegroup.cpp                                                                                                                                                               
CMakeFiles/solid.dir/backends/udisks2/udisksopticaldisc.o: In function `Solid::Backends::UDisks2::OpticalDisc::~OpticalDisc()':                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:344: undefined reference to `UdevQt::Device::~Device()'                                             
CMakeFiles/solid.dir/backends/udisks2/udisksopticaldisc.o: In function `Solid::Backends::UDisks2::OpticalDisc::~OpticalDisc()':                                                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:344: undefined reference to `UdevQt::Device::~Device()'                                             
CMakeFiles/solid.dir/backends/udisks2/udisksopticaldisc.o: In function `Solid::Backends::UDisks2::OpticalDisc::isAppendable() const':                                                                                   
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:371: undefined reference to `UdevQt::Device::deviceProperty(QString const&) const'                 
CMakeFiles/solid.dir/backends/udisks2/udisksopticaldisc.o: In function `Solid::Backends::UDisks2::OpticalDisc::OpticalDisc(Solid::Backends::UDisks2::Device*)':                                                         
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:334: undefined reference to `UdevQt::Device::Device()'                                             
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:336: undefined reference to `UdevQt::Client::Client(QObject*)'                                     
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:337: undefined reference to `UdevQt::Client::deviceByDeviceFile(QString const&)'                   
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:337: undefined reference to `UdevQt::Device::operator=(UdevQt::Device const&)'                     
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:337: undefined reference to `UdevQt::Device::~Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:339: undefined reference to `UdevQt::Device::deviceProperties() const'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:341: undefined reference to `UdevQt::Client::~Client()'
CMakeFiles/solid.dir/backends/udisks2/udisksopticaldisc.o: In function `Solid::Backends::UDisks2::OpticalDisc::OpticalDisc(Solid::Backends::UDisks2::Device*)':
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:334: undefined reference to `UdevQt::Device::Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:336: undefined reference to `UdevQt::Client::Client(QObject*)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:337: undefined reference to `UdevQt::Client::deviceByDeviceFile(QString const&)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:337: undefined reference to `UdevQt::Device::operator=(UdevQt::Device const&)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:337: undefined reference to `UdevQt::Device::~Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:339: undefined reference to `UdevQt::Device::deviceProperties() const'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksopticaldisc.cpp:341: undefined reference to `UdevQt::Client::~Client()'
CMakeFiles/solid.dir/backends/udisks2/udisksstoragedrive.o: In function `Solid::Backends::UDisks2::StorageDrive::~StorageDrive()':
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:39: undefined reference to `UdevQt::Device::~Device()'
CMakeFiles/solid.dir/backends/udisks2/udisksstoragedrive.o: In function `Solid::Backends::UDisks2::StorageDrive::~StorageDrive()':
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:39: undefined reference to `UdevQt::Device::~Device()'
CMakeFiles/solid.dir/backends/udisks2/udisksstoragedrive.o: In function `Solid::Backends::UDisks2::StorageDrive::bus() const':
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:112: undefined reference to `UdevQt::Device::deviceProperty(QString const&) const'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:118: undefined reference to `UdevQt::Device::deviceProperty(QString const&) const'
CMakeFiles/solid.dir/backends/udisks2/udisksstoragedrive.o: In function `Solid::Backends::UDisks2::StorageDrive::StorageDrive(Solid::Backends::UDisks2::Device*)':
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:32: undefined reference to `UdevQt::Device::Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:34: undefined reference to `UdevQt::Client::Client(QObject*)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:35: undefined reference to `UdevQt::Client::deviceByDeviceFile(QString const&)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:35: undefined reference to `UdevQt::Device::operator=(UdevQt::Device const&)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:35: undefined reference to `UdevQt::Device::~Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:36: undefined reference to `UdevQt::Device::deviceProperties() const'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:36: undefined reference to `UdevQt::Client::~Client()'
CMakeFiles/solid.dir/backends/udisks2/udisksstoragedrive.o: In function `Solid::Backends::UDisks2::StorageDrive::StorageDrive(Solid::Backends::UDisks2::Device*)':
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:32: undefined reference to `UdevQt::Device::Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:34: undefined reference to `UdevQt::Client::Client(QObject*)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:35: undefined reference to `UdevQt::Client::deviceByDeviceFile(QString const&)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:35: undefined reference to `UdevQt::Device::operator=(UdevQt::Device const&)'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:35: undefined reference to `UdevQt::Device::~Device()'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:36: undefined reference to `UdevQt::Device::deviceProperties() const'
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:36: undefined reference to `UdevQt::Client::~Client()'
collect2: error: ld returned 1 exit status
make[2]: *** [lib/libsolid.so.4.11.1] Error 1

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Thu Sep 19, 2013 3:12 pm    Post subject: Reply with quote

uhai wrote:
Code:
s -l /usr/portage/kde-base/solid-runtime/
insgesamt 36
-rw-r--r-- 1 root root 17212 15. Sep 16:31 ChangeLog
-rw-r--r-- 1 root root  2820 15. Sep 16:31 Manifest
-rw-r--r-- 1 root root   156  9. Feb 2010  metadata.xml
-rw-r--r-- 1 root root   656  2. Aug 16:31 solid-runtime-4.10.5.ebuild
-rw-r--r-- 1 root root   750 15. Sep 16:31 solid-runtime-4.11.1.ebuild


Richtig, eix -update hat auch ein Problem:

Code:
Datenbankfile '/var/cache/eix/portage.eix' nicht beschreibbar (mode = 'wb')

ls -ali /var/cache/eix/portage.eix
2121 -rw-r--r-- 1 root root 6523363  4. Aug 09:54 /var/cache/eix/portage.eix


So ein Live-chroot-System hat seine Tücken.... wie sollten die Rechte denn da aussehen? Nach dem Chroot bin ich ja als root unterwegs, eventuell mit einer anderen id?

Hm ja, ungewöhnlich. Eigentümer und Gruppe sollten eher auf portage:portage gesetzt sein.
Am chroot sollte es vermutlich nicht liegen. Hast du das System mal umkopiert, oder aus einem Backup wiederhergestellt? wenn ja, sind dabei eventuell Rechte nicht passend mit kopiert worden?
Handelt es sich um dieses System mit lvm systemd und separaten /usr ? Wenn ja, kann das System schon wieder normal gebootet werden?

Quote:
Die bestellten 100 Zeilen:

Code:
(chroot) livecd / # grep -B 100 "Error 1" /media/Backup/portage/kde-base/kdelibs-4.11.1/temp/build.log                                             
[....]
/media/Backup/portage/kde-base/kdelibs-4.11.1/work/kdelibs-4.11.1/solid/solid/backends/udisks2/udisksstoragedrive.cpp:36: undefined reference to `UdevQt::Client::~Client()'
collect2: error: ld returned 1 exit status
make[2]: *** [lib/libsolid.so.4.11.1] Error 1
Ist auch recht ungewöhnlich. Schau mal ob ein rebuild von udisks:2 hilft.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Thu Sep 19, 2013 3:18 pm    Post subject: Reply with quote

richtig, ein Backup , dessen Wiederherstellung nicht ganz glatt lief...

die meisten libs sind auch keine Symlinks mehr...

System bootet, lvm2 lädt aber die partitionen nicht von allein, daher bin ich momentan im chroot unterwegs. Manuell kann ich die lvm2-partitionen laden, X läuft aber nicht.

/usr ist keine lvm-Partition, lediglich /usr/portage und /usr/non-portage.

Rest probiere ich heute abend aus, wenn ich wieder daheim bin...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Sun Sep 22, 2013 6:57 pm    Post subject: Reply with quote

Hallo uhai

Ich denke mit diesen Thread, und auch zusammenfassend mit diesem Thread (der vermutlich auch noch nicht wirklich gelöst ist) solltest du mal über eine Neuinstallation nachdenken. Wahrscheinlich wird dieses System nur noch (wenn überhaupt) mit sehr viel Aufwand zu retten sein.
Langfristig gesehen wird eine frische solide Neuinstallation wahrscheinlich die bessere alternative sein.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sun Sep 22, 2013 8:00 pm    Post subject: Reply with quote

Vermutlich hast Du recht...

Ich würde gerne meine Programme alle wieder haben, kann ich einfach mein world-file über die Neuinstallation kopieren?

Kann ich die package.use und package.keywords behalten?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2278
Location: Germany

PostPosted: Mon Sep 23, 2013 11:45 am    Post subject: Reply with quote

Ja, die world fille (/var/lib/portage/world) und auch die package.use / package.keywords solltest du normal wiederverwenden können. (package.keywords am besten gleich mal nach package.accept_keywords migrieren)
Sichere dir am besten das komplette /etc (aber kopiere es nicht blind ohne nachzuprüfen komplett ins neue System, sondern pflücke dir nur die wirklich benötigten configs raus, möglichst ohne Altlasten mit zu übernehmen :))
und auch die Kernel.config

Und sofern nicht zwingend erforderlich verzichte am besten auf separates /usr
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Oct 05, 2013 6:13 pm    Post subject: Reply with quote

Wo sind meine user gespeichert? Ich möchte nicht pauschal alle /etc/* wiederherstellen. Aber miene user hätte ich schon gerne zurück...

Kann mir da bitte jemand mit dem Zaunpfahl winken?

uhai

Das habe ich gefunden:

/etc/passwd
/etc/groups
/etc/shadow

Reicht das? Meine Nutzer kann ich darin nämlich nicht finden...??
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Sat Oct 05, 2013 7:58 pm    Post subject: Reply with quote

das sind genau die richtigen dateien, wie meinst du, du kannst deine user nicht finden?
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Oct 05, 2013 8:02 pm    Post subject: Reply with quote

cat /backup/etc/passwd enthält die usernamen miener menschlichen Benutzer nicht?? Also z.B. uhai taucht da nicht auf...

Code:

root:x:0:0:root:/root:/bin/bash
bin:x:1:1:bin:/bin:/bin/false
daemon:x:2:2:daemon:/sbin:/bin/false
adm:x:3:4:adm:/var/adm:/bin/false
lp:x:4:7:lp:/var/spool/lpd:/bin/false
sync:x:5:0:sync:/sbin:/bin/sync
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
halt:x:7:0:halt:/sbin:/sbin/halt
news:x:9:13:news:/var/spool/news:/bin/false
uucp:x:10:14:uucp:/var/spool/uucp:/bin/false
operator:x:11:0:operator:/root:/bin/bash
portage:x:250:250:portage:/var/tmp/portage:/bin/false
nobody:x:65534:65534:nobody:/var/empty:/bin/false
man:x:13:15:added by portage for man:/usr/share/man:/sbin/nologin
sshd:x:22:22:added by portage for openssh:/var/empty:/sbin/nologin
dhcp:x:101:248:added by portage for dhcp:/var/lib/dhcp:/sbin/nologin
games:x:36:35:added by portage for foobillard:/usr/games:/bin/bash
ldap:x:439:439:added by portage for openldap:/usr/lib64/openldap:/sbin/nologin
apache:x:81:81:added by portage for apache:/var/www:/sbin/nologin
timidity:x:102:18:added by portage for timidity++:/var/lib/timidity:/sbin/nologin
gpsd:x:103:14:added by portage for gpsd:/dev/null:/sbin/nologin
polkitd:x:104:247:added by portage for polkit:/var/lib/polkit-1:/sbin/nologin
pulse:x:105:245:added by portage for pulseaudio:/var/run/pulse:/sbin/nologin
messagebus:x:106:244:added by portage for dbus:/dev/null:/sbin/nologin

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Sat Oct 05, 2013 8:24 pm    Post subject: Reply with quote

verwendest du sowas wie ldap oder einen anderen verzeichnisdienst?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum