Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error iniciando Servidor X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Pipeng
n00b
n00b


Joined: 23 Jul 2013
Posts: 8

PostPosted: Thu Sep 12, 2013 8:18 pm    Post subject: Error iniciando Servidor X Reply with quote

Hola, hace poco me inicie en gentoo y estoy tratando de instalar e iniciar el servidor x, pero aun no lo logro, me aparecen errores al ejecutar "startx", por si acaso, e seguido paso a paso la instalación de gentoo 64, ya tengo instalado acpid, y también tengo añadido en el arranque acpi=force, mi usuario ya pertenece al grupo "video", como nota, mi computador usa 2 gpus, una intel como predeterminada que al parecer es la que manda errores y otra intel, con la configuración que puse debería ser suficiente, pero sigo con errores :( también instale gnome, utilizo un xorg.conf generado por el mismo xorg, sin el archivo aparecen una tonelada de errores, y debería añadir mas soporte para mas tarjetas, cosa que no se porque, así que les pido ayuda.

Make.conf

Code:
CFLAGS="-O2 -pipe -march=native"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="acpi gbm X glamor python xa libkms bindist mmx sse sse2 udev gtk uxa xvmc dbus gnome qt4 dvd alsa dri sna cdr networkmanager"
MAKEOPTS="-j8"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar"
VIDEO_CARDS="i965 i915 intel nvidia virtualbox vmware"
INPUT_DEVICES="evdev synaptics"
LINGUAS="es"


Xorg.conf

Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor1"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "Throttle"              # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "DelayedFlush"          # [<bool>]
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Device"
   Identifier  "Card1"
   Driver      "nvidia"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card1"
   Monitor    "Monitor1"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Log del Xorg

Code:
[   113.262]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[   113.263] X Protocol Version 11, Revision 0
[   113.263] Build Operating System: Linux 3.2.46 x86_64 Gentoo
[   113.263] Current Operating System: Linux Pipe-Pc 3.10.7-gentoo #1 SMP Wed Sep 11 20:47:15 CLST 2013 x86_64
[   113.263] Kernel command line: BOOT_IMAGE=/boot/kernel-genkernel-x86_64-3.10.7-gentoo root=/dev/sda8
[   113.264] Build Date: 11 September 2013  11:18:37PM
[   113.265] 
[   113.265] Current version of pixman: 0.28.0
[   113.266]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   113.266] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   113.268] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 12 16:01:32 2013
[   113.269] (==) Using config file: "/etc/X11/xorg.conf"
[   113.269] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   113.269] (==) ServerLayout "X.org Configured"
[   113.269] (**) |-->Screen "Screen0" (0)
[   113.269] (**) |   |-->Monitor "Monitor0"
[   113.269] (**) |   |-->Device "Card0"
[   113.269] (**) |-->Screen "Screen1" (1)
[   113.269] (**) |   |-->Monitor "Monitor1"
[   113.270] (**) |   |-->Device "Card1"
[   113.270] (**) |-->Input Device "Mouse0"
[   113.270] (**) |-->Input Device "Keyboard0"
[   113.270] (==) Automatically adding devices
[   113.270] (==) Automatically enabling devices
[   113.270] (==) Automatically adding GPU devices
[   113.270] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[   113.270]    Entry deleted from font path.
[   113.270] (**) FontPath set to:
   
[   113.270] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   113.270] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   113.270] (WW) Disabling Mouse0
[   113.270] (WW) Disabling Keyboard0
[   113.270] (II) Loader magic: 0x806c00
[   113.270] (II) Module ABI versions:
[   113.270]    X.Org ANSI C Emulation: 0.4
[   113.270]    X.Org Video Driver: 13.1
[   113.270]    X.Org XInput driver : 18.0
[   113.270]    X.Org Server Extension : 7.0
[   113.270] (II) config/udev: Adding drm device (/dev/dri/card1)
[   113.270] (II) config/udev: Adding drm device (/dev/dri/card0)
[   113.271] (--) PCI:*(0:0:2:0) 8086:0166:1043:1477 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[   113.271] (--) PCI: (0:1:0:0) 10de:0fdf:1043:1477 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[   113.271] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   113.272] Initializing built-in extension Generic Event Extension
[   113.272] Initializing built-in extension SHAPE
[   113.273] Initializing built-in extension MIT-SHM
[   113.273] Initializing built-in extension XInputExtension
[   113.274] Initializing built-in extension XTEST
[   113.274] Initializing built-in extension BIG-REQUESTS
[   113.275] Initializing built-in extension SYNC
[   113.275] Initializing built-in extension XKEYBOARD
[   113.276] Initializing built-in extension XC-MISC
[   113.276] Initializing built-in extension XINERAMA
[   113.277] Initializing built-in extension XFIXES
[   113.278] Initializing built-in extension RENDER
[   113.278] Initializing built-in extension RANDR
[   113.279] Initializing built-in extension COMPOSITE
[   113.279] Initializing built-in extension DAMAGE
[   113.280] Initializing built-in extension MIT-SCREEN-SAVER
[   113.280] Initializing built-in extension DOUBLE-BUFFER
[   113.281] Initializing built-in extension RECORD
[   113.281] Initializing built-in extension DPMS
[   113.282] Initializing built-in extension X-Resource
[   113.282] Initializing built-in extension XVideo
[   113.283] Initializing built-in extension XVideo-MotionCompensation
[   113.283] Initializing built-in extension XFree86-VidModeExtension
[   113.284] Initializing built-in extension XFree86-DGA
[   113.284] Initializing built-in extension XFree86-DRI
[   113.285] Initializing built-in extension DRI2
[   113.285] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   113.285] (II) LoadModule: "glx"
[   113.285] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   113.285] (II) Module glx: vendor="X.Org Foundation"
[   113.285]    compiled for 1.13.4, module version = 1.0.0
[   113.285]    ABI class: X.Org Server Extension, version 7.0
[   113.285] (==) AIGLX enabled
[   113.286] Loading extension GLX
[   113.286] (II) LoadModule: "intel"
[   113.286] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   113.286] (II) Module intel: vendor="X.Org Foundation"
[   113.286]    compiled for 1.13.4, module version = 2.20.13
[   113.286]    Module class: X.Org Video Driver
[   113.286]    ABI class: X.Org Video Driver, version 13.1
[   113.286] (II) LoadModule: "nvidia"
[   113.286] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[   113.287] (II) Module nvidia: vendor="NVIDIA Corporation"
[   113.287]    compiled for 4.0.2, module version = 1.0.0
[   113.287]    Module class: X.Org Video Driver
[   113.287] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
   Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
   Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
   Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
   Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
   Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
   Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
   Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
   Haswell Server (GT2+), Haswell SDV Desktop (GT1),
   Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
   Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
   Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
   Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
   Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
   Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
   Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
   Haswell ULT Server (GT1), Haswell ULT Server (GT2),
   Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
   Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
   Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
   Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
   Haswell CRW Server (GT2), Haswell CRW Server (GT2+),
   ValleyView PO board
[   113.287] (II) NVIDIA dlloader X Driver  319.49  Tue Aug 13 19:34:58 PDT 2013
[   113.287] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   113.287] (--) using VT number 7

[   113.290] (II) intel(0): using device path '/dev/dri/card0'
[   113.290] (II) Loading sub module "fb"
[   113.290] (II) LoadModule: "fb"
[   113.290] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   113.290] (II) Module fb: vendor="X.Org Foundation"
[   113.290]    compiled for 1.13.4, module version = 1.0.0
[   113.290]    ABI class: X.Org ANSI C Emulation, version 0.4
[   113.290] (WW) Unresolved symbol: fbGetGCPrivateKey
[   113.290] (II) Loading sub module "wfb"
[   113.290] (II) LoadModule: "wfb"
[   113.290] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[   113.290] (II) Module wfb: vendor="X.Org Foundation"
[   113.290]    compiled for 1.13.4, module version = 1.0.0
[   113.290]    ABI class: X.Org ANSI C Emulation, version 0.4
[   113.290] (II) Loading sub module "shadow"
[   113.290] (II) LoadModule: "shadow"
[   113.290] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[   113.290] (II) Module shadow: vendor="X.Org Foundation"
[   113.290]    compiled for 1.13.4, module version = 1.1.0
[   113.290]    ABI class: X.Org ANSI C Emulation, version 0.4
[   113.290] (II) Loading sub module "ramdac"
[   113.290] (II) LoadModule: "ramdac"
[   113.290] (II) Module "ramdac" already built-in
[   113.291] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   113.291] (==) intel(0): RGB weight 888
[   113.291] (==) intel(0): Default visual is TrueColor
[   113.291] (--) intel(0): Integrated Graphics Chipset: Intel(R) Ivybridge Mobile (GT2)
[   113.291] (**) intel(0): Relaxed fencing enabled
[   113.291] (**) intel(0): Wait on SwapBuffers? enabled
[   113.291] (**) intel(0): Triple buffering? enabled
[   113.291] (**) intel(0): Framebuffer tiled
[   113.291] (**) intel(0): Pixmaps tiled
[   113.291] (**) intel(0): 3D buffers tiled
[   113.291] (**) intel(0): SwapBuffers wait enabled
[   113.291] (==) intel(0): video overlay key set to 0x101fe
[   113.291] (II) intel(0): Output LVDS1 using monitor section Monitor0
[   113.291] (--) intel(0): found backlight control interface /sys/class/backlight/acpi_video1
[   113.292] (II) intel(0): Output VGA1 has no monitor section
[   113.292] (II) intel(0): Output HDMI1 has no monitor section
[   113.292] (II) intel(0): Output DP1 has no monitor section
[   113.292] (II) intel(0): EDID for output LVDS1
[   113.292] (II) intel(0): Manufacturer: AUO  Model: 133c  Serial#: 0
[   113.292] (II) intel(0): Year: 2009  Week: 1
[   113.292] (II) intel(0): EDID Version: 1.3
[   113.292] (II) intel(0): Digital Display Input
[   113.292] (II) intel(0): Max Image Size [cm]: horiz.: 31  vert.: 17
[   113.292] (II) intel(0): Gamma: 2.20
[   113.292] (II) intel(0): No DPMS capabilities specified
[   113.292] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[   113.292] (II) intel(0): First detailed timing is preferred mode
[   113.292] (II) intel(0): redX: 0.620 redY: 0.340   greenX: 0.330 greenY: 0.570
[   113.293] (II) intel(0): blueX: 0.150 blueY: 0.600   whiteX: 0.313 whiteY: 0.329
[   113.293] (II) intel(0): Manufacturer's mask: 0
[   113.293] (II) intel(0): Supported detailed timing:
[   113.293] (II) intel(0): clock: 69.3 MHz   Image Size:  309 x 173 mm
[   113.293] (II) intel(0): h_active: 1366  h_sync: 1404  h_sync_end 1426 h_blank_end 1436 h_border: 0
[   113.293] (II) intel(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 803 v_border: 0
[   113.293] (II) intel(0): Unknown vendor-specific block f
[   113.293] (II) intel(0):  AUO
[   113.293] (II) intel(0):  B140XTN01.3
[   113.293] (II) intel(0): EDID (in hex):
[   113.293] (II) intel(0):    00ffffffffffff0006af3c1300000000
[   113.293] (II) intel(0):    01130103801f11780ac8a59e57549226
[   113.293] (II) intel(0):    99505400000001010101010101010101
[   113.293] (II) intel(0):    010101010101121b5646500023302616
[   113.293] (II) intel(0):    360035ad100000180000000f00000000
[   113.293] (II) intel(0):    00000000000000000020000000fe0041
[   113.293] (II) intel(0):    554f0a202020202020202020000000fe
[   113.293] (II) intel(0):    004231343058544e30312e33200a001e
[   113.293] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[   113.293] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[   113.293] (II) intel(0): Printing probed modes for output LVDS1
[   113.293] (II) intel(0): Modeline "1366x768"x60.1   69.30  1366 1404 1426 1436  768 771 777 803 -hsync -vsync (48.3 kHz eP)
[   113.293] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[   113.293] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[   113.293] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[   113.293] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[   113.294] (II) intel(0): EDID for output VGA1
[   113.294] (II) intel(0): EDID for output HDMI1
[   113.294] (II) intel(0): EDID for output DP1
[   113.294] (II) intel(0): Output LVDS1 connected
[   113.294] (II) intel(0): Output VGA1 disconnected
[   113.294] (II) intel(0): Output HDMI1 disconnected
[   113.294] (II) intel(0): Output DP1 disconnected
[   113.294] (II) intel(0): Using exact sizes for initial modes
[   113.294] (II) intel(0): Output LVDS1 using initial mode 1366x768
[   113.294] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[   113.294] (II) intel(0): Kernel page flipping support detected, enabling
[   113.294] (==) intel(0): DPI set to (96, 96)
[   113.294] (II) Loading sub module "fb"
[   113.294] (II) LoadModule: "fb"
[   113.295] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   113.295] (II) Module fb: vendor="X.Org Foundation"
[   113.295]    compiled for 1.13.4, module version = 1.0.0
[   113.295]    ABI class: X.Org ANSI C Emulation, version 0.4
[   113.295] (II) Loading sub module "glamoregl"
[   113.295] (II) LoadModule: "glamoregl"
[   113.295] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[   113.295] (II) Module glamoregl: vendor="X.Org Foundation"
[   113.295]    compiled for 1.13.4, module version = 0.5.0
[   113.295]    ABI class: X.Org ANSI C Emulation, version 0.4
[   113.295] (II) glamor: OpenGL accelerated X.org driver based.
[   113.303] (EE)
[   113.303] (EE) Backtrace:
[   113.303] (EE) 0: /usr/bin/X (xorg_backtrace+0x34) [0x595be4]
[   113.303] (EE) 1: /usr/bin/X (0x400000+0x1999e9) [0x5999e9]
[   113.303] (EE) 2: /lib64/libpthread.so.0 (0x7f36c1b22000+0x10bf0) [0x7f36c1b32bf0]
[   113.303] (EE) 3: /usr/lib64/gbm/gbm_gallium_drm.so (pipe_loader_create_screen+0x4) [0x7f36bb185254]
[   113.303] (EE) 4: /usr/lib64/gbm/gbm_gallium_drm.so (gallium_screen_create+0x2a) [0x7f36bb18516a]
[   113.303] (EE) 5: /usr/lib64/gbm/gbm_gallium_drm.so (gbm_gallium_drm_device_create+0x80) [0x7f36bb1859e0]
[   113.303] (EE) 6: /usr/lib64/libgbm.so.1 (_gbm_create_device+0x8b) [0x7f36bc13d1ab]
[   113.303] (EE) 7: /usr/lib64/libgbm.so.1 (gbm_create_device+0x4e) [0x7f36bc13ccbe]
[   113.303] (EE) 8: /usr/lib64/xorg/modules/libglamoregl.so (glamor_egl_init+0x6a) [0x7f36bc76909a]
[   113.303] (EE) 9: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f36bf533000+0x2caf2) [0x7f36bf55faf2]
[   113.303] (EE) 10: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f36bf533000+0x19767) [0x7f36bf54c767]
[   113.303] (EE) 11: /usr/bin/X (InitOutput+0xa09) [0x47e4b9]
[   113.303] (EE) 12: /usr/bin/X (0x400000+0x29958) [0x429958]
[   113.303] (EE) 13: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7f36c07d260d]
[   113.303] (EE) 14: /usr/bin/X (0x400000+0x29e9d) [0x429e9d]
[   113.303] (EE)
[   113.303] (EE) Segmentation fault at address 0x0
[   113.303]
Fatal server error:
[   113.303] Caught signal 11 (Segmentation fault). Server aborting
[   113.303]
[   113.303] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   113.304] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   113.304] (EE)
[   113.310] Server terminated with error (1). Closing log file.


Muchas Gracias
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 306

PostPosted: Thu Sep 12, 2013 9:02 pm    Post subject: Reply with quote

¿Estas seguro que tienes todas estas tarjetas, VIDEO_CARDS="i965 i915 intel nvidia virtualbox vmware", en tu equipo?
¿Que versión de xf86-video-intel tienes instalada?
Pega la salida de lspci
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Sep 12, 2013 9:09 pm    Post subject: Reply with quote

@Pipeng

Hace falta mas información. Publica tu
Code:
emerge --info xorg-server
y la salida de lspci que ya te han pedido.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3706

PostPosted: Fri Sep 13, 2013 1:12 pm    Post subject: Reply with quote

algún motivo para usar glamor ?
porque parece que justo se la pega despues de cargarlo.
dicho esto : a menos que tengas alguna necesidad concreta, no necesitas un xorg.conf.

saluetes
Back to top
View user's profile Send private message
Pipeng
n00b
n00b


Joined: 23 Jul 2013
Posts: 8

PostPosted: Tue Sep 24, 2013 12:50 am    Post subject: Solucion Reply with quote

Muchas Gracias por las recomendaciones, al final, si tenia problemas con las variables use, mi targeta no era compatible con todas las opciones que le habia puesto, tambien borre el xorg.conf, este es mi nuevo make.conf y funciona bien:

Code:
CFLAGS="-O2 -pipe -march=native"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="icu minizip acpi gbm X python xa libkms bindist mmx sse sse2 udev gtk dbus gnome qt4 dvd alsa dri sna cdr networkmanager"
MAKEOPTS="-j8"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar"
VIDEO_CARDS="i965 i915 intel nvidia"
INPUT_DEVICES="evdev synaptics mouse"
LINGUAS="es"


Gracias
Back to top
View user's profile Send private message
Pipeng
n00b
n00b


Joined: 23 Jul 2013
Posts: 8

PostPosted: Tue Sep 24, 2013 12:54 am    Post subject: Solucion Reply with quote

Muchas Gracias por las recomendaciones, al final, si tenia problemas con las variables use, mi targeta no era compatible con todas las opciones que le habia puesto, tambien borre el xorg.conf, este es mi nuevo make.conf y funciona bien:

Code:
CFLAGS="-O2 -pipe -march=native"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="icu minizip acpi gbm X python xa libkms bindist mmx sse sse2 udev gtk dbus gnome qt4 dvd alsa dri sna cdr networkmanager"
MAKEOPTS="-j8"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar"
VIDEO_CARDS="i965 i915 intel nvidia"
INPUT_DEVICES="evdev synaptics mouse"
LINGUAS="es"


Gracias
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum