Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
virtualbox-4.3.0 available in portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Wed Sep 11, 2013 7:36 am    Post subject: virtualbox-4.3.0 available in portage Reply with quote

IMPORTANT! virtualbox-4.3.0 is now officially in portage. The beta and rc ebuilds have been removed from poly-c overlay!

Hi,

virtualbox-4.3.0_beta2 is available. To have it through portage simply do the following:
Code:
layman -a poly-c
and make sure to unmask it:
Code:
grep virtualbox /var/lib/layman/poly-c/profiles/package.mask >> /etc/portage/package.unmask
.

Please keep in mind that these releases are not ready for production machines.
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)


Last edited by Polynomial-C on Wed Oct 16, 2013 12:52 pm; edited 4 times in total
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Sat Sep 21, 2013 10:19 am    Post subject: Reply with quote

virtualbox-4.3.0_beta3 is available.
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Wed Oct 09, 2013 8:59 am    Post subject: Reply with quote

virtualbox-4.3.0_rc1 is available...
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Wed Oct 16, 2013 8:15 am    Post subject: Reply with quote

virtualbox-4.3.0 has been officially released and is already in portage. So I removed the beta/rc ebuilds from poly-c overlay.
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2227
Location: Netherlands

PostPosted: Wed Oct 16, 2013 12:17 pm    Post subject: Reply with quote

I've upgraded to 4.3.0.
I run Win 7 in it.
When I start Windows 7 I get an error immediately about something missing.
I downgraded to 4.2.18 and things run fine again.
I've upgraded before w/o any problem.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Wed Oct 16, 2013 12:53 pm    Post subject: Reply with quote

Can please be a bit more specific about the error message?
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2227
Location: Netherlands

PostPosted: Wed Oct 16, 2013 1:07 pm    Post subject: Reply with quote

I am short on time.
I would have to re-upgrade again,sorry.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1554
Location: Just over the horizon

PostPosted: Wed Oct 16, 2013 10:33 pm    Post subject: Reply with quote

Not sure if it's appropriate to post this in this thread, but I'm not sure if this is a bug or a configuration issue on my side. Probably the latter. My compilation of the xf86-video-virtualbox-4.3.0 drivers is failing with this error:

Code:
/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.0/work/VirtualBox-4.3.0/src/VBox/GuestHost/OpenGL/include/state/cr_bufferobject.h:12:33: fatal error: state/cr_statefuncs.h: No such file or directory
compilation terminated.
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.0/work/VirtualBox-4.3.0/out/linux.amd64/release/obj/VBoxOGLcrutil/util/net.o] Error 1
kmk: *** Waiting for unfinished jobs....
In file included from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.0/work/VirtualBox-4.3.0/src/VBox/GuestHost/OpenGL/include/state/cr_client.h:12:0,
                 from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.0/work/VirtualBox-4.3.0/src/VBox/GuestHost/OpenGL/include/cr_pixeldata.h:11,
                 from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.0/work/VirtualBox-4.3.0/src/VBox/GuestHost/OpenGL/util/pixel.c:7:
/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.3.0/work/VirtualBox-4.3.0/src/VBox/GuestHost/OpenGL/include/state/cr_bufferobject.h:12:33: fatal error: state/cr_statefuncs.h: No such file or directory
compilation terminated.


No idea what that missing header file belongs to. If you feel this might be a bug, let me know, and I'll open a bug in Bugzilla.
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Thu Oct 17, 2013 6:47 am    Post subject: Reply with quote

platojones can you please try with MAKEOPTS="-j1"?

P.S.: I've tried to reproduce your problem in my ~x86 Gentoo VM but the package compiled/installed successfully each time I re-emerged it.
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1554
Location: Just over the horizon

PostPosted: Thu Oct 17, 2013 11:28 am    Post subject: Reply with quote

Polynomial-C wrote:
platojones can you please try with MAKEOPTS="-j1"?

P.S.: I've tried to reproduce your problem in my ~x86 Gentoo VM but the package compiled/installed successfully each time I re-emerged it.


Yes, I'll try it and report back.
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1554
Location: Just over the horizon

PostPosted: Thu Oct 17, 2013 9:57 pm    Post subject: Reply with quote

I knew it was me...I had that installed on a gentoo host system...not a gentoo virtual machine. I'm surprised the previous version actually installed. Sorry to bother you with that.
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Fri Oct 18, 2013 8:56 am    Post subject: Reply with quote

platojones wrote:
I knew it was me...I had that installed on a gentoo host system...not a gentoo virtual machine. I'm surprised the previous version actually installed. Sorry to bother you with that.
Heh... no problem. I'm glad you figured that out :)
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Thu Oct 24, 2013 11:43 pm    Post subject: Reply with quote

I don't know if this is related but .. I just did an emerge --sync and now Portage wants to downgrade virtualbox-bin-4.2.16 to 4.1.26. I had to make a patched version of virtualbox-modules-4.2.16 to get them to compile properly. I'd prefer to not have to go through that exercise with 4.1.26. Both virtualbox-bin-4.2.16 and virtualbox-modules-4.2.16 are in my package.accept_keywords file. Why am I being forced to downgrade? It seems screwy.

Any suggestions?
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 170

PostPosted: Thu Oct 24, 2013 11:57 pm    Post subject: Reply with quote

BitJam wrote:
I don't know if this is related but .. I just did an emerge --sync and now Portage wants to downgrade virtualbox-bin-4.2.16 to 4.1.26. I had to make a patched version of virtualbox-modules-4.2.16 to get them to compile properly. I'd prefer to not have to go through that exercise with 4.1.26. Both virtualbox-bin-4.2.16 and virtualbox-modules-4.2.16 are in my package.accept_keywords file. Why am I being forced to downgrade? It seems screwy.

Any suggestions?

Not sure what the relation is to VirtualBox 4.3.0, but okay. 4.2.16 has been removed from tree in favor of 4.2.18. If your patched version was to enable support for Linux 3.11+, that fix is already present in 4.2.18. If you only have 4.2.16 in your package.accept_keywords, then I would expect portage to offer 4.1.26 as the only alternative.
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Fri Oct 25, 2013 12:13 am    Post subject: Reply with quote

Great! Thanks. Onward to 4.2.18 then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum