Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Convivenza di okular e chromium [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
eleaffar
n00b
n00b


Joined: 09 May 2011
Posts: 26

PostPosted: Fri Sep 06, 2013 9:28 am    Post subject: Convivenza di okular e chromium [RISOLTO] Reply with quote

Salve,
nella mia macchina voglio emergere sia okular che chromium.
Il primo vuole :
# required by dev-qt/qtwebkit-4.8.4[gstreamer]
# required by kde-base/nepomuk-widgets-4.10.5
# required by kde-base/kdelibs-4.10.5-r1[semantic-desktop]
# required by sys-auth/polkit-kde-agent-0.99.0-r1
>=dev-libs/libxml2-2.9.1-r1 -icu

il secondo :
# required by www-client/chromium-29.0.1547.57
# required by chromium (argument)
dev-libs/libxml2 icu

Come devo fare ? Devo escludere l'installazione di un pacchetto piuttosto che un altro !
Ringrazio anticipatamente tutti quelli che mi risponderanno.
Gazieeee
_________________
Ho visto il film Memento ... non me lo ricordo !


Last edited by eleaffar on Mon Sep 09, 2013 10:20 am; edited 2 times in total
Back to top
View user's profile Send private message
sabayonino
Apprentice
Apprentice


Joined: 03 Jan 2012
Posts: 245

PostPosted: Fri Sep 06, 2013 10:22 am    Post subject: Reply with quote

se ti riferisci al fatto che si porti dentro dipendenze kde è normale.Okular fa parte di tale ambiente
ouoi provare con l'opzione --nodeps ... ma dubito fortemente che vada a buon fine

nepomuk non lo vedo così essenziale se non hai un ambiente KDE ; puoi emergere kdelibs (necessarie) senza "semantic-desktop" (provvisoriamente)

Code:
# USE="-semantic-desktop" emerge kdelibs


Code:
 # emerge okular chromium --a



se tutto ti aggrada , rendi definitivo -semantic-desktop per kdelibs
Code:
# euse -D semantic-desktop -p kde-base/kdelibs


[edit] con kde-4.11 , la use "semantic-desktop" mi sembra sia stata inglobata perchè non ne vedo traccia in quest'ultima versione :roll:

e comunque dal tuo output c'era qualcosa altro in più oltre ai "required" ... pacchetti non installati o da settare correttamente. (libxml2 con icu abilitata e non abilitata ... conflitto . probabilmente abilitando icu per dev-qt/qtwebkit dovresti risolvere)

posta l'output completo

Code:
# emerge okular chromium --pretend

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
eleaffar
n00b
n00b


Joined: 09 May 2011
Posts: 26

PostPosted: Mon Sep 09, 2013 8:16 am    Post subject: Reply with quote

sabayonino wrote:
se ti riferisci al fatto che si porti dentro dipendenze kde è normale.Okular fa parte di tale ambiente
ouoi provare con l'opzione --nodeps ... ma dubito fortemente che vada a buon fine

nepomuk non lo vedo così essenziale se non hai un ambiente KDE ; puoi emergere kdelibs (necessarie) senza "semantic-desktop" (provvisoriamente)

Code:
# USE="-semantic-desktop" emerge kdelibs


Code:
 # emerge okular chromium --a



se tutto ti aggrada , rendi definitivo -semantic-desktop per kdelibs
Code:
# euse -D semantic-desktop -p kde-base/kdelibs


[edit] con kde-4.11 , la use "semantic-desktop" mi sembra sia stata inglobata perchè non ne vedo traccia in quest'ultima versione :roll:

e comunque dal tuo output c'era qualcosa altro in più oltre ai "required" ... pacchetti non installati o da settare correttamente. (libxml2 con icu abilitata e non abilitata ... conflitto . probabilmente abilitando icu per dev-qt/qtwebkit dovresti risolvere)

posta l'output completo

Code:
# emerge okular chromium --pretend


Grazie 1000 delle ditte !
nei miei esperimenti ho visto che :
Code:
brain ~ # emerge -pv --depclean qtwebkit

Calculating dependencies... done!
  dev-qt/qtwebkit-4.8.4 pulled in by:
    kde-base/katepart-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4
    kde-base/kde-l10n-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4
    kde-base/kdelibs-4.10.5-r1 requires >=dev-qt/qtwebkit-4.8.0:4
    kde-base/kdesu-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4
    kde-base/khelpcenter-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4
    kde-base/nepomuk-core-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4
    kde-base/nepomuk-widgets-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4
    [b]kde-base/okular-4.10.5 requires >=dev-qt/qtwebkit-4.8.0:4[/b]
    sys-auth/polkit-kde-agent-0.99.0-r1 requires >=dev-qt/qtwebkit-4.8.0:4

>>> No packages selected for removal by depclean
Packages installed:   824
Packages in world:    96
Packages in system:   44
Required packages:    824
Number to remove:     0
brain ~ #

e che
Code:
brain ~ # emerge -av qtwebkit

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/qtwebkit-4.8.4:4  USE="exceptions gstreamer jit (-aqua) -debug -icu* -pch" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.

brain ~ #

allora ho aggiunto la use icu a qtwebkit
Code:
brain ~ # euse -E icu -p dev-qt/qtwebkit
Adding "dev-qt/qtwebkit[icu]" use flag in "/etc/portage/package.use"
brain ~ #           

Adesso mi permette di emergere il tutto :
Code:
brain ~ # emerge -av okular chromium

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-libs/libxml2-2.9.1-r1:2  USE="icu* ipv6 python readline -debug -examples -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_2 (-python2_5) -python2_6 (-python3_1) (-python3_3)" 0 kB
[ebuild  N     ] www-client/chromium-29.0.1547.57  USE="bindist system-ffmpeg -cups -custom-cflags -gnome -gnome-keyring -gps -kerberos -pulseaudio (-selinux) (-system-sqlite) (-tcmalloc) {-test}" LINGUAS="de es fr it -am -ar -bg -bn -ca -cs -da -el -en_GB -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild   R    ] kde-base/okular-4.10.5:4  USE="crypt handbook jpeg pdf postscript tiff (-aqua) -chm -debug -djvu -ebook" 0 kB

Total: 3 packages (1 new, 2 reinstalls), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] ^CInterrupted.
brain ~ #

Senza problemi !
Grazie 1000 sabayonino senza il tuo aiuto avrei desistito e compilato solo OKULAR ! :D
_________________
Ho visto il film Memento ... non me lo ricordo !
Back to top
View user's profile Send private message
sabayonino
Apprentice
Apprentice


Joined: 03 Jan 2012
Posts: 245

PostPosted: Mon Sep 09, 2013 10:16 am    Post subject: Reply with quote

prego :)
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum