Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE] Desinstalar modulos de KDE [Solucionado]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
miguel_senso
n00b
n00b


Joined: 11 Nov 2009
Posts: 68
Location: Guatemala, Guatemala C.A.

PostPosted: Wed Sep 04, 2013 6:57 pm    Post subject: [KDE] Desinstalar modulos de KDE [Solucionado] Reply with quote

Saludos a toda la comunidad! :D

Recurro a ustedes porque tengo un pequeño problema con un sistema que ha estado sin actualizarse desde hace algún tiempo, es de mis primeras instalaciones y cuando instalé KDE lo hice a través de:

Code:
#emerge kde-meta


Lo cuál instaló KDE completo con todos sus módulos, sin embargo hay algunos módulos que no utilizo como los juegos y educación, y quisiera eliminarlos antes de realizar una actualización completa del sistema.

He estado leyendo en la wiki http://wiki.gentoo.org/wiki/KDE/Removal y me parece que es para remover KDE completamente, sin embargo yo solo quiero remover algunos componentes como si solo hubiera instalado el entorno con kdebase-meta.

Actualmente tengo instalado KDE 4.9.5, espero puedan ayudarme puesto que actualmente una actualización completa representa demasiados paquetes que no utilizaré y también necesito liberar espacio en mi disco.

Espero puedan ayudarme de antemano muy agradecido.


Last edited by miguel_senso on Sun Sep 29, 2013 11:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1056
Location: La Plata, Argentina

PostPosted: Thu Sep 05, 2013 1:43 am    Post subject: Reply with quote

paso A: emerge -C kde-meta
PASO B: emerge -av kdebase-startkde
PASO C: emerge -av [paquetes del meta que queres dejar instalados]
PASO D: emerge --depclean -av (esto desinstala todo lo que no tiene dependencias y no esta en world)

la otra opcion es fijarte que queres dejar y agregarlo a /var/lib/portage/world
primero el paso A
paso B
despues agregas al world
despues paso D
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
miguel_senso
n00b
n00b


Joined: 11 Nov 2009
Posts: 68
Location: Guatemala, Guatemala C.A.

PostPosted: Sun Sep 08, 2013 7:13 pm    Post subject: Reply with quote

Hola pelelademadera gracias por la ayuda, me he quedado en el paso B, básicamente porque al querer realizar emerge -v kdebase-meta, o emerge -v kdebase-startkde portage me devuelve lo siguiente.

Code:

[ebuild     U  ] kde-base/kdebase-meta-4.10.5 [4.9.3]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtsql-4.5.0:4[mysql?,postgres?] required by (app-office/akonadi-server-1.9.2::gentoo, ebuild scheduled for merge)
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, ebuild scheduled for merge)

  (dev-qt/qtsql-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.2[-aqua,-c++0x,-debug,-qpa,qt3support] required by (dev-qt/qt3support-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.4-r5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-4.8.4-r3:4 required by (kde-base/plasma-workspace-4.10.5-r2::gentoo, ebuild scheduled for merge)
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,glib=,qt3support=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problems)

  (dev-qt/qtcore-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.2[-aqua,-c++0x,-debug,-qpa] required by (dev-qt/qtdbus-4.8.2::gentoo, installed)
    (and 11 more with the same problem)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.2[accessibility,-aqua,-c++0x,-debug,-qpa,qt3support] required by (dev-qt/qtdeclarative-4.8.2::gentoo, installed)
    (and 6 more with the same problem)

  (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.4[accessibility=,aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.2[-aqua,-c++0x,-debug,-qpa] required by (dev-qt/qtdeclarative-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

  (dev-qt/qtscript-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)

  (dev-qt/qtdbus-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.2[-aqua,-c++0x,-qpa,-debug] required by (dev-qt/qtgui-4.8.2::gentoo, installed)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)

  (dev-qt/qt3support-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.2[accessibility,-aqua,-c++0x,-debug,-qpa] required by (dev-qt/qtdeclarative-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

media-libs/mesa:0

  (media-libs/mesa-8.0.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    <media-libs/mesa-9 required by (virtual/glu-7.0::gentoo, installed)

  (media-libs/mesa-9.0.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Estoy utilizando el perfil default/linux/amd64/13.0/desktop/kde *, y cuando esto me pasaba lo que hacía era ir paquete por paquete desinstalando el anterior e instalando el nuevo que solicita portage pero no se si haya una forma más técnica de realizarlo.

De antemano muy agradecido por la ayuda.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1056
Location: La Plata, Argentina

PostPosted: Mon Sep 09, 2013 1:15 am    Post subject: Reply with quote

por lo que veo tenes problemas de bloqueos de actualizacion... hiciste emerge --sync antes de hacer esto, no hay drama. es un bloqueo....
volve a hacer el emerge --sync, hace lo siguiente y si vuelve a fallar, es encontrar cual es el que bloquea y a que... usas rama estable o testing? puede estar ahi el problema, postea el make.conf y el package.keywords y package.unask, que ahi podes tener el drama
el 1º paso es emerge -C kde-meta, si haces emerge -v kde-meta estas volviendo a instalar kde-meta

lo primero es desinstalar meta, ese paquete no tiene nada en definitiva, solo instala todo kde como dependencia, en definitiva, no vas a perder nada de lo que tenes instalado sacando el meta hasta que no hagas un deepclean.
entonces,
Code:
emerge -C kde-meta

despues haces
Code:
emerge -av kdebase-startkde


despues, lo que te recomiendo es editar el fichero: /var/lib/portage/world

Quote:
pelo@pelo-pc ~ $ cat /var/lib/portage/world | grep kde
kde-base/ark
kde-base/dolphin
kde-base/gwenview
kde-base/kalarm
kde-base/kate
kde-base/kcalc
kde-base/kde-l10n
kde-base/kdebase-pam
kde-base/kdebase-startkde
kde-base/kdm
kde-base/kfind
kde-base/kmix
kde-base/kolourpaint
kde-base/kompare
kde-base/konsole
kde-base/ksnapshot
kde-base/okular

y dejar los paquetes que uses, eso es lo que yo tengo, podes agregar o quitar los que quieras.

una vez que haces eso es un deepclean lo que tenes que hacer:

Code:
emerge --depclean -av



PD: yo uso el perfil defaul.
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
miguel_senso
n00b
n00b


Joined: 11 Nov 2009
Posts: 68
Location: Guatemala, Guatemala C.A.

PostPosted: Mon Sep 09, 2013 7:18 pm    Post subject: Reply with quote

Hola pelelademadera gracias por tu ayuda, y si antes de intentar actualizar KDE había realizado emerge --sync, y cuando vi el bloqueo entonces decidí esperar un par de días y volví a actualizar el arbol de portage pero el bloqueo persiste, mi última actualización fué ayer.

Utilizo la rama estable, y desinstalé kde-meta el cual no dió ningún tipo de problema, pero al intentar instalar kdebase-startkde el error de bloqueo persiste (lo que mencioné en mi post anterior).

Dejo mi make.conf

Code:
CFLAGS="-O2 -pipe -march=core2"
CXXFLAGS="${CFLAGS}"

CHOST="x86_64-pc-linux-gnu"
MAKEOPTS="-j4"
LINGUAS="es es_ES es_LA"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="intel"
source /var/lib/layman/make.conf
ACCEPT_LICENSE="*"
PORTDIR_OVERLAY="/usr/local/portage ${PORTDIR} ${PORTDIR_OVERLAY}"

USE="mmx sse sse2 -gnome -gtk kde dvd alsa cdr qt4 xorg X udev dbus acpi
dvdr opengl pdf usb java jpeg png samba wicd autoipd java6 resolvconf cups
msn yahoo dhcp"


package.keywords
Code:
>=dev-java/sun-jdk-1.6.0.29-r1 ~amd64
www-client/google-chrome ~amd64
=games-emulation/lxdream-0.9.1-r2 ~amd64
>=www-client/firefox-bin-10.0.2 ~amd64
>=app-emulation/playonlinux-4.1.1 ~amd64
=app-emulation/virtualbox-modules-4.1.18 ~amd64
=app-emulation/emul-linux-x86-bjdeps-1.13 ~amd64
=app-emulation/playonlinux-4.0.14 ~amd64
>=net-im/kmess-2.0.6.2
=dev-java/oracle-jdk-bin-1.7.0.5 ~amd64
=net-misc/dropbox-cli-1 ~amd64
=media-video/cheese-3.2.2 ~amd64
=gnome-base/gnome-desktop-3.2.1 ~amd64
=x11-libs/mx-1.4.2 ~amd64
=sys-kernel/gentoo-sources-3.5.3 ~amd64
=dev-java/oracle-jdk-bin-1.7.0.7 ~amd64
=sci-libs/libticalcs2-1.1.7 ~amd64
=sci-calculators/tiemu-3.03 ~amd64
=sci-libs/libtifiles2-1.1.5 ~amd64
=sci-libs/libticonv-1.1.3 ~amd64
=sci-libs/libticables2-1.3.3 ~amd64
>=sys-kernel/gentoo-sources-3.5.4 ~amd64
>=app-emulation/virtualbox-4.2.0-r1 ~amd64
=app-emulation/virtualbox-extpack-oracle-4.2.0 ~amd64
=app-emulation/virtualbox-additions-4.2.0 ~amd64
=app-emulation/virtualbox-modules-4.2.0-r1 ~amd64
=dev-util/kbuild-0.1.9998_pre20120806 ~amd64
>=sys-power/cpufreqd-2.4.2 ~amd64
>=app-office/texmaker-3.3.4 ~amd64
>=app-office/texstudio-2.4 ~amd64
>=app-arch/tarsync-0.2.1-r1 ~amd64
=sys-apps/portage-2.1.11.33 ~amd64
>=net-im/skype-4.1.0.20 ~amd64
=app-text/libmspub-0.0.3 ~amd64
=dev-python/spyder-2.1.11 ~amd64
=app-admin/hddtemp-0.3_beta15-r22 ~amd64
=app-misc/screenfetch-2.5.3 ~amd64
=net-print/cnijfilter-3.80 ~amd64
=net-print/cnijfilter-drivers-3.80 ~amd64
>=dev-util/eclipse-sdk-bin-4.3 ~amd64
>=media-gfx/gimp-2.6.12-r5:2 ~amd64
=media-libs/babl-0.1.10-r1 ~amd64
=media-libs/gegl-0.2.0-r2 ~amd64


mi package.mask

Code:
#ficheros enmascarados

=gnome-base/librsvg-2.34.2
=app-emulation/virtualbox-9999
=www-client/google-chrome-20.0.1132.21_beta139451
=dev-util/cmake-2.8.7-r5


y mi package.unmask no tiene nada.

Muchas gracias de antemano por la ayuda.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1056
Location: La Plata, Argentina

PostPosted: Tue Sep 10, 2013 3:45 am    Post subject: Reply with quote

los bloqueos son todo un tema en gentoo, pero bueno, es con lo que hay que lidear.

creo que la solucion mas rapida, si no te molesta recompilar paquetes de gusto es hacer un emerge -C y limpiar los paquetes que dicen required by por ejemplo, el 1º bloqueo es app-office/akonadi-server y dev-qt/qt3support

con todos los paquetes lo mismo, si solucionas, genial, sino, habra que hacer un deepclean entero y recompilar todo, vas a tardar recompilando, pero es creo que lo mas rapido que andar renegando con dependencias

ahi emerge nuevamente emerge kdebase-startkde
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 841

PostPosted: Tue Sep 10, 2013 5:45 pm    Post subject: Reply with quote

miguel_senso wrote:
Hola pelelademadera gracias por la ayuda, me he quedado en el paso B, básicamente porque al querer realizar emerge -v kdebase-meta, o emerge -v kdebase-startkde portage me devuelve lo siguiente.

Code:

[ebuild     U  ] kde-base/kdebase-meta-4.10.5 [4.9.3]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
...


¿Que tal esto
Code:
(root)# emerge --unmerge kde-meta && emerge -pv kdebase-startkde world
?
Back to top
View user's profile Send private message
miguel_senso
n00b
n00b


Joined: 11 Nov 2009
Posts: 68
Location: Guatemala, Guatemala C.A.

PostPosted: Tue Sep 10, 2013 7:39 pm    Post subject: Reply with quote

Quote:
¿Que tal esto
Code:
(root)# emerge --unmerge kde-meta && emerge -pv kdebase-startkde world


Gracias por el aporte quilosaq, al ejecutar el comando retorna (solo el final de emerge):

Code:
[ebuild     U  ] kde-base/kdebase-meta-4.10.5:4 [4.9.3:4] USE="wallpapers (-aqua)" 0 kB
[blocks B      ] >dev-qt/qtscript-4.8.2-r9999:4 (">dev-qt/qtscript-4.8.2-r9999:4" is blocking dev-qt/qtopengl-4.8.2, dev-qt/qttest-4.8.2, dev-qt/qtsvg-4.8.2, dev-qt/qtwebkit-4.8.2, dev-qt/qtxmlpatterns-4.8.2, dev-qt/qtdeclarative-4.8.2, dev-qt/qtmultimedia-4.8.2)
[blocks B      ] >dev-qt/qtdbus-4.8.2-r9999:4 (">dev-qt/qtdbus-4.8.2-r9999:4" is blocking dev-qt/qtopengl-4.8.2, dev-qt/qttest-4.8.2, dev-qt/qtsvg-4.8.2, dev-qt/qtwebkit-4.8.2, dev-qt/qtxmlpatterns-4.8.2, dev-qt/qtdeclarative-4.8.2, dev-qt/qtmultimedia-4.8.2)
[blocks B      ] <sys-apps/sysvinit-2.88-r4 ("<sys-apps/sysvinit-2.88-r4" is blocking sys-apps/util-linux-2.22.2)
[blocks B      ] >dev-qt/qtcore-4.8.2-r9999:4 (">dev-qt/qtcore-4.8.2-r9999:4" is blocking dev-qt/qtopengl-4.8.2, dev-qt/qttest-4.8.2, dev-qt/qtsvg-4.8.2, dev-qt/qtwebkit-4.8.2, dev-qt/qtxmlpatterns-4.8.2, dev-qt/qtdeclarative-4.8.2, dev-qt/qtmultimedia-4.8.2)
[blocks B      ] >dev-qt/qt3support-4.8.2-r9999:4 (">dev-qt/qt3support-4.8.2-r9999:4" is blocking dev-qt/qtopengl-4.8.2, dev-qt/qttest-4.8.2, dev-qt/qtsvg-4.8.2, dev-qt/qtwebkit-4.8.2, dev-qt/qtxmlpatterns-4.8.2, dev-qt/qtdeclarative-4.8.2, dev-qt/qtmultimedia-4.8.2)
[blocks B      ] >dev-qt/qtgui-4.8.2-r9999:4 (">dev-qt/qtgui-4.8.2-r9999:4" is blocking dev-qt/qtopengl-4.8.2, dev-qt/qttest-4.8.2, dev-qt/qtsvg-4.8.2, dev-qt/qtwebkit-4.8.2, dev-qt/qtxmlpatterns-4.8.2, dev-qt/qtdeclarative-4.8.2, dev-qt/qtmultimedia-4.8.2)
[blocks B      ] >dev-qt/qtsql-4.8.2-r9999:4 (">dev-qt/qtsql-4.8.2-r9999:4" is blocking dev-qt/qtopengl-4.8.2, dev-qt/qttest-4.8.2, dev-qt/qtsvg-4.8.2, dev-qt/qtwebkit-4.8.2, dev-qt/qtxmlpatterns-4.8.2, dev-qt/qtdeclarative-4.8.2, dev-qt/qtmultimedia-4.8.2)

Total: 315 packages (210 upgrades, 2 downgrades, 27 new, 5 in new slots, 71 reinstalls, 3 uninstalls), Size of downloads: 1,465,271 kB
Fetch Restriction: 1 package
Conflict: 11 blocks (7 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-base/oxygen-icons:4

  (kde-base/oxygen-icons-4.10.5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/oxygen-icons-4.10.5:4[aqua=] required by (kde-base/kquitapp-4.10.5::gentoo, ebuild scheduled for merge)
    (and 91 more with the same problem)

  (kde-base/oxygen-icons-4.9.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libattica:0

  (dev-libs/libattica-0.4.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libattica-0.4.1 required by (kde-base/kdelibs-4.10.5-r1::gentoo, ebuild scheduled for merge)

  (dev-libs/libattica-0.3.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/51.1 required by (app-office/libreoffice-bin-4.0.4.2::gentoo, ebuild scheduled for merge)

  (dev-libs/icu-49.1.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-text/poppler:0

  (app-text/poppler-0.18.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.22.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler:0/35 required by (app-office/libreoffice-bin-4.0.4.2::gentoo, ebuild scheduled for merge)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.45::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libdrm-2.4.42[video_cards_intel] required by (media-libs/mesa-9.1.2-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/libdrm-2.4.40::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2[python,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] required by (media-libs/mesa-9.1.2-r1::gentoo, ebuild scheduled for merge)

  (dev-libs/libxml2-2.8.0_rc1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-apps/hwids:0

  (sys-apps/hwids-20130329::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/hwids-20130326.1[udev] required by (sys-fs/udev-204::gentoo, ebuild scheduled for merge)

  (sys-apps/hwids-20130302::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-libs/ncurses:5

  (sys-libs/ncurses-5.9-r2::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/ncurses[-tinfo] required by (sys-apps/openrc-0.11.8::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-5.9-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-libs/e2fsprogs-libs:0

  (sys-libs/e2fsprogs-libs-1.42.7::gentoo, ebuild scheduled for merge) pulled in by
    ~sys-libs/e2fsprogs-libs-1.42.7 required by (sys-fs/e2fsprogs-1.42.7::gentoo, ebuild scheduled for merge)

  (sys-libs/e2fsprogs-libs-1.42::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/mesa:0

  (media-libs/mesa-9.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/mesa-8.0.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    <media-libs/mesa-9 required by (virtual/glu-7.0::gentoo, installed)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.2[accessibility,-aqua,-c++0x,-debug,-qpa,qt3support] required by (dev-qt/qtdeclarative-4.8.2::gentoo, installed)
    (and 6 more with the same problem)

  (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.4[accessibility=,aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)

  (dev-qt/qt3support-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.2[accessibility,-aqua,-c++0x,-debug,-qpa] required by (dev-qt/qtdeclarative-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.4-r5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,glib=,qt3support=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)
    >=dev-qt/qtcore-4.8.4-r5:4 required by (app-office/libreoffice-bin-4.0.4.2::gentoo, ebuild scheduled for merge)
    (and 5 more with the same problems)

  (dev-qt/qtcore-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.2[-aqua,-c++0x,-debug,-qpa] required by (dev-qt/qtdbus-4.8.2::gentoo, installed)
    (and 11 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtsql-4.5.0:4[mysql?,postgres?] required by (app-office/akonadi-server-1.9.2::gentoo, ebuild scheduled for merge)
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, ebuild scheduled for merge)

  (dev-qt/qtsql-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.2[-aqua,-c++0x,-debug,-qpa,qt3support] required by (dev-qt/qt3support-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.2[-aqua,-c++0x,-debug,-qpa] required by (dev-qt/qtdeclarative-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

  (dev-qt/qtscript-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge)

  (dev-qt/qtdbus-4.8.2::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.2[-aqua,-c++0x,-qpa,-debug] required by (dev-qt/qtgui-4.8.2::gentoo, installed)

app-emulation/emul-linux-x86-opengl:0

  (app-emulation/emul-linux-x86-opengl-20130224::gentoo, ebuild scheduled for merge) pulled in by
    app-emulation/emul-linux-x86-opengl[development] required by (app-emulation/wine-1.6::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-opengl-20130224 required by (app-emulation/emul-linux-x86-gtklibs-20130224::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-opengl-20121202-r1::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-opengl-20121202 required by (app-emulation/emul-linux-x86-qtlibs-20121202::gentoo, installed)

app-emulation/emul-linux-x86-baselibs:0

  (app-emulation/emul-linux-x86-baselibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    >=app-emulation/emul-linux-x86-baselibs-20130224[development] required by (app-emulation/wine-1.6::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-baselibs-20130224 required by (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problems)

  (app-emulation/emul-linux-x86-baselibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20121202 required by (app-emulation/emul-linux-x86-soundlibs-20121202::gentoo, installed)
    (and 4 more with the same problem)

app-emulation/emul-linux-x86-medialibs:0

  (app-emulation/emul-linux-x86-medialibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-medialibs-20121202 required by (app-emulation/emul-linux-x86-soundlibs-20121202::gentoo, installed)
    (and 1 more with the same problem)

  (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-medialibs-20130224 required by (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, ebuild scheduled for merge)

app-emulation/emul-linux-x86-soundlibs:0

  (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    >=app-emulation/emul-linux-x86-soundlibs-2.1[development] required by (app-emulation/wine-1.6::gentoo, ebuild scheduled for merge)
    app-emulation/emul-linux-x86-soundlibs[development] required by (app-emulation/wine-1.6::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-soundlibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-soundlibs-20121202 required by (app-emulation/emul-linux-x86-medialibs-20121202::gentoo, installed)

app-emulation/emul-linux-x86-xlibs:0

  (app-emulation/emul-linux-x86-xlibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20121202 required by (app-emulation/emul-linux-x86-medialibs-20121202::gentoo, installed)

  (app-emulation/emul-linux-x86-xlibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    >=app-emulation/emul-linux-x86-xlibs-2.1[development] required by (app-emulation/wine-1.6::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-xlibs-20130224 required by (app-emulation/emul-linux-x86-gtklibs-20130224::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problems)

app-emulation/emul-linux-x86-db:0

  (app-emulation/emul-linux-x86-db-20130224::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-db-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-db-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-db-20121202 required by (app-emulation/emul-linux-x86-medialibs-20121202::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-emulation/virtualbox-4.2.18[additions]
# required by app-emulation/virtualbox-extpack-oracle-4.2.18
=app-emulation/virtualbox-additions-4.2.18 ~amd64
# required by net-wireless/aircrack-ng-1.2_beta1[airdrop-ng]
# required by @selected
# required by @world (argument)
=net-wireless/lorcon-0.0_p20130212 ~amd64
# required by app-emulation/virtualbox-4.2.18
# required by app-emulation/virtualbox-extpack-oracle-4.2.18
=app-emulation/virtualbox-modules-4.2.18 ~amd64
# required by app-emulation/virtualbox-4.2.18[extensions]
# required by @selected
# required by @world (argument)
=app-emulation/virtualbox-extpack-oracle-4.2.18 ~amd64
# required by @selected
# required by @world (argument)
=net-print/cups-bjnp-1.2.1 ~amd64

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-wireless/aircrack-ng-1.2_beta1[airdrop-ng]
# required by @selected
# required by @world (argument)
=net-wireless/lorcon-0.0_p20130212 python

emerge: there are no ebuilds to satisfy "net-print/cnijfilter-drivers".
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


pelelademadera gracias por el apoyo, ya veo que los bloqueos cuando quieren dan dolores de cabeza, pero es parte de lo que hace grande esta distribución, gracias por su apoyo y les agradezco de antemano por sus ideas para solucionarlo.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1056
Location: La Plata, Argentina

PostPosted: Tue Sep 10, 2013 11:32 pm    Post subject: Reply with quote

sr, tenes problemas entre los paquetes ya instalados y los que vas a instalar xq se va a renovar la version de kde. en cada update de qt o de kde vienen esos problemas si no actualizas seguido y pasa mas de una version entre la que tenes y la que se viene... es normal y vas a renegar bastante para sacarlo adelante...


que te recomiendo como salida rapida, emerge -C kde-meta kdm
ahi proba de emerger kdebase-starkde y kdm con:
emerge kdebase-starkde kdm
si no funciona, hace la desinstalada rapida de todo lo qt:
seria asi:
emerge -1C $(qlist -IC qt/) -av
chequea que se desinstala y dale adelante nomas:
proba de instalar nuevamente kde y fijate que pasa, deberia instalar todo qt nuevamente y sacarte de esos bloqueos que son basicamente qt viejo vs qt nuevo
emerge kdebase-startkde
si no quiere nuevamente
hace algo parecido, mata kde entero:
emerge --depclean
y ahi deberias poder actualizar sin dramas.

t recomiendo francamente que hagas un backup por si te quedas sin sistema, odio quedarme sin pc cuando la necesito, un backup te salva las papas y no cuesta nada.
booteas un livecd y un cp -a y a algun lugar seguro todo lo que sea fundamental, en mi caso es el / el unico fundamental para que arranque, el /home esta aparte y lo demas es lo temporal, el arbol de portage y los sources, que no me interesa tenerlo, se baja, pero depende de tus montajes...

te soy sincero, cada vez que entro en estos rollos, mato todo lo que molesta y recompilo todo.
por suerte tengo una pc que me acompaña.... pero si bien lleva tiempo compilar, con una pc medianamente potente en un rato esta todo.

agrega al startkde los que quieras agregar....
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10040
Location: Córdoba (Spain)

PostPosted: Tue Sep 17, 2013 12:03 pm    Post subject: Reply with quote

La mayoría de estos bloqueos no se resuelven en forma automática alguna. La realidad es simple de entender: la nueva versión de kde quiere una nueva versión de qt, pero ten en cuenta que cuando desinstales la versión que ahora tienes de todos los paquetes qt*, tu kde actual dejará de funcionar. Te aviso más que nada para que si no eres de los que se sienten cómodos en línea de comandos, tengas un gestor de ventanas alternativo a mano, ya que qt puede tardar en recompilarse.

Tendrás que actualizar los paquetes qt (emerge -u debería bastar), tras eso la mayoría de bloqueos deberían haberse solucionado. También tendrás que recompilar cualquier paquete externo que dependa de qt.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
miguel_senso
n00b
n00b


Joined: 11 Nov 2009
Posts: 68
Location: Guatemala, Guatemala C.A.

PostPosted: Sun Sep 29, 2013 11:45 pm    Post subject: Reply with quote

Muchas gracias a toda la comunidad, les comento que solucioné los bloqueos primero instalando un entorno de escritorio alterno para no quedarme sin un entorno en el cual trabajar, opté por XFCE.

Luego desinstalé completamente KDE y qt para iniciar de cero y volver a instalar KDE, y ahora ya estoy de nuevo en KDE, aunque sigo peleando con actualizar udev y python pero por problemas de tiempo voy un problema a la vez.

Gracias a todos por su apoyo :D .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum