Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Non riesco ad installare nm-applet
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Mon Sep 02, 2013 7:14 am    Post subject: [Risolto] Non riesco ad installare nm-applet Reply with quote

ragazzi mi serve un aiuto, devo installare nm-applet una estenzione fondamentale per potere eseguire correttamente nel mio sistema NetworkManager e quindi connettermi facilmente alla rete. Il fatto e' che quando tento di installarlo mi da questa serie di errori, da cui data la mia inesperienza su gentoo non riesco a venirne a capo:

Code:
darkstar ~ # emerge nm-applet

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] net-misc/mobile-broadband-provider-info-20120614
[ebuild     U  ] dev-libs/gobject-introspection-common-1.36.0 [1.32.1]
[ebuild     U  ] dev-libs/glib-2.36.4 [2.32.4-r1] ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%"
[ebuild  N     ] sys-libs/libcap-ng-0.7.3  USE="-python -static-libs"
[ebuild  N     ] app-crypt/p11-kit-0.19.3  USE="asn1 trust -debug"
[ebuild  N     ] dev-util/gdbus-codegen-2.36.4  PYTHON_TARGETS="python2_7 python3_2 (-python2_5) -python2_6 (-python3_1) -python3_3"
[ebuild     U  ] dev-libs/gobject-introspection-1.36.0 [1.32.1] USE="cairo%*" PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*"
[ebuild  N     ] x11-themes/gnome-icon-theme-symbolic-3.8.3
[ebuild  N     ] app-mobilephone/obexd-0.46  USE="usb -eds -nokia -server"
[ebuild  N     ] net-wireless/gnome-bluetooth-3.8.1  USE="introspection -debug"
[ebuild  N     ] app-crypt/gcr-3.8.2  USE="gtk introspection -debug {-test}"
[ebuild     U  ] gnome-base/gnome-keyring-3.8.2 [2.32.1-r1] USE="caps%* filecaps%* (-selinux)"
[blocks b      ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.8.2)
[ebuild     U  ] gnome-base/libgnome-keyring-3.8.0 [2.32.0] USE="introspection%* -vala%"
[ebuild  N     ] app-crypt/libsecret-0.15  USE="crypt introspection -debug {-test} -vala"
[ebuild  N     ] gnome-extra/nm-applet-0.9.8.2  USE="bluetooth introspection -gconf -modemmanager"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/gobject-introspection:0

  (dev-libs/gobject-introspection-1.32.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-1.36.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, ebuild scheduled for merge)

dev-libs/glib:2

  (dev-libs/glib-2.36.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)

dev-libs/gobject-introspection-common:0

  (dev-libs/gobject-introspection-common-1.32.1::gentoo, installed) pulled in by
    <dev-libs/gobject-introspection-common-1.35.9 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)

  (dev-libs/gobject-introspection-common-1.36.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-common-1.36.0 required by (dev-libs/gobject-introspection-1.36.0::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Mi aiutate per favore a venirne a capo postamdomi la corretta procedura o i comandi esatti che devo dare??
Premetto che questo problema riscontrato qui, mi trascina anche altri, tipo il non potere procedere all'aggiornamento del mio sistema:

Code:
darkstar ~ # emerge --update --ask world

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-arch/xz-utils-5.0.5-r1 [5.0.4-r1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] app-arch/bzip2-1.0.6-r4 [1.0.6-r3] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] sys-devel/gnuconfig-20130516 [20130111]
[ebuild     U  ] app-arch/gzip-1.6 [1.5]
[ebuild     U  ] sys-apps/which-2.20-r1 [2.20]
[ebuild     U  ] sys-boot/os-prober-1.62 [1.53]
[ebuild     U  ] sys-apps/net-tools-1.60_p20130513023548 [1.60_p20120127084908] USE="(-selinux)"
[ebuild     U  ] sys-apps/coreutils-8.21 [8.20]
[ebuild     U  ] sys-apps/less-460 [457]
[ebuild     U  ] dev-lang/perl-5.16.3 [5.12.4-r1]
[ebuild  N     ] dev-perl/Text-Unidecode-0.40.0
[ebuild  N     ] dev-perl/libintl-perl-1.230.0
[ebuild     U  ] sys-devel/patch-2.7.1-r2 [2.6.1] USE="-xattr%"
[ebuild  N     ] dev-perl/Unicode-EastAsianWidth-1.330.0
[ebuild     U  ] sys-apps/sed-4.2.2 [4.2.1-r1]
[ebuild     U  ] sys-devel/binutils-2.23.2 [2.23.1]
[ebuild     U  ] sys-apps/texinfo-5.1 [4.13-r2]
[ebuild     U  ] sys-apps/gawk-4.1.0 [4.0.1]
[ebuild     U  ] sys-apps/findutils-4.5.11 [4.4.2-r1]
[ebuild  NS    ] sys-devel/gcc-4.7.3 [4.6.3] USE="cxx fortran gtk mudflap (multilib) nls nptl openmp (-altivec) -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -lto -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla"
[ebuild  N     ] app-admin/eselect-cdparanoia-0.1
[ebuild     U  ] sys-apps/man-pages-3.53 [3.50]
[ebuild     U  ] sys-apps/busybox-1.21.1 [1.20.2] USE="-syslog%"
[ebuild     U  ] sys-apps/kbd-1.15.5-r1 [1.15.3] USE="pam%*"
[ebuild     U  ] net-misc/iputils-20121221-r1 [20121221] USE="filecaps%* gnutls*"
[ebuild  N     ] dev-util/gdbus-codegen-2.36.4  PYTHON_TARGETS="python2_7 python3_2 (-python2_5) -python2_6 (-python3_1) -python3_3"
[ebuild     U  ] dev-libs/glib-2.36.4 [2.32.4-r1] ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%"
[ebuild     U  ] net-misc/rsync-3.0.9-r3 [3.0.9-r2]
[ebuild     U  ] sys-process/procps-3.3.8 [3.3.6]
[ebuild     U  ] xfce-base/libxfce4util-4.10.1 [4.10.0]
[ebuild     U  ] dev-libs/libcdio-0.90-r1 [0.83] USE="{-test%}" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] net-misc/dhcpcd-6.0.5-r1 [5.6.4] USE="ipv6%*"
[ebuild     U  ] app-admin/syslog-ng-3.4.3 [3.4.2]
[ebuild  N     ] dev-libs/libcdio-paranoia-0.90_p1-r1  USE="cxx -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] x11-libs/gdk-pixbuf-2.28.2 [2.26.4]
[ebuild     U  ] dev-libs/atk-2.8.0 [2.6.0] USE="{-test%}"
[ebuild  N     ] dev-libs/json-glib-0.16.0-r1  USE="introspection -debug"
[ebuild     U  ] media-libs/fontconfig-2.10.93 [2.8.0-r1] USE="-static-libs%" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] x11-libs/pango-1.34.1 [1.30.1]
[ebuild     U  ] x11-base/xorg-drivers-1.14 [1.13] VIDEO_CARDS="fbdev* vesa* -radeonsi%"
[ebuild  N     ] x11-drivers/xf86-video-fbdev-0.4.3-r1
[ebuild  N     ] x11-drivers/xf86-video-vesa-2.3.2-r1
[ebuild  NS    ] sys-kernel/gentoo-sources-3.10.10 [3.10.7] USE="-build -deblob -symlink"
[ebuild  N     ] app-accessibility/at-spi2-core-2.8.0  USE="introspection"
[ebuild  N     ] app-accessibility/at-spi2-atk-2.8.1  USE="{-test}"
[ebuild     U  ] sys-apps/util-linux-2.23.2 [2.22.2] USE="udev* -bash-completion% -caps% -cytune% -fdformat% -tty-helpers%"
[ebuild  N     ] sys-apps/gptfdisk-0.8.6  USE="icu ncurses -static"
[ebuild     U  ] sys-kernel/genkernel-3.4.47 [3.4.45.1]
[ebuild     U  ] x11-libs/gtk+-3.8.2 [3.4.4]
[ebuild     U  ] x11-terms/xfce4-terminal-0.6.2 [0.4.8]
[ebuild     U  ] app-arch/file-roller-3.8.4 [2.32.2] USE="(-packagekit)"
[ebuild  NS    ] sys-fs/udisks-2.1.1 [1.0.4-r5] USE="gptfdisk introspection -cryptsetup -debug (-selinux) -systemd"
[ebuild     U  ] xfce-extra/xfce4-power-manager-1.2.0-r2 [1.2.0-r1] USE="networkmanager*"
[ebuild     U  ] sys-apps/openrc-0.12 [0.11.8] USE="netifrc%* -tools%"
[ebuild  N     ] net-misc/netifrc-0.1
[ebuild     U  ] media-video/ffmpeg-1.2.3 [1.0.7] USE="cdio* gnutls* iconv%* pulseaudio* theora* -libsoxr%" FFTOOLS="ffescape%*"
[ebuild     U  ] media-video/mplayer-1.2_pre20130729 [1.1.1-r1] USE="bidi* pulseaudio* -dv* -faad* -rar* -rtc* -speex* -toolame* -tremor* -twolame*"
[ebuild  N     ] media-video/ffmpegthumbnailer-2.0.8  USE="gtk jpeg png -gnome"
[ebuild     U  ] gnome-base/gvfs-1.16.3 [1.12.3-r1] USE="gtk%* udisks* -gnome-online-accounts% -mtp% -systemd% {-test%}"
[ebuild     U  ] xfce-base/thunar-1.6.3 [1.6.2]
[ebuild     U  ] xfce-extra/tumbler-0.1.29 [0.1.25] USE="ffmpeg* -curl%"
[ebuild     U  ] xfce-extra/thunar-archive-plugin-0.3.1 [0.3.0]
[blocks B      ] <media-sound/cdparanoia-3.10.2-r5 ("<media-sound/cdparanoia-3.10.2-r5" is blocking app-admin/eselect-cdparanoia-0.1)
[blocks B      ] <sys-apps/sysvinit-2.88-r5 ("<sys-apps/sysvinit-2.88-r5" is blocking sys-apps/util-linux-2.23.2)
[blocks B      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4)
[blocks B      ] >=sys-apps/util-linux-2.23 (">=sys-apps/util-linux-2.23" is blocking sys-apps/sysvinit-2.88-r4)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4::gentoo, ebuild scheduled for merge)
    (and 5 more with the same problem)

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.32.1::gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-204::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (gnome-extra/libgsf-1.14.25::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.38.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.3 required by (net-misc/networkmanager-0.9.8.2-r3::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.20-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    dev-libs/gobject-introspection required by (dev-libs/keybinder-0.3.0-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.110::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.17::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r204::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.2-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.38.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.0-r1::gentoo, ebuild scheduled for merge)

  (sys-apps/util-linux-2.23.2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.7::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/gptfdisk-0.8.6::gentoo, ebuild scheduled for merge)
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.19.1::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (x11-libs/libSM-1.2.1::gentoo, installed)
    >=sys-apps/util-linux-2.13 required by (sys-power/pm-utils-1.4.1-r2::gentoo, installed)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-fs/udev-204::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.97-r1::gentoo, installed)
    >=sys-apps/util-linux-2.22 required by (virtual/eject-0::gentoo, installed)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-2.1.1::gentoo, ebuild scheduled for merge)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.4.8-r1::gentoo, installed)

  (media-sound/cdparanoia-3.10.2-r4::gentoo, installed) pulled in by
    >=media-sound/cdparanoia-3.10.2-r3 required by (media-plugins/gst-plugins-cdparanoia-0.10.36::gentoo, installed)

  (sys-apps/sysvinit-2.88-r4::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.12::gentoo, ebuild scheduled for merge)

  (app-admin/eselect-cdparanoia-0.1::gentoo, ebuild scheduled for merge) pulled in by
    app-admin/eselect-cdparanoia required by (dev-libs/libcdio-paranoia-0.90_p1-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Last edited by tano70 on Tue Sep 03, 2013 6:27 am; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Mon Sep 02, 2013 3:17 pm    Post subject: Reply with quote

Prova a fare un emerge -C di tutta la roba che ti esce come blocco, poi emerge -DuNq world
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4520
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Sep 02, 2013 3:23 pm    Post subject: Reply with quote

ago wrote:
Prova a fare un emerge -C di tutta la roba che ti esce come blocco, poi emerge -DuNq world

:) più o meno quello che dicevo io qui.

probabilmente stai facendo molti post per lo stesso problema.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Tue Sep 03, 2013 5:47 am    Post subject: Reply with quote

Allora cerco di fare un po di chiarezza aggiornandovi su quantoi da me fatto. Premetto che su consiglio di utenti del forum internazionale (non avevo ancora letto questo post in quanto lo avete scritto dopo) avevo dato questi comandi:

emerge -1 media-sound/cdparanoia sys-apps/sysvinit dev-libs/gobject-introspectio

ed alla fine era uscito questo:

Code:
>>> Installing (3 of 3) dev-libs/gobject-introspection-1.32.1
 * Compilation and optimization of Python modules placed outside of site-packages directories for CPython 2.7 ...                                        [ ok ]
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-libs/libjpeg-turbo-1.3.0-r2
 *  - /usr/lib64/libjpeg.so.8
 *  - /usr/lib64/libjpeg.so.8.0.2
 *      used by /usr/bin/cwebp (media-libs/libwebp-0.3.1)
 *      used by /usr/bin/gs (app-text/ghostscript-gpl-9.05-r1)
 *      used by /usr/bin/jpegicc (media-libs/lcms-1.19)
 *      used by 20 other files
>>> package: media-video/ffmpeg-1.2.3
 *  - /usr/lib64/libavutil.so.51
 *  - /usr/lib64/libavutil.so.51.73.101
 *      used by /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so (media-video/vlc-2.0.7)
 *      used by /usr/lib64/vlc/plugins/demux/libavformat_plugin.so (media-video/vlc-2.0.7)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items


Poi come suggerito dal terminale stesso ho dato questo altro comando:

emerge @preserved-rebuild

dandomi questo:
Code:
darkstar tano # emerge @preserved-rebuild

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] dev-libs/ppl-0.12.1-r1  USE="-doc -lpsol -pch -static-libs {-test}"
[ebuild   R    ] media-libs/tiff-4.0.3-r4
[ebuild   R    ] media-libs/lcms-2.3
[ebuild     UD ] media-libs/libwebp-0.2.1 [0.3.1]
[ebuild     UD ] dev-lang/v8-3.19.18.19 [3.20.17.1]
[ebuild   R    ] media-libs/netpbm-10.51.00-r2
[ebuild   R    ] app-text/poppler-0.22.2-r2
[ebuild   R    ] x11-libs/gdk-pixbuf-2.26.4
[ebuild   R    ] media-libs/lcms-1.19
[ebuild  N     ] media-libs/libart_lgpl-2.3.21-r1
[ebuild  N     ] dev-libs/cloog-ppl-0.15.10  USE="-static-libs"
[ebuild   R    ] media-libs/libmng-1.0.10-r1
[ebuild  N     ] dev-lang/nacl-toolchain-newlib-0_p9093
[ebuild   R    ] app-text/ghostscript-gpl-9.05-r1
[ebuild   R    ] net-print/cups-filters-1.0.34-r1
[ebuild   R    ] media-gfx/imagemagick-6.8.6.8
[ebuild   R    ] app-office/abiword-2.8.6-r2
[ebuild   R    ] x11-misc/xscreensaver-5.22
[ebuild     UD ] media-video/ffmpeg-1.0.7 [1.2.3] USE="opus*"
[ebuild     UD ] www-client/chromium-29.0.1547.57 [30.0.1599.15] USE="pulseaudio* system-ffmpeg*"
[ebuild  N     ] media-video/ffmpegthumbnailer-2.0.8  USE="gtk jpeg png -gnome"
[ebuild   R    ] media-video/vlc-2.0.7  USE="vaapi*"
[ebuild   R    ] xfce-extra/tumbler-0.1.25  USE="ffmpeg*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-video/ffmpeg:0

  (media-video/ffmpeg-1.2.3::gentoo, installed) pulled in by
    >=media-video/ffmpeg-1.2.1:0/0= required by (media-video/mplayer-1.2_pre20130729::gentoo, installed)
    (and 1 more with the same problem)

  (media-video/ffmpeg-1.0.7::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-1.0:0=[opus] required by (www-client/chromium-29.0.1547.57::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by www-client/chromium-29.0.1547.57[system-ffmpeg]
# required by @preserved-rebuild (argument)
=media-video/ffmpeg-1.0.7 opus

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


poi non so se ho fatto bene o meno, ma come suggerito sempre dalla finestra terminale, ho dato questo:

emerge @preserved-rebuild --autounmask-write

e poi
etc-update ed ho scelto opzione -3 di sostituire tutti i files

poi ho dato il comando che avete suggerito in questo post:

emerge -DuNq world

e mi ha restituito questo:

Code:
darkstar tano # emerge -DuNq world

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



!!! Problem resolving dependencies for net-misc/networkmanager from @selected

!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-0.9.6.4::gentoo USE="bluetooth consolekit dhcpcd gnutls introspection nss ppp wext -avahi -connection-sharing -dhclient -doc -modemmanager -resolvconf -vala -wimax"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
darkstar tano # emerge -DuNq world


Quindi adesso cosa dovrei fare?? mi pare di capire che dovrei eliminare uno dei due, ma se li ho entrambi nelle USE vuol dire che un programma specifico aveva chiesto di inserirle, per funzionare al meglio ed essere installato. Posso solo dire che per la connessione utilizzo NetworkManager (che si connette in automatico alla mia wifi) come browser web utilizzo chromium versione 30, e come lettore email thunderbild. Qualsiasi cosa devo scegliere, a me serve il buon funzionamento di questi programmi che ho elencato!!
Per la cronaca e' doveroso dire che sono riuscito ad installare nm-applet semplicemente rimuovendo da ACCEPT_KEYWORDS="~amd64"
Quindi per il momento metto risolto per quando attiene al titolo della discussione, pero vorrei gentilmente un aiuto per risolvere questi conflitti che mi da il sistema, postati sopra, e portarlo ad una condizione di assoluta stabilita'!!
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4520
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Sep 04, 2013 5:46 am    Post subject: Reply with quote

devi modificare le useflag secondo le indicazioni per i pacchetti specifici, usando la cartella (o il file) /etc/portage/package.use, come è spiegato qui.

se hai ancora problemi, apri un topic nuovo, perché hai dichiarato questo risolto.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Wed Sep 04, 2013 7:40 pm    Post subject: Reply with quote

Si infatti grazie mille sei stato gentilissimo e disponibile!! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum