Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cups-filter will unstable ghostscript-gpl
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5388
Location: Langen (Hessen), Germany

PostPosted: Sun Aug 25, 2013 8:26 am    Post subject: Cups-filter will unstable ghostscript-gpl Reply with quote

Hallo,

Code:

app-text/ghostscript-gpl:0

  (app-text/ghostscript-gpl-9.09::gentoo, ebuild scheduled for merge) pulled in by
    >=app-text/ghostscript-gpl-9.09 required by (net-print/cups-filters-1.0.36-r2::gentoo, ebuild scheduled for merge)

  (app-text/ghostscript-gpl-9.05-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

Code:
media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/opencv-2.4.5::gentoo, installed)
    media-libs/libpng:0/0= required by (dev-python/wxpython-2.8.12.1-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/gwenview-4.11.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/libwebp-0.3.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/ksplash-4.11.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.11.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/digikam-3.2.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/ffmpegthumbnailer-2.0.8::gentoo, installed)
    media-libs/libpng:0/0= required by (media-plugins/kipi-plugins-3.2.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/openjpeg-1.5.1::gentoo, installed)
    >=media-libs/libpng-1.5:0/0= required by (dev-java/icedtea-bin-6.1.12.6::gentoo, installed)
    (and 4 more with the same problems)

  (media-libs/libpng-1.6.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.6.2:0= required by (app-text/ghostscript-gpl-9.09::gentoo, ebuild scheduled for merge)


Warum darf denn ein stable Pakte eine Referenz auf unstable Pakete haben?
Und dann auch noch so viele Probleme verursachen?!

Als Lösung könnte ich cups-filter erstmal maskieren, aber schön ist das auch nicht.

Hat noch jemand das Problem? System ist amd64.

Vielen Dank & viele Grüße
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3930
Location: Irgendwo im Nirgendwo

PostPosted: Sun Aug 25, 2013 8:31 am    Post subject: Reply with quote

cups-filters-1.0.36-r2 ist doch gar nicht stable.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4115

PostPosted: Sun Aug 25, 2013 8:34 am    Post subject: Reply with quote

net-print/cups-filters-1.0.36-r2 ist nicht stable. die version 1.0.34-r1 ist stable...
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5388
Location: Langen (Hessen), Germany

PostPosted: Sun Aug 25, 2013 2:30 pm    Post subject: Reply with quote

Problem gelöst.
Ich hatte package.keywords.gnome3 -> /var/lib/layman/gnome/status/portage-configs/package.keywords.gnome3 gelinkt gehabt.

Wenn ich in /etc/portage: grep cups-filters * -ir ausführe, dann kommt da nix.
grep cups-filters * -iR hingegen zeigt mir an: package.keywords/package.keywords.gnome3:net-print/cups-filters

Dadurch, dass ich mit -ir nichts gesehen habe, dachte ich an ein ominöses Problem...
Im Endeffekt war in der Datei aber cups-filter und ~sys-devel/gcc-4.7.2:4.7 enthalten.

Vielen Dank für den richtigen Denkanstoß!
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum