Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev net names once again?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
WhatTheFoo
n00b
n00b


Joined: 22 Aug 2013
Posts: 2

PostPosted: Thu Aug 22, 2013 6:54 pm    Post subject: udev net names once again? Reply with quote

just compiled and installed linux-3.8.13-gentoo...
no net after reboot;
reason: names of nics have changed, once again;
after the hassle, in May I guess, with udev, was it 197 or so... and this was not the first time.
I would really appreciate a hint BEFORE updates automagically render my machines unreachable!

Is there anything a normal user can do to provide help or whatever is needed?
What is the reason for this? Just a bug? No tests? Human nature? Ignorance?

Sorry guys, I do not write this to annoy you. Gentoo usually gives me what I want and need, I'm glad Gentoo exists. And so it really makes me unhappy when the same younameit happens over and over again. And I want this to change. And I imagine a user who is not into this stuff since that long as me and facing a dead machine in a datacenter or so, not next door. This is not funny anymore in my eyes.

FOO! This forum just mailed me my "password" in plain. Seriously!?!
Please wake someone up, really, thank you
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3901
Location: USA

PostPosted: Thu Aug 22, 2013 7:07 pm    Post subject: Reply with quote

I hope the new udev/kernel combo will be the last of the network interface changes... Are you getting the "persistent" enXXXX interface names now?

Sometimes I don't think that Gentoo is a good fit for remote administration. I do it anyway - the trick I have to do to limit the amount of pain is to have a mirror setup locally and implement the changes on it first. It's still risky however. (Those people with single interfaces and use Networkmanager will never see this problem!)

BTW, this thread probably belongs on Chat or OTW subforums, unless you still need some help figuring out how to recover...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
WhatTheFoo
n00b
n00b


Joined: 22 Aug 2013
Posts: 2

PostPosted: Thu Aug 22, 2013 8:04 pm    Post subject: Reply with quote

yes I also have my own mirrors, staging basically;
and thanks, I don't need help currently;
my nics were named ens3 and ens7 before, now they are enp0s3 and enp0s7, where former 3 still is 3 and 7 still is 7, on this box;

next in turn will be my router, it has 6 physical nics and some vlans, and iptables and routing ... feels like I'm getting old with that crap :/
hopefully you are right and this is the last change of that kind;
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7957

PostPosted: Mon Aug 26, 2013 2:38 am    Post subject: Reply with quote

WhatTheFoo wrote:
yes I also have my own mirrors, staging basically;
and thanks, I don't need help currently;
Given that, this seems to fit better outside of the support forums.

Moved from Kernel & Hardware to Gentoo Chat, as opposed to Off the Wall, considering the generally less technical bent of the latter of late.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum