Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IMMOU issues.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 434

PostPosted: Wed Aug 21, 2013 8:32 pm    Post subject: IMMOU issues. Reply with quote

hey fellas. i am having a strange immou issue. if i disable it in my bios the issue goes away but as soon as i do that, my keyboard and mouse wont work. ive tried a few different commands at boot but nothing. i have both usb 3 and 2 ports and have tried both with no luck... here is an output of dmesg -- http://nopaste.info/bc2355776f.html


i am using gentoo-sources 3.10.5-r1. if theres anything else i can add let me know
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1658
Location: Berlin, Germany

PostPosted: Wed Aug 21, 2013 9:19 pm    Post subject: Reply with quote

Try booting with iommu=pt kernel parameter.
Back to top
View user's profile Send private message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 434

PostPosted: Fri Aug 23, 2013 1:18 am    Post subject: Reply with quote

tried that, no luck. also tried amd_immou=off
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 434

PostPosted: Fri Aug 23, 2013 1:31 am    Post subject: Reply with quote

but i didnt try both, lets see
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 168

PostPosted: Fri Aug 23, 2013 2:00 am    Post subject: Reply with quote

Hell-Razor wrote:
tried that, no luck. also tried amd_immou=off

You keep typing immou, but I strongly suspect you mean iommu. Are you sure you're trying the correctly spelled option?
Back to top
View user's profile Send private message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 434

PostPosted: Sat Aug 24, 2013 4:16 pm    Post subject: Reply with quote

kurly wrote:
Hell-Razor wrote:
tried that, no luck. also tried amd_immou=off

You keep typing immou, but I strongly suspect you mean iommu. Are you sure you're trying the correctly spelled option?
doh :oops:
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 434

PostPosted: Sat Aug 24, 2013 4:19 pm    Post subject: Reply with quote

chithanh wrote:
Try booting with iommu=pt kernel parameter.
Worked, thank you
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum