Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Subversion character encoding problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 128

PostPosted: Mon Aug 12, 2013 8:58 pm    Post subject: Subversion character encoding problem Reply with quote

I have the following problem, which I think is related to that I used ISO-8859-1 when I initially created the files and directories. Now I have UTF-8 on Gentoo and want to use the old ISO-8859-1 directories on this UTF-8 system. I get the following problem:

With UTF-8 (set in /etc/env.d/02locale):

Code:

$ svn up
Updating '.':
svn: E000022: Error converting entry in directory '/home/printer' to UTF-8
svn: E000022: Valid UTF-8 data
(hex: 62 75 74 69 6b 6b 65 72 5f 6b 6c)
followed by invalid UTF-8 sequence
(hex: e6 72 2e 74)


svn commit works fine with UTF-8.

With ISO-8859-1 (set in /etc/env.d/02locale):

Code:

    $ svn up
    svn: warning: cannot set LC_CTYPE locale
    svn: warning: environment variable LANG is ISO-8859-1
    svn: warning: please check that your locale name is correct
    Updating '.':
    svn: E000022: Error converting entry in directory '/home/printer/docs' to UTF-8
    svn: E000022: Can't convert string from native encoding to 'UTF-8':
    svn: E000022: kj?\248ing.txt
     
    $ svn commit -m ""
    svn: warning: cannot set LC_CTYPE locale
    svn: warning: environment variable LANG is ISO-8859-1
    svn: warning: please check that your locale name is correct
    svn: E000022: Commit failed (details follow):
    svn: E000022: Can't convert string from 'UTF-8' to native encoding:
    svn: E000022: /home/printer/docs/kj?\195?\152ing.txt


Edit:

I also tried creating a new directory on my Gentoo system and just checking out everything from the subversion server again to that directory, but it stops at this:

Code:

svn: E000022: Can't convert string from 'UTF-8' to native encoding:
...


I find it strange that it says from 'UTF-8' to "native encoding", when my native encoding should be UTF-8?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum