Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] unable to install texmaker on my gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
rain_physics
n00b
n00b


Joined: 24 Mar 2013
Posts: 22

PostPosted: Sun Aug 04, 2013 9:31 pm    Post subject: [SOLVED] unable to install texmaker on my gentoo Reply with quote

Hi Friends

I am trying to install texmaker on my laptop but I am facing some dependencies problem.

Code:

emerge -av texmaker

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/kpathsea-6.1.0_p20120701  USE="-doc -source -static-libs" 128,853 kB
[ebuild  N     ] app-text/dvipsk-5.992_p20120701  USE="-doc -source" 94 kB
[ebuild  N     ] app-text/ps2pkm-1.5_p20120701  0 kB
[ebuild  N     ] sys-apps/ed-1.6  85 kB
[ebuild  N     ] dev-tex/bibtexu-3.71_p20120701  0 kB
[ebuild  N     ] dev-qt/qtxmlpatterns-4.8.4:4  USE="(-aqua) -c++0x -debug -pch" 0 kB
[ebuild  N     ] media-libs/netpbm-10.51.00-r2  USE="jpeg png tiff xml zlib -X -jbig -jpeg2k -rle (-svga)" 1,800 kB
[ebuild  N     ] app-text/psutils-1.17-r2  40 kB
[ebuild  N     ] virtual/perl-Getopt-Long-2.380.0-r2  0 kB
[ebuild   R    ] dev-libs/libxml2-2.9.1-r1:2  USE="ipv6 python readline -debug -examples -icu* -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)" 0 kB
[ebuild   R    ] app-text/poppler-0.22.2-r2:0/35  USE="cairo cxx introspection jpeg lcms png qt4* tiff utils -cjk -curl -debug -doc -jpeg2k" 0 kB
[ebuild  N     ] dev-qt/qtwebkit-4.8.4:4  USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" 0 kB
[ebuild  N     ] app-text/texlive-core-2012-r1  USE="-X -cjk -doc -source -tk -xetex" 998 kB
[ebuild  N     ] dev-texlive/texlive-documentation-base-2012  USE="-source" 1,441 kB
[ebuild  N     ] dev-libs/zziplib-0.13.60-r1  USE="sdl -doc -static-libs {-test}" 670 kB
[ebuild  N     ] dev-tex/luatex-0.70.1-r2  USE="-doc" 9,014 kB
[ebuild  N     ] dev-texlive/texlive-basic-2012  USE="-doc -source" 5,190 kB
[ebuild  N     ] dev-texlive/texlive-fontutils-2012  USE="-doc -source" 215 kB
[ebuild  N     ] dev-texlive/texlive-latex-2012  USE="-doc -source" 889 kB
[ebuild  N     ] dev-texlive/texlive-latexrecommended-2012-r1  USE="-doc -source" 6,631 kB
[ebuild  N     ] virtual/latex-base-1.0  0 kB
[ebuild  N     ] app-office/texmaker-4.0.1  12,760 kB

Total: 22 packages (20 new, 2 reinstalls), Size of downloads: 168,674 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:2[!icu?] required by (dev-qt/qtwebkit-4.8.4::gentoo, ebuild scheduled for merge)

  (dev-libs/libxml2-2.9.1-r1::gentoo, installed) pulled in by
    dev-libs/libxml2:2/2=[icu] required by (www-client/chromium-28.0.1500.95::gentoo, installed)
    dev-libs/libxml2:=[icu] required by (www-client/chromium-28.0.1500.95::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Any body help me , how can I install texmaker from portage

Thanks in advance


Last edited by rain_physics on Sun Aug 04, 2013 10:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1450

PostPosted: Sun Aug 04, 2013 10:21 pm    Post subject: Reply with quote

Add USE="icu" to dev-qt/qtwebkit. This way, chromium and qtwebkit will share the dependency instead of fighting over it. Use /etc/portage/package.use

You may also want to specifically install any latex packages you want to use. What you get from a basic instillation is very basic indeed.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
rain_physics
n00b
n00b


Joined: 24 Mar 2013
Posts: 22

PostPosted: Sun Aug 04, 2013 10:53 pm    Post subject: [solved] Reply with quote

Thanks a lot

you have solved my problem

once again thanks a lot :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum