Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mceusb ir transmitter, anbody got it to work?[Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
trumee
Guru
Guru


Joined: 02 Mar 2003
Posts: 464
Location: London,UK

PostPosted: Sat Aug 03, 2013 12:23 pm    Post subject: mceusb ir transmitter, anbody got it to work?[Solved] Reply with quote

Hi,

Has anybody tried getting their IR transmitter to work?

Unfortunately, the transmitter doesnt seem to work for me. The receiver works fine though.

This is the device http://i1213.photobucket.com/albums/cc468/oriental-hony/1-dell56FE6587906563A75668hp63A565365668_zps92364df1.jpg

On inserting the device i get
Code:


[ 3847.644574] usb 2-1.2: new full-speed USB device number 9 using ehci-pci
[ 3847.732182] usb 2-1.2: New USB device found, idVendor=1934, idProduct=5168
[ 3847.732190] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3847.732194] usb 2-1.2: Product: eHome Infrared Transceiver
[ 3847.732198] usb 2-1.2: Manufacturer: FINTEK
[ 3847.732201] usb 2-1.2: SerialNumber: 88636562727801
[ 3847.733001] Registered IR keymap rc-rc6-mce
[ 3847.733083] input: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/rc/rc2/input13
[ 3847.733122] rc2: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/rc/rc2
[ 3847.733177] rc rc2: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
[ 3847.865059] mceusb 2-1.2:1.0: Registered FINTEK eHome Infrared Transceiver with mce emulator interface version 1
[ 3847.865067] mceusb 2-1.2:1.0: 2 tx ports (0x0 cabled) and 2 rx sensors (0x0 active)


lsusb reports
Code:

Bus 002 Device 009: ID 1934:5168 Feature Integration Technology Inc. (Fintek) F71610A or F71612A Consumer Infrared Receiver/Transceiver



lircd is setup as
Code:

#cat  /etc/conf.d/lircd

LIRCD_OPTS="-H devinput -d /dev/input/by-id/usb-FINTEK_eHome_Infrared_Transceiver_88636562727801-event-if00"


However, when i issue
Code:

#irsend   SET_TRANSMITTERS 1
irsend: command failed: SET_TRANSMITTERS 1
irsend: hardware does not support sending

#irsend   SET_TRANSMITTERS 2
irsend: command failed: SET_TRANSMITTERS 2
irsend: hardware does not support sending


i get errors on irsend. The receiver works fine though.
Code:

#irw
00000000800100ae 00 KEY_EXIT devinput
0000000080010067 00 KEY_UP devinput
000000008001006a 00 KEY_RIGHT devinput
0000000080010069 00 KEY_LEFT devinput
0000000080010067 00 KEY_UP devinput
00000000800100a8 00 KEY_REWIND devinput



lirc is installed as following:
Code:

emerge -pv lirc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-misc/lirc-0.9.0-r2  USE="X transmitter -debug -doc -hardware-carrier -static-libs" LIRC_DEVICES="devinput"


any idea how do i get the transmitter to work?


Last edited by trumee on Tue Aug 06, 2013 5:30 pm; edited 3 times in total
Back to top
View user's profile Send private message
trumee
Guru
Guru


Joined: 02 Mar 2003
Posts: 464
Location: London,UK

PostPosted: Sat Aug 03, 2013 9:45 pm    Post subject: Reply with quote

Ok, after few hours of messing about I finally got this to work. Here are some rough steps.

1. Install kernel linux-3.10.4. This device is buggy on lower kernels where only the receiver works. The transmitter works in 3.10.4 which has a patched mceusb driver for this device.

2. In the kernel enable the following: Remote controller decoders --->LIRC interface driver, Remote controller decoders --->Enable IR to LIRC bridge. Do NOT enable any other IR decoders.

3. Again, enable Remote Controller devices --->Windows Media Center Ed. eHome Infrared Transceiver
4. All the kernel modules are built directly into the kernel.
5. Emerge lirc using "userspace" driver, LIRC_DEVICES="userspace" and USE="transmitter"
6. Set LIRCD_OPTS="-d /dev/lirc0" in /etc/config.d/lircd
7. Finally, copy http://lirc.sourceforge.net/remotes/mceusb/lircd.conf.mceusb as /etc/lircd/lircd.conf
8. Start /etc/init.d/lircd
9. irsend SEND_ONCE mceusb One should make the led on the ir device flash
10. irw will also work.

HOWEVER, i can only get irsend to work in the console tty1 with X turned off. Inside the X session, irsend doesnt make the ir device to flash.

The problem seems to be evdev which is picking up the device as a keyboard in X. i tried to make X ignore the device using
Code:

#cat /etc/X11/xorg.conf.d/5-evdev.conf
Section "InputClass"
        Identifier "Media Center Ed. eHome Infrared Remote Transceiver (1934:5168)"
        MatchProduct "Media Center Ed. eHome Infrared Remote Transceiver (1934:5168)"
        MatchDevicePath "/dev/input/event*"
         Option "Ignore"
        EndSection


which does disable the device as seen below. But still irsend refuses to make the device to flash its LED's inside X.

Code:

[   920.522] (II) config/udev: Adding input device Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) (/dev/input/event8)
[   920.523] (**) Media Center Ed. eHome Infrared Remote Transceiver (1934:5168): Ignoring device from InputClass "Media Center Ed. eHome Infrared Remote Transceiver (1934:5168)"


Solved, need CONFIG_USB_EHCI_TT_NEWSCHED in the kernel config, see this http://thread.gmane.org/gmane.linux.drivers.video-input-infrastructure/67492/focus=67616
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum