Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Noticably slower performance
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
daniel4230877
n00b
n00b


Joined: 25 Jul 2013
Posts: 31

PostPosted: Sun Jul 28, 2013 12:16 am    Post subject: Noticably slower performance Reply with quote

In my Gentoo installation I'm getting noticably slower performance than I did when I used Arch Linux. I have a quad core intel i7 and 16 GB ram, my computer should not be this slow. KWin desktop effects run slow, when I run the Higan emulator, I only get 20 FPS or so. I used to get 60 FPS on Arch. My system boots slower than it did on Arch as well. What can I do to get the performance that I used to get in Arch?
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Sun Jul 28, 2013 1:18 am    Post subject: Reply with quote

With kde, the semantic desktop is usually the culprit of poor performance. You can disable it either with the use flag ,which may go away soon unfortunately, or using the system settings to disable nepomuk. It should be easy to find. Also, try playing with how the desktop effects are displayed. Arch may have done it differently and there can be a big difference between the options in terms of performance.

For boot times, there are a few tricks you can try, but two general things you can look at are 1) are you starting unnecessary services? 2) are you using an initramfs? If you used genkernel, you may be stuck with suboptimal options that are slowing down your graphics and due to the nature of using an initramfs your boot.

The best solution to compiling a kernel I have found is to use http://kernel-seeds.org/. Its minimal and it will not require an initramfs to boot which will cut off a good deal of time.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
daniel4230877
n00b
n00b


Joined: 25 Jul 2013
Posts: 31

PostPosted: Sun Jul 28, 2013 3:20 am    Post subject: Reply with quote

The Doctor wrote:
With kde, the semantic desktop is usually the culprit of poor performance. You can disable it either with the use flag ,which may go away soon unfortunately, or using the system settings to disable nepomuk. It should be easy to find. Also, try playing with how the desktop effects are displayed. Arch may have done it differently and there can be a big difference between the options in terms of performance.

For boot times, there are a few tricks you can try, but two general things you can look at are 1) are you starting unnecessary services? 2) are you using an initramfs? If you used genkernel, you may be stuck with suboptimal options that are slowing down your graphics and due to the nature of using an initramfs your boot.

The best solution to compiling a kernel I have found is to use http://kernel-seeds.org/. Its minimal and it will not require an initramfs to boot which will cut off a good deal of time.


I didabled nepomuk and there is no performance difference. I am using a custom kernel, but I am using the initramfs from genkernel. I couldn't get it to boot from grub without an initramfs for some reason. I'll try kernel-seeds.org
Back to top
View user's profile Send private message
daniel4230877
n00b
n00b


Joined: 25 Jul 2013
Posts: 31

PostPosted: Tue Jul 30, 2013 4:43 am    Post subject: Reply with quote

What I did for the higan issue was used the balanced profile rather than the accurate one. For some reason, on Gentoo it doesn't run at full speed but balanced works perfectly with every game I tested. I was also able to get everything else working by adding VIDEO_CARDS="intel nvidia" because I'm using bumblebee.

Somehow I forgot that... I have no clue how. But adding that and emerging world with new use flags fixed it.
Back to top
View user's profile Send private message
rg.viza
n00b
n00b


Joined: 23 Mar 2012
Posts: 11

PostPosted: Tue Jul 30, 2013 2:50 pm    Post subject: Reply with quote

The Doctor wrote:
With kde, the semantic desktop is usually the culprit of poor performance. You can disable it either with the use flag ,which may go away soon unfortunately, or using the system settings to disable nepomuk. It should be easy to find. Also, try playing with how the desktop effects are displayed. Arch may have done it differently and there can be a big difference between the options in terms of performance.

For boot times, there are a few tricks you can try, but two general things you can look at are 1) are you starting unnecessary services? 2) are you using an initramfs? If you used genkernel, you may be stuck with suboptimal options that are slowing down your graphics and due to the nature of using an initramfs your boot.

The best solution to compiling a kernel I have found is to use http://kernel-seeds.org/. Its minimal and it will not require an initramfs to boot which will cut off a good deal of time.


I second this.... I don't do genkernel at all. I just follow the handbook and skip the genkernel section. I don't even think the info at that link is necessary to not use genkernel, but it's definitely awesome info for streamlining the kernel!

I've always just used the standard menuconfig and hand edited the kernel config when needed. Of course this is much slower than using kernel-seeds :-p
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum