Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
More optimus problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 135

PostPosted: Fri Jul 19, 2013 2:34 am    Post subject: More optimus problems Reply with quote

I now have a working system with Optimus. Working in the sense that I have the ability to run two X servers. The primary one running on i915 and the secondary on the proprietary nvidia driver.

Problem: xrandr shows no connected device when I hook up something to the VGA port.

How is this resolved? I'm unable to find any guide on doing this. This is not trivial for me, because I actually need VGA out to work.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31705
Location: 56N 3W

PostPosted: Fri Jul 19, 2013 6:49 pm    Post subject: Reply with quote

deltamalloc,

I'm fairly sure that displays are not hot pluggable, so your VGA will only be seen if its there when xorg starts, or you write a stub xorg.conf to describe the display that you will attach later.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Fri Jul 19, 2013 7:16 pm    Post subject: Reply with quote

NeddySeagoon wrote:
deltamalloc,

I'm fairly sure that displays are not hot pluggable, so your VGA will only be seen if its there when xorg starts, or you write a stub xorg.conf to describe the display that you will attach later.
Displays are hotpluggable and have been so for years. I don't know if optimus loses this functionality.

With nvidia drivers (not an optimus machine) I could dynamically enable and configure the second display using the nvidia control center. On an intel system (again, not an optimus machine) I can actually get a udev event (in the "drm" subsystem) and can configure my laptop to automatically enable some specific configuration in the external display as soon as it is plugged in.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 135

PostPosted: Sat Jul 20, 2013 6:29 am    Post subject: Reply with quote

ppurka wrote:
NeddySeagoon wrote:
deltamalloc,

I'm fairly sure that displays are not hot pluggable, so your VGA will only be seen if its there when xorg starts, or you write a stub xorg.conf to describe the display that you will attach later.
Displays are hotpluggable and have been so for years. I don't know if optimus loses this functionality.

With nvidia drivers (not an optimus machine) I could dynamically enable and configure the second display using the nvidia control center. On an intel system (again, not an optimus machine) I can actually get a udev event (in the "drm" subsystem) and can configure my laptop to automatically enable some specific configuration in the external display as soon as it is plugged in.


The problem is the following:

Using intel only (forced through a BIOS setting), xrandr shows nothing connected.
Using nvidia only (forced through a BIOS setting), xrandr does show the display connected, and working.
Using Optimus, with both intel and nvidia active, xrandr shows nothing connected.

When xrandr works, nvidia-settings also works.

What I need is some way to make the primary X session be the one driven by the nvidia card when I want to use vga out. Can you, or anyone suggest an X config file for making this happen?

Primary X (intel) server:

Code:

Section "Module"
    Disable        "dri"
EndSection

Section "ServerFlags"
    Option "AllowEmptyInput" "no"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 73.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "intel"
    VendorName     "onboard"
    BusID          "PCI:0:2:0"
    #Screen         1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device1"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Secondary (nvidia) X server:

Code:

Section "DRI"
        Mode 0666
EndSection

Section "ServerLayout"
    Identifier     "Layout0"
    Screen         "Screen1"
    Option         "AutoAddDevices" "false"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
EndSection

Section "Files"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:01:00:0"
    Option         "IgnoreEDID"
    Option         "ConnectedMonitor" "CRT-0"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 73.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection


These two configurations are taken directly from http://en.gentoo-wiki.com/wiki/X.Org/nVidia_Optimus
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum