Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME 3.6 y problemas para actualizar el Sistema
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
2uncas
Apprentice
Apprentice


Joined: 22 Oct 2004
Posts: 258
Location: Cogolludo (Guadalajara)

PostPosted: Thu Jul 18, 2013 6:18 pm    Post subject: GNOME 3.6 y problemas para actualizar el Sistema Reply with quote

Hola

Llevo un tiempo que al intentar actualizar el sistema me aparece lo siguiente:

El sistema lo actualizo con
emerge --update --newuse --deep --with-bdeps=y @world

Quote:

emerge: there are no ebuilds built with USE flags to satisfy "dev-python/rdflib[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)]".
!!! One of the following packages is required to complete your request:
- dev-python/rdflib-4.0.1::gentoo (Change USE: +python_targets_python2_7)
- gnome-extra/zeitgeist-0.9.14::gentoo (Change USE: -python_targets_python2_7, this change violates use flag constraints defined by gnome-extra/zeitgeist-0.9.14: 'any-of ( python_targets_python2_6 python_targets_python2_7 ) downloads-monitor? ( datahub )')
(dependency required by "gnome-extra/zeitgeist-0.9.14" [ebuild])
(dependency required by "dev-libs/libzeitgeist-0.3.18" [installed])
(dependency required by "dev-libs/folks-0.8.0" [installed])
(dependency required by "net-im/empathy-3.6.4" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])



No se si tiene que ver con tener GNOME 3.6 y tener todas sus dependencias en package.accept_keywords,

Gracias .
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Thu Jul 18, 2013 6:57 pm    Post subject: Reply with quote

¿Que interprete de Python tienes seleccionado?

En mi caso:
Code:
agd-desktop # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.2
agd-desktop #

_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
2uncas
Apprentice
Apprentice


Joined: 22 Oct 2004
Posts: 258
Location: Cogolludo (Guadalajara)

PostPosted: Thu Jul 18, 2013 7:08 pm    Post subject: Reply with quote

Pues el mismo

Quote:

localhost ~ # eselect python list

Available Python interpreters:
[1] python2.7 *
[2] python3.2



Gracias
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 820

PostPosted: Thu Jul 18, 2013 7:50 pm    Post subject: Reply with quote

¿Qué dice
Code:
equery uses rdflib-4.0.1
?
Back to top
View user's profile Send private message
2uncas
Apprentice
Apprentice


Joined: 22 Oct 2004
Posts: 258
Location: Cogolludo (Guadalajara)

PostPosted: Thu Jul 18, 2013 9:13 pm    Post subject: Reply with quote

Esto:
Quote:

localhost ~ # equery uses rdflib-4.0.1
[ Legend : U - final flag setting for installation]
[ : I - package is installed with flag ]
[ Colors : set, unset ]
* Found these USE flags for dev-python/rdflib-4.0.1:
U I
+ + berkdb : Adds support for sys-libs/db (Berkeley DB for MySQL)
- - examples : Install examples, usually source code
- - mysql : Adds mySQL Database support
- - python_targets_python2_6 : Build with Python 2.6
- + python_targets_python2_7 : Build with Python 2.7
+ + python_targets_python3_2 : Build with Python 3.2
- - python_targets_python3_3 : Build with Python 3.3
- - redland : enable support for Redland triplestore
- - sqlite : Adds support for sqlite - embedded sql database
- - test : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this
internally, so don't set it in make.conf/package.use anymore

Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Thu Jul 18, 2013 10:20 pm    Post subject: Reply with quote

2uncas wrote:

localhost ~ # equery uses rdflib-4.0.1
...
- + python_targets_python2_7 : Build with Python 2.7
+ + python_targets_python3_2 : Build with Python 3.2
...

Parece que en algún momento ha estado activo Python-3.2, vuelve a emerger el paquete: emerge -avql rdflib, y asegúrate que se compila con python-2.7
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 820

PostPosted: Thu Jul 18, 2013 10:37 pm    Post subject: Reply with quote

Quote:
- + python_targets_python2_7 : Build with Python 2.7
Tienes que activar esta USE. Deberías hacerlo a nivel global a no ser que tengas una buena razón para lo contrario. Debes modificar la variable PYTHON_TARGETS, añadiendo a lo que ya haya "python_2_7" (sin comillas). Publica la salida de
Code:
emerge --info | grep PYTHON_TARGETS
antes y después de modificar.
Back to top
View user's profile Send private message
2uncas
Apprentice
Apprentice


Joined: 22 Oct 2004
Posts: 258
Location: Cogolludo (Guadalajara)

PostPosted: Fri Jul 19, 2013 5:13 am    Post subject: Reply with quote

Muchas gracias,

Ahora estoy en el trabajo y no puedo luego hago.

Saludos.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum